Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
brother mfcj470dw not printing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
theblackraven
n00b
n00b


Joined: 12 Oct 2005
Posts: 17

PostPosted: Thu Jan 22, 2015 8:28 pm    Post subject: brother mfcj470dw not printing Reply with quote

hi,

i followed this guide: http://wiki.gentoo.org/wiki/Brother_networked_printer for my printer.

I'm using systemd and i installed successfully my printer. In Cups i modified the installed printer to following: lpd://192.168.178.102/binary_p1
When i try to print a page, cups reports:
completed at
Thu Jan 22 21:22:09 2015

But the printer didn't print.

Error Log shows this:
E [22/Jan/2015:21:22:09 +0100] [Client 32] Returning HTTP Forbidden for CUPS-Get-Devices (no URI) from localhost
E [22/Jan/2015:21:22:09 +0100] [Client 32] Returning HTTP Forbidden for CUPS-Add-Modify-Printer (ipp://localhost:631/printers/MFCJ470DW) from localhost

i searched for about 2 hours, but nothing seems to be similar to my problem...
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Thu Jan 22, 2015 10:38 pm    Post subject: Reply with quote

have you tried printing a testpage from cups?

First I suggest to print a testpage so you can see if the communciatin from cups to the printer works. Therefore cups has to be started first.

It also depends on teh connection from your printer to your hardware?
Network printer / wifi / usb / ...

do you need to be in a certain group to be able to print? did you try to print as root? did it work for a newly generated user?

did you checked the net for hints regarding your priter type? ...
Back to top
View user's profile Send private message
theblackraven
n00b
n00b


Joined: 12 Oct 2005
Posts: 17

PostPosted: Fri Jan 23, 2015 11:42 am    Post subject: Reply with quote

i tried as root and user to print a testpage in cups. cups ist started.
driver is installed correct and wrapper is linked to the correct place.
Printing over wifi ( lpd://192.168.178.102/binary_p1 ).
If i wan't to print, the printer display goes on, but the printer won't print.

But cups reports:
completed at
Thu Jan 22 21:22:09 2015
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum