Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot boot iso with UEFI bios setting in VMware Workstatio
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Thaidog
Veteran
Veteran


Joined: 19 May 2004
Posts: 1053

PostPosted: Sat Jan 24, 2015 11:31 pm    Post subject: Cannot boot iso with UEFI bios setting in VMware Workstatio Reply with quote

I'm trying my luck on building a Gentoo VM using the new UEFI bios feature in VMware Workstation.

You have to add these two lines to your VM's .vmx file:
Code:

firmware = "efi"
bios.forceSetupOnce = "FALSE"


This works for booting a Windows 8 iso to install but I cannot seem get the bios to see the minimal install amd64 iso for some reason.

Has anyone had any luck trying this?
_________________
Registered Linux User: 437619
"I'm a big believer in technology over politics" - Linus Torvalds
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Sun Jan 25, 2015 2:04 am    Post subject: Reply with quote

minimal install remains incapable of booting in uefi. http://www.sysresccd.org/Download is the non-minimal install cd based on gentoo.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Thaidog
Veteran
Veteran


Joined: 19 May 2004
Posts: 1053

PostPosted: Sun Jan 25, 2015 5:12 am    Post subject: Reply with quote

DONAHUE wrote:
minimal install remains incapable of booting in uefi. http://www.sysresccd.org/Download is the non-minimal install cd based on gentoo.


Ok thanks! Is there any guide for installing gentoo with this iso? I am running in to a few snags like links is not available on this livecd.
_________________
Registered Linux User: 437619
"I'm a big believer in technology over politics" - Linus Torvalds
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Sun Jan 25, 2015 5:18 am    Post subject: Reply with quote

I usually boot all the way to the xfce4 gui and use the midori browser to do the stage3 download.
networkmanager icon is lower right corner of the desktop.
may have lynx in terminal. IIRC .
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Thaidog
Veteran
Veteran


Joined: 19 May 2004
Posts: 1053

PostPosted: Sun Jan 25, 2015 8:20 pm    Post subject: Reply with quote

DONAHUE wrote:
I usually boot all the way to the xfce4 gui and use the midori browser to do the stage3 download.
networkmanager icon is lower right corner of the desktop.
may have lynx in terminal. IIRC .


Ok that worked great thanks... but a few more things and hopefully I'll be on my way. I'm getting failed to install gentoo-sources and it says to look in the build.log for errors - but there are none. I try to install vanilla-sources and it errors saying:

'sys-kernel/vanilla-sources....' merged despite file collisions.


I emerged gentoolkit and ran revdep-rebuild but that did not help. Not sure what this errors means... it's been a while since I built a gentoo system!
_________________
Registered Linux User: 437619
"I'm a big believer in technology over politics" - Linus Torvalds
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Mon Jan 26, 2015 2:34 am    Post subject: Reply with quote

merged despite file collisions. is usually not a problem.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Thaidog
Veteran
Veteran


Joined: 19 May 2004
Posts: 1053

PostPosted: Mon Feb 02, 2015 4:02 am    Post subject: Reply with quote

DONAHUE wrote:
merged despite file collisions. is usually not a problem.


Not sure why that happened although my network has been blocking a ton of packages.... could have mangled something. I opened up lynx and downloaded the latest stable from kernel.org and got my system running...
_________________
Registered Linux User: 437619
"I'm a big believer in technology over politics" - Linus Torvalds
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum