Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No incoming mail - sylpheed [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
catchpole
Tux's lil' helper
Tux's lil' helper


Joined: 03 Sep 2014
Posts: 103
Location: Leeds UK

PostPosted: Tue Jan 27, 2015 10:49 am    Post subject: No incoming mail - sylpheed [SOLVED] Reply with quote

I've emerged sylpheed email client.

I can send email but can't receive it.
Send is SMTP form port 25 and incoming mail is IMAP with port 143.

I've checked my connection settings many times and compared them with the setting I use in Thunderbird on my Linux Mint box.
Everything looks OK.
Searching the web has not given me any clues.

How can I check that port 143 is enabled?

What else do I need to do or check?
_________________
Noob
With experience of Mint and trying to learn more by intalling Gentoo
Motherboard = MS-7211- MICRO-STAR INTERNATIONAL CO., LTD
CPU = Intel(R) Celeron(R) CPU 2.80GHz version: 15.4.9
Memory = 2GB


Last edited by catchpole on Sun Feb 01, 2015 8:14 am; edited 1 time in total
Back to top
View user's profile Send private message
AndrewAmmerlaan
Apprentice
Apprentice


Joined: 25 Jun 2014
Posts: 151
Location: Lent

PostPosted: Thu Jan 29, 2015 3:01 pm    Post subject: Reply with quote

Sorry if this question is too obvious, but did you check if your router/modem isn't blocking that port? Did you forward that port in your router/modem settings? (I always get router and modem mixed up (: . )
_________________
OS: Gentoo KDE x86_64 (~amd64, 5.1.15-gentoo)
MB: MSI Z370-A PRO
CPU: Intel Core i7-8700K
GPU: NVIDIA GTX 1060 6GB & Intel UHD Graphics 630
SSD: Samsung 970 Pro 512GB
RAM: Crucial Ballistix 32GB DDR4-2400
Back to top
View user's profile Send private message
catchpole
Tux's lil' helper
Tux's lil' helper


Joined: 03 Sep 2014
Posts: 103
Location: Leeds UK

PostPosted: Thu Jan 29, 2015 6:07 pm    Post subject: Reply with quote

Hi Andrew,

I have six computers and they all work through the same modem/router without any email problems.

However I've done a lot of searching and found this site:
http://wiki.gentoo.org/wiki/Complete_Virtual_Mail_Server/Courier-IMAP_to_Database
It seems to indicate that I need to install "Courier-IMAP.

I've had no feedback on this one yet so I'll have to go ahead and do the install and see what happens.

I hope after a while that things will start to click into place but at the moment my knowledge is very patchy.
If it wasn't for this forum I would have given up a long time ago with Gentoo but its a valuable learning experience.
I normally use Linux Mint.
_________________
Noob
With experience of Mint and trying to learn more by intalling Gentoo
Motherboard = MS-7211- MICRO-STAR INTERNATIONAL CO., LTD
CPU = Intel(R) Celeron(R) CPU 2.80GHz version: 15.4.9
Memory = 2GB
Back to top
View user's profile Send private message
catchpole
Tux's lil' helper
Tux's lil' helper


Joined: 03 Sep 2014
Posts: 103
Location: Leeds UK

PostPosted: Sat Jan 31, 2015 3:47 pm    Post subject: Reply with quote

Perhaps this log will help if anyone's still reading this:
Quote:
* Connecting to SMTP server: smtp.myisp.net ...
[10:46:02] SMTP< 220 out1.ip07ir2.mytelecom.net ESMTP
[10:46:02] SMTP> HELO GentooBox
[10:46:02] SMTP< 250 out1.ip07ir2.mytelecom.net
[10:46:02] SMTP> MAIL FROM:<mymail@myisp>
[10:46:02] SMTP< 250 sender <mymail@myisp> ok
[10:46:02] SMTP> RCPT TO:<mymail@myisp>
[10:46:02] SMTP< 250 recipient <mymail@myisp> ok
[10:46:02] SMTP> DATA
[10:46:02] SMTP< 354 go ahead
[10:46:02] SMTP> . (EOM)
[10:46:02] SMTP< 250 ok: Message 128758771 accepted
[10:46:02] SMTP> QUIT
[10:46:02] SMTP< 221 out1.ip07ir2.mytelecom.net
* Connecting to SMTP server: smtp.myisp.net ...
[10:51:48] SMTP< 220 out1.ip07ir2.mytelecom.net ESMTP
[10:51:48] SMTP> HELO mail.myisp.net
[10:51:49] SMTP< 250 out1.ip07ir2.mytelecom.net
[10:51:49] SMTP> MAIL FROM:<mymail@myisp>
[10:51:49] SMTP< 250 sender <mymail@myisp> ok
[10:51:49] SMTP> RCPT TO:<myimai2@myisp.net>
[10:51:49] SMTP< 250 recipient <myimai2@myisp.net> ok
[10:51:49] SMTP> RCPT TO:<mymail@myisp>
[10:51:49] SMTP< 250 recipient <mymail@myisp> ok
[10:51:49] SMTP> DATA
[10:51:49] SMTP< 354 go ahead
[10:51:49] SMTP> . (EOM)
[10:51:49] SMTP< 250 ok: Message 128759699 accepted
[10:51:49] SMTP> QUIT
[10:51:49] SMTP< 221 out1.ip07ir2.mytelecom.net
* creating IMAP4 connection to mail.myisp.net:143 ...
[10:52:24] IMAP4< * OK IMAP4 ready
[10:52:24] IMAP4> 1 CAPABILITY
[10:52:24] IMAP4< * CAPABILITY ACL BINARY CATENATE CHILDREN CONDSTORE ENABLE ESEARCH ESORT I18NLEVEL=1 ID IDLE IMAP4rev1 LIST-EXTENDED LITERAL+ MULTIAPPEND NAMESPACE QRESYNC QUOTA RIGHTS=ektx SASL-IR SEARCHRES SORT THREAD=ORDEREDSUBJECT UIDPLUS UNSELECT WITHIN AUTH=PLAIN STARTTLS
[10:52:24] IMAP4< 1 OK completed
[10:52:24] IMAP4> 2 AUTHENTICATE PLAIN
[10:52:24] IMAP4< +
[10:52:24] IMAP4> ****************
[10:52:24] IMAP4< 2 OK [CAPABILITY IMAP4rev1 ACL BINARY CATENATE CHILDREN CONDSTORE ENABLE ESEARCH ESORT I18NLEVEL=1 ID IDLE LIST-EXTENDED LIST-STATUS LITERAL+ LOGIN-REFERRALS MULTIAPPEND NAMESPACE QRESYNC QUOTA RIGHTS=ektx SASL-IR SEARCHRES SORT THREAD=ORDEREDSUBJECT UIDPLUS UNSELECT WITHIN XLIST] AUTHENTICATE completed
[10:52:24] IMAP4> 3 NAMESPACE
[10:52:24] IMAP4< * NAMESPACE (("" "/")) (("/home/" "/")) NIL
[10:52:24] IMAP4< 3 OK NAMESPACE completed
[10:52:24] IMAP4> 4 LIST "" Inbox1
[10:52:24] IMAP4< 4 OK LIST completed
[10:52:24] IMAP4> 5 CREATE Inbox1
[10:52:24] IMAP4< 5 OK CREATE completed
[10:52:24] IMAP4> 6 LIST "" Inbox1
[10:52:24] IMAP4< * LIST (\HasNoChildren) "/" "Inbox1"
[10:52:24] IMAP4< 6 OK LIST completed
[10:52:28] IMAP4> 7 STATUS Inbox1 (MESSAGES RECENT UIDNEXT UIDVALIDITY UNSEEN)
[10:52:28] IMAP4< * STATUS "Inbox1" (MESSAGES 0 RECENT 0 UIDNEXT 21266 UIDVALIDITY 168112 UNSEEN 0)
[10:52:28] IMAP4< 7 OK STATUS completed
[10:52:31] IMAP4> 8 SELECT Inbox1
[10:52:31] IMAP4< * 0 EXISTS
[10:52:31] IMAP4< * 0 RECENT
[10:52:31] IMAP4< * OK [UIDVALIDITY 168112] UIDs are valid for this mailbox
[10:52:31] IMAP4< * OK [UIDNEXT 21266] next expected UID is 21266
[10:52:31] IMAP4< * FLAGS (\Answered \Deleted \Draft \Flagged \Seen $Forwarded $MDNSent Forwarded $Junk $NotJunk Junk JunkRecorded NonJunk NotJunk reference $label2 $label3 $label1 $label4 $label5)
[10:52:31] IMAP4< * OK [PERMANENTFLAGS (\Answered \Deleted \Draft \Flagged \Seen $Forwarded $MDNSent Forwarded reference $label2 $label3 $label1 $label4 $label5 \*)] junk-related flags are not permanent
[10:52:31] IMAP4< * OK [HIGHESTMODSEQ 168112] modseq tracked on this mailbox
[10:52:31] IMAP4< 8 OK [READ-WRITE] SELECT completed
[10:54:20] IMAP4> 9 NOOP
[10:54:20] IMAP4< 9 OK NOOP completed
[10:54:20] IMAP4> 10 CLOSE
[10:54:20] IMAP4< 10 OK CLOSE completed
[10:54:27] IMAP4> 11 SELECT Inbox1
[10:54:27] IMAP4< * 0 EXISTS
[10:54:27] IMAP4< * 0 RECENT
[10:54:27] IMAP4< * OK [UIDVALIDITY 168112] UIDs are valid for this mailbox
[10:54:27] IMAP4< * OK [UIDNEXT 21266] next expected UID is 21266
[10:54:27] IMAP4< * FLAGS (\Answered \Deleted \Draft \Flagged \Seen $Forwarded $MDNSent Forwarded $Junk $NotJunk Junk JunkRecorded NonJunk NotJunk reference $label2 $label3 $label1 $label4 $label5)
[10:54:27] IMAP4< * OK [PERMANENTFLAGS (\Answered \Deleted \Draft \Flagged \Seen $Forwarded $MDNSent Forwarded reference $label2 $label3 $label1 $label4 $label5 \*)] junk-related flags are not permanent
[10:54:27] IMAP4< * OK [HIGHESTMODSEQ 168112] modseq tracked on this mailbox
[10:54:27] IMAP4< 11 OK [READ-WRITE] SELECT completed

_________________
Noob
With experience of Mint and trying to learn more by intalling Gentoo
Motherboard = MS-7211- MICRO-STAR INTERNATIONAL CO., LTD
CPU = Intel(R) Celeron(R) CPU 2.80GHz version: 15.4.9
Memory = 2GB
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Sun Feb 01, 2015 6:49 am    Post subject: Reply with quote

IDK much about email, but it appears to have decided your inbox is called "Inbox1" and created that for you.
OFC there's nothing in it; though it does mean your connection is good, afaics.
Back to top
View user's profile Send private message
catchpole
Tux's lil' helper
Tux's lil' helper


Joined: 03 Sep 2014
Posts: 103
Location: Leeds UK

PostPosted: Sun Feb 01, 2015 7:31 am    Post subject: Reply with quote

Hi steveL,

Using my usual Linux Mint box, I've just checked my account on the web rather than using my usual Thunderbird.
The "Inbox1" appears there but not in my Thunderbird email client.

I named the "Inbox" as "Inbox1" so I wouldn't get it mixed up with any existing Inbox.

If I change it to "Inbox", will it overwrite my existing Inbox and email messages?

The port was set at 993 which I changed to 143. So I need to look again at letting Sylpheed make the folders.

Thanks for pointing that out. Its given me some direction.

Watch this space.

EDIT
I've just let Sylpheed build the folder tree and now I can get incoming mail.
So everything is now working as it should.

steveL, Thanks again for the pointer.
_________________
Noob
With experience of Mint and trying to learn more by intalling Gentoo
Motherboard = MS-7211- MICRO-STAR INTERNATIONAL CO., LTD
CPU = Intel(R) Celeron(R) CPU 2.80GHz version: 15.4.9
Memory = 2GB
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Sun Feb 01, 2015 2:43 pm    Post subject: Reply with quote

Good one :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum