Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Gelöst]Benötige Hilfe Bezüglich xorg mit Nvidia
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
dekoding
n00b
n00b


Joined: 26 Jan 2015
Posts: 34

PostPosted: Mon Jan 26, 2015 10:10 pm    Post subject: [Gelöst]Benötige Hilfe Bezüglich xorg mit Nvidia Reply with quote

Huhu ihrs Hab ab heute es geschaft Gentoo zum laufen zu bringen es ist echt super wirklich ich freunde mich auch noch an mit gentoo

ich taste mich langsam und schrittweise an mir ist bewußt das noch sehr viel gemacht werden muss *lächle* aber ich kann stolz sagen ich hab gentoo *megafreu* da lohnt es sich jede harte arbeit
ich hab ein prob sobald wen ich meiner xorg config sage er soll nvidia nehmen und nicht nouveau

bekomme ich diese meldung

Code:

[     8.491] (EE) Failed to load /usr/lib64/xorg/modules/libglamoregl.so: /usr/$
[     8.491] (II) UnloadModule: "glamoregl"
[     8.491] (II) Unloading glamoregl
[     8.491] (EE) Failed to load module "glamoregl" (loader failed, 7)


linux header und glamor ist installiert ich habe mich auch an die wiki anleitung gehalten beuüglich Nvidia

Code:
Portage 2.2.14 (python 2.7.9-final-0, default/linux/amd64/13.0/desktop/kde, gcc-4.8.3, glibc-2.19-r1, 3.17.7-gentoo x86_64)
=================================================================
System uname: Linux-3.17.7-gentoo-x86_64-Intel-R-_Core-TM-_i7-4771_CPU_@_3.50GHz-with-gentoo-2.2
KiB Mem:    11210560 total,   9829252 free
KiB Swap:   12582908 total,  12582908 free
Timestamp of tree: Mon, 26 Jan 2015 16:45:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p53
dev-lang/perl:            5.18.2-r2
dev-lang/python:          2.7.9-r1, 3.3.5-r1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.4
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.swin.edu.au/gentoo http://ftp.swin.edu.au/gentoo ftp://gentoo.inode.at/source/ http://gentoo.inode.at/ ftp://gd.tuwien.ac.at/opsys/linux/gentoo/ http://gd.tuwien.ac.at/opsys/linux/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://ftp.halifax.rwth-aachen.de/gentoo/ rsync://ftp.halifax.rwth-aachen.de/gentoo/ ftp://ftp.halifax.rwth-aachen.de/gentoo/"
LANG="de_DE.iso885915@euro"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync10.de.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gt4 iconv ipv6 jpeg kde kipi lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qt3support qt4 readline sdl semantic-desktop session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Edit: ich habe Das problem Gelöst ich bin ja so richtig stolz auf mich *grinst breit*

Meine nvifia 660 TI Funktioniert endlich.

was ich gemacht habe ich habe im kernel enable KMS makiert und in der grafich ebene ein verweis raus genomen.
und bin dann in mein Bios rein gegangen und habe die Aktuele onboard Deakteviert,
Dachte erst wie gennto starte und die schrieft zu ende war und der monitor schwarz wurde das es nicht gefunkt hat aber sihe da es hat doch gefunkt nach cirka 2 sekunden ist mein KDE erschienen endlich *schwitz*

Code:
[     9.868] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20130102)
[     9.868] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 660 Ti (GK104) at PCI:1:0:0 (GPU-0)
[     9.868] (--) NVIDIA(0): Memory: 2097152 kBytes
[     9.868] (--) NVIDIA(0): VideoBIOS: 80.04.4b.00.5a
[     9.868] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[     9.879] (--) NVIDIA(0): Valid display device(s) on GeForce GTX 660 Ti at PCI:1:0:0
[     9.879] (--) NVIDIA(0):     BenQ T2200HD (CRT-0) (boot, connected)


Last edited by dekoding on Fri Jan 30, 2015 2:54 pm; edited 2 times in total
Back to top
View user's profile Send private message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 205
Location: Wien

PostPosted: Tue Jan 27, 2015 12:03 pm    Post subject: Reply with quote

Soweit mir bekannt, ist die Konfiguration über eine /etc/X11/xorg.conf Datei veraltet und zu vermeiden.
Stattdessen sollte in der Datei /etc/portage/make.conf z.b folgender Eintrag stehen
Code:

 # X11 Settings
 INPUT_DEVICES="evdev"
 VIDEO_CARDS="nvidia"

Danach Xorg und Nvidia Treiber installieren mit
Code:

# emerge xorg-server
# emerge nvidia-drivers

Kann auch nicht schaden
Code:
# env-update
# source /etc/profile

Keyboard und Maus wird über /etc/X11/xorg.conf.d/10-evdev.conf konfiguriert
wenn dann alles bereit, einfach mal testen mit
Code:
# startx
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1733
Location: St. Wendel

PostPosted: Tue Jan 27, 2015 12:52 pm    Post subject: Reply with quote

Für nvidia braucht man leider noch Teile der xorg.conf, AFAIK.

Das Problem hier dürfte ein vergessenes "eselect opengl" sein.

Außerdem darf natürlich noveau nicht geladen sein.

Bye
Py
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Tue Jan 27, 2015 2:52 pm    Post subject: Reply with quote

Moin,
zunächst einmal Willkommen bei Gentoo und im Forum.

Neben den genannten Tips (/etc/X11/xorg.conf.d als Konfigurationsverzeichnis reicht aus, eine Datei xorg.conf ist nicht mehr erforderlich) fehlt Dir dann wohl auch noch folgender Schnipsel:

$ cat /etc/X11/xorg.conf.d/20-nvidia.conf
Code:

Section "Device"
        Identifier      "Device0"
        Driver          "nvidia"
        VendorName      "NVIDIA Corporation"
EndSection

Section "Screen"
       Identifier     "Default Screen"
       Device         "nVidia Corporation GK106 [GeForce 660 GTX]"
       Monitor        "Generic Monitor"
       DefaultDepth    24
       SubSection "Display"
               Depth       24
               Modes      "1980x1200"
       EndSubSection
EndSection

Danach nimmt Dein System dann auch das NVidia-Modul und nicht mehr nouveau ... die Werte müsstest Du natürlich etwas an Deine Grafikkarte anpassen.

Viel Erfolg ...
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3650
Location: Germany

PostPosted: Tue Jan 27, 2015 3:38 pm    Post subject: Reply with quote

Nutze am besten auch die Info vom Wiki :)
http://wiki.gentoo.org/wiki/NVidia
Back to top
View user's profile Send private message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 205
Location: Wien

PostPosted: Wed Jan 28, 2015 11:23 am    Post subject: Reply with quote

Bei mir funktionierts auch ohne /etc/X11/xorg.conf.d/20-nvidia.conf
die Datei gibt es zwar, aber die ist leer (Größe 0 Byte)
Aber um bei der Sache zu bleiben:
Der Fragesteller: dekoding sollte mal sagen ob er überhaupt eine grafische Benutzeroberfläche starten kann,
oder ob es nur darum geht den Treiber zu ändern
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3650
Location: Germany

PostPosted: Wed Jan 28, 2015 12:13 pm    Post subject: Reply with quote

oliver2104 wrote:
Bei mir funktionierts auch ohne /etc/X11/xorg.conf.d/20-nvidia.conf
die Datei gibt es zwar, aber die ist leer (Größe 0 Byte)

Sorry nein. Unter Gentoo wirst du dem xorg-server mitteilen müssen wenn ein proprietärer Treiber wie zb nvidia oder fglrx genutzt werden soll (ob nun in einer xorg.conf oder in einer /X11/xorg.conf.d/datei ist wurscht.
Bei anderen Distributionen ist dies mitunter anders, da die ihre xorg-server patchen - gentoo macht das nicht.
Back to top
View user's profile Send private message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 205
Location: Wien

PostPosted: Thu Jan 29, 2015 11:12 am    Post subject: Reply with quote

Bei mir läuft 3.16.5-gentoo und soweit ich mich erinnere musste ich nur /etc/portage/make.conf
manuell anpassen d.h dort den Eintrag: VIDEO_CARDS="nvidia" setzen.
Hab wirklich keine xorg.conf und /etc/X11/xorg.conf.d/20-nvidia.conf ist wirklich eine 0 Byte Datei.

Leider sind gerade jetzt auf www.gentoo.de die Seiten zur Gentoo-Desktop Dokumentation nicht erreichbar.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3650
Location: Germany

PostPosted: Thu Jan 29, 2015 12:17 pm    Post subject: Reply with quote

oliver2104 wrote:
Hab wirklich keine xorg.conf und /etc/X11/xorg.conf.d/20-nvidia.conf ist wirklich eine 0 Byte Datei.
Dann hast du es irgendwo anders gesetzt.
Schau zb in der Xorg.0.log welche config directory genutzt werden - dort sollte sich finden lassen aus welcher Config die Angabe stammt.

Um sicher zu gehen hab ich es einfach ausprobiert (sprich, ohne Angabe des Treibers in der X Konfiguration) :)
Die Fehlermeldung lautet dann (wie erwartet)
(EE) No drivers available.

Quote:
Leider sind gerade jetzt auf www.gentoo.de die Seiten zur Gentoo-Desktop Dokumentation nicht erreichbar.
Die Dokumentation wurde vor ein paar Tagen ins http://wiki.gentoo.org migriert - die Dokumentation findet sich nun dort.
Back to top
View user's profile Send private message
dekoding
n00b
n00b


Joined: 26 Jan 2015
Posts: 34

PostPosted: Thu Jan 29, 2015 6:04 pm    Post subject: Reply with quote

Guten abend ihr lieben

ich hatte vor gehabt meine nvidia 660 TI pzw überhaubt meine zwei nvidia zu aktevieren damit ich auch maö wieder youtube guggn kann.

ich habe eine onboard nvidia ... wieso auch immer xDD
und ich habe eine reinzustecken mir fehlt nun nicht der fach begriff ein sorry

ich bin jetzt auch gerade am lapi damit ich schreiben kann usw da ich gentoo neu installieren musste

und jetzt sitzt ich mal am xorg einzu stellen mit einigen tipps und infos von euch.

aktueller stand das ich nvidia installiere und danach mach ich die xorg.conf einstellung.

ich frage mich nur wo ich im kernel sage das er auch die nicht onboard grafich card erlaubt denn zurzeit fahre ich mit meiner onboard card.

wen ich es geschaft habe oder auch nicht was ich ned hoffe xD geb ich euch natürlich bescheid auf jedenfals herzlichen dank an alle !!! und sorry wegen das lange warten
Back to top
View user's profile Send private message
dekoding
n00b
n00b


Joined: 26 Jan 2015
Posts: 34

PostPosted: Fri Jan 30, 2015 11:34 am    Post subject: Reply with quote

so mein latein ist am ende :(

xauth filen /home/username/.serverauth does not exist

und dann schaute ich mir meine xorg logs durch und da steht

ee no devices detected.
ee fatal server error:
ee no screens found.

dabei habe ich ja in der xorg.conf.d denn 20.nvidia.conf auch eingerichtet

es ist egal ob ich nun eine nvidia-xconfig mache und die xorg.conf habe oder nicht, der fehler besteht

ich habe die wikis befolgt und auch beim genkernel --menuconfig all sehr aufgepasst.

woran kann das nur liegen hmm
_________________
habt nach sicht ich leide unter starke legastheni.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3650
Location: Germany

PostPosted: Fri Jan 30, 2015 3:04 pm    Post subject: Re: [Gelöst]Benötige Hilfe Bezüglich xorg mit Nvidia Reply with quote

dekoding wrote:
Edit: ich habe Das problem Gelöst ich bin ja so richtig stolz auf mich *grinst breit*

Meine nvifia 660 TI Funktioniert endlich.

was ich gemacht habe ich habe im kernel enable KMS makiert und in der grafich ebene ein verweis raus genomen.
und bin dann in mein Bios rein gegangen und habe die Aktuele onboard Deakteviert,
Dachte erst wie gennto starte und die schrieft zu ende war und der monitor schwarz wurde das es nicht gefunkt hat aber sihe da es hat doch gefunkt nach cirka 2 sekunden ist mein KDE erschienen endlich *schwitz*

Code:
[     9.868] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20130102)
[     9.868] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 660 Ti (GK104) at PCI:1:0:0 (GPU-0)
[     9.868] (--) NVIDIA(0): Memory: 2097152 kBytes
[     9.868] (--) NVIDIA(0): VideoBIOS: 80.04.4b.00.5a
[     9.868] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[     9.879] (--) NVIDIA(0): Valid display device(s) on GeForce GTX 660 Ti at PCI:1:0:0
[     9.879] (--) NVIDIA(0):     BenQ T2200HD (CRT-0) (boot, connected)

Hehe, prima :)
Back to top
View user's profile Send private message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 205
Location: Wien

PostPosted: Mon Feb 02, 2015 8:43 am    Post subject: Reply with quote

Es freut mich, dass dekoding sein Problem gelöst hat.
Möchte euch auch nicht weiter langweilen oder das Thema unnötig strapazieren
aber das interessiert mich doch noch:
Quote:
Schau zb in der Xorg.0.log welche config directory genutzt werden - dort sollte sich finden lassen aus welcher Config die Angabe stammt.

darum poste ich jetzt noch meine komplette Xorg.0.log
Code:

[    31.043]
X.Org X Server 1.15.2
Release Date: 2014-06-27
[    31.044] X Protocol Version 11, Revision 0
[    31.044] Build Operating System: Linux 3.16.5-gentoo i686 Gentoo
[    31.044] Current Operating System: Linux geo.gentoo32 3.16.5-gentoo #2 SMP PREEMPT Sat Jan 31 12:10:41 CET 2015 i686
[    31.044] Kernel command line: BOOT_IMAGE=Gentoo ro root=812
[    31.044] Build Date: 12 January 2015  11:20:41AM
[    31.045] 
[    31.045] Current version of pixman: 0.32.4
[    31.045]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    31.045] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    31.048] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Feb  2 08:59:23 2015
[    31.080] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    31.080] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    31.109] (==) No Layout section.  Using the first Screen section.
[    31.109] (**) |-->Screen "Screen0" (0)
[    31.109] (**) |   |-->Monitor "Monitor0"
[    31.109] (**) |   |-->Device "Card0"
[    31.109] (==) Automatically adding devices
[    31.109] (==) Automatically enabling devices
[    31.109] (==) Automatically adding GPU devices
[    31.141] (==) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[    31.141] (==) ModulePath set to "/usr/lib/xorg/modules"
[    31.141] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    31.141] (II) Loader magic: 0x8266640
[    31.141] (II) Module ABI versions:
[    31.141]    X.Org ANSI C Emulation: 0.4
[    31.141]    X.Org Video Driver: 15.0
[    31.141]    X.Org XInput driver : 20.0
[    31.141]    X.Org Server Extension : 8.0
[    31.141] (II) xfree86: Adding drm device (/dev/dri/card0)
[    31.142] (--) PCI:*(0:1:0:0) 10de:1200:1462:2600 rev 161, Mem @ 0xf8000000/33554432, 0xc8000000/134217728, 0xd0000000/67108864, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[    31.142] (--) PCI: (0:6:1:0) 4444:0803:0070:4000 rev 1, Mem @ 0xd8000000/67108864
[    31.143] Initializing built-in extension Generic Event Extension
[    31.143] Initializing built-in extension SHAPE
[    31.143] Initializing built-in extension MIT-SHM
[    31.143] Initializing built-in extension XInputExtension
[    31.144] Initializing built-in extension XTEST
[    31.144] Initializing built-in extension BIG-REQUESTS
[    31.144] Initializing built-in extension SYNC
[    31.144] Initializing built-in extension XKEYBOARD
[    31.144] Initializing built-in extension XC-MISC
[    31.145] Initializing built-in extension XINERAMA
[    31.145] Initializing built-in extension XFIXES
[    31.145] Initializing built-in extension RENDER
[    31.145] Initializing built-in extension RANDR
[    31.145] Initializing built-in extension COMPOSITE
[    31.146] Initializing built-in extension DAMAGE
[    31.146] Initializing built-in extension MIT-SCREEN-SAVER
[    31.146] Initializing built-in extension DOUBLE-BUFFER
[    31.146] Initializing built-in extension RECORD
[    31.146] Initializing built-in extension DPMS
[    31.147] Initializing built-in extension Present
[    31.147] Initializing built-in extension DRI3
[    31.147] Initializing built-in extension X-Resource
[    31.147] Initializing built-in extension XVideo
[    31.147] Initializing built-in extension XVideo-MotionCompensation
[    31.148] Initializing built-in extension XFree86-VidModeExtension
[    31.148] Initializing built-in extension XFree86-DGA
[    31.148] Initializing built-in extension XFree86-DRI
[    31.148] Initializing built-in extension DRI2
[    31.148] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    31.148] (II) LoadModule: "glx"
[    31.180] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    31.898] (II) Module glx: vendor="NVIDIA Corporation"
[    31.898]    compiled for 4.0.2, module version = 1.0.0
[    31.898]    Module class: X.Org Server Extension
[    31.898] (II) NVIDIA GLX Module  343.36  Mon Dec  1 15:51:16 PST 2014
[    31.898] Loading extension GLX
[    31.898] (II) LoadModule: "nvidia"
[    31.898] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    31.969] (II) Module nvidia: vendor="NVIDIA Corporation"
[    31.969]    compiled for 4.0.2, module version = 1.0.0
[    31.969]    Module class: X.Org Video Driver
[    31.972] (II) NVIDIA dlloader X Driver  343.36  Mon Dec  1 15:27:47 PST 2014
[    31.972] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    31.973] (--) using VT number 7

[    31.978] (II) Loading sub module "fb"
[    31.978] (II) LoadModule: "fb"
[    31.978] (II) Loading /usr/lib/xorg/modules/libfb.so
[    31.987] (II) Module fb: vendor="X.Org Foundation"
[    31.987]    compiled for 1.15.2, module version = 1.0.0
[    31.987]    ABI class: X.Org ANSI C Emulation, version 0.4
[    31.987] (II) Loading sub module "wfb"
[    31.987] (II) LoadModule: "wfb"
[    31.987] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    31.989] (II) Module wfb: vendor="X.Org Foundation"
[    31.989]    compiled for 1.15.2, module version = 1.0.0
[    31.989]    ABI class: X.Org ANSI C Emulation, version 0.4
[    31.990] (II) Loading sub module "ramdac"
[    31.990] (II) LoadModule: "ramdac"
[    31.990] (II) Module "ramdac" already built-in
[    31.991] (II) NVIDIA(0): Creating default Display subsection in Screen section
   "Screen0" for depth/fbbpp 24/32
[    31.991] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    31.991] (==) NVIDIA(0): RGB weight 888
[    31.991] (==) NVIDIA(0): Default visual is TrueColor
[    31.991] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    31.993] (**) NVIDIA(0): Enabling 2D acceleration
[    32.571] (II) NVIDIA(0): Display (Ancor Communications Inc VS248 (DFP-0)) does not
[    32.571] (II) NVIDIA(0):     support NVIDIA 3D Vision stereo.
[    32.571] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20130102)
[    32.572] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 560 Ti (GF114) at PCI:1:0:0 (GPU-0)
[    32.572] (--) NVIDIA(0): Memory: 1048576 kBytes
[    32.572] (--) NVIDIA(0): VideoBIOS: 70.24.11.00.00
[    32.572] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    32.592] (--) NVIDIA(0): Valid display device(s) on GeForce GTX 560 Ti at PCI:1:0:0
[    32.592] (--) NVIDIA(0):     CRT-0
[    32.592] (--) NVIDIA(0):     CRT-1
[    32.592] (--) NVIDIA(0):     Ancor Communications Inc VS248 (DFP-0) (boot, connected)
[    32.592] (--) NVIDIA(0):     DFP-1
[    32.592] (--) NVIDIA(0):     DFP-2
[    32.592] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[    32.592] (--) NVIDIA(GPU-0): CRT-1: 400.0 MHz maximum pixel clock
[    32.592] (--) NVIDIA(0): Ancor Communications Inc VS248 (DFP-0): Internal TMDS
[    32.592] (--) NVIDIA(GPU-0): Ancor Communications Inc VS248 (DFP-0): 330.0 MHz maximum pixel clock
[    32.592] (--) NVIDIA(0): DFP-1: Internal TMDS
[    32.592] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[    32.592] (--) NVIDIA(0): DFP-2: Internal TMDS
[    32.592] (--) NVIDIA(GPU-0): DFP-2: 330.0 MHz maximum pixel clock
[    32.592] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[    32.592] (**) NVIDIA(0):     device Ancor Communications Inc VS248 (DFP-0) (Using EDID
[    32.592] (**) NVIDIA(0):     frequencies has been enabled on all display devices.)
[    32.593] (==) NVIDIA(0):
[    32.593] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[    32.593] (==) NVIDIA(0):     will be used as the requested mode.
[    32.593] (==) NVIDIA(0):
[    32.593] (II) NVIDIA(0): Validated MetaModes:
[    32.593] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select"
[    32.593] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[    32.628] (--) NVIDIA(0): DPI set to (92, 91); computed from "UseEdidDpi" X config
[    32.628] (--) NVIDIA(0):     option
[    32.628] (--) Depth 24 pixmap format is 32 bpp
[    32.628] (II) NVIDIA: Using 1024.00 MB of virtual memory for indirect memory
[    32.628] (II) NVIDIA:     access.
[    32.630] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[    32.630] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[    32.630] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[    32.630] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[    32.630] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[    32.630] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[    32.630] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[    32.630] (II) NVIDIA(0):     Config Options in the README.
[    32.649] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[    32.687] Loading extension NV-GLX
[    32.755] (==) NVIDIA(0): Disabling shared memory pixmaps
[    32.755] (==) NVIDIA(0): Backing store enabled
[    32.755] (==) NVIDIA(0): Silken mouse enabled
[    32.756] (==) NVIDIA(0): DPMS enabled
[    32.756] Loading extension NV-CONTROL
[    32.756] Loading extension XINERAMA
[    32.756] (II) Loading sub module "dri2"
[    32.756] (II) LoadModule: "dri2"
[    32.756] (II) Module "dri2" already built-in
[    32.756] (II) NVIDIA(0): [DRI2] Setup complete
[    32.756] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    32.756] (--) RandR disabled
[    32.761] (II) Initializing extension GLX
[    33.156] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[    33.156] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    33.156] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    33.156] (II) LoadModule: "evdev"
[    33.156] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    33.177] (II) Module evdev: vendor="X.Org Foundation"
[    33.177]    compiled for 1.15.2, module version = 2.8.2
[    33.177]    Module class: X.Org XInput Driver
[    33.177]    ABI class: X.Org XInput driver, version 20.0
[    33.177] (II) Using input driver 'evdev' for 'Power Button'
[    33.177] (**) Power Button: always reports core events
[    33.177] (**) evdev: Power Button: Device: "/dev/input/event1"
[    33.178] (--) evdev: Power Button: Vendor 0 Product 0x1
[    33.178] (--) evdev: Power Button: Found keys
[    33.178] (II) evdev: Power Button: Configuring as keyboard
[    33.178] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[    33.178] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    33.178] (**) Option "xkb_rules" "evdev"
[    33.178] (**) Option "xkb_model" "pc105"
[    33.178] (**) Option "xkb_layout" "de"
[    33.178] (**) Option "xkb_variant" "nodeadkeys"
[    33.178] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    33.206] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[    33.206] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    33.206] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    33.206] (II) Using input driver 'evdev' for 'Power Button'
[    33.206] (**) Power Button: always reports core events
[    33.206] (**) evdev: Power Button: Device: "/dev/input/event0"
[    33.206] (--) evdev: Power Button: Vendor 0 Product 0x1
[    33.206] (--) evdev: Power Button: Found keys
[    33.206] (II) evdev: Power Button: Configuring as keyboard
[    33.206] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0/event0"
[    33.206] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[    33.206] (**) Option "xkb_rules" "evdev"
[    33.206] (**) Option "xkb_model" "pc105"
[    33.206] (**) Option "xkb_layout" "de"
[    33.206] (**) Option "xkb_variant" "nodeadkeys"
[    33.206] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    33.206] (II) config/udev: Adding drm device (/dev/dri/card0)
[    33.206] (II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/event3)
[    33.206] (**) Logitech USB-PS/2 Optical Mouse: Applying InputClass "evdev pointer catchall"
[    33.206] (**) Logitech USB-PS/2 Optical Mouse: Applying InputClass "evdev pointer catchall"
[    33.206] (II) Using input driver 'evdev' for 'Logitech USB-PS/2 Optical Mouse'
[    33.206] (**) Logitech USB-PS/2 Optical Mouse: always reports core events
[    33.206] (**) evdev: Logitech USB-PS/2 Optical Mouse: Device: "/dev/input/event3"
[    33.206] (--) evdev: Logitech USB-PS/2 Optical Mouse: Vendor 0x46d Product 0xc050
[    33.206] (--) evdev: Logitech USB-PS/2 Optical Mouse: Found 12 mouse buttons
[    33.206] (--) evdev: Logitech USB-PS/2 Optical Mouse: Found scroll wheel(s)
[    33.206] (--) evdev: Logitech USB-PS/2 Optical Mouse: Found relative axes
[    33.206] (--) evdev: Logitech USB-PS/2 Optical Mouse: Found x and y relative axes
[    33.206] (II) evdev: Logitech USB-PS/2 Optical Mouse: Configuring as mouse
[    33.206] (II) evdev: Logitech USB-PS/2 Optical Mouse: Adding scrollwheel support
[    33.206] (**) evdev: Logitech USB-PS/2 Optical Mouse: YAxisMapping: buttons 4 and 5
[    33.206] (**) evdev: Logitech USB-PS/2 Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    33.206] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/0003:046D:C050.0001/input/input3/event3"
[    33.206] (II) XINPUT: Adding extended input device "Logitech USB-PS/2 Optical Mouse" (type: MOUSE, id 8)
[    33.206] (II) evdev: Logitech USB-PS/2 Optical Mouse: initialized for relative axes.
[    33.206] (**) Logitech USB-PS/2 Optical Mouse: (accel) keeping acceleration scheme 1
[    33.206] (**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration profile 0
[    33.206] (**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration factor: 2.000
[    33.206] (**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration threshold: 4
[    33.207] (II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/mouse0)
[    33.207] (II) No input driver specified, ignoring this device.
[    33.207] (II) This device may have been added with another device file.
[    33.207] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event2)
[    33.207] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    33.207] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    33.207] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[    33.207] (**) AT Translated Set 2 keyboard: always reports core events
[    33.207] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event2"
[    33.207] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[    33.207] (--) evdev: AT Translated Set 2 keyboard: Found keys
[    33.207] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[    33.207] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input2/event2"
[    33.207] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 9)
[    33.207] (**) Option "xkb_rules" "evdev"
[    33.207] (**) Option "xkb_model" "pc105"
[    33.207] (**) Option "xkb_layout" "de"
[    33.207] (**) Option "xkb_variant" "nodeadkeys"
[    33.207] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    35.906] (II) NVIDIA(GPU-0): Display (Ancor Communications Inc VS248 (DFP-0)) does not
[    35.906] (II) NVIDIA(GPU-0):     support NVIDIA 3D Vision stereo.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3650
Location: Germany

PostPosted: Mon Feb 02, 2015 10:33 am    Post subject: Reply with quote

oliver2104 wrote:
Code:
[    31.080] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    31.080] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
Hehe, ist ja spannend :)
Ich sah grade das einige nvidia-drivers-346er Versionen nun folgende config mit installieren
/usr/share/X11/xorg.conf.d/50-nvidia-drm-outputclass.conf:
# This xorg.conf.d configuration snippet configures the X server to
# automatically load the nvidia driver when it detects a device driven by the
# nvidia.ko kernel module.  Please note that this only works on Linux kernels
# version 3.9 or higher with CONFIG_DRM enabled, and only if the nvidia.ko
# kernel module is loaded before the X server is started.

Section "OutputClass"
    Identifier     "nvidia"
    MatchDriver    "nvidia-drm"
    Driver         "nvidia"
EndSection
Wenn diese Vorausetzungen bei dir erfüllt sind - ja dann könnte es wohl tatsächlich auch ohne selbst angelegte (xorg.conf) funktionieren.

thx fürs nachbohren - kannte ich so auch noch nicht :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum