Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201502-01 ] mpg123
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2226

PostPosted: Fri Feb 06, 2015 3:26 pm    Post subject: [ GLSA 201502-01 ] mpg123 Reply with quote

Gentoo Linux Security Advisory

Title: mpg123: User-assisted execution of arbitrary code (GLSA 201502-01)
Severity: normal
Exploitable: remote
Date: February 06, 2015
Bug(s): #500262
ID: 201502-01

Synopsis

A vulnerability has been found in mpg123, which could result in
arbitrary code execution.


Background

mpg123 is a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and
3.


Affected Packages

Package: media-sound/mpg123
Vulnerable: < 1.18.1
Unaffected: >= 1.18.1
Architectures: All supported architectures


Description

An issue has been found in mpg123 when decoding specifically crafted MP3
file, that causes a heap-based buffer overflow.


Impact

A remote attacker could entice a user to open a specially crafted MPEG
file using mpg123, possibly resulting in execution of arbitrary code with
the privileges of the process or a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All mpg123 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=media-sound/mpg123-1.18.1"
   


References

CVE-2014-9497


Last edited by GLSA on Thu Jun 18, 2015 4:16 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum