Joined: 12 May 2004
|Posted: Fri Feb 06, 2015 3:26 pm Post subject: [ GLSA 201502-01 ] mpg123
|Gentoo Linux Security Advisory
Title: mpg123: User-assisted execution of arbitrary code (GLSA 201502-01)
Date: February 06, 2015
A vulnerability has been found in mpg123, which could result in
arbitrary code execution.
mpg123 is a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and
Vulnerable: < 1.18.1
Unaffected: >= 1.18.1
Architectures: All supported architectures
An issue has been found in mpg123 when decoding specifically crafted MP3
file, that causes a heap-based buffer overflow.
A remote attacker could entice a user to open a specially crafted MPEG
file using mpg123, possibly resulting in execution of arbitrary code with
the privileges of the process or a Denial of Service condition.
There is no known workaround at this time.
All mpg123 users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=media-sound/mpg123-1.18.1"
Last edited by GLSA on Thu Jun 18, 2015 4:16 am; edited 1 time in total