Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Block: libtool blockt libltdl
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Mon Feb 09, 2015 10:57 am    Post subject: Block: libtool blockt libltdl Reply with quote

Hi,

bis jetzt habe ich jeden Block gelöst bekommen. Aber hier muss ich kapitulieren und dass obwohl ich fast 100% stable fahre:

Code:

[...]
media-libs/flac-1.3.1-r1  USE="cxx ogg (-altivec) -debug -static-libs (-sse%*)" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="sse%*" 0 KiB
[ebuild     UD ]    sys-devel/libtool-2.4.2-r1:2 [2.4.4:2] USE="-static-libs% {-test%} -vanilla" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[...]
[blocks B      ] <sys-devel/libtool-2.4.3-r2:2 ("<sys-devel/libtool-2.4.3-r2:2" is blocking dev-libs/libltdl-2.4.4)
[...]
(dev-libs/libltdl-2.4.4:0/0::gentoo, installed) pulled in by
    dev-libs/libltdl:0 required by (media-gfx/imagemagick-6.9.0.3:0/6.9.0.3::gentoo, installed)
    dev-libs/libltdl:0 required by (dev-libs/redland-1.0.16:0/0::gentoo, installed)

  (sys-devel/libtool-2.4.2-r1:2/2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-devel/libtool-2.4 required by (media-sound/vorbis-tools-1.4.0-r2:0/0::gentoo, installed)
    >=sys-devel/libtool-2.4 required by (x11-apps/xgamma-1.0.5:0/0::gentoo, installed)
    >=sys-devel/libtool-2.4 required by (x11-libs/libXp-1.0.2:0/0::gentoo, installed)
[...]
[...]
[...]


Habt ihr da einen Rat?

Vielen Dank
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Mon Feb 09, 2015 11:01 am    Post subject: Reply with quote

libtool -2.4.4 ist stable. Theoretisch sollte ein emerge -1 libtool helfen...
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Mon Feb 09, 2015 2:51 pm    Post subject: Reply with quote

Das Interessante ist, dass libtool schon in der stable Version 2.4.4 installiert ist.
Trotzdem kommt der Block...
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Mon Feb 09, 2015 3:48 pm    Post subject: Reply with quote

Hm, ich würde versuchen herauszubekommen welches Paket warum ein libtool Downgade fordert.
Hau doch zur Not mal vorübergehend <sys-devel/libtool-2.4.4 in die package.mask
dann sollte portage vermutlich genauer ausspucken welches Paket warum das Downgade fordert.

/edit:
Oder die komplette ungekürzte emerge Ausgabe posten - dort sollte das normal auch mit drinstehen :)
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Mon Feb 09, 2015 9:09 pm    Post subject: Reply with quote

Spannend: Nach dem Eintragen in die package.mask möchte portage das in package.use:
+=dev-libs/libltdl-2.4.4 abi_x86_32

Danach läuft alles durch.
Kann ich mir aber nicht wirklich erklären :/
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum