Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No ACPI event created
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 768

PostPosted: Mon Feb 09, 2015 4:23 pm    Post subject: No ACPI event created Reply with quote

I'm trying to get the microphone mute button to work on this ThinkPad T530. Neither acpi_listen nor xev register anything when the button is pressed.

Kernel: 3.17.8-aufs-r1
Kernel options:
Code:

CONFIG_THINKPAD_ACPI=m
CONFIG_THINKPAD_ACPI_ALSA_SUPPORT=y
# CONFIG_THINKPAD_ACPI_DEBUGFACILITIES is not set
# CONFIG_THINKPAD_ACPI_DEBUG is not set
CONFIG_THINKPAD_ACPI_UNSAFE_LEDS=y
CONFIG_THINKPAD_ACPI_VIDEO=y
CONFIG_THINKPAD_ACPI_HOTKEY_POLL=y

Related modules installed: app-laptop/tpacpi-bat-9999, sys-power/acpi_call-9999.

Mute and volume up/down work fine, as does screen brightness.

I tried this kernel patch http://permalink.gmane.org/gmane.linux.drivers.platform.x86.devel/1962, which is listed on thinkwiki. It kinda works, in that it allows one to turn the micmute button LED on and off, but it doesn't actually mute the microphone.

I found this thread, https://forums.gentoo.org/viewtopic-t-984374-postdays-0-postorder-asc-highlight-thinkpad%2Bacpi-start-25.html and tried the hotkey method, with, hhm, mixed results.
Code:

 # cat /proc/acpi/ibm/hotkey
status:      enabled
mask:      0x0000ffbb
commands:   enable, disable, reset, <mask>
 # echo "enable,0xffffffff" >/proc/acpi/ibm/hotkey
 # cat /proc/acpi/ibm/hotkey
status:      enabled
mask:      0x07fffffb
commands:   enable, disable, reset, <mask>
 #

This made the micmute button visible in xev
Code:

KeyPress event, serial 39, synthetic NO, window 0x3800001,
    root 0x2b5, subw 0x0, time 5778981, (173,-12), root:(183,54),
    state 0x0, keycode 198 (keysym 0x1008ffb2, XF86AudioMicMute), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 39, synthetic NO, window 0x3800001,
    root 0x2b5, subw 0x0, time 5778981, (173,-12), root:(183,54),
    state 0x0, keycode 198 (keysym 0x1008ffb2, XF86AudioMicMute), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

but at the same time caused these dmesg entries
Code:

[ 4899.740344] thinkpad_acpi: procfs hotkey enable/disable: access by process with PID 5188
[ 4899.740348] ------------[ cut here ]------------
[ 4899.740374] WARNING: CPU: 2 PID: 5188 at drivers/platform/x86/thinkpad_acpi.c:3924 hotkey_enabledisable_warn+0x3a/0x4d [thinkpad_acpi]()
[ 4899.740380] thinkpad_acpi: hotkey enable/disable functionality has been removed from the driver.  Hotkeys are always enabled.
[ 4899.740381] Modules linked in: tun nvidia(PO) cpufreq_ondemand bnep bluetooth ipv6 ctr ccm xt_tcpudp nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack iptable_filter ip_tables x_tables dm_crypt dm_mod vboxpci(O) vboxnetadp(O) vboxnetflt(O) vboxdrv(O) acpi_call(O) uvcvideo x86_pkg_temp_thermal coretemp videobuf2_vmalloc videobuf2_memops videobuf2_core kvm usbhid v4l2_common videodev aesni_intel i915 i2c_algo_bit aes_x86_64 drm_kms_helper glue_helper lrw gf128mul arc4 ablk_helper cryptd iwldvm drm mac80211 microcode thermal iwlwifi pcspkr thinkpad_acpi i2c_i801 e1000e ptp cfg80211 i2c_core pps_core battery nvram acpi_cpufreq video processor snd_hda_codec_realtek snd_hda_codec_generic ac thermal_sys rtc_cmos led_class rfkill intel_gtt ehci_pci snd_hda_intel ehci_hcd backlight snd_hda_controller
[ 4899.740447]  xhci_hcd usbcore lpc_ich button mfd_core usb_common snd_hda_codec snd_hwdep snd_pcm snd_timer snd [last unloaded: nvidia]
[ 4899.740462] CPU: 2 PID: 5188 Comm: bash Tainted: P           O   3.17.8-aufs-r1 #1
[ 4899.740464] Hardware name: LENOVO 2392AQU/2392AQU, BIOS G4ETA1WW (2.61 ) 05/07/2014
[ 4899.740466]  0000000000000000 ffff88009dbcbdd0 ffffffff813bd342 ffff88009dbcbe18
[ 4899.740470]  ffff88009dbcbe08 ffffffff8103aed7 ffffffffa037ff6a 0000000000000001
[ 4899.740474]  0000000000000000 ffffffffa0388b60 00007f115e21e000 ffff88009dbcbe68
[ 4899.740478] Call Trace:
[ 4899.740488]  [<ffffffff813bd342>] dump_stack+0x45/0x56
[ 4899.740493]  [<ffffffff8103aed7>] warn_slowpath_common+0x75/0x8e
[ 4899.740503]  [<ffffffffa037ff6a>] ? hotkey_enabledisable_warn+0x3a/0x4d [thinkpad_acpi]
[ 4899.740508]  [<ffffffff8103af37>] warn_slowpath_fmt+0x47/0x49
[ 4899.740517]  [<ffffffffa037ff6a>] hotkey_enabledisable_warn+0x3a/0x4d [thinkpad_acpi]
[ 4899.740524]  [<ffffffffa037fff0>] hotkey_write+0x73/0x190 [thinkpad_acpi]
[ 4899.740532]  [<ffffffffa03801d1>] dispatch_proc_write+0x88/0xb7 [thinkpad_acpi]
[ 4899.740538]  [<ffffffff811238f8>] proc_reg_write+0x45/0x64
[ 4899.740542]  [<ffffffff810db735>] vfs_write+0xb5/0x169
[ 4899.740545]  [<ffffffff810dbfd3>] SyS_write+0x42/0x86
[ 4899.740550]  [<ffffffff813c2492>] system_call_fastpath+0x16/0x1b
[ 4899.740553] ---[ end trace d2417fb2b6783481 ]---
[ 4899.740557] thinkpad_acpi: setting the hotkey mask to 0xffffffff is likely not the best way to go about it
[ 4899.740559] thinkpad_acpi: please consider using the driver defaults, and refer to up-to-date thinkpad-acpi documentation
[ 4899.741658] thinkpad_acpi: asked for hotkey mask 0xffffffff, but firmware forced it to 0x07fffffb

Also, the thinkwiki now deprecates the mask method and points to lsinput/input-events instead. So, lsinput points to event6 ("ThinkPad Extra Buttons"), and input-events gives me
Code:

 #  input-events 6
/dev/input/event6
   bustype : BUS_HOST
   vendor  : 0x17aa
   product : 0x5054
   version : 16641
   name    : "ThinkPad Extra Buttons"
   phys    : "thinkpad_acpi/input0"
   bits ev : EV_SYN EV_KEY EV_MSC EV_SW

waiting for events
16:13:47.293379: EV_MSC MSC_SCAN 26
16:13:47.293379: EV_KEY KEY_F20 pressed
16:13:47.293379: EV_SYN code=0 value=0
16:13:47.293389: EV_MSC MSC_SCAN 26
16:13:47.293389: EV_KEY KEY_F20 released
16:13:47.293389: EV_SYN code=0 value=0
 #


Finally, the mute button LEDs are mentioned in the kernel docs (thinkpad-acpi.txt), but just the LEDs, not actual mute functionality.

Apologies for the long-winded posting, but I'm trying to give as complete information as possible, and I'm not sure where to go from here.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum