Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
lspci: Cannot open/sys/bus/pci/devices/0000:00:00.0/resource
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
enoch_root
n00b
n00b


Joined: 10 Feb 2015
Posts: 3

PostPosted: Tue Feb 10, 2015 8:48 am    Post subject: lspci: Cannot open/sys/bus/pci/devices/0000:00:00.0/resource Reply with quote

Hi, looking for help or documentation to solve problem with sys-apps/pciutils. Freshly installed system. "lspci: Cannot open /sys/bus/pci/devices/0000:00:00.0/resource: No such file or directory". reemerging of lspci havent changed anything. Also there is no files or folders "resource" in the whole /sys/bus/pci/device directory.
Thanks for help.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7006

PostPosted: Tue Feb 10, 2015 4:24 pm    Post subject: Reply with quote

Code:
pwd
/sys/bus/pci/devices/0000:00:00.0
ls
broken_parity_status      dma_mask_bits  modalias  resource          vendor
class                     enable         msi_bus   subsystem
config                    irq            power     subsystem_device
consistent_dma_mask_bits  local_cpulist  remove    subsystem_vendor
device                    local_cpus     rescan    uevent

So you should have one, at least you know lspci is doing fine.
I would look at kernel (and no, no idea what option enable that, but i would dig PCI options)
Back to top
View user's profile Send private message
enoch_root
n00b
n00b


Joined: 10 Feb 2015
Posts: 3

PostPosted: Tue Feb 10, 2015 7:47 pm    Post subject: Reply with quote

thanks for quick response. digging in.
Back to top
View user's profile Send private message
enoch_root
n00b
n00b


Joined: 10 Feb 2015
Posts: 3

PostPosted: Wed Feb 11, 2015 12:23 pm    Post subject: Reply with quote

Solved the problem by enabling additional PCI options in kernel. Thanks for the hint.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7006

PostPosted: Wed Feb 11, 2015 3:15 pm    Post subject: Reply with quote

enoch_root wrote:
Solved the problem by enabling additional PCI options in kernel. Thanks for the hint.

more a guess than an hint :)
lucky me (and you)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum