Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
grub-0.97 and Windows 8.1 - please help
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Oniryczny
Guru
Guru


Joined: 01 Dec 2011
Posts: 388
Location: Poland

PostPosted: Thu Feb 12, 2015 9:12 pm    Post subject: grub-0.97 and Windows 8.1 - please help Reply with quote

Hello

I would like to add an entry to boot Windows 8.1


Can I ask for help?
_________________
cogito ergo sum
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Thu Feb 12, 2015 10:37 pm    Post subject: Reply with quote

Just any howto about adding window from any linux distro should work.
Just google for it

e.g. http://www.dedoimedo.com/computers/grub-2.html

well you need to read about the documentation of your bootlaoder and know where the configuration files and your windows files for booting are.

as booting "window" is in any bootloader the same you can use any guide for the bootloader you use as of now
Back to top
View user's profile Send private message
Oniryczny
Guru
Guru


Joined: 01 Dec 2011
Posts: 388
Location: Poland

PostPosted: Fri Feb 13, 2015 6:27 am    Post subject: Reply with quote

but the article you gave me link is for grub-2 and I do not wan't to use grub-2
I already have an entry for Windows 7

anyway I also have opensuse (with grub-2) and it does not see Windows 8 too
_________________
cogito ergo sum
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Fri Feb 13, 2015 1:14 pm    Post subject: Reply with quote

Oniryczny wrote:
but the article you gave me link is for grub-2 and I do not wan't to use grub-2
I already have an entry for Windows 7

anyway I also have opensuse (with grub-2) and it does not see Windows 8 too


just add an entry for susi grub2 for your window operating system
Back to top
View user's profile Send private message
Oniryczny
Guru
Guru


Joined: 01 Dec 2011
Posts: 388
Location: Poland

PostPosted: Fri Feb 13, 2015 2:27 pm    Post subject: Reply with quote

thought It will detect automatically as it detected Windows 7 and gentoo
_________________
cogito ergo sum
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Fri Feb 13, 2015 2:35 pm    Post subject: Reply with quote

you may ask the susi peeps why it is not detected

or just do it fast and write those rules yourself. up to you <gurantee that you know what is done and that it works>
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Fri Feb 13, 2015 2:46 pm    Post subject: Re: grub-0.97 and Windows 8.1 - please help Reply with quote

Oniryczny wrote:
I would like to add an entry to boot Windows 8.1


This is what I have in my grub.conf:
Code:
title Windows 8.1
rootnoverify (hd0,0)
makeactive
chainloader +1

Adjust (hd0,0) if your Windows install is on another partition.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
Oniryczny
Guru
Guru


Joined: 01 Dec 2011
Posts: 388
Location: Poland

PostPosted: Fri Feb 13, 2015 5:55 pm    Post subject: Reply with quote

yngwin
Your example doesn't work for me
I tried such example before I wrote this topic

I get 'booting Windows 8.1'
and an error that system was not found

I have
Code:

default 2
timeout 5
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Windows 7
rootnoverify (hd1,0)
makeactive
chainloader +1

title Windows 8.1
rootnoverify (hd2,0)
makeactive
chainloader +1

title Gentoo Linux 3.10.7
root (hd0,0)
kernel /boot/kernel-genkernel-x86_64-3.10.7-gentoo real_root=/dev/sda1
initrd /boot/initramfs-genkernel-x86_64-3.10.7-gentoo

Linux is on sda, Win7 is on sdb and Win8.1 is on sdc

from fdisk -l:
Code:

...
/dev/sdc1      2048       616447    300M Windows recovery environment
/dev/sdc2    616448       821247    100M EFI System
/dev/sdc3    821248      1083391    128M Microsoft reserved
/dev/sdc4   1083392    347617279  165,2G Microsoft basic data
...

_________________
cogito ergo sum
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Fri Feb 13, 2015 8:07 pm    Post subject: Reply with quote

Quote:
title Windows 8.1
rootnoverify (hd0,0)
makeactive
chainloader +1


you may adjust rootnoverify (hd0,0) until it works, you can edit it on the fly for test purposes with the e key in grub2 usually.

try hd1,0 hd0,1, hd2,0 hd0,2 ...... and so on until it works thats the fastest way.
Back to top
View user's profile Send private message
Oniryczny
Guru
Guru


Joined: 01 Dec 2011
Posts: 388
Location: Poland

PostPosted: Fri Feb 13, 2015 8:24 pm    Post subject: Reply with quote

I have 1,0 for Windows 7 so I thought it will work with hd2,0 but 2,0 2,1 2,2 does not work and chainloader +1 +2 not
_________________
cogito ergo sum
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Sat Feb 14, 2015 7:46 am    Post subject: Reply with quote

run
Code:
parted -l wgetpaste
and post the url returned here. wgetpaste is in portage if you have not emerged it earlier. suspect sda and sdb may need bios mode and sdc needs uefi.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Oniryczny
Guru
Guru


Joined: 01 Dec 2011
Posts: 388
Location: Poland

PostPosted: Sat Feb 14, 2015 10:12 am    Post subject: Reply with quote

I didn't get any url (guess I've never configured it)
but here's what I got

http://pastebin.com/J0KB20kP
_________________
cogito ergo sum
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Sat Feb 14, 2015 1:41 pm    Post subject: Reply with quote

Code:
/dev/sdc2    616448       821247    100M EFI System

This is most likely the problem. Grub legacy does not support EFI. You will need to either get a patched version or use another bootloader such as grub2.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Sat Feb 14, 2015 3:22 pm    Post subject: Reply with quote

does your motherboard support uefi? What is its make and model?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Oniryczny
Guru
Guru


Joined: 01 Dec 2011
Posts: 388
Location: Poland

PostPosted: Sat Feb 14, 2015 3:27 pm    Post subject: Reply with quote

of course it does it's ASUS M5A99X EVO with the latest BIOS :)

but for me the problem is that switching from grub-0.97 to grub-2 is like moving to systemd :(
_________________
cogito ergo sum
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum