Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
media-video/ffmpeg:0" is blocking media-video/libav-11.2)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Sat Feb 14, 2015 6:54 pm    Post subject: media-video/ffmpeg:0" is blocking media-video/libav-11. Reply with quote

Hallo,

ich habe hier 2 Blocks, die ich nicht auflösen kann. Habe schon verschiedene Lösungsvorschläge getestet. Leider kein Erfolg.

Code:
[ebuild     U  ] sys-libs/timezone-data-2014j [2014i-r1]
[ebuild     UD ] dev-util/boost-build-1.52.0-r1 [1.55.0]
[ebuild     U  ] dev-util/re2c-0.13.7.5 [0.13.5-r1]
[ebuild     U  ] media-libs/libquvi-scripts-0.4.21-r2 [0.4.21-r1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     UD ] dev-lang/perl-5.18.2-r2 [5.20.1-r4]
[ebuild     U  ] virtual/perl-Compress-Raw-Zlib-2.65.0 [2.60.0-r2]
[ebuild     UD ] dev-libs/boost-1.52.0-r7 [1.55.0-r2]
[ebuild   R    ] dev-libs/elfutils-0.158  USE="static-libs*"
[ebuild     U  ] media-libs/freetype-2.5.5 [2.5.3-r1]
[ebuild     U  ] www-client/lynx-2.8.8_p2 [2.8.8_rc1]
[ebuild  N     ] gnome-extra/yelp-xsl-3.12.0
[ebuild     U  ] media-libs/libquvi-scripts-0.9.20131130-r1 [0.9.20131130] ABI_X86="(64%*) (-32) (-x32)"
[ebuild   R    ] x11-proto/xcb-proto-1.10  PYTHON_TARGETS="(-python2_6%) (-python3_2%)"
[ebuild     U  ] media-libs/libsoundtouch-1.8.0-r1 [1.8.0] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] media-libs/libquvi-0.4.1-r2 [0.4.1-r1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] media-libs/libquvi-0.9.4-r1 [0.9.4] ABI_X86="(64%*) (-32) (-x32)"
[ebuild   R    ] dev-lang/ruby-2.0.0_p598  USE="(-sse2%*)" CPU_FLAGS_X86="sse2%*"
[ebuild  N     ] media-video/ffmpeg-1.2.6-r1  USE="X aac alsa bzip2 cpudetection encode hardcoded-tables iconv ieee1394 jack mp3 network pulseaudio sdl threads truetype vaapi vdpau vorbis x264 xvid zlib -aacplus (-altivec) -amr -bindist -bluray -cdio (-celt) -debug -doc -examples -faac -fdk -flite -fontconfig -frei0r -gnutls -gsm -iec61883 -jpeg2k -libass -libcaca -libsoxr -libv4l -modplug (-neon) -openal -openssl -opus -oss -pic -rtmp -schroedinger -speex -static-libs {-test} -theora -twolame -v4l (-vis) -vpx" ABI_X86="(64) (-32) (-x32)" CPU_FLAGS_X86="mmx -3dnow -3dnowext -avx -mmxext -ssse3" FFTOOLS="aviocat cws2fws ffescape ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher"
[ebuild     U  ] media-libs/sdl-gfx-2.0.25 [2.0.24-r2] ABI_X86="(64%*) (-32) (-x32)" CPU_FLAGS_X86="(-mmx)"
[ebuild  N     ] virtual/ffmpeg-9-r1  USE="X encode mp3 sdl threads truetype vaapi vdpau x264 -gsm -jpeg2k -opus -speex -theora" ABI_X86="(64) (-32) (-x32)"
[ebuild     U  ] media-libs/libquicktime-1.2.4-r1 [1.2.4] ABI_X86="(64%*) (-32) (-x32)"
[ebuild  N     ] media-plugins/gst-plugins-libav-1.2.4  USE="orc" ABI_X86="(64) (-32) (-x32)"
[ebuild     U  ] media-video/mjpegtools-2.1.0-r2 [2.1.0-r1] ABI_X86="(64%*) (-32) (-x32)"
[blocks B      ] >=media-video/libav-10 (">=media-video/libav-10" is hard blocking media-plugins/gst-plugins-libav-1.2.4)
[blocks B      ] media-video/ffmpeg:0 ("media-video/ffmpeg:0" is blocking media-video/libav-11.2)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.20.1-r4:0/5.20::gentoo, installed) pulled in by
    =dev-lang/perl-5.20* required by (virtual/perl-Compress-Raw-Zlib-2.65.0:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                   
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/XML-SAX-Base-1.80.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                   
    (and 43 more with the same problems)

  (dev-lang/perl-5.18.2-r2:0/5.18::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Text-WrapI18N-0.60.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                     
    (and 6 more with the same problem)

dev-libs/boost:0

  (dev-libs/boost-1.55.0-r2:0/1.55.0::gentoo, installed) pulled in by
    >=dev-libs/boost-1.46:0/1.55.0= required by (app-office/libreoffice-4.2.8.2:0/0::gentoo, installed)
                         ^^^^^^^^^^                                                                                                       
    (and 4 more with the same problem)

  (dev-libs/boost-1.52.0-r7:0/1.52::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/boost:0/1.52= required by (app-text/libebook-0.0.2:0/0::gentoo, installed)
                  ^^^^^^^^                                                                                                 

dev-util/boost-build:0

  (dev-util/boost-build-1.55.0:0/0::gentoo, installed) pulled in by
    =dev-util/boost-build-1.55* required by (dev-libs/boost-1.55.0-r2:0/1.55.0::gentoo, installed)
    ^                     ^^^^^                                                                                                                         

  (dev-util/boost-build-1.52.0-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.52.0* required by (dev-libs/boost-1.52.0-r7:0/1.52::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^^^                                                                                                                                         


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-video/ffmpeg-1.2.6-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=media-video/ffmpeg-1.2:0 required by (media-video/vlc-2.1.2:0/5-7::gentoo, installed)
    media-video/ffmpeg:0 required by (media-video/mplayer2-2.0_p20131009:0/0::gentoo, installed)
    media-video/ffmpeg:0 required by (media-libs/xine-lib-1.2.6:1/1::gentoo, installed)
    >=media-video/ffmpeg-1.2.6-r1:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-video/ffmpeg-1.2.6-r1:0[abi_x86_64(-)]) required by (media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r2:0.10/0.10::gentoo, installed)
    >=media-video/ffmpeg-1.2.6:0/0=[threads,vdpau] required by (media-video/mplayer2-2.0_p20131009:0/0::gentoo, installed)

  (media-video/libav-11.2:0/10::gentoo, installed) pulled in by
    >=media-video/libav-0.8.9:0/10= required by (media-video/makemkv-1.8.13-r1:0/0::gentoo, installed)
    >=media-video/libav-0.8.9:0= required by (media-video/makemkv-1.8.13-r1:0/0::gentoo, installed)
    >=media-video/libav-9.12[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,threads?,truetype?,vaapi?,vdpau?,x264?] (>=media-video/libav-9.12[abi_x86_64(-),X,encode,mp3,sdl,threads,truetype,vaapi,vdpau,x264]) required by (virtual/ffmpeg-9-r1:0/0::gentoo, ebuild scheduled for merge)
    >=media-video/libav-9.12:=[threads?,vdpau?] (>=media-video/libav-9.12:=[threads,vdpau]) required by (media-video/mplayer2-2.0_p20131009:0/0::gentoo, installed)

  (media-plugins/gst-plugins-libav-1.2.4:1.0/1.0::gentoo, ebuild scheduled for merge) pulled in by
    >=media-plugins/gst-plugins-libav-1.1.0_pre20130128-r1:1.0 required by (www-client/seamonkey-2.32:0/0::gentoo, installed)
    >=media-plugins/gst-plugins-libav-1.1.0_pre20130128-r1:1.0 required by (www-client/firefox-35.0:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Könnt Ihr helfen?
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Sun Feb 15, 2015 8:09 am    Post subject: Reply with quote

ffmpeg und libav können nicht gleichzeitig installiert werden. Welches von beiden installiert wird, kannst du mit dem USE-Flag libav bestimmen. libav zickt bei mir aber etwas rum. Mit -libav klappt es bei mir wunderbar.

Es gibt dazu auch eine News, emerge sagt dir doch nach dem syncen, dass es eine neue News gibt. Die sollte man dann auch mit eselect news read lesen, da wird diese Situation erklärt.
Back to top
View user's profile Send private message
boospy
Apprentice
Apprentice


Joined: 07 Feb 2010
Posts: 299
Location: Austria

PostPosted: Sun Feb 15, 2015 9:02 pm    Post subject: Reply with quote

ja ich kann dir auch nur -libav empfehlen. Libav funktioniert mit nem Intelchip sehr gut. Aber mit Nvidia brauchste ffmpeg.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Sun Feb 15, 2015 9:24 pm    Post subject: Reply with quote

Jetzt echt? Danke für den Hinweis. Ich habe mich immer gefragt, warum es ffmpeg und libav gibt und welches Vorteile hat. Kannst du das etwas näher ausführen oder mir dazu eine Quelle geben?

Das Problem bei mir war bislang immer, dass ich ja ein emerge @preserved_rebuild machen muss, wenn ich von ffmpeg auf libav umsteigen will. Und Das ist bei mir nie durchgegangen. Ich habe Intel-Grafik.
Back to top
View user's profile Send private message
boospy
Apprentice
Apprentice


Joined: 07 Feb 2010
Posts: 299
Location: Austria

PostPosted: Sun Feb 15, 2015 9:52 pm    Post subject: Reply with quote

Naja, also das ist nur meine Erfahrung. Hab öfters mal von ffmpeg zu libav und umgekehrt geschaltet. Der Default ist ja libav... warum auch immer. Jedenfalls bei meinen Geräten zuhause hab ich überall Nvidia verbaut, dort läuft libav grausig. Je nach Containerformat von Videos rauschen... bei meinem Firmennotebook das ne Intelgrafikkarte hat, funzt libav auch gut, keine Probleme. Generell wenn man so googelt wird dazu geraten beim origenal ffmpeg zu bleiben.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Sun Feb 15, 2015 10:08 pm    Post subject: Reply with quote

Meine Leidensgeschichte mit libav ist lang, obwohl es bei mir in der Nutzung nie Probleme gemacht hat.

Hatte KDE mal mit -vlc und gtreamer. Da installiert sich ja automatisch libav. Und die Grafik war ok.
Bin dann auf vlc und gstreamer umgestiegen. Das ging ja bis vor einiger Zeit nur mit ffmpeg.
Dann kam das libav-Flag für den vlc. Ging zuerst nur mit einer Version von libav, die hardmasked war. Wenn man sich die unmaskiert hatte, brauchte man eine Version von gstreamer, die hardmasked war. Mit dieser Version von libav ging dann aber @preserved-rebuild nicht und es ließen sich auch noch ein paar andere Pakete nicht kompilieren. Da habe ich es dann aufgegeben.

Aus diesem Grund habe ich absolut keinen Bock mehr auf libav. Finde es dann schon sehr seltsam, dass zu libav geraten wird, wenn es so viele Probleme macht und ffmpeg problemlos läuft. Aber die Tatsache, dass man bei Gentoo zu libav rät, hat mich dann schon etwas beschäftigt. Ohne dass ich mir das schlüssig erklären konnte.

Na danke für deine Hinweise. Damit ist das Thema für mich erledigt.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Mon Feb 16, 2015 7:28 am    Post subject: Reply with quote

@Klaus: Google einfach nach "libav ffmpeg", da kannst du alles über das Drama lesen ;)
libav entwickelt oft ohne Rücksicht auf backwards-compatibility. Wenn denen eine API nicht mehr gefällt wird sie geändert. So kommt es zu Kompiler-Fehlern: Programme wir vlc, mplayer, ... müssen erst angepasst werden. ffmpeg ist da konservativer, wobei sie aber auch die Änderungen von libav übernehmen. Das hat in der Vergangenheit öfters etwas länger gedauert, weshalb generell Software mit ffmpeg kompiliert hat und mit libav Probleme hatte. (Erinner mich da auch noch dran...)
Die Empfehlung "libav als default" scheint (jedenfalls sagt das Yamakuzure) deshalb gefällt worden zu sein, weil Gentoo einen libav-Dev in den eigenen Reihen hat und deshalb Probleme schneller behoben werden können. Wenn du stable fährst wirst du auch keine Probleme haben, und stable ist eigentlich das einzige was wirklich zählt. Wenn du testing fährst muss dir das Risiko bekannt sein - und wenn das dann noch hardmasked einschließt bekommst du eben mit ziemlicher Garantie Probleme ;) Und als testing-User solltest du auch erfahren genug sein den Default "libav" gegen ffmpeg zu tauschen.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Mon Feb 16, 2015 9:03 am    Post subject: Reply with quote

@franzf, ich bin schon erfahren genug, um das gebacken zu bekommen. Aber es geht mir einfach tierisch auf den Sack, weil da wohl mal wieder das Ego vor Nutzen steht. Entsprechende Bugreports schreibe ich schon dazu.

Heute morgen, ok ist so mein Ding, während des Frühstücks mache ich immer die Updates, gab es ein neues Ebuild für vlc. Geile Kiste, auf einmal geht es nicht mehr mit der aktuellen Version von ffmpeg, die bei mir aber problemlos lief. Also Downgrade gemacht. Ok, soweit erst mal so gut. Aber dann wurde ich so wahnsinnig, mir mal den mpv (wegen smplayer) anzutun. Ergebnis: Mpv wollte das ffmpeg, welches vlc nicht mehr will. Und beide gleichzeitig geht nicht. Als Lösung hab ich dann -libav entfernt. Das geht soweit. Außer das damit die rebuilds von alsa-plugins und transcode nicht durchgehen. Entsprechende Bugreports gibt es.

Keine Angst, ich bekomme das für mich schon gebacken, aber das ist aktuell ein ganz düsteres Kapitel von Gentoo. Zur Zeit geht weder libav noch ffmpeg unter Testing problemlos. Und wenn du glaubst, du hast es, dann kommen täglich neue Probleme dazu.

mpv habe ich entsorgt, ist irgenwie mit smplayer nicht so knackig. Alle anderen mplayer sind peng, weil sie kein vaapi unterstützen. In diesem Sinne. Ab heute bleibt da -libav stehen. Für immer. Und wenn ich demnächst irgendwo noch mal lese, dass libav empfohlen wird, dann knalle ich demjenigen, der so etwas schreibt, meine persönlichen Erfahrungen um die Ohren.

Bis vor drei Monaten ging doch alles ohne Probleme. Seit dem dieses verschissene libav-Flag eingeführt wurde, gibt es nur noch Stress. In diesem Sinne, ich bin mit diesem Thema durch.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Mon Feb 16, 2015 9:25 am    Post subject: Reply with quote

* mpv mit smplayer geht nicht, da mpv die Funktion zum Einbetten rausgeworfen hat. Stattdessen gibt es jetzt ne ordentliche Lib. Denke nicht dass smplayer das unterstützt.
* mpv-0.7.3 (ebenso 9999) braucht ffmpeg >= 2.1.4 - damit sollte es problemlos mit dem für vlc-2.1.5-r1 notwendigen ffmpeg <2.5 kompatibel sein.
* vlc-2.1.5-r1 mag <ffmpeg-2.5 - dagegen hat =vlc-2.1.5 keine derartige Einschränkung, der ist mit allem zufrieden.

Demnach sollte ffmpeg downgrade auf <2.5 ebenso gehen wie vlc downgrade auf =2.1.5 - mpv und vlc funktionieren in jedem Fall parallel.
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 483
Location: münchen.de

PostPosted: Mon Feb 16, 2015 2:17 pm    Post subject: Reply with quote

Im englischsprachigen Teil des Forums gibt es auch eine Diskussion zu libav vs ffmpeg. Mit Umfrage, was wir User so denken. Initiiert wurde das von einem Gentoo Dev. Der Großteil der Umfrage Teilnehmer ist der Meinung, dass ffmpeg default sein sollte. Mir persönlich ist es mehr oder weniger egal, hauptsache es funktioniert. Hab bisher gute Erfahrungen mit "+ffmpeg -libav" gemacht, ein zeitweiliger Umstieg auf Libav hat aber auch funktioniert.
_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Mon Feb 16, 2015 2:34 pm    Post subject: Reply with quote

Wobei du aber auf eins achten solltest, wenn ich deine Aussage richtig verstanden habe:+ffmpeg sorgt nicht dafür, dass ffmpeg installiert wird.+ffmpeg bewirkt, dass libav oder ffmpeg installiert wird. Und welches von beiden, dass entscheidest du mit dem Flag libav.
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 483
Location: münchen.de

PostPosted: Mon Feb 16, 2015 3:39 pm    Post subject: Reply with quote

Richtig, das ist mir bewusst. Das hab ich wohl etwas missverständlich ausgedrückt.
_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum