Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
building plasma-workspace:5 fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2542
Location: Near Toronto

PostPosted: Sun Feb 15, 2015 1:10 pm    Post subject: building plasma-workspace:5 fails Reply with quote

Hi all - I'm fooling around with kde5 and in general everything works
well and looks great (apart from a few small issues)

But the last few days when I run smart-live-rebuild and it attempts
to update plasma-workspace the ebuild fails immediately with this
patch error:

Code:
* Messages for package kde-plasma/plasma-workspace-9999:

 * Failed Patch: plasma-workspace-9999-tests-optional.patch !
 *  ( /var/lib/layman/kde/kde-plasma/plasma-workspace/files/plasma-workspace-9999-tests-optional.patch )
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/kde-plasma/plasma-workspace-9999/temp/plasma-workspace-9999-tests-optional.patch.out
 * ERROR: kde-plasma/plasma-workspace-9999::kde failed (prepare phase):
 *   Failed Patch: plasma-workspace-9999-tests-optional.patch!
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 4178:  Called epatch '/var/lib/layman/kde/kde-plasma/plasma-workspace/files/plasma-workspace-9999-tests-optional.patch'
 *   environment, line 1873:  Called die
 * The specific snippet of code:
 *               die "Failed Patch: ${patchname}!";


Is this just a matter of waiting until a corrected ebuild is released, or is there
something I can do (is is bad form to submit a bug for unsupported software
from an overlay e.g.)?
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Sun Feb 15, 2015 2:19 pm    Post subject: Reply with quote

Most likely patch fails because of eclass automagic with doc/handbook enabled. Will make a pull request and try to get the patch committed upstream asap.

EDIT: ...actually I can't reproduce this?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2542
Location: Near Toronto

PostPosted: Mon Feb 16, 2015 2:05 pm    Post subject: Reply with quote

Quote:
...actually I can't reproduce this?


:oops: I needed to update the overlay; works now and thanks
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum