Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst:] app-cdr/nero wie rückstandslos wieder entfernen?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Andreas O.
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jan 2003
Posts: 132
Location: Welthauptstadt der Biere

PostPosted: Mon Feb 16, 2015 7:20 pm    Post subject: [gelöst:] app-cdr/nero wie rückstandslos wieder entfernen? Reply with quote

Hallo,

ich war auf der Suche nach einem Brennprogramm, das u. a. Blu-rays, insbesondere Daten darauf, unter (Gentoo-)Linux brennen kann - k3b funktioniert diesbezüglich leider nicht richtig, hatte diesbezüglich schon einige verbrannte Blu-rays.
Also bin auf 'app-cdr/nero' gestoßen, das sich aber leider nicht vollständig installieren lässt - ich habe immer einen 'connection timeout' mit wget, was mir auch der Bug-Report, unter: http://gentoobrowse.randomdan.homeip.net/package/app-cdr/nero
bestätigt...

Komischerweise habe ich aber bereits Menüeinträge unter LXDE unter 'Unterhaltungsmedien' -> 'Nero Linux' 'Nero Linux Express' aber eben keine funktionierenden, installierten Binaries...

Code:
revdep-rebuild i


zeigt mir, dass 'nero' mir einiges durcheinander gebracht hat und es sich nicht mehr automatisch auflösen lässt:

Code:
 * Configuring search environment for revdep-rebuild
 * Environment mismatch from previous run, deleting temporary files...

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 15% ]  *   broken /usr/bin/nero (requires libatk-1.0.so.0
libcairo.so.2
libgdk-x11-2.0.so.0
libgdk_pixbuf-2.0.so.0
libgtk-x11-2.0.so.0
libpango-1.0.so.0
libpangocairo-1.0.so.0)
 *   broken /usr/bin/nerocmd (requires libatk-1.0.so.0
libcairo.so.2
libgdk-x11-2.0.so.0
libgdk_pixbuf-2.0.so.0
libgtk-x11-2.0.so.0
libpango-1.0.so.0
libpangocairo-1.0.so.0)
 *   broken /usr/bin/neroexpress (requires libatk-1.0.so.0
libcairo.so.2
libgdk-x11-2.0.so.0
libgdk_pixbuf-2.0.so.0
libgtk-x11-2.0.so.0
libpango-1.0.so.0
libpangocairo-1.0.so.0)
[ 71% ]  *   broken /usr/lib64/nero/libNeroAudioPluginMgr.so (requires libatk-1.0.so.0
libcairo.so.2
libgdk-x11-2.0.so.0
libgdk_pixbuf-2.0.so.0
libgtk-x11-2.0.so.0
libpango-1.0.so.0
libpangocairo-1.0.so.0)
[ 100% ]                 
 * Generated new 3_broken.rr
 * Assigning files to packages
 *  !!! /usr/bin/nero not owned by any package is broken !!!
 *   /usr/bin/nero -> (none)
 *  !!! /usr/bin/nerocmd not owned by any package is broken !!!
 *   /usr/bin/nerocmd -> (none)
 *  !!! /usr/bin/neroexpress not owned by any package is broken !!!
 *   /usr/bin/neroexpress -> (none)
 *  !!! /usr/lib64/nero/libNeroAudioPluginMgr.so not owned by any package is broken !!!
 *   /usr/lib64/nero/libNeroAudioPluginMgr.so -> (none)
 * Generated new 4_raw.rr and 4_owners.rr
 * Found some broken files, but none of them were associated with known packages
 * Unable to proceed with automatic repairs.
 * The broken files are listed in 4_owners.r


ein

emerge --unmerge nero sagt mir eben Folgendes:
Code:
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

--- Couldn't find 'nero' to unmerge.


Komischerweise wurden aber bereits /usr/bin/nero und /usr/bin/neroexpress sowie /usr/bin/nerocmd erzeugt (1,8 bzw. 1,6 MB sowie 179 KB groß), die sich aber nicht ausführen lassen... :roll:

Da mich hier ein, sagen wir 'mulmiges Gefühl' beschleicht, hätte ich 'nero' nun wieder vollständig los - doch wie kann ich etwas deinstallieren, das offensichtlich gar nicht vollständig installiert wurde?

P.S.: weiß hier jemand unter Linux ein zuverläsiges Programm, das Daten-Blu-rays brennen kann (wie gesagt, k3b hat mir nur lauter "verbrannte" Rohlinge beschert... :(

Andreas


Last edited by Andreas O. on Tue Feb 17, 2015 8:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Mon Feb 16, 2015 9:40 pm    Post subject: Reply with quote

Hm, kann ich so nicht bestätigen.
app-cdr/nero-4.0.0.0b::gentoo installiert und deinstalliert hier einwandfrei und rückstandslos. auch "revdep-rebuild -i" ist danach sauber.

Was für eine portage Version nutzt du denn? (siehe zb via emerge -V)

Eventuell sind es auch nur alte Leichen die noch instaliert sind? Teste mal mit
Code:
emerge -a --depclean
(Das hilft allerdings nur wenn alte, nicht mehr (im Tree) vorhandene Pakete nicht mehr im world-File (oder in Sets) enthalten sind.)
Back to top
View user's profile Send private message
Andreas O.
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jan 2003
Posts: 132
Location: Welthauptstadt der Biere

PostPosted: Tue Feb 17, 2015 5:23 am    Post subject: Reply with quote

Josef.95 wrote:
Hm, kann ich so nicht bestätigen.
app-cdr/nero-4.0.0.0b::gentoo installiert und deinstalliert hier einwandfrei und rückstandslos. auch "revdep-rebuild -i" ist danach sauber.

Was für eine portage Version nutzt du denn? (siehe zb via emerge -V)

Eventuell sind es auch nur alte Leichen die noch instaliert sind? Teste mal mit
Code:
emerge -a --depclean
(Das hilft allerdings nur wenn alte, nicht mehr (im Tree) vorhandene Pakete nicht mehr im world-File (oder in Sets) enthalten sind.)


emerge -V sagt:

Code:
Portage 2.2.14 (python 3.3.5-final-0, default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.19-r1, 3.16.5-gentoo x86_64)


emerge -a --depclean bringt:

Code:

* Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 *
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence of this, it often becomes necessary to run
 * `emerge --update --newuse --deep @world` prior to depclean.

Calculating dependencies... done!
 * Dependencies could not be completely resolved due to
 * the following required packages not being installed:
 *
 *   >=dev-libs/icu-3.8.1-r1:0/52= pulled in by:
 *     net-libs/webkit-gtk-2.4.4-r201
 *
 *   dev-lang/perl:0/5.18=[-build(-)] pulled in by:
 *     app-arch/rpm-4.11.0.1
 *
 * Have you forgotten to do a complete update prior to depclean? The
 * most comprehensive command for this purpose is as follows:
 *
 *   emerge --update --newuse --deep --with-bdeps=y @world
 *
 * Note that the --with-bdeps=y option is not required in many
 * situations. Refer to the emerge manual page (run `man emerge`)
 * for more information about --with-bdeps.
 *
 * Also, note that it may be necessary to manually uninstall
 * packages that no longer exist in the portage tree, since it may
 * not be possible to satisfy their dependencies.


Dabei fiel mit schon vorher auf, ganz gleich, was ich mache, dass sich webkit-gtk-2.4.4-r201 nicht upgraden ließ auf webkit-gtk-2.4.8-r200 - hier brach das Kompilieren nach ziemlich langer Zeit immer wieder ab.
Ich hatte auch schon mal kurz überlegt, beherzt webkit-gtk zu deinstallieren und neu zu installieren - ich habe aber gemerkt, dass hier so ziemlich mein ganzes System von diesem Monsterpaket abhängig ist, so dass ich es dann wieder bleiben ließ...

So halfen weder ein
Code:
 emerge --update --newuse --deep --with-bdeps=y @world


noch ein:

Code:
emerge @preserved-rebuild


- das Update brach immer bei diesem Monsterpaket webkit-gtk ab... :(

O.k. , ich konnte mit:

Code:
emerge --skipfirst --resume


und

Code:
emerge --keep-going


die anderen Pakete aktualisieren, aber webkit-gtk scheiterte immer... :evil:


Andreas
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Tue Feb 17, 2015 6:37 am    Post subject: Reply with quote

Wenn ein Update nicht will, bitte auf keinem Fall das Paket löschen. Zum einen kann es sein, dass es sich dabei um Programme handelt, die für den Build-Process gehören und dann geht gar nichts mehr.

Ok, webkit-gtk gehört nicht dazu. Aber wenn du es löscht, dann wird es mit deinem System noch schlimmer, wenn die Neuinstallation dann nicht klappt. Poste doch bitte mal die Fehlermeldung. Also nicht die 2km Text, nur den Teil, wo die Fehler beschrieben werden. Und es sieht so aus, als ob es bei webkit-gtk zur Zeit einiges im Argen liegt, es gibt einige Bugreports, die unconfirmed sind. Schau mal hier, vielleicht ist ja etwas dabei, was dir hilft: https://bugs.gentoo.org/buglist.cgi?quicksearch=webkit-gtk
Back to top
View user's profile Send private message
Andreas O.
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jan 2003
Posts: 132
Location: Welthauptstadt der Biere

PostPosted: Tue Feb 17, 2015 7:36 am    Post subject: Reply with quote

Also, zunächst mal die Ausgabe von emerge --info '=net-libs/webkit-gtk-2.4.8-r200::gentoo':
Code:
Portage 2.2.14 (python 3.3.5-final-0, default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.19-r1, 3.16.5-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.16.5-gentoo-x86_64-AMD_Athlon-tm-_II_X3_455_Processor-with-gentoo-2.2
KiB Mem:     8175776 total,   2191852 free
KiB Swap:   12048744 total,  12048744 free
Timestamp of tree: Mon, 16 Feb 2015 17:45:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p53
dev-java/java-config:     2.2.0
dev-lang/perl:            5.20.1-r4
dev-lang/python:          2.7.9-r1, 3.3.5-r1, 3.4.1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.9
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6-r1, 1.12.6, 1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.7.3-r1, 4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.4
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg lcms ldap libav libnotify mad mmx mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support qt4 readline sdl session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMdf interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHONERAS="ptp2" COLLECTD_PLUGINS="


Hier nun meine Fehlermeldung am Schluss:

Code:
make[1]: Leaving directory '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'
GNUmakefile:25583: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: net-libs/webkit-gtk-2.4.8-r200::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=net-libs/webkit-gtk-2.4.8-r200::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/webkit-gtk-2.4.8-r200::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/temp/environment'.
 * Working directory: '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'
 * S: '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'

>>> Failed to emerge net-libs/webkit-gtk-2.4.8-r200, Log file:

>>>  '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/temp/build.log'

 * Messages for package net-print/cups-2.0.1-r1:

 * Your usb printers will be managed via libusb. In this case,
 * cups-2.0.1 requires the USB_PRINTER support disabled.
 * Please disable it:
 *     CONFIG_USB_PRINTER=n
 * in /usr/src/linux/.config or
 *     Device Drivers --->
 *         USB support  --->
 *             [ ] USB Printer support
 * Alternatively, just disable the usb useflag for cups (your printer will still work).

 * Messages for package net-print/cups-filters-1.0.53:

 * This version of cups-filters includes cups-browsed, a daemon that autodiscovers
 * remote queues via avahi or cups-1.5 browsing protocol and adds them to your cups
 * configuration. You may want to add it to your default runlevel.

 * Messages for package net-libs/webkit-gtk-2.4.8-r200:

 * ERROR: net-libs/webkit-gtk-2.4.8-r200::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=net-libs/webkit-gtk-2.4.8-r200::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/webkit-gtk-2.4.8-r200::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/temp/environment'.
 * Working directory: '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'
 * S: '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: net-libs/gnutls-3.3.10-r2
 *  - /usr/lib64/libgnutls.so.26
 *  - /usr/lib64/libgnutls.so.26.22.6
 *      used by /usr/libexec/nullmailer/qmqp (mail-mta/nullmailer-1.13-r5)
 *      used by /usr/libexec/nullmailer/smtp (mail-mta/nullmailer-1.13-r5)
>>> package: dev-libs/icu-53.1
 *  - /usr/lib64/libicui18n.so.52
 *  - /usr/lib64/libicui18n.so.52.1
 *      used by /usr/lib64/libjavascriptcoregtk-1.0.so.0.16.12 (net-libs/webkit-gtk-2.4.4-r201)
 *  4-r201)
 *  - /usr/lib64/libicudata.so.52
 *  - /usr/lib64/libicudata.so.52.1
 *  - /usr/lib64/libicuuc.so.52
 *  - /usr/lib64/libicuuc.so.52.1
 *      used by /usr/lib64/libjavascriptcoregtk-1.0.so.0.16.12 (net-libs/webkit-gtk-2.4.4-r201)
 *      used by /usr/lib64/libwebkitgtk-1.0.so.0.22.10 (net-libs/webkit-gtk-2.4.4-r201)
Use emerge @preserved-rebuild to rebuild packages using these libraries    used by /usr/lib64/libwebkitgtk-1.0.so.0.22.10 (net-libs/webkit-gtk-2.4.


'emerge @preserved-rebuild' führte eben dann zu o. g. Fehler...

das 'build-log' in Auszügen (wurde mit leafpad geöffnet und kann ein paar Zeichen nicht richtig darstellen, ich hoffe aber trotzdem, dass hier jemand was rauslesen kann:

Code:
mv -f Source/WebCore/inspector/.deps/libWebCore_la-InspectorCSSAgent.Tpo Source/WebCore/inspector/.deps/libWebCore_la-InspectorCSSAgent.Plo
/bin/sh ./libtool  --tag=CXX   --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I.  -DBUILDING_WebCore -DBUILDING_WEBKIT -Wall -W -Wcast-align -Wchar-subscripts -Wreturn-type -Wformat -Wformat-security -Wno-format-y2k -Wundef -Wmissing-format-attribute -Wpointer-arith -Wwrite-strings -Wno-unused-parameter -Wno-parentheses -fno-exceptions -DBUILDING_CAIRO__ -DBUILDING_GTK__   -I./Source/ThirdParty/ANGLE/src -I./Source/ThirdParty/ANGLE/include -I./Source/ThirdParty/ANGLE/include/GLSLANG -I./Source/ThirdParty/ANGLE/include/KHR -I./DerivedSources/Platform  -DWEBKITGTK_API_VERSION_STRING=\"1.0\" -DDATA_DIR=\"/usr/share\" -I./Source/ThirdParty/ANGLE/src -I./Source/ThirdParty/ANGLE/include -I./Source/ThirdParty/ANGLE/include/GLSLANG -I./Source/ThirdParty/ANGLE/include/KHR -I./Source/WebCore -I./Source/WebCore/Modules/battery -I./Source/WebCore/Modules/gamepad -I./Source/WebCore/Modules/geolocation -I./Source/WebCore/Modules/indexeddb -I./Source/WebCore/Modules/indexeddb/leveldb -I./Source/WebCore/Modules/indieui -I./Source/WebCore/Modules/mediasource -I./Source/WebCore/Modules/mediastream -I./Source/WebCore/Modules/navigatorcontentutils -I./Source/WebCore/Modules/notifications -I./Source/WebCore/Modules/plugins -I./Source/WebCore/Modules/proximity -I./Source/WebCore/Modules/quota -I./Source/WebCore/Modules/webaudio -I./Source/WebCore/Modules/webdatabase -I./Source/WebCore/Modules/websockets -I./Source/WebCore/accessibility -I./Source/WebCore/bindings -I./Source/WebCore/bindings/generic -I./Source/WebCore/bindings/js -I./Source/WebCore/bridge -I./Source/WebCore/bridge/c -I./Source/WebCore/bridge/jsc -I./Source/WebCore/crypto -I./Source/WebCore/crypto/keys -I./Source/WebCore/css -I./Source/WebCore/cssjit -I./Source/WebCore/dom -I./Source/WebCore/dom/default -I./Source/WebCore/editing -I./Source/WebCore/fileapi -I./Source/WebCore/history -I./Source/WebCore/html -I./Source/WebCore/html/canvas -I./Source/WebCore/html/forms -I./Source/WebCore/html/parser -I./Source/WebCore/html/shadow -I./Source/WebCore/html/track -I./Source/WebCore/inspector -I./Source/WebCore/loader -I./Source/WebCore/loader/appcache -I./Source/WebCore/loader/archive -I./Source/WebCore/loader/archive/mhtml -I./Source/WebCore/loader/cache -I./Source/WebCore/loader/icon -I./Source/WebCore/mathml -I./Source/WebCore/page -I./Source/WebCore/page/animation -I./Source/WebCore/page/scrolling -I./Source/WebCore/platform -I./Source/WebCore/platform/animation -I./Source/WebCore/platform/audio -I./Source/WebCore/platform/graphics -I./Source/WebCore/platform/graphics/cpu/arm -I./Source/WebCore/platform/graphics/cpu/arm/filters/ -I./Source/WebCore/platform/graphics/filters -I./Source/WebCore/platform/graphics/filters/texmap -I./Source/WebCore/platform/graphics/freetype -I./Source/WebCore/platform/graphics/gpu -I./Source/WebCore/platform/graphics/harfbuzz -I./Source/WebCore/platform/graphics/harfbuzz/ng -I./Source/WebCore/platform/graphics/opengl -I./Source/WebCore/platform/graphics/opentype -I./Source/WebCore/platform/graphics/transforms -I./Source/WebCore/platform/image-decoders -I./Source/WebCore/platform/image-decoders/bmp -I./Source/WebCore/platform/image-decoders/gif -I./Source/WebCore/platform/image-decoders/ico -I./Source/WebCore/platform/image-decoders/jpeg -I./Source/WebCore/platform/image-decoders/png -I./Source/WebCore/platform/image-decoders/webp -I./Source/WebCore/platform/leveldb -I./Source/WebCore/platform/linux -I./Source/WebCore/platform/mediastream -I./Source/WebCore/platform/mediastream/gstreamer -I./Source/WebCore/platform/mock -I./Source/WebCore/platform/mock/mediasource -I./Source/WebCore/platform/network -I./Source/WebCore/platform/network/gtk -I./Source/WebCore/platform/sql -I./Source/WebCore/platform/text -I./Source/WebCore/platform/text/icu -I./Source/WebCore/platform/win -I./Source/WebCore/plugins -I./Source/WebCore/plugins/win -I./Source/WebCore/rendering -I./Source/WebCore/rendering/line -I./Source/WebCore/rendering/mathml -I./Source/WebCore/rendering/shapes -I./Source/WebCore/rendering/style -I./Source/WebCore/rendering/svg -I./Source/WebCore/storage -I./Source/WebCore/style -I./Source/WebCore/svg -I./Source/WebCore/svg/animation -I./Source/WebCore/svg/graphics -I./Source/WebCore/svg/graphics/filters -I./Source/WebCore/svg/properties -I./Source/WebCore/testing -I./Source/WebCore/testing/js -I./Source/WebCore/websockets -I./Source/WebCore/workers -I./Source/WebCore/xml -I./Source/WebCore/xml/parser -I./WebCore/bindings/js -I./DerivedSources/WebCore -I./DerivedSources -I./DerivedSources/JavaScriptCore -I./Source/WebCore/platform/graphics/texmap  -DWEBKITGTK_API_VERSION_STRING=\"1.0\" -I./Source/WebCore/accessibility/atk -I./Source/WebCore/loader/gtk -I./Source/WebCore/page/gtk -I./Source/WebCore/platform/cairo -I./Source/WebCore/platform/audio/gstreamer -I./Source/WebCore/platform/graphics/cairo -I./Source/WebCore/platform/graphics/freetype -I./Source/WebCore/platform/graphics/glx -I./Source/WebCore/platform/graphics/harfbuzz -I./Source/WebCore/platform/graphics/harfbuzz/ng -I./Source/WebCore/platform/graphics/egl -I./Source/WebCore/platform/graphics/gstreamer -I./Source/WebCore/platform/graphics/gtk -I./Source/WebCore/platform/gtk -I./Source/WebCore/platform/mediastream/gstreamer -I./Source/WebCore/platform/network/soup -I./Source/WebCore/platform/text/enchant  -I./Source -I./Source/JavaScriptCore -I./Source/JavaScriptCore/API -I./Source/JavaScriptCore/ForwardingHeaders -I./Source/JavaScriptCore/assembler -I./Source/JavaScriptCore/bindings -I./Source/JavaScriptCore/bytecode -I./Source/JavaScriptCore/bytecompiler -I./Source/JavaScriptCore/debugger -I./Source/JavaScriptCore/dfg -I./Source/JavaScriptCore/disassembler -I./Source/JavaScriptCore/ftl -I./Source/JavaScriptCore/heap -I./Source/JavaScriptCore/inspector -I./Source/JavaScriptCore/inspector/agents -I./Source/JavaScriptCore/interpreter -I./Source/JavaScriptCore/jit -I./Source/JavaScriptCore/llint -I./Source/JavaScriptCore/parser -I./Source/JavaScriptCore/profiler -I./Source/JavaScriptCore/runtime -I./Source/JavaScriptCore/tools -I./Source/JavaScriptCore/yarr -I./DerivedSources/JavaScriptCore -I./Source/WTF  -fno-omit-frame-pointer -fno-tree-dce -fno-strict-aliasing -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libdrm -I/usr/include/libpng16   -pthread -I/usr/include/enchant -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/libpng16 -I/usr/include/freetype2 -I/usr/include/harfbuzz  -I/usr/include/harfbuzz   -pthread -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -pthread -I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include   -pthread -I/usr/include/libsoup-2.4 -I/usr/include/libxml2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -I/usr/include/libxml2  -I/usr/include/libxml2  -pthread -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2   -I/usr/include     -fvisibility-inlines-hidden -fno-rtti -O2 -pipe -pthread -std=c++11 -Wno-c++11-compat   -MT Source/WebCore/inspector/libWebCore_la-InspectorFrontendClientLocal.lo -MD -MP -MF Source/WebCore/inspector/.deps/libWebCore_la-InspectorFrontendClientLocal.Tpo -c -o Source/WebCore/inspector/libWebCore_la-InspectorFrontendClientLocal.lo `test -f 'Source/WebCore/inspector/InspectorFrontendClientLocal.cpp' || echo './'`Source/WebCore/inspector/InspectorFrontendClientLocal.cpp
mv -f Source/WebCore/inspector/.deps/libWebCore_la-InspectorDOMStorageAgent.Tpo Source/WebCore/inspector/.deps/libWebCore_la-InspectorDOMStorageAgent.Plo
/bin/sh ./libtool  --tag=CXX   --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I.  -DBUILDING_WebCore -DBUILDING_WEBKIT -Wall -W -Wcast-align -Wchar-subscripts -Wreturn-type -Wformat -Wformat-security -Wno-format-y2k -Wundef -Wmissing-format-attribute -Wpointer-arith -Wwrite-strings -Wno-unused-parameter -Wno-parentheses -fno-exceptions -DBUILDING_CAIRO__ -DBUILDING_GTK__   -I./Source/ThirdParty/ANGLE/src -I./Source/ThirdParty/ANGLE/include -I./Source/ThirdParty/ANGLE/include/GLSLANG -I./Source/ThirdParty/ANGLE/include/KHR -I./DerivedSources/Platform  -DWEBKITGTK_API_VERSION_STRING=\"1.0\" -DDATA_DIR=\"/usr/share\" -I./Source/ThirdParty/ANGLE/src -I./Source/ThirdParty/ANGLE/include -I./Source/ThirdParty/ANGLE/include/GLSLANG -I./Source/ThirdParty/ANGLE/include/KHR -I./Source/WebCore -I./Source/WebCore/Modules/battery -I./Source/WebCore/Modules/gamepad -I./Source/WebCore/Modules/geolocation -I./Source/WebCore/Modules/indexeddb -I./Source/WebCore/Modules/indexeddb/leveldb -I./Source/WebCore/Modules/indieui -I./Source/WebCore/Modules/mediasource -I./Source/WebCore/Modules/mediastream -I./Source/WebCore/Modules/navigatorcontentutils -I./Source/WebCore/Modules/notifications -I./Source/WebCore/Modules/plugins -I./Source/WebCore/Modules/proximity -I./Source/WebCore/Modules/quota -I./Source/WebCore/Modules/webaudio -I./Source/WebCore/Modules/webdatabase -I./Source/WebCore/Modules/websockets -I./Source/WebCore/accessibility -I./Source/WebCore/bindings -I./Source/WebCore/bindings/generic -I./Source/WebCore/bindings/js -I./Source/WebCore/bridge -I./Source/WebCore/bridge/c -I./Source/WebCore/bridge/jsc -I./Source/WebCore/crypto -I./Source/WebCore/crypto/keys -I./Source/WebCore/css -I./Source/WebCore/cssjit -I./Source/WebCore/dom -I./Source/WebCore/dom/default -I./Source/WebCore/editing -I./Source/WebCore/fileapi -I./Source/WebCore/history -I./Source/WebCore/html -I./Source/WebCore/html/canvas -I./Source/WebCore/html/forms -I./Source/WebCore/html/parser -I./Source/WebCore/html/shadow -I./Source/WebCore/html/track -I./Source/WebCore/inspector -I./Source/WebCore/loader -I./Source/WebCore/loader/appcache -I./Source/WebCore/loader/archive -I./Source/WebCore/loader/archive/mhtml -I./Source/WebCore/loader/cache -I./Source/WebCore/loader/icon -I./Source/WebCore/mathml -I./Source/WebCore/page -I./Source/WebCore/page/animation -I./Source/WebCore/page/scrolling -I./Source/WebCore/platform -I./Source/WebCore/platform/animation -I./Source/WebCore/platform/audio -I./Source/WebCore/platform/graphics -I./Source/WebCore/platform/graphics/cpu/arm -I./Source/WebCore/platform/graphics/cpu/arm/filters/ -I./Source/WebCore/platform/graphics/filters -I./Source/WebCore/platform/graphics/filters/texmap -I./Source/WebCore/platform/graphics/freetype -I./Source/WebCore/platform/graphics/gpu -I./Source/WebCore/platform/graphics/harfbuzz -I./Source/WebCore/platform/graphics/harfbuzz/ng -I./Source/WebCore/platform/graphics/opengl -I./Source/WebCore/platform/graphics/opentype -I./Source/WebCore/platform/graphics/transforms -I./Source/WebCore/platform/image-decoders -I./Source/WebCore/platform/image-decoders/bmp -I./Source/WebCore/platform/image-decoders/gif -I./Source/WebCore/platform/image-decoders/ico -I./Source/WebCore/platform/image-decoders/jpeg -I./Source/WebCore/platform/image-decoders/png -I./Source/WebCore/platform/image-decoders/webp -I./Source/WebCore/platform/leveldb -I./Source/WebCore/platform/linux -I./Source/WebCore/platform/mediastream -I./Source/WebCore/platform/mediastream/gstreamer -I./Source/WebCore/platform/mock -I./Source/WebCore/platform/mock/mediasource -I./Source/WebCore/platform/network -I./Source/WebCore/platform/network/gtk -I./Source/WebCore/platform/sql -I./Source/WebCore/platform/text -I./Source/WebCore/platform/text/icu -I./Source/WebCore/platform/win -I./Source/WebCore/plugins -I./Source/WebCore/plugins/win -I./Source/WebCore/rendering -I./Source/WebCore/rendering/line -I./Source/WebCore/rendering/mathml -I./Source/WebCore/rendering/shapes -I./Source/WebCore/rendering/style -I./Source/WebCore/rendering/svg -I./Source/WebCore/storage -I./Source/WebCore/style -I./Source/WebCore/svg -I./Source/WebCore/svg/animation -I./Source/WebCore/svg/graphics -I./Source/WebCore/svg/graphics/filters -I./Source/WebCore/svg/properties -I./Source/WebCore/testing -I./Source/WebCore/testing/js -I./Source/WebCore/websockets -I./Source/WebCore/workers -I./Source/WebCore/xml -I./Source/WebCore/xml/parser -I./WebCore/bindings/js -I./DerivedSources/WebCore -I./DerivedSources -I./DerivedSources/JavaScriptCore -I./Source/WebCore/platform/graphics/texmap  -DWEBKITGTK_API_VERSION_STRING=\"1.0\" -I./Source/WebCore/accessibility/atk -I./Source/WebCore/loader/gtk -I./Source/WebCore/page/gtk -I./Source/WebCore/platform/cairo -I./Source/WebCore/platform/audio/gstreamer -I./Source/WebCore/platform/graphics/cairo -I./Source/WebCore/platform/graphics/freetype -I./Source/WebCore/platform/graphics/glx -I./Source/WebCore/platform/graphics/harfbuzz -I./Source/WebCore/platform/graphics/harfbuzz/ng -I./Source/WebCore/platform/graphics/egl -I./Source/WebCore/platform/graphics/gstreamer -I./Source/WebCore/platform/graphics/gtk -I./Source/WebCore/platform/gtk -I./Source/WebCore/platform/mediastream/gstreamer -I./Source/WebCore/platform/network/soup -I./Source/WebCore/platform/text/enchant  -I./Source -I./Source/JavaScriptCore -I./Source/JavaScriptCore/API -I./Source/JavaScriptCore/ForwardingHeaders -I./Source/JavaScriptCore/assembler -I./Source/JavaScriptCore/bindings -I./Source/JavaScriptCore/bytecode -I./Source/JavaScriptCore/bytecompiler -I./Source/JavaScriptCore/debugger -I./Source/JavaScriptCore/dfg -I./Source/JavaScriptCore/disassembler -I./Source/JavaScriptCore/ftl -I./Source/JavaScriptCore/heap -I./Source/JavaScriptCore/inspector -I./Source/JavaScriptCore/inspector/agents -I./Source/JavaScriptCore/interpreter -I./Source/JavaScriptCore/jit -I./Source/JavaScriptCore/llint -I./Source/JavaScriptCore/parser -I./Source/JavaScriptCore/profiler -I./Source/JavaScriptCore/runtime -I./Source/JavaScriptCore/tools -I./Source/JavaScriptCore/yarr -I./DerivedSources/JavaScriptCore -I./Source/WTF  -fno-omit-frame-pointer -fno-tree-dce -fno-strict-aliasing -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libdrm -I/usr/include/libpng16   -pthread -I/usr/include/enchant -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/libpng16 -I/usr/include/freetype2 -I/usr/include/harfbuzz  -I/usr/include/harfbuzz   -pthread -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -pthread -I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include   -pthread -I/usr/include/libsoup-2.4 -I/usr/include/libxml2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -I/usr/include/libxml2  -I/usr/include/libxml2  -pthread -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2   -I/usr/include     -fvisibility-inlines-hidden -fno-rtti -O2 -pipe -pthread -std=c++11 -Wno-c++11-compat   -MT Source/WebCore/inspector/libWebCore_la-InspectorFrontendHost.lo -MD -MP -MF Source/WebCore/inspector/.deps/libWebCore_la-InspectorFrontendHost.Tpo -c -o Source/WebCore/inspector/libWebCore_la-InspectorFrontendHost.lo `test -f 'Source/WebCore/inspector/InspectorFrontendHost.cpp' || echo './'`Source/WebCore/inspector/InspectorFrontendHost.cpp
libtool: compile:  x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -DBUILDING_WebCore -DBUILDING_WEBKIT -Wall -W -Wcast-align -Wchar-subscripts -Wreturn-type -Wformat -Wformat-security -Wno-format-y2k -Wundef -Wmissing-format-attribute -Wpointer-arith -Wwrite-strings -Wno-unused-parameter -Wno-parentheses -fno-exceptions -DBUILDING_CAIRO__ -DBUILDING_GTK__ -I./Source/ThirdParty/ANGLE/src -I./Source/ThirdParty/ANGLE/include -I./Source/ThirdParty/ANGLE/include/GLSLANG -I./Source/ThirdParty/ANGLE/include/KHR -I./DerivedSources/Platform -DWEBKITGTK_API_VERSION_STRING=\"1.0\" -DDATA_DIR=\"/usr/share\" -I./Source/ThirdParty/ANGLE/src -I./Source/ThirdParty/ANGLE/include -I./Source/ThirdParty/ANGLE/include/GLSLANG -I./Source/ThirdParty/ANGLE/include/KHR -I./Source/WebCore -I./Source/WebCore/Modules/battery -I./Source/WebCore/Modules/gamepad -I./Source/WebCore/Modules/geolocation -I./Source/WebCore/Modules/indexeddb -I./Source/WebCore/Modules/indexeddb/leveldb -I./Source/WebCore/Modules/indieui -I./Source/WebCore/Modules/mediasource -I./Source/WebCore/Modules/mediastream -I./Source/WebCore/Modules/navigatorcontentutils -I./Source/WebCore/Modules/notifications -I./Source/WebCore/Modules/plugins -I./Source/WebCore/Modules/proximity -I./Source/WebCore/Modules/quota -I./Source/WebCore/Modules/webaudio -I./Source/WebCore/Modules/webdatabase -I./Source/WebCore/Modules/websockets -I./Source/WebCore/accessibility -I./Source/WebCore/bindings -I./Source/WebCore/bindings/generic -I./Source/WebCore/bindings/js -I./Source/WebCore/bridge -I./Source/WebCore/bridge/c -I./Source/WebCore/bridge/jsc -I./Source/WebCore/crypto -I./Source/WebCore/crypto/keys -I./Source/WebCore/css -I./Source/WebCore/cssjit -I./Source/WebCore/dom -I./Source/WebCore/dom/default -I./Source/WebCore/editing -I./Source/WebCore/fileapi -I./Source/WebCore/history -I./Source/WebCore/html -I./Source/WebCore/html/canvas -I./Source/WebCore/html/forms -I./Source/WebCore/html/parser -I./Source/WebCore/html/shadow -I./Source/WebCore/html/track -I./Source/WebCore/inspector -I./Source/WebCore/loader -I./Source/WebCore/loader/appcache -I./Source/WebCore/loader/archive -I./Source/WebCore/loader/archive/mhtml -I./Source/WebCore/loader/cache -I./Source/WebCore/loader/icon -I./Source/WebCore/mathml -I./Source/WebCore/page -I./Source/WebCore/page/animation -I./Source/WebCore/page/scrolling -I./Source/WebCore/platform -I./Source/WebCore/platform/animation -I./Source/WebCore/platform/audio -I./Source/WebCore/platform/graphics -I./Source/WebCore/platform/graphics/cpu/arm -I./Source/WebCore/platform/graphics/cpu/arm/filters/ -I./Source/WebCore/platform/graphics/filters -I./Source/WebCore/platform/graphics/filters/texmap -I./Source/WebCore/platform/graphics/freetype -I./Source/WebCore/platform/graphics/gpu -I./Source/WebCore/platform/graphics/harfbuzz -I./Source/WebCore/platform/graphics/harfbuzz/ng -I./Source/WebCore/platform/graphics/opengl -I./Source/WebCore/platform/graphics/opentype -I./Source/WebCore/platform/graphics/transforms -I./Source/WebCore/platform/image-decoders -I./Source/WebCore/platform/image-decoders/bmp -I./Source/WebCore/platform/image-decoders/gif -I./Source/WebCore/platform/image-decoders/ico -I./Source/WebCore/platform/image-decoders/jpeg -I./Source/WebCore/platform/image-decoders/png -I./Source/WebCore/platform/image-decoders/webp -I./Source/WebCore/platform/leveldb -I./Source/WebCore/platform/linux -I./Source/WebCore/platform/mediastream -I./Source/WebCore/platform/mediastream/gstreamer -I./Source/WebCore/platform/mock -I./Source/WebCore/platform/mock/mediasource -I./Source/WebCore/platform/network -I./Source/WebCore/platform/network/gtk -I./Source/WebCore/platform/sql -I./Source/WebCore/platform/text -I./Source/WebCore/platform/text/icu -I./Source/WebCore/platform/win -I./Source/WebCore/plugins -I./Source/WebCore/plugins/win -I./Source/WebCore/rendering -I./Source/WebCore/rendering/line -I./Source/WebCore/rendering/mathml -I./Source/WebCore/rendering/shapes -I./Source/WebCore/rendering/style -I./Source/WebCore/rendering/svg -I./Source/WebCore/storage -I./Source/WebCore/style -I./Source/WebCore/svg -I./Source/WebCore/svg/animation -I./Source/WebCore/svg/graphics -I./Source/WebCore/svg/graphics/filters -I./Source/WebCore/svg/properties -I./Source/WebCore/testing -I./Source/WebCore/testing/js -I./Source/WebCore/websockets -I./Source/WebCore/workers -I./Source/WebCore/xml -I./Source/WebCore/xml/parser -I./WebCore/bindings/js -I./DerivedSources/WebCore -I./DerivedSources -I./DerivedSources/JavaScriptCore -I./Source/WebCore/platform/graphics/texmap -DWEBKITGTK_API_VERSION_STRING=\"1.0\" -I./Source/WebCore/accessibility/atk -I./Source/WebCore/loader/gtk -I./Source/WebCore/page/gtk -I./Source/WebCore/platform/cairo -I./Source/WebCore/platform/audio/gstreamer -I./Source/WebCore/platform/graphics/cairo -I./Source/WebCore/platform/graphics/freetype -I./Source/WebCore/platform/graphics/glx -I./Source/WebCore/platform/graphics/harfbuzz -I./Source/WebCore/platform/graphics/harfbuzz/ng -I./Source/WebCore/platform/graphics/egl -I./Source/WebCore/platform/graphics/gstreamer -I./Source/WebCore/platform/graphics/gtk -I./Source/WebCore/platform/gtk -I./Source/WebCore/platform/mediastream/gstreamer -I./Source/WebCore/platform/network/soup -I./Source/WebCore/platform/text/enchant -I./Source -I./Source/JavaScriptCore -I./Source/JavaScriptCore/API -I./Source/JavaScriptCore/ForwardingHeaders -I./Source/JavaScriptCore/assembler -I./Source/JavaScriptCore/bindings -I./Source/JavaScriptCore/bytecode -I./Source/JavaScriptCore/bytecompiler -I./Source/JavaScriptCore/debugger -I./Source/JavaScriptCore/dfg -I./Source/JavaScriptCore/disassembler -I./Source/JavaScriptCore/ftl -I./Source/JavaScriptCore/heap -I./Source/JavaScriptCore/inspector -I./Source/JavaScriptCore/inspector/agents -I./Source/JavaScriptCore/interpreter -I./Source/JavaScriptCore/jit -I./Source/JavaScriptCore/llint -I./Source/JavaScriptCore/parser -I./Source/JavaScriptCore/profiler -I./Source/JavaScriptCore/runtime -I./Source/JavaScriptCore/tools -I./Source/JavaScriptCore/yarr -I./DerivedSources/JavaScriptCore -I./Source/WTF -fno-omit-frame-pointer -fno-tree-dce -fno-strict-aliasing -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libdrm -I/usr/include/libpng16 -pthread -I/usr/include/enchant -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/libpng16 -I/usr/include/freetype2 -I/usr/include/harfbuzz -I/usr/include/harfbuzz -pthread -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/libsoup-2.4 -I/usr/include/libxml2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -I/usr/include/libxml2 -pthread -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -I/usr/include -fvisibility-inlines-hidden -fno-rtti -O2 -pipe -pthread -std=c++11 -Wno-c++11-compat -MT Source/WebCore/inspector/libWebCore_la-InspectorFrontendClientLocal.lo -MD -MP -MF Source/WebCore/inspector/.deps/libWebCore_la-InspectorFrontendClientLocal.Tpo -c Source/WebCore/inspector/InspectorFrontendClientLocal.cpp  -fPIC -DPIC -o Source/WebCore/inspector/.libs/libWebCore_la-InspectorFrontendClientLocal.o
libtool: compile:  x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -DBUILDING_WebCore -DBUILDING_WEBKIT -Wall -W -Wcast-align -Wchar-subscripts -Wreturn-type -Wformat -Wformat-security -Wno-format-y2k -Wundef -Wmissing-format-attribute -Wpointer-arith -Wwrite-strings -Wno-unused-parameter -Wno-parentheses -fno-exceptions -DBUILDING_CAIRO__ -DBUILDING_GTK__ -I./Source/ThirdParty/ANGLE/src -I./Source/ThirdParty/ANGLE/include -I./Source/ThirdParty/ANGLE/include/GLSLANG -I./Source/ThirdParty/ANGLE/include/KHR -I./DerivedSources/Platform -DWEBKITGTK_API_VERSION_STRING=\"1.0\" -DDATA_DIR=\"/usr/share\" -I./Source/ThirdParty/ANGLE/src -I./Source/ThirdParty/ANGLE/include -I./Source/ThirdParty/ANGLE/include/GLSLANG -I./Source/ThirdParty/ANGLE/include/KHR -I./Source/WebCore -I./Source/WebCore/Modules/battery -I./Source/WebCore/Modules/gamepad -I./Source/WebCore/Modules/geolocation -I./Source/WebCore/Modules/indexeddb -I./Source/WebCore/Modules/indexeddb/leveldb -I./Source/WebCore/Modules/indieui -I./Source/WebCore/Modules/mediasource -I./Source/WebCore/Modules/mediastream -I./Source/WebCore/Modules/navigatorcontentutils -I./Source/WebCore/Modules/notifications -I./Source/WebCore/Modules/plugins -I./Source/WebCore/Modules/proximity -I./Source/WebCore/Modules/quota -I./Source/WebCore/Modules/webaudio -I./Source/WebCore/Modules/webdatabase -I./Source/WebCore/Modules/websockets -I./Source/WebCore/accessibility -I./Source/WebCore/bindings -I./Source/WebCore/bindings/generic -I./Source/WebCore/bindings/js -I./Source/WebCore/bridge -I./Source/WebCore/bridge/c -I./Source/WebCore/bridge/jsc -I./Source/WebCore/crypto -I./Source/WebCore/crypto/keys -I./Source/WebCore/css -I./Source/WebCore/cssjit -I./Source/WebCore/dom -I./Source/WebCore/dom/default -I./Source/WebCore/editing -I./Source/WebCore/fileapi -I./Source/WebCore/history -I./Source/WebCore/html -I./Source/WebCore/html/canvas -I./Source/WebCore/html/forms -I./Source/WebCore/html/parser -I./Source/WebCore/html/shadow -I./Source/WebCore/html/track -I./Source/WebCore/inspector -I./Source/WebCore/loader -I./Source/WebCore/loader/appcache -I./Source/WebCore/loader/archive -I./Source/WebCore/loader/archive/mhtml -I./Source/WebCore/loader/cache -I./Source/WebCore/loader/icon -I./Source/WebCore/mathml -I./Source/WebCore/page -I./Source/WebCore/page/animation -I./Source/WebCore/page/scrolling -I./Source/WebCore/platform -I./Source/WebCore/platform/animation -I./Source/WebCore/platform/audio -I./Source/WebCore/platform/graphics -I./Source/WebCore/platform/graphics/cpu/arm -I./Source/WebCore/platform/graphics/cpu/arm/filters/ -I./Source/WebCore/platform/graphics/filters -I./Source/WebCore/platform/graphics/filters/texmap -I./Source/WebCore/platform/graphics/freetype -I./Source/WebCore/platform/graphics/gpu -I./Source/WebCore/platform/graphics/harfbuzz -I./Source/WebCore/platform/graphics/harfbuzz/ng -I./Source/WebCore/platform/graphics/opengl -I./Source/WebCore/platform/graphics/opentype -I./Source/WebCore/platform/graphics/transforms -I./Source/WebCore/platform/image-decoders -I./Source/WebCore/platform/image-decoders/bmp -I./Source/WebCore/platform/image-decoders/gif -I./Source/WebCore/platform/image-decoders/ico -I./Source/WebCore/platform/image-decoders/jpeg -I./Source/WebCore/platform/image-decoders/png -I./Source/WebCore/platform/image-decoders/webp -I./Source/WebCore/platform/leveldb -I./Source/WebCore/platform/linux -I./Source/WebCore/platform/mediastream -I./Source/WebCore/platform/mediastream/gstreamer -I./Source/WebCore/platform/mock -I./Source/WebCore/platform/mock/mediasource -I./Source/WebCore/platform/network -I./Source/WebCore/platform/network/gtk -I./Source/WebCore/platform/sql -I./Source/WebCore/platform/text -I./Source/WebCore/platform/text/icu -I./Source/WebCore/platform/win -I./Source/WebCore/plugins -I./Source/WebCore/plugins/win -I./Source/WebCore/rendering -I./Source/WebCore/rendering/line -I./Source/WebCore/rendering/mathml -I./Source/WebCore/rendering/shapes -I./Source/WebCore/rendering/style -I./Source/WebCore/rendering/svg -I./Source/WebCore/storage -I./Source/WebCore/style -I./Source/WebCore/svg -I./Source/WebCore/svg/animation -I./Source/WebCore/svg/graphics -I./Source/WebCore/svg/graphics/filters -I./Source/WebCore/svg/properties -I./Source/WebCore/testing -I./Source/WebCore/testing/js -I./Source/WebCore/websockets -I./Source/WebCore/workers -I./Source/WebCore/xml -I./Source/WebCore/xml/parser -I./WebCore/bindings/js -I./DerivedSources/WebCore -I./DerivedSources -I./DerivedSources/JavaScriptCore -I./Source/WebCore/platform/graphics/texmap -DWEBKITGTK_API_VERSION_STRING=\"1.0\" -I./Source/WebCore/accessibility/atk -I./Source/WebCore/loader/gtk -I./Source/WebCore/page/gtk -I./Source/WebCore/platform/cairo -I./Source/WebCore/platform/audio/gstreamer -I./Source/WebCore/platform/graphics/cairo -I./Source/WebCore/platform/graphics/freetype -I./Source/WebCore/platform/graphics/glx -I./Source/WebCore/platform/graphics/harfbuzz -I./Source/WebCore/platform/graphics/harfbuzz/ng -I./Source/WebCore/platform/graphics/egl -I./Source/WebCore/platform/graphics/gstreamer -I./Source/WebCore/platform/graphics/gtk -I./Source/WebCore/platform/gtk -I./Source/WebCore/platform/mediastream/gstreamer -I./Source/WebCore/platform/network/soup -I./Source/WebCore/platform/text/enchant -I./Source -I./Source/JavaScriptCore -I./Source/JavaScriptCore/API -I./Source/JavaScriptCore/ForwardingHeaders -I./Source/JavaScriptCore/assembler -I./Source/JavaScriptCore/bindings -I./Source/JavaScriptCore/bytecode -I./Source/JavaScriptCore/bytecompiler -I./Source/JavaScriptCore/debugger -I./Source/JavaScriptCore/dfg -I./Source/JavaScriptCore/disassembler -I./Source/JavaScriptCore/ftl -I./Source/JavaScriptCore/heap -I./Source/JavaScriptCore/inspector -I./Source/JavaScriptCore/inspector/agents -I./Source/JavaScriptCore/interpreter -I./Source/JavaScriptCore/jit -I./Source/JavaScriptCore/llint -I./Source/JavaScriptCore/parser -I./Source/JavaScriptCore/profiler -I./Source/JavaScriptCore/runtime -I./Source/JavaScriptCore/tools -I./Source/JavaScriptCore/yarr -I./DerivedSources/JavaScriptCore -I./Source/WTF -fno-omit-frame-pointer -fno-tree-dce -fno-strict-aliasing -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libdrm -I/usr/include/libpng16 -pthread -I/usr/include/enchant -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/libpng16 -I/usr/include/freetype2 -I/usr/include/harfbuzz -I/usr/include/harfbuzz -pthread -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/libsoup-2.4 -I/usr/include/libxml2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -I/usr/include/libxml2 -pthread -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -I/usr/include -fvisibility-inlines-hidden -fno-rtti -O2 -pipe -pthread -std=c++11 -Wno-c++11-compat -MT Source/WebCore/inspector/libWebCore_la-InspectorFrontendHost.lo -MD -MP -MF Source/WebCore/inspector/.deps/libWebCore_la-InspectorFrontendHost.Tpo -c Source/WebCore/inspector/InspectorFrontendHost.cpp  -fPIC -DPIC -o Source/WebCore/inspector/.libs/libWebCore_la-InspectorFrontendHost.o
In file included from ./Source/WebCore/page/MainFrame.h:30:0,
                 from Source/WebCore/inspector/InspectorFrontendHost.cpp:48:
./Source/WebCore/page/Frame.h:178:58: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <https://bugs.gentoo.org/> for instructions.
GNUmakefile:57953: recipe for target 'Source/WebCore/inspector/libWebCore_la-InspectorFrontendHost.lo' failed
make[1]: *** [Source/WebCore/inspector/libWebCore_la-InspectorFrontendHost.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
mv -f Source/WebCore/inspector/.deps/libWebCore_la-InspectorDOMDebuggerAgent.Tpo Source/WebCore/inspector/.deps/libWebCore_la-InspectorDOMDebuggerAgent.Plo
mv -f Source/WebCore/inspector/.deps/libWebCore_la-InspectorFrontendClientLocal.Tpo Source/WebCore/inspector/.deps/libWebCore_la-InspectorFrontendClientLocal.Plo
mv -f Source/WebCore/inspector/.deps/libWebCore_la-InspectorDOMAgent.Tpo Source/WebCore/inspector/.deps/libWebCore_la-InspectorDOMAgent.Plo
make[1]: Leaving directory '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'
GNUmakefile:25583: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: net-libs/webkit-gtk-2.4.8-r200::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=net-libs/webkit-gtk-2.4.8-r200::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/webkit-gtk-2.4.8-r200::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/temp/environment'.
 * Working directory: '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'
 * S: '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'


Jetzt fiel mir bei 'emerge --info' die Zeile:
Code:
ACCEPT_LICENSE="* -@EULA"

auf - könnte diese ggf. etwas damit zu tun haben, dass 'nero' nicht runtergeladen werden kann?
Ich werde diese Zeile mal auskommentieren und es nochmal mit der Installation versuchen...

Andreas
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Tue Feb 17, 2015 7:41 am    Post subject: Reply with quote

Diese Zeile auf gar keinen Fall auskommentieren. Dann geht gar nichts mehr. Damit akzeptierst du gar keine Lizenz. Was du da machen kannst, ist
Code:
ACCEPT_LICENSE="*"
damit akzeptierst du jede Lizenz, für den Fall, dass es daran liegen sollte. Aber das Problem mit webkit-gtk löst du damit nicht.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Tue Feb 17, 2015 11:28 am    Post subject: Reply with quote

Hm, webkit-gtk wird vermutlich nicht mehr mit deinem alten aktuell noch gesetzten gcc-4.7 bauen. Schalte mit gcc-config am besten auf den neuen schon installierten gcc-4.8 um.

Andreas O. wrote:
könnte diese ggf. etwas damit zu tun haben, dass 'nero' nicht runtergeladen werden kann?
Achso, es scheitern schon beim runterladen der Sourcen?
Diese sind auf dem Mirror vermutlich nicht mehr verfügbar - siehe dazu zb auch im Bug 510594
Schau mal mit einer Suchmaschine nach dem benötigten nerolinux-4.0.0.0b-x86_64.rpm Sourcen, und packe sie mit in /usr/portage/distfiles

/edit
Wenn die distfiles für nero nicht heruntergeladen werden konnten, dann verstehe ich aber nicht so recht wo die schon installierten nero Dateien im System herkommen könnten.
Wurde nero eventuell mal manuell am Paketmanager (ohne portage/emerge) vorbei ins System installiert?
Falls ja, dann wird man die wahrscheinlich auch manuell wieder entfernen müssen.
Back to top
View user's profile Send private message
Andreas O.
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jan 2003
Posts: 132
Location: Welthauptstadt der Biere

PostPosted: Tue Feb 17, 2015 6:11 pm    Post subject: Reply with quote

Josef.95 wrote:
Hm, webkit-gtk wird vermutlich nicht mehr mit deinem alten aktuell noch gesetzten gcc-4.7 bauen. Schalte mit gcc-config am besten auf den neuen schon installierten gcc-4.8 um.

Andreas O. wrote:
könnte diese ggf. etwas damit zu tun haben, dass 'nero' nicht runtergeladen werden kann?
Achso, es scheitern schon beim runterladen der Sourcen?
Diese sind auf dem Mirror vermutlich nicht mehr verfügbar - siehe dazu zb auch im Bug 510594
Schau mal mit einer Suchmaschine nach dem benötigten nerolinux-4.0.0.0b-x86_64.rpm Sourcen, und packe sie mit in /usr/portage/distfiles

/edit
Wenn die distfiles für nero nicht heruntergeladen werden konnten, dann verstehe ich aber nicht so recht wo die schon installierten nero Dateien im System herkommen könnten.
Wurde nero eventuell mal manuell am Paketmanager (ohne portage/emerge) vorbei ins System installiert?
Falls ja, dann wird man die wahrscheinlich auch manuell wieder entfernen müssen.


Hmmm, jetzt wo Du es sagst, könnte es sein, dass ich vor etlichen Monaten es mal manuell mit 'rpm' versucht hatte, nero zu installieren und ich mich nur nicht mehr daran erinnern konnte :oops: (Asche über mein Haupt)...


So, habe nun mit gcc-config auf den neuen gcc umgeschaltet:
Code:
gcc-config -l
 [1] x86_64-pc-linux-gnu-4.7.3
 [2] x86_64-pc-linux-gnu-4.8.3 *


und anschließend noch
Code:
env-update && source /etc/profile


und zum Schluss nochmal
Code:
emerge @preserved-rebuild


neu gestartet, leider immer noch ohne Erfolg:

Code:
In file included from ./Source/WTF/wtf/HashFunctions.h:24:0,
                 from ./Source/WTF/wtf/HashTraits.h:24,
                 from ./Source/WTF/wtf/HashTable.h:32,
                 from ./Source/WTF/wtf/HashMap.h:25,
                 from ./Source/WebCore/svg/properties/SVGAnimatedPropertyDescription.h:26,
                 from ./Source/WebCore/svg/properties/SVGAnimatedProperty.h:25,
                 from ./Source/WebCore/svg/properties/SVGAnimatedStaticPropertyTearOff.h:25,
                 from Source/WebCore/svg/SVGAnimatedBoolean.h:24,
                 from Source/WebCore/svg/SVGMaskElement.h:24,
                 from Source/WebCore/svg/SVGMaskElement.cpp:27:
./Source/WTF/wtf/RefPtr.h: In instantiation of ‘void WTF::RefPtr<T>::swap(WTF::RefPtr<T>&) [with T = WebCore::Document]’:
./Source/WTF/wtf/RefPtr.h:123:17:   required from ‘WTF::RefPtr<T>& WTF::RefPtr<T>::operator=(T*) [with T = WebCore::Document]’
./Source/WebCore/dom/Document.h:923:80:   required from here
./Source/WTF/wtf/RefPtr.h:165:5: internal compiler error: Segmentation fault
     }
     ^
Please submit a full bug report,
with preprocessed source if appropriate.
See <https://bugs.gentoo.org/> for instructions.
GNUmakefile:68166: recipe for target 'Source/WebCore/svg/libWebCoreSVG_la-SVGMaskElement.lo' failed
make[1]: *** [Source/WebCore/svg/libWebCoreSVG_la-SVGMaskElement.lo] Error 1
make[1]: Leaving directory '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'
GNUmakefile:25583: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: net-libs/webkit-gtk-2.4.8-r200::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=net-libs/webkit-gtk-2.4.8-r200::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/webkit-gtk-2.4.8-r200::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/temp/environment'.
 * Working directory: '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'
 * S: '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'

>>> Failed to emerge net-libs/webkit-gtk-2.4.8-r200, Log file:

>>>  '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/temp/build.log'

 * Messages for package net-libs/webkit-gtk-2.4.8-r200:

 * ERROR: net-libs/webkit-gtk-2.4.8-r200::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=net-libs/webkit-gtk-2.4.8-r200::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/webkit-gtk-2.4.8-r200::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/temp/environment'.
 * Working directory: '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'
 * S: '/var/tmp/portage/net-libs/webkit-gtk-2.4.8-r200/work/webkitgtk-2.4.8'

 * Regenerating GNU info directory index...
 * Processed 8 info files.

!!! existing preserved libs:
>>> package: dev-libs/icu-53.1
 *  - /usr/lib64/libicui18n.so.52
 *  - /usr/lib64/libicui18n.so.52.1
 *      used by /usr/lib64/libjavascriptcoregtk-1.0.so.0.16.12 (net-libs/webkit-gtk-2.4.4-r201)
 *      used by /usr/lib64/libwebkitgtk-1.0.so.0.22.10 (net-libs/webkit-gtk-2.4.4-r201)
 *  - /usr/lib64/libicudata.so.52
 *  - /usr/lib64/libicudata.so.52.1
 *  - /usr/lib64/libicuuc.so.52
 *  - /usr/lib64/libicuuc.so.52.1
 *      used by /usr/lib64/libjavascriptcoregtk-1.0.so.0.16.12 (net-libs/webkit-gtk-2.4.4-r201)
 *      used by /usr/lib64/libwebkitgtk-1.0.so.0.22.10 (net-libs/webkit-gtk-2.4.4-r201)
Use emerge @preserved-rebuild to rebuild packages using these libraries


insbesondere hier liegt doch der konkrete Fehler, oder nicht?

Code:
./Source/WTF/wtf/RefPtr.h:165:5: internal compiler error: Segmentation fault


Hmm, soll ich vielleicht, soweit überhaupt noch technisch möglich, auf gcc-4.6 downgraden, oder woran erkenne ich, bei welchem Paket bauen welcher gcc am Werke war bzw. optimal ist?
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Tue Feb 17, 2015 7:15 pm    Post subject: Reply with quote

Den gcc downgraden würde ich auf gar keinen Fall. Du solltest immer den gcc verwenden, der sich bei dir automatisch installiert. Je nachdem, ob du auf Stable oder Testing bist. Die Pakete, die zu diesem Zweig gehören, sind daraufhin getestet, dass sie mit diesem gcc funktionieren. Ein anderer gcc löst da kein Problem, er schafft höchstens welche. Und wenn es mit diesem gcc nicht geht -> Bugreport.
Back to top
View user's profile Send private message
Andreas O.
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jan 2003
Posts: 132
Location: Welthauptstadt der Biere

PostPosted: Tue Feb 17, 2015 8:09 pm    Post subject: Reply with quote

Das mit nero habe ich nun lösen können :D

Josef.95 hatte mich auf die richtige Lösung gebracht, wenn auch von einer anderen Richtung:
Quote:
Schau mal mit einer Suchmaschine nach dem benötigten nerolinux-4.0.0.0b-x86_64.rpm Sourcen, und packe sie mit in /usr/portage/distfiles


In einem Anfall geistiger Umnachtung hatte ich mir wohl mal ein rpm-Binary-Paket besorgt und mit 'rpm' installiert.

Dieses konnte ich nun mit:

Code:
rpm -e -v nerolinux
Pakete vorbereiten...
nerolinux-4.0.0.0-1.i386


wieder komplett deinstallieren, danach lief auch 'revdep-rebuild -i' wieder sauber durch - wer weiß, vielleicht klappt's jetzt ja nun noch mit 'emerge @preserved-rebuild', das ich soeben nochmal gestartet habe.

Das war mir jedenfalls eine Lehre, mir weder mit 'rpm' noch mit 'dpkg" oder ähnlichen tools mir nochmal fremde Pakete ins System zu holen (abgesehen vielleicht von irgendwelchen Drucker-/ oder Scanner-Treibern, die es nur im .deb. bzw. .rpm-Format gibt... :!:
Ich sage noch Bescheid, wenn 'emerge @preserved-rebuild' nun durchlief, ansonsten ist das eigentliche Thema "Nero rückstandslos wieder entfernen" nun gelöst :D

[edit:] 'emerge @preserved-rebuild' lief nun auch durch bezüglich Installation von 'webkit-gtk-2.4.8-r200' :D


Vielen Dank nochmal an alle, die mir geholfen haben!

Andreas
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum