Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[zu Teils Erledigt]nvidia-drivers Kernel-3.19 Problem
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
dekoding
n00b
n00b


Joined: 26 Jan 2015
Posts: 34

PostPosted: Sat Feb 14, 2015 3:32 pm    Post subject: [zu Teils Erledigt]nvidia-drivers Kernel-3.19 Problem Reply with quote

Guten morgen ihr lieben

und zwar linux-3.19.0-gentoo steht bei mir in der ls liste so weit so gut .. und wen ich linux-3.19.0-gentoo in mein boot grub.cfg hinzufüge. mekert er das nvidia nicht laden kann.

okay habe ich dann modprobe nvidia gemacht und naja lauter fehler meldungen, dabei habe ich zufor noch denn nvidia auf denn aktuellen Driver aktualisiert. und dennoch will er nit starten =)

aber mit denn alten Kernel -> Kernel: x86_64 Linux 3.17.8-gentoo-r1 geht es komischer weise =) naja nun boot ich eben halt noch mim alten kernel
_________________
habt nach sicht ich leide unter starke legastheni.


Last edited by dekoding on Tue Feb 17, 2015 7:53 pm; edited 2 times in total
Back to top
View user's profile Send private message
Jean-Paul
Apprentice
Apprentice


Joined: 13 Apr 2009
Posts: 269

PostPosted: Sat Feb 14, 2015 3:46 pm    Post subject: Reply with quote

Nach einem neuen Kernel bietet es sich an ein
Quote:
emerge @module-rebuild
auszuführen, weil Kernelmodule immer gegen den aktuellen Kernel gebaut werden müssen.
_________________
”Everything should be made as simple as possible, but no simpler.” – Albert Einstein
Back to top
View user's profile Send private message
dekoding
n00b
n00b


Joined: 26 Jan 2015
Posts: 34

PostPosted: Sat Feb 14, 2015 4:32 pm    Post subject: Reply with quote

Das habe ich auch gemacht nur denoch ->

Code:
[     7.714] (II) LoadModule: "glx"
[     7.716] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[     7.779] (II) Module glx: vendor="NVIDIA Corporation"
[     7.779]    compiled for 4.0.2, module version = 1.0.0
[     7.779]    Module class: X.Org Server Extension
[     7.779] (II) NVIDIA GLX Module  346.35  Sat Jan 10 20:53:39 PST 2015
[     7.780] Loading extension GLX
[     7.780] (II) LoadModule: "nvidia"
[     7.780] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[     7.785] (II) Module nvidia: vendor="NVIDIA Corporation"
[     7.785]    compiled for 4.0.2, module version = 1.0.0
[     7.785]    Module class: X.Org Video Driver
[     7.786] (II) NVIDIA dlloader X Driver  346.35  Sat Jan 10 20:32:18 PST 2015
[     7.786] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[     7.786] (++) using VT number 7

[     7.787] (II) Loading sub module "fb"
[     7.787] (II) LoadModule: "fb"
[     7.787] (II) Loading /usr/lib64/xorg/modules/libfb.so
[     7.788] (II) Module fb: vendor="X.Org Foundation"
[     7.788]    compiled for 1.15.2, module version = 1.0.0
[     7.788]    ABI class: X.Org ANSI C Emulation, version 0.4
[     7.788] (II) Loading sub module "wfb"
[     7.788] (II) LoadModule: "wfb"
[     7.788] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[     7.789] (II) Module wfb: vendor="X.Org Foundation"
[     7.789]    compiled for 1.15.2, module version = 1.0.0
[     7.789]    ABI class: X.Org ANSI C Emulation, version 0.4
[     7.789] (II) Loading sub module "ramdac"
[     7.789] (II) LoadModule: "ramdac"
[     7.789] (II) Module "ramdac" already built-in
[     7.860] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[     7.860] (EE) NVIDIA:     system's kernel log for additional error messages and
[     7.860] (EE) NVIDIA:     consult the NVIDIA README for details.
[     7.860] (EE) No devices detected.
[     7.860] (EE)
Fatal server error:
[     7.860] (EE) no screens found(EE)
[     7.860] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[     7.860] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[     7.860] (EE)


und so sieht es dann aus nach modprobe nvidia wen ich mein pc neustarte

http://www11.pic-upload.de/14.02.15/ewb7jjnob2ix.jpg

und danach geht nix mehr auser ein neustart und auf nen alten kernel zu booten[/url]
_________________
habt nach sicht ich leide unter starke legastheni.
Back to top
View user's profile Send private message
dekoding
n00b
n00b


Joined: 26 Jan 2015
Posts: 34

PostPosted: Sat Feb 14, 2015 5:58 pm    Post subject: Reply with quote

Was habe ich gemacht.

Als erstes habe ich

Quote:
grub2-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Linux-Abbild gefunden: /boot/kernel-genkernel-x86_64-3.19.0-gentoo
initrd-Abbild gefunden: /boot/initramfs-genkernel-x86_64-3.19.0-gentoo
Linux-Abbild gefunden: /boot/kernel-genkernel-x86_64-3.17.8-gentoo-r1
initrd-Abbild gefunden: /boot/initramfs-genkernel-x86_64-3.17.8-gentoo-r1


damit ich in mein Boot komme von den neuen Kernel.
Danach habe ich denn Kernel mittels genkernel --menuconfig all Aktualliesiert
Danach habe ich modprobe nvidia gemacht
Danach habe ich ein neustart gemacht und seit dem sehe ich nur das komische text verlauf was beim bild angegeben wurde, werde ein neueres schöneres bildchen machen.
_________________
habt nach sicht ich leide unter starke legastheni.
Back to top
View user's profile Send private message
Jean-Paul
Apprentice
Apprentice


Joined: 13 Apr 2009
Posts: 269

PostPosted: Sat Feb 14, 2015 7:45 pm    Post subject: Reply with quote

Zunächst, ich nutze kein nvidia und mit genkernel kenne ich mich überhaupt nicht aus - hab ich noch nie genutzt.

Wenn ich dich richtig verstanden habe, hast du:
- den Kernel-3.19 installiert
- grub aktuallisiert
- danach hast du "menuconfig" nochmals ausgeführt ? Keine Ahnung, ob "genkernel --menuconfig all" nochmals den Kernel baut.
- dann modprobe nvidia

Dann stimmt meines erachtens die Reihenfolge nicht.
- menuconfig ausführen
- Kernel installieren
- grub aktuallieren
- modprobe -r nvidia (altes Modul entfernen)
- modprobe nvidia (neues Modul laden)

Hast du die wiki.Seiten gelesen ?
http://wiki.gentoo.org/wiki/Genkernel
http://wiki.gentoo.org/wiki/NVidia/nvidia-drivers

Ich fürchte, ich kann dir nicht weiterhelfen - wie gesagt, kein genkernel und kein nvidia.
Vielleicht kommt hier auch einer vorbei der nvidia nutzt.
_________________
”Everything should be made as simple as possible, but no simpler.” – Albert Einstein
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3652
Location: Germany

PostPosted: Sat Feb 14, 2015 8:27 pm    Post subject: Reply with quote

Es gibt zZt noch keine kompatiblen nVidia Treiber für den brandneuen linux-3.19.0 Kernel
Hab ein wenig Geduld bis nVidia kompatible Treiber released hat.
Back to top
View user's profile Send private message
arfe
Apprentice
Apprentice


Joined: 24 Aug 2005
Posts: 190
Location: Essen

PostPosted: Sat Feb 14, 2015 8:36 pm    Post subject: Reply with quote

Einen nvidia-driver für den 3.19.0 gibt es schon, aber nicht als stable.

Ebuild nvidia-drivers-346.35.ebuild funktioniert mit 3.19.0
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3652
Location: Germany

PostPosted: Sat Feb 14, 2015 9:02 pm    Post subject: Reply with quote

@arfe
Hm, =nvidia-drivers-346.35 sind auf amd64 und x86 stable markiert - siehe zb im
Code:
eshowkw nvidia-drivers
Keywords for x11-drivers/nvidia-drivers:
             |                             | u   | 
             | a a   a           p     s   | n   | 
             | l m   r h i m m   p s   p   | u s | r
             | p d a m p a 6 i p c 3   a x | s l | e
             | h 6 r 6 p 6 8 p p 6 9 s r 8 | e o | p
             | a 4 m 4 a 4 k s c 4 0 h c 6 | d t | o
-------------+-----------------------------+-----+-------
 [M]96.43.23 | * + * * * * * * * * * * * + | # 0 | gentoo
[M]173.14.39 | * + * * * * * * * * * * * + | #   | gentoo
     304.125 | * + * * * * * * * * * * * + | #   | gentoo
     331.113 | * + * * * * * * * * * * * + | #   | gentoo
      340.76 | * + * * * * * * * * * * * + | #   | gentoo
      343.36 | * + * * * * * * * * * * * + | #   | gentoo
   [I]346.35 | * + * * * * * * * * * * * + | o   | gentoo

Ohne weitere Patches werden diese für >=linux-3.18 aber wahrscheinlich noch nicht wirklich wie gewünscht funktionieren.
(sie bauen vielleicht, aber auch funktionieren ist ne andere sache :))

Laut nvidia-drivers-346.35.ebuild wird zZt
"<sys-kernel/gentoo-sources-3.18"
"<sys-kernel/vanilla-sources-3.18"
unterstützt.

/edit
Mit dem im https://bugs.gentoo.org/show_bug.cgi?id=532082#c5
verlinkten Patch sollte linux-3.18 wahrscheinlich schon gut gehen, aber 3.19? ...
Back to top
View user's profile Send private message
platinumviper
l33t
l33t


Joined: 12 Feb 2004
Posts: 626
Location: Munich, Germany

PostPosted: Sun Feb 15, 2015 11:31 pm    Post subject: Reply with quote

Bei mir funktioniert nvidia-drivers-346.35 mit Kernel 3.19 problemlos. Ich verwende allerdings den Original-Kernel und nicht einen gepatchten und ich kompiliere ihn so, wie es seit 15 Jahren in der README steht, also als normaler User und in einem Verzeichnis unter ~.
_________________
No money back garantee. In case of problems, don't call us, we call you.
Back to top
View user's profile Send private message
arfe
Apprentice
Apprentice


Joined: 24 Aug 2005
Posts: 190
Location: Essen

PostPosted: Mon Feb 16, 2015 9:20 am    Post subject: Reply with quote

Genauso ist es bei mir auch. :D
Back to top
View user's profile Send private message
dekoding
n00b
n00b


Joined: 26 Jan 2015
Posts: 34

PostPosted: Mon Feb 16, 2015 9:23 am    Post subject: Reply with quote

naja ich hab ihn wohl mit modprobe nvidia beleidigt :(

(Schöneres foto als zuvor)

http://www11.pic-upload.de/15.02.15/rwtapov853z7.jpg

und nein es ist kein panic.

und zwar startet er denn boot vorgang reibungs los

und dann wo die Anmeldung (Oberfläche) kommen sollte kommt halt das Bildchen.

und mein latein ist da am ende mit rrmod usw schon alles getestet.

ich vermute das der modprobe selbst was hat.
_________________
habt nach sicht ich leide unter starke legastheni.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3652
Location: Germany

PostPosted: Mon Feb 16, 2015 5:16 pm    Post subject: Reply with quote

@platinumviper,arfe
Ok prima wenn es schon ohne zusätzliche Patches mit linux-3.19 funktioniert (ich hatte es ehrlich gesagt noch gar nicht selbst ausprobiert).

@dekoding
Dein neues Foto ist (für mich) immer noch nicht lesbar. (man sollte lesen können was da steht)
dekoding wrote:
[...]ich vermute das der modprobe selbst was hat.

Hm nee, vermutlich macht eher das laden des nvidia Moduls irgendwas im Kernel oder/und X kaputt.
Eventuell könnte es auch an einer nicht passenden Kernel .config liegen. Magst du die mal via pastebin-service mit bereitstellen?
/edit Und das komplette /var/log/Xorg.0.log bitte.
Back to top
View user's profile Send private message
dekoding
n00b
n00b


Joined: 26 Jan 2015
Posts: 34

PostPosted: Tue Feb 17, 2015 7:52 pm    Post subject: Reply with quote

so...

Nach ein neu Installation dessen Kernel usw.

ich vermute mal das meine 660TI noch nicht unterstützt wird, ist alles kein Problem ich hab es soweit geschaft das in nouveau soweit alles funktioniert

und ich bin nun auch etwas schlauer geworden =) wen ich in OpenBox bin und modprobe nvidia mache hängt sich mein gesamtes pc auf *lächle*
_________________
habt nach sicht ich leide unter starke legastheni.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3652
Location: Germany

PostPosted: Tue Feb 17, 2015 10:20 pm    Post subject: Reply with quote

dekoding,
vermutlich versuchst du zwei Grafiktreiber gleichzeitig zu nutzen (nouveau und nvidia)
das kann nicht gutgehen.
Stelle sicher das im Kernel nicht schon der nouveau Treiber geladen ist - dann sollte es auch mit dem laden des nvidia Moduls klappen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum