Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No ethernet connection with Intel 82566DC-2 after install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
jrambo
n00b
n00b


Joined: 17 Feb 2015
Posts: 9

PostPosted: Wed Feb 18, 2015 3:27 pm    Post subject: No ethernet connection with Intel 82566DC-2 after install Reply with quote

After doing a ping
ping: unknown host www.google.com

After command:
ifconfig - a

lo:flags=73 etc...
sit0 = flags 128 etc...

lspci gave me the following network card
Ethernet controller: Intel Corporation 82566DC-2 Gigabit Network Connection (rev 02)

I tested out with some Intel devices in the kernel:
Intel PRO/1000 PCI-Express Gigabit Ethernet support (Build-in)

Also added :
Drivers for the Intel LXT PHYs

After :
make menuconfig

I do a : make or make && make modules_install (What's the difference? between these 2)

And last : make install

Also 1 note when systeem boots I just see in a flash some error network related but its to fast
is there a pause option...

Also found this driver from Intel but that's only supported as a Module.
I have no Idea how to get it on the harddrive.

The e1000e Linux base driver supports the 2.4.x, 2.6.x, and 3.x kernels, and
includes support for Itanium® 2-based systems. It is only supported as a
loadable module.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2613

PostPosted: Wed Feb 18, 2015 5:53 pm    Post subject: Re: No ethernet connection with Intel 82566DC-2 after instal Reply with quote

jrambo wrote:
lspci gave me the following network card
Ethernet controller: Intel Corporation 82566DC-2 Gigabit Network Connection (rev 02)
Please try lspci -k in order to check for the driver.
Back to top
View user's profile Send private message
jrambo
n00b
n00b


Joined: 17 Feb 2015
Posts: 9

PostPosted: Wed Feb 18, 2015 8:57 pm    Post subject: Re: No ethernet connection with Intel 82566DC-2 after instal Reply with quote

charles17 wrote:
jrambo wrote:
lspci gave me the following network card
Ethernet controller: Intel Corporation 82566DC-2 Gigabit Network Connection (rev 02)
Please try lspci -k in order to check for the driver.


I used : lspci -k

For other devices I see (example):
Subsystem: Intel Corporation Desktop Board DPD35DP
Kernel driver in use : uhci_hcd

For the networkcard 82566DC-2
Subsystem : Intel Corporation Device 0001
But NO line Kernel driver in use at all...

Also took a picture of the screen this time because its scrolls to fast:
ERROR: interface eth0 does not exist
Ensure that you have loaded the correct...
ERROR: net.eth0 failed to start
ERROR: cannot start netmount as net.eth0...
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43192
Location: 56N 3W

PostPosted: Wed Feb 18, 2015 9:50 pm    Post subject: Reply with quote

jrambo,

Run lspci -nn and post the Vendor and Device IDs.
The vendor will be 8086 for intel.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
jrambo
n00b
n00b


Joined: 17 Feb 2015
Posts: 9

PostPosted: Wed Feb 18, 2015 9:59 pm    Post subject: Reply with quote

NeddySeagoon wrote:
jrambo,

Run lspci -nn and post the Vendor and Device IDs.
The vendor will be 8086 for intel.


Hi Neddy

When I lspci -nn

I see Connection
00:19:0 Ethernet controller [0200]: Intel Corporation 82566DC-2 Gigabit Network Connection
[8086:294c] (rev 02)

I just downloaded a driver from intel for this card:
wget -P /tmp http://downloadmirror.intel.com/15817/eng/e1000e-3.1.0.2.tar.gz

Didn't know where to place it "/tmp" or extract or how to go from here.
Back to top
View user's profile Send private message
jrambo
n00b
n00b


Joined: 17 Feb 2015
Posts: 9

PostPosted: Wed Feb 18, 2015 10:03 pm    Post subject: Reply with quote

jrambo wrote:
NeddySeagoon wrote:
jrambo,

Run lspci -nn and post the Vendor and Device IDs.
The vendor will be 8086 for intel.


Hi Neddy

When I lspci -nn

I see Connection
00:19:0 Ethernet controller [0200]: Intel Corporation 82566DC-2 Gigabit Network Connection
[8086:294c] (rev 02)

I just downloaded a driver from intel for this card:
wget -P /tmp http://downloadmirror.intel.com/15817/eng/e1000e-3.1.0.2.tar.gz

Didn't know where to place it "/tmp" or extract or how to go from here.


Well I thought I downloaded it with the Gentoo boot cd.
When rebooted it was gone...
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43192
Location: 56N 3W

PostPosted: Wed Feb 18, 2015 10:06 pm    Post subject: Reply with quote

jrambo,

This page says your NIC is covered by the kernel e1000e driver.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
jrambo
n00b
n00b


Joined: 17 Feb 2015
Posts: 9

PostPosted: Wed Feb 18, 2015 10:36 pm    Post subject: Reply with quote

NeddySeagoon wrote:
jrambo,

This page says your NIC is covered by the kernel e1000e driver.


I've put Intel(R) PRO/1000 PCI-Express Gigabit Ethernet support as a module <M>

lspci -k now shows

Subsystem: Intel Corporation Device 0001
Kernel driver in use : e1000e
Kernel modules : e1000e

and ifconfig -a

enp0s25: flags=4098<BROADCAST,MULTICAST> mtu etc etc
lo: etc
sit0: etc

I don't get an ip adress in ifconfig

Also name is not eth0 but enp0s25
Back to top
View user's profile Send private message
jrambo
n00b
n00b


Joined: 17 Feb 2015
Posts: 9

PostPosted: Wed Feb 18, 2015 11:42 pm    Post subject: Reply with quote

I give up being busy for hours for only trying to install a network driver.

Thanks for the help neddy
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum