Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
switch 3.18 -> 3.19 problems recompiling ati-drivers14.12-r3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1439
Location: indiana

PostPosted: Wed Feb 18, 2015 8:29 pm    Post subject: switch 3.18 -> 3.19 problems recompiling ati-drivers14.12 Reply with quote

hi there,

switching the kernel worked so far. except when i try to start X11 server after kernel update. gnome3 quits with some strange error, and so i thought it is time to recompile the ati-drivers but that does not work :

Code:
build_mod/2.6.x/kcl_iommu.c: In function 'KCL_IOMMU_RestoreCBs':
/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_iommu.c:230:1: warning: control reaches end of non-void function [-Wreturn-type]
 }
 ^
/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'kasSetExecutionLevel':
/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4821:5: error: implicit declaration of function '__get_cpu_var' [-Werror=implicit-function-declaration]
     orig_level = __get_cpu_var(kasExecutionLevel);
     ^
/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4822:38: error: lvalue required as left operand of assignment
     __get_cpu_var(kasExecutionLevel) = level;
                                      ^
/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: At top level:
/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:6398:12: warning: 'KCL_fpu_save_init' defined but not used [-Wunused-function]
 static int KCL_fpu_save_init(struct task_struct *tsk)
            ^
cc1: some warnings being treated as errors
scripts/Makefile.build:257: recipe for target '/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o' failed
make[2]: *** [/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
Makefile:1382: recipe for target '_module_/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/work/common/lib/modules/fglrx/build_mod/2.6.x' failed
make[1]: *** [_module_/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/work/common/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[1]: Leaving directory '/usr/src/linux-3.19.0-gentoo'
Makefile:88: recipe for target 'kmod_build' failed
make: *** [kmod_build] Error 2



the drivers compile fine when using 3.18.1 kernel. has anyone any suggestions on this ?? thanks in advance
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
KAMIKAZE_
Guru
Guru


Joined: 09 Oct 2003
Posts: 306
Location: Riga, Latvia

PostPosted: Sat Feb 21, 2015 1:01 am    Post subject: Reply with quote

have the same problem
_________________
-=[powered by Gentoo]=-
Back to top
View user's profile Send private message
bdouxx
Tux's lil' helper
Tux's lil' helper


Joined: 28 Dec 2009
Posts: 116

PostPosted: Sat Feb 21, 2015 8:36 am    Post subject: Reply with quote

same for me.

I have declared a bug

https://bugs.gentoo.org/show_bug.cgi?id=540880
Back to top
View user's profile Send private message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1439
Location: indiana

PostPosted: Sat Feb 28, 2015 11:59 am    Post subject: Reply with quote

it is a known issue : https://forums.gentoo.org/viewtopic-t-1010546.html?sid=e93f3b1419a02fb217e579e2e7eecc6f
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1439
Location: indiana

PostPosted: Thu Mar 12, 2015 8:55 pm    Post subject: Reply with quote

since now there is sys-kernel/gentoo-sources-3.19.2 in portage available. did someone check if the error is gone now ?

there are still no new ati-drivers out ...



edit : 3.19.2 leads to same fault in gnome3 start. also it is still impossible to compile the current unstable ati-drivers with it. strange thing, since my last world update i cannot start gnome3 with 3.18 anymore.

i am using 3.19.2 with XFCE4 and old (with 3.18 ) compiled ati-drivers.

i`d really appreciate it if someone could share experiences :)

thanks
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1439
Location: indiana

PostPosted: Fri Apr 03, 2015 2:03 pm    Post subject: Reply with quote

i guess the gnome error is unrelated to the 3.19 and ati-drivers issue(i uninstalled some gnome packages)

still with 3.19.3 i can not compile the latest ati-drivers-14.12-r3, so still no 3d acceleration with 3.19.3

i could give the open-source a shot, but so far they have been much slower than the ati binaries.
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1439
Location: indiana

PostPosted: Fri Apr 03, 2015 2:56 pm    Post subject: Reply with quote

ati-drivers-14.12-r3 and r4 from x11 overlay did not work for me. i could install ati-drivers-15.1 though.

using gentoo-sources-3.19.3 and ati-drivers-15.1 from x11 overlay does work. still have to check if they work with xorg-1.17. and then do a performace test with 32 bit steam games, lets see if it was all worth the hassle.


edit:after recent abi_32 changes i had to remove emul-linux-*. now 32 bit sound dont work (steam/firefox-flash)
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1439
Location: indiana

PostPosted: Wed Apr 08, 2015 2:57 pm    Post subject: Reply with quote

ati-drivers-15.1 are in regular portage tree now. so 3.19 should run fine with current ati-drivers.
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
lostinspace2011
Apprentice
Apprentice


Joined: 09 Sep 2005
Posts: 211

PostPosted: Sun Nov 15, 2015 3:52 am    Post subject: Reply with quote

I am still only seeing the old version

Quote:
* x11-drivers/ati-drivers
Latest version available: 14.12-r3
Latest version installed: 14.12-r3
Size of files: 152540 KiB
Homepage: http://www.amd.com
Description: Ati precompiled drivers for Radeon Evergreen (HD5000 Series) and newer chipsets
License: AMD GPL-2 QPL-1.0
Back to top
View user's profile Send private message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1439
Location: indiana

PostPosted: Sun Nov 15, 2015 3:56 am    Post subject: Reply with quote

Maybe you should put ati-drivers in /etc/portage/package.keywords. means you have to unmask the unstable drivers...

Good luck
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
lostinspace2011
Apprentice
Apprentice


Joined: 09 Sep 2005
Posts: 211

PostPosted: Wed Dec 23, 2015 5:48 am    Post subject: Reply with quote

Upgrading to the latest kernel / driver works which is great. However now I am having issues with firefox:
https://forums.gentoo.org/viewtopic-t-1035436-highlight-.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum