Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gentoo rtl8192ce: firmware load failed with error -2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
muAries
n00b
n00b


Joined: 19 Feb 2015
Posts: 6

PostPosted: Thu Feb 19, 2015 10:22 am    Post subject: gentoo rtl8192ce: firmware load failed with error -2 Reply with quote

Hello,
My wireless firmware can not be loaded. Here is some information:
Thankyou!
:)

Code:

dmesg | grep rtl
[    1.155354] rtl8192ce:_rtl92ce_read_chip_version():<0-0> Chip Version ID: B_CHIP_88C
[    1.165360] rtl8192ce: Using firmware rtlwifi/rtl8192cfw.bin
[    1.166256] rtl8192ce 0000:02:00.0: Direct firmware load for rtlwifi/rtl8192cfw.bin failed with error -2
[    1.167163] rtlwifi: Firmware rtlwifi/rtl8192cfw.bin not available

============================================================

lspci -k
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
   Subsystem: Toshiba America Info Systems Device ff1e
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
   Subsystem: Toshiba America Info Systems Device fce0
   Kernel driver in use: i915
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
   Subsystem: Toshiba America Info Systems Device ff1e
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
   Subsystem: Toshiba America Info Systems Device ff1e
   Kernel driver in use: ehci-pci
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
   Subsystem: Toshiba America Info Systems Device ff1e
   Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
   Kernel driver in use: pcieport
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
   Kernel driver in use: pcieport
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
   Subsystem: Toshiba America Info Systems Device ff1e
   Kernel driver in use: ehci-pci
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
   Subsystem: Toshiba America Info Systems Device ff1e
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
   Subsystem: Toshiba America Info Systems Device ff1e
   Kernel driver in use: ahci
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
   Subsystem: Toshiba America Info Systems Device ff1e
01:00.0 Ethernet controller: Qualcomm Atheros AR8152 v2.0 Fast Ethernet (rev c1)
   Subsystem: Toshiba America Info Systems Device ff1e
   Kernel driver in use: atl1c
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
   Subsystem: Realtek Semiconductor Co., Ltd. Device 8182
   Kernel driver in use: rtl8192ce


============================================================

uname -a


Linux Jemir 3.17.8-gentoo-r1 #2 SMP Tue Feb 17 14:25:29 CST 2015 x86_64 Intel(R) Core(TM) i3-2330M CPU @ 2.20GHz GenuineIntel GNU/Linux


============================================================

ifconfig -a

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.104  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::226:6cff:fed6:34ac  prefixlen 64  scopeid 0x20<link>
        ether 00:26:6c:d6:34:ac  txqueuelen 1000  (Ethernet)
        RX packets 19641  bytes 17957659 (17.1 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 18800  bytes 2593047 (2.4 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 1  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 4  bytes 240 (240.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4  bytes 240 (240.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

sit0: flags=128<NOARP>  mtu 1480
        sit  txqueuelen 0  (IPv6-in-IPv4)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


_________________
ILoveYou SYQ.


Last edited by muAries on Fri Feb 20, 2015 10:48 am; edited 2 times in total
Back to top
View user's profile Send private message
massimo
Veteran
Veteran


Joined: 22 Jun 2003
Posts: 1226

PostPosted: Thu Feb 19, 2015 1:29 pm    Post subject: Reply with quote

Is the package sys-kernel/linux-firmware installed on your system?
_________________
Hello 911? How are you?
Back to top
View user's profile Send private message
muAries
n00b
n00b


Joined: 19 Feb 2015
Posts: 6

PostPosted: Thu Feb 19, 2015 3:04 pm    Post subject: Reply with quote

massimo wrote:
Is the package sys-kernel/linux-firmware installed on your system?

sure
_________________
ILoveYou SYQ.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2613

PostPosted: Thu Feb 19, 2015 3:08 pm    Post subject: Reply with quote

muAries wrote:
massimo wrote:
Is the package sys-kernel/linux-firmware installed on your system?

sure
And driver compiled as module?
Back to top
View user's profile Send private message
muAries
n00b
n00b


Joined: 19 Feb 2015
Posts: 6

PostPosted: Thu Feb 19, 2015 3:10 pm    Post subject: Reply with quote

charles17 wrote:
muAries wrote:
massimo wrote:
Is the package sys-kernel/linux-firmware installed on your system?

sure
And driver compiled as module?


No, it is compiled into kernel.
Look at my output of lspci
_________________
ILoveYou SYQ.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2613

PostPosted: Thu Feb 19, 2015 3:47 pm    Post subject: Reply with quote

muAries wrote:
No, it is compiled into kernel.
Look at my output of lspci
And also firmware compiled into the kernel?
Back to top
View user's profile Send private message
muAries
n00b
n00b


Joined: 19 Feb 2015
Posts: 6

PostPosted: Thu Feb 19, 2015 3:51 pm    Post subject: Reply with quote

charles17 wrote:
muAries wrote:
No, it is compiled into kernel.
Look at my output of lspci
And also firmware compiled into the kernel?


I did not compile it into the kernel before. The problem raises.
Then someone suggest me compiling it into kernel and I did. The problem remains...
_________________
ILoveYou SYQ.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2613

PostPosted: Thu Feb 19, 2015 4:27 pm    Post subject: Reply with quote

muAries wrote:
Then someone suggest me compiling it into kernel and I did. The problem remains...
Try again with both as modules and check dmesg again. It should work.
Did you see this post?
Back to top
View user's profile Send private message
muAries
n00b
n00b


Joined: 19 Feb 2015
Posts: 6

PostPosted: Fri Feb 20, 2015 9:36 am    Post subject: Reply with quote

charles17 wrote:
muAries wrote:
Then someone suggest me compiling it into kernel and I did. The problem remains...
Try again with both as modules and check dmesg again. It should work.
Did you see this post?


Thank you very much. I compiled it as a module and it worked![/topic]
_________________
ILoveYou SYQ.
Back to top
View user's profile Send private message
muAries
n00b
n00b


Joined: 19 Feb 2015
Posts: 6

PostPosted: Fri Feb 20, 2015 10:58 am    Post subject: Reply with quote

But when I start wlan0:

Code:

/etc/init.d/wlan0 start

* Bringing up interface wlan0
 *   Starting wpa_supplicant on wlan0 ...Successfully initialized wpa_supplicant
wlan0: Unsupported driver 'rtl8192ce'
 [ !! ]
art-stop-daemon: failed to start `/usr/sbin/wpa_supplicant'
 * ERROR: net.wlan0 failed to start

====================




I do no know how to configure it very well however...
Thank you!
Here are some configuration:

Code:

====================
ifconfig

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.104  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::226:6cff:fed6:34ac  prefixlen 64  scopeid 0x20<link>
        ether 00:26:6c:d6:34:ac  txqueuelen 1000  (Ethernet)
        RX packets 29854  bytes 26490170 (25.2 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 28474  bytes 4106948 (3.9 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 1  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 10  bytes 600 (600.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 10  bytes 600 (600.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::e2ca:94ff:fe46:b1ba  prefixlen 64  scopeid 0x20<link>
        ether e0:ca:94:46:b1:ba  txqueuelen 1000  (Ethernet)
        RX packets 28  bytes 6842 (6.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 18  bytes 2240 (2.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

====================
lspci -k

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
   Subsystem: Toshiba America Info Systems Device ff1e
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
   Subsystem: Toshiba America Info Systems Device fce0
   Kernel driver in use: i915
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
   Subsystem: Toshiba America Info Systems Device ff1e
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
   Subsystem: Toshiba America Info Systems Device ff1e
   Kernel driver in use: ehci-pci
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
   Subsystem: Toshiba America Info Systems Device ff1e
   Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
   Kernel driver in use: pcieport
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
   Kernel driver in use: pcieport
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
   Subsystem: Toshiba America Info Systems Device ff1e
   Kernel driver in use: ehci-pci
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
   Subsystem: Toshiba America Info Systems Device ff1e
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
   Subsystem: Toshiba America Info Systems Device ff1e
   Kernel driver in use: ahci
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
   Subsystem: Toshiba America Info Systems Device ff1e
01:00.0 Ethernet controller: Qualcomm Atheros AR8152 v2.0 Fast Ethernet (rev c1)
   Subsystem: Toshiba America Info Systems Device ff1e
   Kernel driver in use: atl1c
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
   Subsystem: Realtek Semiconductor Co., Ltd. Device 8182
   Kernel driver in use: rtl8192ce
   Kernel modules: rtl8192ce


====================
iwconfig

wlan0     IEEE 802.11bgn  ESSID:"TP-LINK_472FBC" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: A8:57:4E:47:2F:BC   
          Bit Rate=15 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-20 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

====================
cat /etc/wpa_supplicant/wpa_supplicant.conf

# The below line not be changed otherwise wpa_supplicant refuses to work
ctrl_interface=/var/run/wpa_supplicant GROUP=wheel
update_config=1
# Ensure that only root can read the WPA configuration
ctrl_interface_group=0
 
# Let wpa_supplicant take care of scanning and AP selection
ap_scan=1
 
# Simple case: WPA-PSK, PSK as an ASCII passphrase, allow all valid ciphers
network={
  ssid="TP-LINK_472FBC"
  psk="123456"
  # The higher the priority the sooner we are matched
#scan_ssid=1
#proto="WPA2"
  priority=5
#key_mgmt=WPA-PSK
#group=CCMP TKIP
#pairwise=CCMP TKIP
}

====================
cat /etc/conf.d/net

config_eth0="dhcp"

config_wlan0="dhcp"
modules_wlan0=("wpa_supplicant")
wpa_supplicant_wlan0="-Drtl8192ce"

key_ESSID1="[1] s:123456 key [1] enc open"
preferred_aps="'TP-LINK_472FBC'"

====================



_________________
ILoveYou SYQ.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2613

PostPosted: Sat Feb 21, 2015 8:35 am    Post subject: Reply with quote

muAries wrote:
But when I start wlan0:

Code:

/etc/init.d/wlan0 start

* Bringing up interface wlan0
 *   Starting wpa_supplicant on wlan0 ...Successfully initialized wpa_supplicant
wlan0: Unsupported driver 'rtl8192ce'
 [ !! ]
art-stop-daemon: failed to start `/usr/sbin/wpa_supplicant'
 * ERROR: net.wlan0 failed to start

====================




I do no know how to configure it very well however...

There is a severe mistake in your /etc/conf.d/net. Driver should be nl80211 and IIRC that line should no longer be needed at all.
But maybe you might want to have a look at https://wiki.gentoo.org/wiki/Network_management_using_DHCPCD making things much easier.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum