Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Logitech G930 Headset - Microphone not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
thegromph
n00b
n00b


Joined: 22 Feb 2015
Posts: 4

PostPosted: Sun Feb 22, 2015 6:58 pm    Post subject: Logitech G930 Headset - Microphone not working Reply with quote

Hello,

I am stuck trying to troubleshoot this problem. My Logitech G930 Headset is detected by pulseaudio and audio playback is working correctly. However I can't get the microphone working. It's not muted in pavucontrol but arecord | aplay doesn't play anything. Wild googling didn't yield any solutions. I would appreciate any guidance for things that I should try.

Thanks!
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44153
Location: 56N 3W

PostPosted: Sun Feb 22, 2015 9:52 pm    Post subject: Reply with quote

thegromph,

Welcome to Gentoo.

A few things to look at. Headsets usually have a mute switch.
On some its a physical switch, on others its a signal to software.

Sound inputs usually need to be selected correctly in your mixer software.
Further, thate ore at least two classes of mic, those that need the 20db Mic boost and those that don't.

The last complication is that a headset is usually its own sound card. This means that you most likely have two or more sound cards, so you need to pick the input from the right sound card too.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
thegromph
n00b
n00b


Joined: 22 Feb 2015
Posts: 4

PostPosted: Mon Feb 23, 2015 1:00 am    Post subject: Reply with quote

Thanks NeddySeagoon,

The headset itself isn't muted (that would have been embarrassing). I also tried cranking up the gain in pavucontrol but it still doesn't seem to be working.

Here is the output of pactl list so you can see what other sound devices there are. Seems like the correct profile is in use for the card and all the other inputs are disabled.

Code:
Card #0
   Name: alsa_card.pci-0000_01_00.1
   Driver: module-alsa-card.c
   Owner Module: 6
   Properties:
      alsa.card = "1"
      alsa.card_name = "HDA ATI HDMI"
      alsa.long_card_name = "HDA ATI HDMI at 0xf0040000 irq 30"
      alsa.driver_name = "snd_hda_intel"
      device.bus_path = "pci-0000:01:00.1"
      sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1"
      device.bus = "pci"
      device.vendor.id = "1002"
      device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
      device.product.id = "aa88"
      device.product.name = "Barts HDMI Audio [Radeon HD 6800 Series]"
      device.string = "1"
      device.description = "Barts HDMI Audio [Radeon HD 6800 Series]"
      module-udev-detect.discovered = "1"
      device.icon_name = "audio-card-pci"
   Profiles:
      output:hdmi-stereo: Digital Stereo (HDMI) Output (sinks: 1, sources: 0, priority: 5400, available: yes)
      off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
   Active Profile: output:hdmi-stereo
   Ports:
      hdmi-output-0: HDMI / DisplayPort (priority: 5900, latency offset: 0 usec, available)
         Properties:
            device.icon_name = "video-display"
         Part of profile(s): output:hdmi-stereo

Card #1
   Name: alsa_card.pci-0000_00_1b.0
   Driver: module-alsa-card.c
   Owner Module: 7
   Properties:
      alsa.card = "0"
      alsa.card_name = "HDA Intel PCH"
      alsa.long_card_name = "HDA Intel PCH at 0xf0330000 irq 29"
      alsa.driver_name = "snd_hda_intel"
      device.bus_path = "pci-0000:00:1b.0"
      sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
      device.bus = "pci"
      device.vendor.id = "8086"
      device.vendor.name = "Intel Corporation"
      device.product.id = "8c20"
      device.product.name = "8 Series/C220 Series Chipset High Definition Audio Controller"
      device.form_factor = "internal"
      device.string = "0"
      device.description = "Built-in Audio"
      module-udev-detect.discovered = "1"
      device.icon_name = "audio-card-pci"
   Profiles:
      input:analog-stereo: Analog Stereo Input (sinks: 0, sources: 1, priority: 60, available: yes)
      input:iec958-stereo: Digital Stereo (IEC958) Input (sinks: 0, sources: 1, priority: 55, available: yes)
      output:analog-stereo: Analog Stereo Output (sinks: 1, sources: 0, priority: 6000, available: yes)
      output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (sinks: 1, sources: 1, priority: 6060, available: yes)
      output:analog-stereo+input:iec958-stereo: Analog Stereo Output + Digital Stereo (IEC958) Input (sinks: 1, sources: 1, priority: 6055, available: yes)
      output:analog-surround-40: Analog Surround 4.0 Output (sinks: 1, sources: 0, priority: 700, available: yes)
      output:analog-surround-40+input:analog-stereo: Analog Surround 4.0 Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 760, available: yes)
      output:analog-surround-40+input:iec958-stereo: Analog Surround 4.0 Output + Digital Stereo (IEC958) Input (sinks: 1, sources: 1, priority: 755, available: yes)
      output:analog-surround-41: Analog Surround 4.1 Output (sinks: 1, sources: 0, priority: 800, available: yes)
      output:analog-surround-41+input:analog-stereo: Analog Surround 4.1 Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 860, available: yes)
      output:analog-surround-41+input:iec958-stereo: Analog Surround 4.1 Output + Digital Stereo (IEC958) Input (sinks: 1, sources: 1, priority: 855, available: yes)
      output:analog-surround-50: Analog Surround 5.0 Output (sinks: 1, sources: 0, priority: 700, available: yes)
      output:analog-surround-50+input:analog-stereo: Analog Surround 5.0 Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 760, available: yes)
      output:analog-surround-50+input:iec958-stereo: Analog Surround 5.0 Output + Digital Stereo (IEC958) Input (sinks: 1, sources: 1, priority: 755, available: yes)
      output:analog-surround-51: Analog Surround 5.1 Output (sinks: 1, sources: 0, priority: 800, available: yes)
      output:analog-surround-51+input:analog-stereo: Analog Surround 5.1 Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 860, available: yes)
      output:analog-surround-51+input:iec958-stereo: Analog Surround 5.1 Output + Digital Stereo (IEC958) Input (sinks: 1, sources: 1, priority: 855, available: yes)
      output:analog-surround-71: Analog Surround 7.1 Output (sinks: 1, sources: 0, priority: 700, available: yes)
      output:analog-surround-71+input:analog-stereo: Analog Surround 7.1 Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 760, available: yes)
      output:analog-surround-71+input:iec958-stereo: Analog Surround 7.1 Output + Digital Stereo (IEC958) Input (sinks: 1, sources: 1, priority: 755, available: yes)
      output:iec958-stereo: Digital Stereo (IEC958) Output (sinks: 1, sources: 0, priority: 5500, available: yes)
      output:iec958-stereo+input:analog-stereo: Digital Stereo (IEC958) Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 5560, available: yes)
      output:iec958-stereo+input:iec958-stereo: Digital Stereo Duplex (IEC958) (sinks: 1, sources: 1, priority: 5555, available: yes)
      off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
   Active Profile: off
   Ports:
      analog-input-front-mic: Front Microphone (priority: 8500, latency offset: 0 usec, not available)
         Properties:
            device.icon_name = "audio-input-microphone"
         Part of profile(s): input:analog-stereo, output:analog-stereo+input:analog-stereo, output:analog-surround-40+input:analog-stereo, output:analog-surround-41+input:analog-stereo, output:analog-surround-50+input:analog-stereo, output:analog-surround-51+input:analog-stereo, output:analog-surround-71+input:analog-stereo, output:iec958-stereo+input:analog-stereo
      analog-input-rear-mic: Rear Microphone (priority: 8200, latency offset: 0 usec, not available)
         Properties:
            device.icon_name = "audio-input-microphone"
         Part of profile(s): input:analog-stereo, output:analog-stereo+input:analog-stereo, output:analog-surround-40+input:analog-stereo, output:analog-surround-41+input:analog-stereo, output:analog-surround-50+input:analog-stereo, output:analog-surround-51+input:analog-stereo, output:analog-surround-71+input:analog-stereo, output:iec958-stereo+input:analog-stereo
      analog-input-linein: Line In (priority: 8100, latency offset: 0 usec, not available)
         Part of profile(s): input:analog-stereo, output:analog-stereo+input:analog-stereo, output:analog-surround-40+input:analog-stereo, output:analog-surround-41+input:analog-stereo, output:analog-surround-50+input:analog-stereo, output:analog-surround-51+input:analog-stereo, output:analog-surround-71+input:analog-stereo, output:iec958-stereo+input:analog-stereo
      iec958-stereo-input: Digital Input (S/PDIF) (priority: 0, latency offset: 0 usec)
         Part of profile(s): input:iec958-stereo, output:analog-stereo+input:iec958-stereo, output:analog-surround-40+input:iec958-stereo, output:analog-surround-41+input:iec958-stereo, output:analog-surround-50+input:iec958-stereo, output:analog-surround-51+input:iec958-stereo, output:analog-surround-71+input:iec958-stereo, output:iec958-stereo+input:iec958-stereo
      analog-output-lineout: Line Out (priority: 9900, latency offset: 0 usec, not available)
         Part of profile(s): output:analog-stereo, output:analog-stereo+input:analog-stereo, output:analog-stereo+input:iec958-stereo, output:analog-surround-40, output:analog-surround-40+input:analog-stereo, output:analog-surround-40+input:iec958-stereo, output:analog-surround-41, output:analog-surround-41+input:analog-stereo, output:analog-surround-41+input:iec958-stereo, output:analog-surround-50, output:analog-surround-50+input:analog-stereo, output:analog-surround-50+input:iec958-stereo, output:analog-surround-51, output:analog-surround-51+input:analog-stereo, output:analog-surround-51+input:iec958-stereo, output:analog-surround-71, output:analog-surround-71+input:analog-stereo, output:analog-surround-71+input:iec958-stereo
      analog-output-headphones: Headphones (priority: 9000, latency offset: 0 usec)
         Properties:
            device.icon_name = "audio-headphones"
         Part of profile(s): output:analog-stereo, output:analog-stereo+input:analog-stereo, output:analog-stereo+input:iec958-stereo
      iec958-stereo-output: Digital Output (S/PDIF) (priority: 0, latency offset: 0 usec)
         Part of profile(s): output:iec958-stereo, output:iec958-stereo+input:analog-stereo, output:iec958-stereo+input:iec958-stereo

Card #2
   Name: alsa_card.usb-Logitech_Logitech_G930_Headset-00-Headset
   Driver: module-alsa-card.c
   Owner Module: 8
   Properties:
      alsa.card = "2"
      alsa.card_name = "Logitech G930 Headset"
      alsa.long_card_name = "Logitech Logitech G930 Headset at usb-0000:00:1d.0-1.5.3, full speed"
      alsa.driver_name = "snd_usb_audio"
      device.bus_path = "pci-0000:00:1d.0-usb-0:1.5.3:1.0"
      sysfs.path = "/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.5/2-1.5.3/2-1.5.3:1.0/sound/card2"
      udev.id = "usb-Logitech_Logitech_G930_Headset-00-Headset"
      device.bus = "usb"
      device.vendor.id = "046d"
      device.vendor.name = "Logitech, Inc."
      device.product.id = "0a1f"
      device.product.name = "G930"
      device.serial = "Logitech_Logitech_G930_Headset"
      device.form_factor = "headset"
      device.string = "2"
      device.description = "G930"
      module-udev-detect.discovered = "1"
      device.icon_name = "audio-headset-usb"
      device.intended_roles = "phone"
   Profiles:
      input:analog-mono: Analog Mono Input (sinks: 0, sources: 1, priority: 1, available: yes)
      output:analog-stereo: Analog Stereo Output (sinks: 1, sources: 0, priority: 6000, available: yes)
      output:analog-stereo+input:analog-mono: Analog Stereo Output + Analog Mono Input (sinks: 1, sources: 1, priority: 6001, available: yes)
      output:iec958-stereo: Digital Stereo (IEC958) Output (sinks: 1, sources: 0, priority: 5500, available: yes)
      output:iec958-stereo+input:analog-mono: Digital Stereo (IEC958) Output + Analog Mono Input (sinks: 1, sources: 1, priority: 5501, available: yes)
      off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
   Active Profile: output:iec958-stereo+input:analog-mono
   Ports:
      analog-input-mic: Microphone (priority: 8700, latency offset: 0 usec)
         Properties:
            device.icon_name = "audio-input-microphone"
         Part of profile(s): input:analog-mono, output:analog-stereo+input:analog-mono, output:iec958-stereo+input:analog-mono
      analog-output: Analog Output (priority: 9900, latency offset: 0 usec)
         Part of profile(s): output:analog-stereo, output:analog-stereo+input:analog-mono
      iec958-stereo-output: Digital Output (S/PDIF) (priority: 0, latency offset: 0 usec)
         Part of profile(s): output:iec958-stereo, output:iec958-stereo+input:analog-mono
Back to top
View user's profile Send private message
ogenos
n00b
n00b


Joined: 22 Feb 2013
Posts: 41

PostPosted: Wed Feb 25, 2015 10:00 pm    Post subject: Reply with quote

Hello thegromph,

Just a shot in the dark... yours may be a case when a kernel-usb-sound module "quirks" option needs to be activated.
Back to top
View user's profile Send private message
thegromph
n00b
n00b


Joined: 22 Feb 2015
Posts: 4

PostPosted: Thu Feb 26, 2015 4:05 am    Post subject: Reply with quote

Hi ogenos,

Thanks for the idea. How do I activate that option?
Back to top
View user's profile Send private message
lovelytux
Tux's lil' helper
Tux's lil' helper


Joined: 23 Aug 2013
Posts: 108
Location: Westwoods of Germany

PostPosted: Thu Feb 26, 2015 12:40 pm    Post subject: Reply with quote

Hey thegromph!

I have the G930 to and this headset work fine for me on gentoo. I dont know wich exactly kernel flag he means.

Perhaps the solution is easy: Wich soundsystem do you use? Do you use alsasound? Do you checked with alsamixer the levels of the channels, has the micro full power here?

lovelytux
Back to top
View user's profile Send private message
thegromph
n00b
n00b


Joined: 22 Feb 2015
Posts: 4

PostPosted: Fri Feb 27, 2015 3:58 am    Post subject: Reply with quote

I think it is a usb problem. I found out that the microphone works using the usb hub in my keyboard but there audio does not work. I realized that I had usb 3.0 so I enabled that in the kernel but then both audio and mic didn't work. So I think its a usb 3.0 problem but enabling that in the kernel doesn't help. At least I know its not a muting problem and that pulseaudio is set up correctly. Any more ideas?

Update: I enabled USB 3.0 and disabled USB 2.0 in my kernel. My headset now works in the USB hub (which I assume is USB 2.0). Any idea what else I might change or am I doomed to crash my mouse into the dongle sticking out from my keyboard.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum