Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] AMD graphics not detected: No screen found
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
ShanaXXII
Apprentice
Apprentice


Joined: 29 Jun 2014
Posts: 281
Location: Canada

PostPosted: Thu Feb 26, 2015 12:35 am    Post subject: [solved] AMD graphics not detected: No screen found Reply with quote

I am trying to install Gentoo on one of my laptops.
It appears that my graphics card is not being used and I have this probably 640x480 screen size with only the terminal.

Code:
# lspci | grep VGA
01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS780MC [Mobility Radeon HD 3100]


I am using the gentoo-sources-3.18.7
Code:
Device Drivers -->
..... Generic Driver Options -->
.......... [ * ] Prevent firmware from being built
..........  -*-  Userspace firmware loading support
.......... [ * ] Include in-kernel firmware blobs in kernel binary
..... Graphics support -->
.......... <*> /dev/agpart (AGP Support) -->
............... <*> AMD Opteron/Athlon64 on-CPU GART support
............... <*> Intel 440LX/BX/GX, I8xx and E7x85 chipset support
..... Direct Rendering Manager -->
.......... <*> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)
.......... <*> ATI Radeon
............... [   ] Enable userspace modesetting on radeon (DEPRECATED)
..... Frame buffer Devices -->
..........  -*-  Support for frame buffer devices -->


Code:
# cat /etc/portage/make.conf | grep VIDEO_CARDS
VIDEO_CARDS="radeon"


I also have the linux-firmware installed

Not sure what I'm missing :/


Last edited by ShanaXXII on Fri Feb 27, 2015 3:09 am; edited 1 time in total
Back to top
View user's profile Send private message
schorsch_76
Guru
Guru


Joined: 19 Jun 2012
Posts: 450

PostPosted: Thu Feb 26, 2015 6:33 am    Post subject: Reply with quote

Maybe the radeon module isn't loaded. Please show

Code:
lspci -k

Code:
dmesg | grep radeon
Back to top
View user's profile Send private message
ShanaXXII
Apprentice
Apprentice


Joined: 29 Jun 2014
Posts: 281
Location: Canada

PostPosted: Thu Feb 26, 2015 1:22 pm    Post subject: Reply with quote

Code:
# lspci -k
...
01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS780MC [Mobility Radeon HD 3100]
Subsystem: Toshiba America Info Systems Device ff00
...


Code:
# dmesg | grep radeon
[0.234511] [drm] radeon kernel modesetting enabled.
[0.235616] radeon 0000:01:05.0: VRAM: 256M 0x00000000C0000000 - 0x00000000CFFFFFFF (256M used)
[0.235713] radeon 0000:01:05.0: GTT: 512M 0x00000000A0000000 - 0x00000000BFFFFFFF
[0.236383] [drm] radeon: 256M of VRAM memory ready.
[0.236449] [drm] radeon: 512M of GTT memory ready.
[0.236623] radeon 0000:01:05.0: Direct firmware load for radeon/r600_rlc.bin failed with error -2
[0.236752] r600_cp: Failed to load firmware "radeon/r600_rlc.bin"
[0.236890] radeon 0000:01:05.0: Fatal error during GPU init
[0.236959] [drm] radeon: finishing device.
[0.238394] [drm] radeon: ttm finalized.
[0.238889] radeon: probe of 0000:01:05.0 failed with error -2
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Thu Feb 26, 2015 2:25 pm    Post subject: Reply with quote

Code:
 [0.236623] radeon 0000:01:05.0: Direct firmware load for radeon/r600_rlc.bin failed with error -2

You are possibly missing the firmware for the card. Installing either sys-kernel/linux-firmware or x11-drivers/radeon-ucode is only enough if radeon is built as module.

If it is compiled into your kernel, additionally set
Kernel .config:
CONFIG_EXTRA_FIRMWARE="radeon/R600_rlc.bin radeon/RS780_uvd.bin"
CONFIG_EXTRA_FIRMWARE_DIR="/lib/firmware"

http://wiki.gentoo.org/wiki/Radeon#Firmware
Back to top
View user's profile Send private message
ShanaXXII
Apprentice
Apprentice


Joined: 29 Jun 2014
Posts: 281
Location: Canada

PostPosted: Fri Feb 27, 2015 3:09 am    Post subject: Reply with quote

chithanh wrote:
Code:
 [0.236623] radeon 0000:01:05.0: Direct firmware load for radeon/r600_rlc.bin failed with error -2

You are possibly missing the firmware for the card. Installing either sys-kernel/linux-firmware or x11-drivers/radeon-ucode is only enough if radeon is built as module.

If it is compiled into your kernel, additionally set
Kernel .config:
CONFIG_EXTRA_FIRMWARE="radeon/R600_rlc.bin radeon/RS780_uvd.bin"
CONFIG_EXTRA_FIRMWARE_DIR="/lib/firmware"

http://wiki.gentoo.org/wiki/Radeon#Firmware


Thank you :) that fixed it
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum