Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot update gentoo system
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Mati
Apprentice
Apprentice


Joined: 02 Sep 2008
Posts: 172

PostPosted: Sat Feb 28, 2015 6:50 pm    Post subject: Cannot update gentoo system Reply with quote

Hi,

i just try to update my system via

"emerge --update --deep --with-bdeps=y --newuse @world --exclude=app-office/libreoffice --exclude=x11-drivers/xf86-input-synaptics --exclude=x11-drivers/nvidia-drivers"

but the error message i don't know how to handle in order to updat the system is:

Code:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.20.1-r4:0/5.20::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-lang/perl-5.18.2-r2:0/5.18::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/JSON-2.590.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    (and 4 more with the same problem)

dev-libs/icu:0

  (dev-libs/icu-54.1-r1:0/54a::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-52.1:0/52::gentoo, installed) pulled in by
    >=dev-libs/icu-49:0/52= required by (dev-qt/qtcore-4.8.5-r2:4/4::gentoo, installed)
                     ^^^^^^                                                                                               
    (and 6 more with the same problem)

app-text/poppler:0

  (app-text/poppler-0.26.5:0/46::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.24.5:0/44::gentoo, installed) pulled in by
    >=app-text/poppler-0.16:0/44=[xpdf-headers(+),cxx] required by (app-office/libreoffice-4.2.5.2:0/0::gentoo, installed)
                           ^^^^^^                                                                                                                             
    (and 1 more with the same problem)

www-client/chromium:0

  (www-client/chromium-40.0.2214.111:0/0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (www-client/chromium-36.0.1985.125:0/0::gentoo, installed) pulled in by
    =www-client/chromium-36* required by (www-plugins/chrome-binary-plugins-36.0.1985.67_beta1:beta/beta::gentoo, installed)
    ^                    ^^^                                                                                                                                                       

dev-libs/re2:0

  (dev-libs/re2-0_p20140304:0/0.20140110::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/re2-0_p20130115:0/0::gentoo, installed) pulled in by
    dev-libs/re2:0/0= required by (www-client/chromium-36.0.1985.125:0/0::gentoo, installed)
                ^^^^^                                                                                                           

x11-base/xorg-server:0

  (x11-base/xorg-server-1.16.4:0/1.16.1::gentoo, ebuild scheduled for merge) pulled in by
    x11-base/xorg-server[glamor?] required by (x11-drivers/xf86-video-nouveau-1.0.11:0/0::gentoo, ebuild scheduled for merge)
                         ^^^^^^^                                                                                                                                 

  (x11-base/xorg-server-1.15.0:0/1.15.0::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.15.0= required by (x11-drivers/xf86-input-synaptics-1.7.4:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                #
dev-libs/boost:0

  (dev-libs/boost-1.55.0-r2:0/1.55.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.52.0-r7:0/1.52::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/boost-1.46:0/1.52= required by (app-office/libreoffice-4.2.5.2:0/0::gentoo, installed)
                         ^^^^^^^^                                                                                                       


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


emerge: there are no ebuilds to satisfy "~app-office/libreoffice-l10n-4.2.5.2".
(dependency required by "app-office/libreoffice-4.2.5.2" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Back to top
View user's profile Send private message
lovelytux
Tux's lil' helper
Tux's lil' helper


Joined: 23 Aug 2013
Posts: 93
Location: Westwoods of Germany

PostPosted: Sat Feb 28, 2015 10:06 pm    Post subject: Reply with quote

Hey,
where to start?

When was last run of perl-cleaner?

lovelytux
Back to top
View user's profile Send private message
Mati
Apprentice
Apprentice


Joined: 02 Sep 2008
Posts: 172

PostPosted: Sun Mar 01, 2015 2:08 pm    Post subject: Reply with quote

Hey,

what is perl-cleaner? I never used this "tool" ! Sorry.

Thanks for further help
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7094
Location: Saint Amant, Acadiana

PostPosted: Sun Mar 01, 2015 2:19 pm    Post subject: Reply with quote

Mati wrote:
Hey,

what is perl-cleaner? I never used this "tool" ! Sorry.

Thanks for further help


man perl-cleaner
Also, Search Forums
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Mati
Apprentice
Apprentice


Joined: 02 Sep 2008
Posts: 172

PostPosted: Sun Mar 01, 2015 2:42 pm    Post subject: Reply with quote

even pearl-cleaner does not come to an end
Code:

perl-cleaner reallyall

 * Beginning a clean up of .ph files
 * Excluding files for 0.0.0 and 0.0.0/i686-linux from cleaning

 * Locating ph files for removal

 * Updating ph files.
 * Ignore all "No such file..." messages!
Can't open machine/ansi.h: Datei oder Verzeichnis nicht gefunden
Can't open sys/_types.h: Datei oder Verzeichnis nicht gefunden
Can't open gnu/stubs-64.h: Datei oder Verzeichnis nicht gefunden
Can't open gnu/stubs-x32.h: Datei oder Verzeichnis nicht gefunden
Can't open gnu/stubs-64.h: Datei oder Verzeichnis nicht gefunden
Can't open gnu/stubs-x32.h: Datei oder Verzeichnis nicht gefunden
Can't open gnu/stubs-64.h: Datei oder Verzeichnis nicht gefunden
Can't open gnu/stubs-x32.h: Datei oder Verzeichnis nicht gefunden
Can't open gnu/stubs-64.h: Datei oder Verzeichnis nicht gefunden
Can't open gnu/stubs-x32.h: Datei oder Verzeichnis nicht gefunden

 * Locating packages for an update
 * Locating ebuilds linked against libperl
 *   Adding to list: perl-core/Module-CoreList:0
 *                   virtual/perl-Module-CoreList:0
 *   Adding to list: perl-core/Module-Load:0
 *                   virtual/perl-Module-Load:0
 *   Adding to list: perl-core/IO-Compress:0
 *                   virtual/perl-IO-Compress:0
 *   Adding to list: perl-core/Scalar-List-Utils:0
 *                   virtual/perl-Scalar-List-Utils:0
 *   Adding to list: perl-core/Module-Load-Conditional:0
 *                   virtual/perl-Module-Load-Conditional:0
 *   Adding to list: perl-core/Test-Harness:0
 *                   virtual/perl-Test-Harness:0
 *   Adding to list: perl-core/File-Spec:0
 *                   virtual/perl-File-Spec:0
 *   Adding to list: perl-core/Compress-Raw-Zlib:0
 *                   virtual/perl-Compress-Raw-Zlib:0
 *   Adding to list: perl-core/Compress-Raw-Bzip2:0
 *                   virtual/perl-Compress-Raw-Bzip2:0
 *   Adding to list: perl-core/Sys-Syslog:0
 *                   virtual/perl-Sys-Syslog:0
 *   Adding to list: perl-core/version:0
 *                   virtual/perl-version:0
 *   Adding to list: perl-core/CPAN-Meta-YAML:0
 *                   virtual/perl-CPAN-Meta-YAML:0
 *   Adding to list: perl-core/ExtUtils-Manifest:0
 *                   virtual/perl-ExtUtils-Manifest:0
 *   Adding to list: perl-core/IO:0
 *                   virtual/perl-IO:0
 *   Adding to list: perl-core/Params-Check:0
 *                   virtual/perl-Params-Check:0
 *   Adding to list: perl-core/Module-Metadata:0
 *                   virtual/perl-Module-Metadata:0
 *   Adding to list: perl-core/Parse-CPAN-Meta:0
 *                   virtual/perl-Parse-CPAN-Meta:0
 *   Adding to list: perl-core/CPAN-Meta-Requirements:0
 *                   virtual/perl-CPAN-Meta-Requirements:0
 *   Adding to list: perl-core/Archive-Tar:0
 *                   virtual/perl-Archive-Tar:0
 *   Adding to list: perl-core/IPC-Cmd:0
 *                   virtual/perl-IPC-Cmd:0
 *   Adding to list: perl-core/ExtUtils-CBuilder:0
 *                   virtual/perl-ExtUtils-CBuilder:0
 *   Adding to list: perl-core/ExtUtils-ParseXS:0
 *                   virtual/perl-ExtUtils-ParseXS:0
 *   Adding to list: perl-core/ExtUtils-MakeMaker:0
 *                   virtual/perl-ExtUtils-MakeMaker:0
 *   Adding to list: perl-core/Module-Build:0
 *                   virtual/perl-Module-Build:0
 *   Adding to list: perl-core/CPAN-Meta:0
 *                   virtual/perl-CPAN-Meta:0
 *   Adding to list: app-text/po4a:0
 *   Adding to list: dev-perl/Net-Daemon:0
 *   Adding to list: dev-perl/SGMLSpm:0
 *   Adding to list: dev-perl/XML-Parser:0
 *   Adding to list: dev-perl/TermReadKey:0
 *   Adding to list: dev-perl/Text-CharWidth:0
 *   Adding to list: dev-perl/JSON:0
 *   Adding to list: dev-perl/File-BaseDir:0
 *   Adding to list: dev-perl/Archive-Zip:0
 *   Adding to list: dev-perl/Text-WrapI18N:0
 *   Adding to list: dev-perl/File-DesktopEntry:0
 *   Adding to list: dev-perl/Locale-gettext:0
 *   Adding to list: dev-perl/File-MimeInfo:0
 *   Adding to list: dev-perl/PlRPC:0
 *   Adding to list: dev-perl/DBI:0
 *   Adding to list: dev-perl/DBD-mysql:0
 * emerge -vD1 --backtrack=30 perl-core/Module-CoreList:0 virtual/perl-Module-CoreList:0 perl-core/Module-Load:0 virtual/perl-Module-Load:0 perl-core/IO-Compress:0 virtual/perl-IO-Compress:0 perl-core/Scalar-List-Utils:0 virtual/perl-Scalar-List-Utils:0 perl-core/Module-Load-Conditional:0 virtual/perl-Module-Load-Conditional:0 perl-core/Test-Harness:0 virtual/perl-Test-Harness:0 perl-core/File-Spec:0 virtual/perl-File-Spec:0 perl-core/Compress-Raw-Zlib:0 virtual/perl-Compress-Raw-Zlib:0 perl-core/Compress-Raw-Bzip2:0 virtual/perl-Compress-Raw-Bzip2:0 perl-core/Sys-Syslog:0 virtual/perl-Sys-Syslog:0 perl-core/version:0 virtual/perl-version:0 perl-core/CPAN-Meta-YAML:0 virtual/perl-CPAN-Meta-YAML:0 perl-core/ExtUtils-Manifest:0 virtual/perl-ExtUtils-Manifest:0 perl-core/IO:0 virtual/perl-IO:0 perl-core/Params-Check:0 virtual/perl-Params-Check:0 perl-core/Module-Metadata:0 virtual/perl-Module-Metadata:0 perl-core/Parse-CPAN-Meta:0 virtual/perl-Parse-CPAN-Meta:0 perl-core/CPAN-Meta-Requirements:0 virtual/perl-CPAN-Meta-Requirements:0 perl-core/Archive-Tar:0 virtual/perl-Archive-Tar:0 perl-core/IPC-Cmd:0 virtual/perl-IPC-Cmd:0 perl-core/ExtUtils-CBuilder:0 virtual/perl-ExtUtils-CBuilder:0 perl-core/ExtUtils-ParseXS:0 virtual/perl-ExtUtils-ParseXS:0 perl-core/ExtUtils-MakeMaker:0 virtual/perl-ExtUtils-MakeMaker:0 perl-core/Module-Build:0 virtual/perl-Module-Build:0 perl-core/CPAN-Meta:0 virtual/perl-CPAN-Meta:0 app-text/po4a:0 dev-perl/Net-Daemon:0 dev-perl/SGMLSpm:0 dev-perl/XML-Parser:0 dev-perl/TermReadKey:0 dev-perl/Text-CharWidth:0 dev-perl/JSON:0 dev-perl/File-BaseDir:0 dev-perl/Archive-Zip:0 dev-perl/Text-WrapI18N:0 dev-perl/File-DesktopEntry:0 dev-perl/Locale-gettext:0 dev-perl/File-MimeInfo:0 dev-perl/PlRPC:0 dev-perl/DBI:0 dev-perl/DBD-mysql:0

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


 * IMPORTANT: 3 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.18.2-r1:0/5.18::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-lang/perl-5.20.1-r4:0/5.20::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.20* required by (virtual/perl-Module-Metadata-1.0.19:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                 
    (and 16 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


emerge: there are no ebuilds to satisfy "=dev-lang/perl-5.16*".
(dependency required by "virtual/perl-JSON-PP-2.272.0-r2" [installed])
(dependency required by "perl-core/Parse-CPAN-Meta-1.440.400-r1" [ebuild])
(dependency required by "perl-core/Parse-CPAN-Meta:0" [argument])
 * perl-cleaner is stopping here:
 * Fix the problem and start perl-cleaner again.
 *
 * If you encounter blockers involving virtuals and perl-core, here are
 * some things to try:
 *   Remove all perl-core packages from your world file
 *     emerge --deselect --ask $(qlist -IC 'perl-core/*')
 *   Update all the installed Perl virtuals
 *     emerge -uD1a $(qlist -IC 'virtual/perl-*')
 *   Afterwards re-run perl-cleaner
 *
 * Note that upgrading Perl with emerge option --ignore-built-slot-operator-deps=y is not supported.

Back to top
View user's profile Send private message
lovelytux
Tux's lil' helper
Tux's lil' helper


Joined: 23 Aug 2013
Posts: 93
Location: Westwoods of Germany

PostPosted: Sun Mar 01, 2015 4:21 pm    Post subject: Reply with quote

Hey,

gentoo speaks to you. Look down. And try this.

Quote:
* If you encounter blockers involving virtuals and perl-core, here are
* some things to try:
* Remove all perl-core packages from your world file
* emerge --deselect --ask $(qlist -IC 'perl-core/*')
* Update all the installed Perl virtuals
* emerge -uD1a $(qlist -IC 'virtual/perl-*')
* Afterwards re-run perl-cleaner
*
* Note that upgrading Perl with emerge option --ignore-built-slot-operator-deps=y is not supported.


:D

lovelytux
Back to top
View user's profile Send private message
Mati
Apprentice
Apprentice


Joined: 02 Sep 2008
Posts: 172

PostPosted: Fri Mar 06, 2015 8:43 pm    Post subject: Reply with quote

thank, i tried this but it didn't help. what else can i do?
Back to top
View user's profile Send private message
dimko
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2006
Posts: 126

PostPosted: Sat May 02, 2015 1:17 pm    Post subject: Reply with quote

Mati wrote:
thank, i tried this but it didn't help. what else can i do?

I run similar issues, multilib broke my sistem to bits. I need to get this dependancy sorted somehow...
_________________
Just a user.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43213
Location: 56N 3W

PostPosted: Sat May 02, 2015 2:18 pm    Post subject: Reply with quote

Mati,

emerge -1 perl may run, or it may give a few blocks.

If it runs, let it complete then run perl-cleaner reallyall again.
emerge -1 perl will update your perl then perl-cleaner will update all of your perl modules to use your new perl.

If emerge -1 perl fails, post the blockers.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum