Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Can't use recompiled kernel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
ramdzet
n00b
n00b


Joined: 28 Feb 2015
Posts: 15

PostPosted: Sun Mar 01, 2015 10:56 am    Post subject: [SOLVED] Can't use recompiled kernel Reply with quote

Hi, I use dual boot, Gentoo on my extended partition.

Today I add some modules on kernel and compile it. But my Gentoo doesn't use that recompiled kernel although bzimage, config, etc is newer.

This is my uname
Code:
uname -v
#3 SMP Fri Feb 27 00:38:55 WIB 2015


/usr/src/linux
Code:
ls -lia /usr/src/linux
total 12
396221 drwxr-xr-x  3 root root 4096 Mar  1 14:32 .
393217 drwxr-xr-x 13 root root 4096 Feb 25 19:58 ..
396222 -rw-r--r--  1 root root    0 Dec  4 08:25 .keep
393563 lrwxrwxrwx  1 root root   19 Mar  1 14:32 linux -> linux-3.18.7-gentoo
787110 drwxr-xr-x 25 root root 4096 Mar  1 16:52 linux-3.18.7-gentoo


/boot/
Code:
ls -lia /boot/
total 17724
524289 drwxr-xr-x  2 root root    4096 Mar  1 16:52 .
     2 drwxr-xr-x 21 root root    4096 Feb 26 16:28 ..
527128 -rw-r--r--  1 root root   99193 Mar  1 16:52 config-3.18.7-gentoo
527125 -rw-r--r--  1 root root   99166 Mar  1 16:46 config-3.18.7-gentoo.old
527127 -rw-r--r--  1 root root 3131556 Mar  1 16:52 System.map-3.18.7-gentoo
527124 -rw-r--r--  1 root root 3126704 Mar  1 16:46 System.map-3.18.7-gentoo.old
527126 -rw-r--r--  1 root root 5848192 Mar  1 16:52 vmlinuz-3.18.7-gentoo
527123 -rw-r--r--  1 root root 5822432 Mar  1 16:46 vmlinuz-3.18.7-gentoo.old


This is my dmesg if you want to know (I think it is nothing special)
Code:
dmesg
gs: Mfr=0, Product=0, SerialNumber=0
[    1.156215] hub 2-1:1.0: USB hub found
[    1.156324] hub 2-1:1.0: 6 ports detected
[    1.421741] usb 1-1.1: new high-speed USB device number 3 using ehci-pci
[    1.437844] Console: switching to colour frame buffer device 170x48
[    1.507484] usb 1-1.1: New USB device found, idVendor=0bda, idProduct=0139
[    1.507485] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    1.507486] usb 1-1.1: Product: USB2.0-CRW
[    1.507487] usb 1-1.1: Manufacturer: Generic
[    1.507488] usb 1-1.1: SerialNumber: 20100201396000000
[    1.524859] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    1.524860] i915 0000:00:02.0: registered panic notifier
[    1.526896] console [netcon0] enabled
[    1.527889] netconsole: network logging started
[    1.529402] PM: Hibernation image not present or could not be loaded.
[    1.529407] ALSA device list:
[    1.530388]   #0: HDA Intel PCH at 0xf7d10000 irq 26
[    1.532878] scsi 0:0:0:0: Direct-Access     ATA      WDC WD5000BPVT-2 1A01 PQ: 0 ANSI: 5
[    1.534151] sd 0:0:0:0: [sda] 976773168 512-byte logical blocks: (500 GB/465 GiB)
[    1.534174] sd 0:0:0:0: Attached scsi generic sg0 type 0
[    1.536245] sd 0:0:0:0: [sda] 4096-byte physical blocks
[    1.537303] sd 0:0:0:0: [sda] Write Protect is off
[    1.538325] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    1.538338] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    1.541413] scsi 1:0:0:0: CD-ROM            Slimtype DVD A  DS8A8SH   KX12 PQ: 0 ANSI: 5
[    1.577718] sr 1:0:0:0: [sr0] scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[    1.578797] cdrom: Uniform CD-ROM driver Revision: 3.20
[    1.579980] sr 1:0:0:0: Attached scsi CD-ROM sr0
[    1.580053] sr 1:0:0:0: Attached scsi generic sg1 type 5
[    1.622791] tsc: Refined TSC clocksource calibration: 2394.559 MHz
[    1.652465]  sda: sda1 sda2 sda3 sda4 < sda5 sda6 sda7 sda8 >
[    1.654194] sd 0:0:0:0: [sda] Attached SCSI disk
[    2.624807] Switched to clocksource tsc
[    2.764258] input: PS/2 Logitech Wheel Mouse as /devices/platform/i8042/serio1/input/input7
[    2.768800] md: Waiting for all devices to be available before autodetect
[    2.769871] md: If you don't use raid, use raid=noautodetect
[    2.771049] md: Autodetecting RAID arrays.
[    2.772087] md: Scanned 0 and added 0 devices.
[    2.773090] md: autorun ...
[    2.774096] md: ... autorun DONE.
[    2.796522] EXT4-fs (sda7): couldn't mount as ext2 due to feature incompatibilities
[    2.838714] EXT4-fs (sda7): mounted filesystem with ordered data mode. Opts: (null)
[    2.839723] VFS: Mounted root (ext4 filesystem) readonly on device 8:7.
[    2.903469] devtmpfs: mounted
[    2.905112] Freeing unused kernel memory: 1072K (ffffffff81edc000 - ffffffff81fe8000)
[    2.906077] Write protecting the kernel read-only data: 14336k
[    2.910976] Freeing unused kernel memory: 1900K (ffff880001825000 - ffff880001a00000)
[    2.914778] Freeing unused kernel memory: 1392K (ffff880001ca4000 - ffff880001e00000)
[    3.268160] random: nonblocking pool is initialized
[    3.840710] loadkeys (1105) used greatest stack depth: 13256 bytes left
[    3.841705] init-early.sh (1102) used greatest stack depth: 12728 bytes left
[    5.046239] systemd-udevd[1285]: starting version 216
[    5.160520] udevadm (1292) used greatest stack depth: 12440 bytes left
[    5.538435] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[    5.538443] r8169 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control
[    5.538809] r8169 0000:02:00.0: irq 27 for MSI/MSI-X
[    5.538995] r8169 0000:02:00.0 eth0: RTL8168evl/8111evl at 0xffffc9000033a000, 8c:89:a5:04:b0:ba, XID 0c900800 IRQ 27
[    5.538997] r8169 0000:02:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[    5.558580] xhci_hcd 0000:00:14.0: xHCI Host Controller
[    5.558632] xhci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 3
[    5.558855] xhci_hcd 0000:00:14.0: cache line size of 64 is not supported
[    5.558872] xhci_hcd 0000:00:14.0: irq 28 for MSI/MSI-X
[    5.558963] usb usb3: New USB device found, idVendor=1d6b, idProduct=0002
[    5.558966] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    5.558968] usb usb3: Product: xHCI Host Controller
[    5.558969] usb usb3: Manufacturer: Linux 3.18.7-gentoo xhci-hcd
[    5.558971] usb usb3: SerialNumber: 0000:00:14.0
[    5.559080] hub 3-0:1.0: USB hub found
[    5.559103] hub 3-0:1.0: 4 ports detected
[    5.559396] xhci_hcd 0000:00:14.0: xHCI Host Controller
[    5.559427] xhci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 4
[    5.559489] usb usb4: New USB device found, idVendor=1d6b, idProduct=0003
[    5.559491] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    5.559492] usb usb4: Product: xHCI Host Controller
[    5.559494] usb usb4: Manufacturer: Linux 3.18.7-gentoo xhci-hcd
[    5.559495] usb usb4: SerialNumber: 0000:00:14.0
[    5.559579] hub 4-0:1.0: USB hub found
[    5.559593] hub 4-0:1.0: 4 ports detected
[    5.604040] r8169 0000:02:00.0 enp2s0: renamed from eth0
[    5.609224] systemd-udevd[1305]: renamed network interface eth0 to enp2s0
[    5.732071] ath: phy0: ASPM enabled: 0x43
[    5.732075] ath: EEPROM regdomain: 0x60
[    5.732076] ath: EEPROM indicates we should expect a direct regpair map
[    5.732077] ath: Country alpha2 being used: 00
[    5.732078] ath: Regpair used: 0x60
[    5.732439] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[    5.732603] ieee80211 phy0: Atheros AR9485 Rev:1 mem=0xffffc90014e00000, irq=16
[    5.735660] ath9k 0000:01:00.0 wlp1s0: renamed from wlan0
[    5.740353] systemd-udevd[1303]: renamed network interface wlan0 to wlp1s0
[    5.912436] usb 3-1: new high-speed USB device number 2 using xhci_hcd
[    6.078223] usb 3-1: New USB device found, idVendor=12d1, idProduct=1c23
[    6.078227] usb 3-1: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[    6.078229] usb 3-1: Product: HUAWEI Mobile
[    6.078231] usb 3-1: Manufacturer: HUAWEI
[    6.079669] usb-storage 3-1:1.4: USB Mass Storage device detected
[    6.079747] scsi host6: usb-storage 3-1:1.4
[    7.082433] scsi 6:0:0:0: Direct-Access     HUAWEI   SD Storage       2.31 PQ: 0 ANSI: 2
[    7.082587] sd 6:0:0:0: Attached scsi generic sg2 type 0
[    7.084228] sd 6:0:0:0: [sdb] Attached SCSI removable disk
[    9.307731] EXT4-fs (sda7): re-mounted. Opts: (null)
[    9.506435] Adding 3762172k swap on /dev/sda3.  Priority:-1 extents:1 across:3762172k
[    9.598010] EXT4-fs (sda8): mounted filesystem with ordered data mode. Opts: (null)
[   11.577412] r8169 0000:02:00.0 enp2s0: link down
[   11.577439] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready
[   11.577515] ip (1950) used greatest stack depth: 11000 bytes left


I found this but it doesn't help

what's wrong?
Thanks for your help!
err .. sorry for my bad english


Last edited by ramdzet on Sun Mar 01, 2015 3:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
Irre
Guru
Guru


Joined: 09 Nov 2013
Posts: 340
Location: Stockholm

PostPosted: Sun Mar 01, 2015 12:21 pm    Post subject: Reply with quote

You must tell the bootloader what to load.

See commands: grub2-mkconfig, lilo or edit .../menu.lst if you are using grub
Back to top
View user's profile Send private message
ramdzet
n00b
n00b


Joined: 28 Feb 2015
Posts: 15

PostPosted: Sun Mar 01, 2015 3:32 pm    Post subject: Reply with quote

Irre wrote:
You must tell the bootloader what to load.

See commands: grub2-mkconfig, lilo or edit .../menu.lst if you are using grub


I try grub2-mkconfig, nothing happen, it is still same.

solved, after I chroot from other system, my Gentoo can use the recompiled kernel.

But, I still don't know why I have to use chroot to 'make install' kernel.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum