Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problem with newer kernels
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1543

PostPosted: Wed Mar 04, 2015 2:46 pm    Post subject: problem with newer kernels Reply with quote

I have a machine that has four kernels on it: 3.10.7-gentoo, 3.14.14-gentoo, 3.16.5-gentoo, and 3.17.7-gentoo. Basically, the only one I can boot with is 3.10.7-gentoo. With all of the subsequent ones, as soon as I select the kernel (via grub), the screen goes completely black, and I am unable to get anything at all out of it without rebooting (the boot does finish - I can log in via ssh, and do all of the usual remote tasks).

I am seeing this in the boot log of all of the "defective" kernels:

Code:

Mar  4 04:08:15 system kernel: [    0.170007] ------------[ cut here ]------------
Mar  4 04:08:15 system kernel: [    0.170062] WARNING: CPU: 1 PID: 1 at kernel/time/tick-sched.c:191 can_stop_full_tick+0x84/0x91()
Mar  4 04:08:15 system kernel: [    0.170131] NO_HZ FULL will not work with unstable sched clock
Mar  4 04:08:15 system kernel: [    0.170171] Modules linked in:
Mar  4 04:08:15 system kernel: [    0.170291] CPU: 1 PID: 1 Comm: swapper/0 Not tainted 3.14.14-gentoo #1
Mar  4 04:08:15 system kernel: [    0.170345] Hardware name: Acer Veriton L480/EG43LMK, BIOS P01-B2L    09/08/2011
Mar  4 04:08:15 system kernel: [    0.170412]  0000000000000000 0000000000000009 ffffffff8159af68 ffff88012fc83f08
Mar  4 04:08:15 system kernel: [    0.170596]  ffffffff8105b026 0000000000012180 ffffffff8109e3e4 ffff88012aaa8000
Mar  4 04:08:15 system kernel: [    0.170780]  ffff88012fc8d830 0000000000000001 0000000000008000 ffffffff8114a5e7
Mar  4 04:08:15 system kernel: [    0.170964] Call Trace:
Mar  4 04:08:15 system kernel: [    0.171010]  <IRQ>  [<ffffffff8159af68>] ? dump_stack+0x41/0x51
Mar  4 04:08:15 system kernel: [    0.171127]  [<ffffffff8105b026>] ? warn_slowpath_common+0x73/0x8b
Mar  4 04:08:15 system kernel: [    0.171181]  [<ffffffff8109e3e4>] ? can_stop_full_tick+0x84/0x91
Mar  4 04:08:15 system kernel: [    0.171235]  [<ffffffff8114a5e7>] ? __kernfs_new_node+0x4a/0xb7
Mar  4 04:08:15 system kernel: [    0.171289]  [<ffffffff8105b0d6>] ? warn_slowpath_fmt+0x45/0x4a
Mar  4 04:08:15 system kernel: [    0.171343]  [<ffffffff8105e4ab>] ? __do_softirq+0x177/0x205
Mar  4 04:08:15 system kernel: [    0.171396]  [<ffffffff8109e3e4>] ? can_stop_full_tick+0x84/0x91
Mar  4 04:08:15 system kernel: [    0.171449]  [<ffffffff8109e6af>] ? tick_nohz_irq_exit+0x66/0x8b
Mar  4 04:08:15 system kernel: [    0.171503]  [<ffffffff8105e713>] ? irq_exit+0x9e/0xc9
Mar  4 04:08:15 system kernel: [    0.171556]  [<ffffffff81021193>] ? smp_apic_timer_interrupt+0x3b/0x46
Mar  4 04:08:15 system kernel: [    0.171611]  [<ffffffff815a2387>] ? apic_timer_interrupt+0x67/0x70
Mar  4 04:08:15 system kernel: [    0.171663]  <EOI>  [<ffffffff8122b566>] ? ida_get_new_above+0x174/0x18e
Mar  4 04:08:15 system kernel: [    0.171780]  [<ffffffff810f2a12>] ? kmem_cache_alloc+0x7c/0xac
Mar  4 04:08:15 system kernel: [    0.171834]  [<ffffffff810f29b9>] ? kmem_cache_alloc+0x23/0xac
Mar  4 04:08:15 system kernel: [    0.171887]  [<ffffffff8114a5e7>] ? __kernfs_new_node+0x4a/0xb7
Mar  4 04:08:15 system kernel: [    0.171940]  [<ffffffff8114ad30>] ? kernfs_new_node+0x1f/0x40
Mar  4 04:08:15 system kernel: [    0.171993]  [<ffffffff8114bd7b>] ? __kernfs_create_file+0x33/0xb8
Mar  4 04:08:15 system kernel: [    0.172047]  [<ffffffff811490d3>] ? sysfs_add_file_mode_ns+0xf4/0x130
Mar  4 04:08:15 system kernel: [    0.172102]  [<ffffffff8122c3f3>] ? kobject_init_and_add+0x6e/0x7b
Mar  4 04:08:15 system kernel: [    0.172156]  [<ffffffff811499ad>] ? internal_create_group+0x130/0x1bc
Mar  4 04:08:15 system kernel: [    0.172210]  [<ffffffff810f2bbb>] ? sysfs_slab_add+0xfe/0x146
Mar  4 04:08:15 system kernel: [    0.172265]  [<ffffffff818b0e0b>] ? slab_sysfs_init+0x72/0xef
Mar  4 04:08:15 system kernel: [    0.172318]  [<ffffffff818b0d99>] ? bootstrap+0x135/0x135
Mar  4 04:08:15 system kernel: [    0.172370]  [<ffffffff81000297>] ? do_one_initcall+0x78/0xf9
Mar  4 04:08:15 system kernel: [    0.172424]  [<ffffffff8106fb3b>] ? parse_args+0x18d/0x24c
Mar  4 04:08:15 system kernel: [    0.172478]  [<ffffffff81899ca7>] ? kernel_init_freeable+0x101/0x192
Mar  4 04:08:15 system kernel: [    0.172532]  [<ffffffff818995d5>] ? loglevel+0x34/0x34
Mar  4 04:08:15 system kernel: [    0.172585]  [<ffffffff8159450c>] ? rest_init+0x70/0x70
Mar  4 04:08:15 system kernel: [    0.172637]  [<ffffffff81594512>] ? kernel_init+0x6/0xd7
Mar  4 04:08:15 system kernel: [    0.172689]  [<ffffffff815a173c>] ? ret_from_fork+0x7c/0xb0
Mar  4 04:08:15 system kernel: [    0.172742]  [<ffffffff8159450c>] ? rest_init+0x70/0x70
Mar  4 04:08:15 system kernel: [    0.172797] ---[ end trace 25fd55f5dd0bee02 ]---


I am a bit suspicious of the message - I have several other machines running (without any problems) with both CONFIG_HAVE_UNSTABLE_SCHED_CLOCK=y and CONFIG_NO_HZ_FULL=y.

Someone (on #gentoo) suggested that I change CONFIG_DRM_I915_KMS=y to no and recompile That actually worked (sort of) - the machine finished booting normally (tried it with the 3.17.7-gentoo kernel), but then X would not start at all:

Code:

[   531.436]
X.Org X Server 1.16.4
Release Date: 2014-12-20
[   531.436] X Protocol Version 11, Revision 0
[   531.436] Build Operating System: Linux 3.17.7-gentoo x86_64 Gentoo
[   531.436] Current Operating System: Linux shchuply 3.17.7-gentoo #1 SMP Wed Mar 4 06:43:19 UTC 2015 x86_64
[   531.436] Kernel command line: BOOT_IMAGE=/bzImage-3.17.7-gentoo root=/dev/sda6
[   531.436] Build Date: 04 March 2015  06:52:27AM
[   531.436] 
[   531.436] Current version of pixman: 0.32.6
[   531.436]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[   531.436] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   531.436] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Mar  4 06:54:27 2015
[   531.436] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   531.436] (==) No Layout section.  Using the first Screen section.
[   531.436] (==) No screen section available. Using defaults.
[   531.436] (**) |-->Screen "Default Screen Section" (0)
[   531.436] (**) |   |-->Monitor "<default monitor>"
[   531.436] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[   531.436] (==) Automatically adding devices
[   531.436] (==) Automatically enabling devices
[   531.436] (==) Automatically adding GPU devices
[   531.436] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[   531.436]    Entry deleted from font path.
[   531.436] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[   531.436]    Entry deleted from font path.
[   531.436] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   531.436]    Entry deleted from font path.
[   531.436] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[   531.436]    Entry deleted from font path.
[   531.436] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[   531.436]    Entry deleted from font path.
[   531.436] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[   531.436]    Entry deleted from font path.
[   531.436] (==) FontPath set to:

[   531.436] (==) ModulePath set to "/usr/lib64/xorg/modules"
[   531.436] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[   531.436] (II) Loader magic: 0x806c80
[   531.436] (II) Module ABI versions:
[   531.437]    X.Org ANSI C Emulation: 0.4
[   531.437]    X.Org Video Driver: 18.0
[   531.437]    X.Org XInput driver : 21.0
[   531.437]    X.Org Server Extension : 8.0
[   531.438] (--) PCI:*(0:0:2:0) 8086:2e22:1025:0257 rev 3, Mem @ 0xfe400000/4194304, 0xd0000000/268435456, I/O @ 0x0000dc00/8
[   531.438] (--) PCI: (0:0:2:1) 8086:2e23:1025:0257 rev 3, Mem @ 0xfe800000/1048576
[   531.438] (II) LoadModule: "glx"
[   531.438] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   531.439] (II) Module glx: vendor="X.Org Foundation"
[   531.439]    compiled for 1.16.4, module version = 1.0.0
[   531.439]    ABI class: X.Org Server Extension, version 8.0
[   531.439] (==) AIGLX enabled
[   531.440] (==) Matched intel as autoconfigured driver 0
[   531.440] (==) Matched modesetting as autoconfigured driver 1
[   531.440] (==) Matched fbdev as autoconfigured driver 2
[   531.440] (==) Matched vesa as autoconfigured driver 3
[   531.440] (==) Assigned the driver to the xf86ConfigLayout
[   531.440] (II) LoadModule: "intel"
[   531.440] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[   531.440] (II) Module intel: vendor="X.Org Foundation"
[   531.440]    compiled for 1.16.4, module version = 2.99.917
[   531.440]    Module class: X.Org Video Driver
[   531.440]    ABI class: X.Org Video Driver, version 18.0
[   531.440] (II) LoadModule: "modesetting"
[   531.440] (WW) Warning, couldn't open module modesetting
[   531.440] (II) UnloadModule: "modesetting"
[   531.440] (II) Unloading modesetting
[   531.440] (EE) Failed to load module "modesetting" (module does not exist, 0)
[   531.440] (II) LoadModule: "fbdev"
[   531.440] (WW) Warning, couldn't open module fbdev
[   531.440] (II) UnloadModule: "fbdev"
[   531.440] (II) Unloading fbdev
[   531.440] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   531.440] (II) LoadModule: "vesa"
[   531.441] (WW) Warning, couldn't open module vesa
[   531.441] (II) UnloadModule: "vesa"
[   531.441] (II) Unloading vesa
[   531.441] (EE) Failed to load module "vesa" (module does not exist, 0)
[   531.441] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
        i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
        915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
        Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[   531.441] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[   531.441] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[   531.441] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[   531.441] (++) using VT number 7

[   531.441] (WW) xf86OpenConsole: setpgid failed: Operation not permitted
[   531.441] (WW) xf86OpenConsole: setsid failed: Operation not permitted
[   531.448] (EE) No devices detected.
[   531.448] (EE)
Fatal server error:
[   531.448] (EE) no screens found(EE)
[   531.448] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[   531.448] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   531.448] (EE)


So then I was advised to add "i915.modeset=1", which basically put me back to square one (the screen went black immediately after selecting the kernel).

Any advice?
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13845

PostPosted: Thu Mar 05, 2015 3:15 am    Post subject: Reply with quote

In all the named kernel versions, the help text for NO_HZ_FULL specifically suggests that you not enable it. You are lucky that it works on some machines, but upstream considers it not to be ready for general use. Use NO_HZ_IDLE instead, which is well tested.
Back to top
View user's profile Send private message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1543

PostPosted: Thu Mar 05, 2015 9:36 am    Post subject: Reply with quote

Hu wrote:
In all the named kernel versions, the help text for NO_HZ_FULL specifically suggests that you not enable it. You are lucky that it works on some machines, but upstream considers it not to be ready for general use. Use NO_HZ_IDLE instead, which is well tested.


The good news? This got rid of the traceback when I boot. Those messages no longer appear in the log (thanks).

The bad news? This did nothing else to resolve my video problems. The screen still goes completely dark immediately after kernel selection. And I can find no way of recovering it.

/var/log/Xorg.0.log indicates that the machine believes it has started X (but I get "no input" on the monitor, and can't even change to a console)

Here is /var/log/Xorg.0.log:

Code:

[    16.767]
X.Org X Server 1.16.4
Release Date: 2014-12-20
[    16.767] X Protocol Version 11, Revision 0
[    16.767] Build Operating System: Linux 3.17.7-gentoo x86_64 Gentoo
[    16.767] Current Operating System: Linux system 3.17.7-gentoo #1 SMP Thu Mar 5 05:21:31 UTC 2015 x86_64
[    16.767] Kernel command line: BOOT_IMAGE=/bzImage-3.17.7-gentoo root=/dev/sda6 i915.modeset=1
[    16.767] Build Date: 04 March 2015  06:52:27AM
[    16.767] 
[    16.767] Current version of pixman: 0.32.6
[    16.767]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    16.767] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    16.767] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Mar  5 08:37:03 2015
[    16.801] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    16.818] (==) No Layout section.  Using the first Screen section.
[    16.818] (==) No screen section available. Using defaults.
[    16.818] (**) |-->Screen "Default Screen Section" (0)
[    16.818] (**) |   |-->Monitor "<default monitor>"
[    16.818] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[    16.818] (==) Automatically adding devices
[    16.818] (==) Automatically enabling devices
[    16.818] (==) Automatically adding GPU devices
[    16.833] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[    16.833]    Entry deleted from font path.
[    16.833] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    16.833]    Entry deleted from font path.
[    16.833] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    16.834]    Entry deleted from font path.
[    16.834] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    16.834]    Entry deleted from font path.
[    16.834] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[    16.834]    Entry deleted from font path.
[    16.834] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[    16.834]    Entry deleted from font path.
[    16.834] (==) FontPath set to:

[    16.834] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    16.834] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    16.834] (II) Loader magic: 0x806c80
[    16.834] (II) Module ABI versions:
[    16.834]    X.Org ANSI C Emulation: 0.4
[    16.834]    X.Org Video Driver: 18.0
[    16.834]    X.Org XInput driver : 21.0
[    16.834]    X.Org Server Extension : 8.0
[    16.834] (II) xfree86: Adding drm device (/dev/dri/card0)
[    16.835] (--) PCI:*(0:0:2:0) 8086:2e22:1025:0257 rev 3, Mem @ 0xfe400000/4194304, 0xd0000000/268435456, I/O @ 0x0000dc00/8
[    16.835] (--) PCI: (0:0:2:1) 8086:2e23:1025:0257 rev 3, Mem @ 0xfe800000/1048576
[    16.835] (II) LoadModule: "glx"
[    16.885] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    17.017] (II) Module glx: vendor="X.Org Foundation"
[    17.017]    compiled for 1.16.4, module version = 1.0.0
[    17.017]    ABI class: X.Org Server Extension, version 8.0
[    17.017] (==) AIGLX enabled
[    17.017] (==) Matched intel as autoconfigured driver 0
[    17.017] (==) Matched intel as autoconfigured driver 1
[    17.017] (==) Matched modesetting as autoconfigured driver 2
[    17.017] (==) Matched fbdev as autoconfigured driver 3
[    17.017] (==) Matched vesa as autoconfigured driver 4
[    17.017] (==) Assigned the driver to the xf86ConfigLayout
[    17.017] (II) LoadModule: "intel"
[    17.024] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[    17.059] (II) Module intel: vendor="X.Org Foundation"
[    17.059]    compiled for 1.16.4, module version = 2.99.917
[    17.059]    Module class: X.Org Video Driver
[    17.059]    ABI class: X.Org Video Driver, version 18.0
[    17.059] (II) LoadModule: "modesetting"
[    17.064] (WW) Warning, couldn't open module modesetting
[    17.064] (II) UnloadModule: "modesetting"
[    17.064] (II) Unloading modesetting
[    17.064] (EE) Failed to load module "modesetting" (module does not exist, 0)
[    17.064] (II) LoadModule: "fbdev"
[    17.065] (WW) Warning, couldn't open module fbdev
[    17.065] (II) UnloadModule: "fbdev"
[    17.065] (II) Unloading fbdev
[    17.065] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    17.065] (II) LoadModule: "vesa"
[    17.065] (WW) Warning, couldn't open module vesa
[    17.065] (II) UnloadModule: "vesa"
[    17.065] (II) Unloading vesa
[    17.065] (EE) Failed to load module "vesa" (module does not exist, 0)
[    17.065] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
        i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
        915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
        Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    17.065] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[    17.065] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[    17.065] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[    17.065] (++) using VT number 7

[    17.065] (WW) xf86OpenConsole: setpgid failed: Operation not permitted
[    17.065] (WW) xf86OpenConsole: setsid failed: Operation not permitted
[    17.066] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20140725
[    17.067] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    17.068] (--) intel(0): Integrated Graphics Chipset: Intel(R) G45/G43
[    17.068] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1
[    17.068] (II) intel(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[    17.068] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[    17.068] (==) intel(0): RGB weight 888
[    17.068] (==) intel(0): Default visual is TrueColor
[    17.068] (II) intel(0): Output VGA1 has no monitor section
[    17.068] (II) intel(0): Enabled output VGA1
[    17.068] (II) intel(0): Output HDMI1 has no monitor section
[    17.068] (II) intel(0): Enabled output HDMI1
[    17.068] (II) intel(0): Output DP1 has no monitor section
[    17.068] (II) intel(0): Enabled output DP1
[    17.068] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[    17.068] (II) intel(0): Output VIRTUAL1 has no monitor section
[    17.068] (II) intel(0): Enabled output VIRTUAL1
[    17.068] (==) intel(0): TearFree disabled
[    17.068] (==) intel(0): DPI set to (96, 96)
[    17.068] (II) Loading sub module "dri2"
[    17.068] (II) LoadModule: "dri2"
[    17.068] (II) Module "dri2" already built-in
[    17.068] (II) Loading sub module "present"
[    17.068] (II) LoadModule: "present"
[    17.068] (II) Module "present" already built-in
[    17.068] (==) Depth 24 pixmap format is 32 bpp
[    17.091] (II) intel(0): SNA initialized with Eaglelake (gen4.5) backend
[    17.091] (==) intel(0): Backing store enabled
[    17.091] (==) intel(0): Silken mouse enabled
[    17.091] (II) intel(0): HW Cursor enabled
[    17.091] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    17.091] (==) intel(0): DPMS enabled
[    17.092] (==) intel(0): display hotplug detection enabled
[    17.092] (II) intel(0): [DRI2] Setup complete
[    17.092] (II) intel(0): [DRI2]   DRI driver: i965
[    17.092] (II) intel(0): [DRI2]   VDPAU driver: i965
[    17.092] (II) intel(0): direct rendering: DRI2 enabled
[    17.092] (II) intel(0): hardware support for Present enabled
[    17.092] (--) RandR disabled
[    17.273] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[    17.273] (II) AIGLX: enabled GLX_ARB_create_context
[    17.273] (II) AIGLX: enabled GLX_ARB_create_context_profile
[    17.273] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[    17.273] (II) AIGLX: enabled GLX_INTEL_swap_event
[    17.273] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[    17.273] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[    17.273] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[    17.273] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[    17.273] (II) AIGLX: Loaded and initialized i965
[    17.273] (II) GLX: Initialized DRI2 GL provider for screen 0
[    17.547] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[    17.547] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    17.547] (II) LoadModule: "evdev"
[    17.547] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[    17.576] (II) Module evdev: vendor="X.Org Foundation"
[    17.576]    compiled for 1.16.4, module version = 2.9.1
[    17.576]    Module class: X.Org XInput Driver
[    17.576]    ABI class: X.Org XInput driver, version 21.0
[    17.576] (II) Using input driver 'evdev' for 'Power Button'
[    17.576] (**) Power Button: always reports core events
[    17.576] (**) evdev: Power Button: Device: "/dev/input/event1"
[    17.577] (--) evdev: Power Button: Vendor 0 Product 0x1
[    17.577] (--) evdev: Power Button: Found keys
[    17.577] (II) evdev: Power Button: Configuring as keyboard
[    17.577] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[    17.577] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    17.577] (**) Option "xkb_rules" "evdev"
[    17.577] (**) Option "xkb_model" "pc104"
[    17.577] (**) Option "xkb_layout" "us"
[    17.603] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[    17.603] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    17.603] (II) Using input driver 'evdev' for 'Power Button'
[    17.603] (**) Power Button: always reports core events
[    17.603] (**) evdev: Power Button: Device: "/dev/input/event0"
[    17.603] (--) evdev: Power Button: Vendor 0 Product 0x1
[    17.603] (--) evdev: Power Button: Found keys
[    17.603] (II) evdev: Power Button: Configuring as keyboard
[    17.603] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0/event0"
[    17.603] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[    17.603] (**) Option "xkb_rules" "evdev"
[    17.603] (**) Option "xkb_model" "pc104"
[    17.603] (**) Option "xkb_layout" "us"
[    17.604] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/event5)
[    17.604] (**) Genius Optical Mouse: Applying InputClass "evdev pointer catchall"
[    17.604] (II) Using input driver 'evdev' for 'Genius Optical Mouse'
[    17.604] (**) Genius Optical Mouse: always reports core events
[    17.604] (**) evdev: Genius Optical Mouse: Device: "/dev/input/event5"
[    17.604] (--) evdev: Genius Optical Mouse: Vendor 0x458 Product 0x3a
[    17.604] (--) evdev: Genius Optical Mouse: Found 3 mouse buttons
[    17.604] (--) evdev: Genius Optical Mouse: Found scroll wheel(s)
[    17.604] (--) evdev: Genius Optical Mouse: Found relative axes
[    17.604] (--) evdev: Genius Optical Mouse: Found x and y relative axes
[    17.604] (II) evdev: Genius Optical Mouse: Configuring as mouse
[    17.604] (II) evdev: Genius Optical Mouse: Adding scrollwheel support
[    17.604] (**) evdev: Genius Optical Mouse: YAxisMapping: buttons 4 and 5
[    17.604] (**) evdev: Genius Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    17.604] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb6/6-1/6-1:1.0/0003:0458:003A.0003/input/input6/event5"
[    17.604] (II) XINPUT: Adding extended input device "Genius Optical Mouse" (type: MOUSE, id 8)
[    17.604] (II) evdev: Genius Optical Mouse: initialized for relative axes.
[    17.604] (**) Genius Optical Mouse: (accel) keeping acceleration scheme 1
[    17.604] (**) Genius Optical Mouse: (accel) acceleration profile 0
[    17.604] (**) Genius Optical Mouse: (accel) acceleration factor: 2.000
[    17.604] (**) Genius Optical Mouse: (accel) acceleration threshold: 4
[    17.604] (II) config/udev: Adding input device Genius Optical Mouse (/dev/input/mouse0)
[    17.604] (II) No input driver specified, ignoring this device.
[    17.604] (II) This device may have been added with another device file.
[    17.605] (II) config/udev: Adding input device   USB Keyboard (/dev/input/event3)
[    17.605] (**)   USB Keyboard: Applying InputClass "evdev keyboard catchall"
[    17.605] (II) Using input driver 'evdev' for '  USB Keyboard'
[    17.605] (**)   USB Keyboard: always reports core events
[    17.605] (**) evdev:   USB Keyboard: Device: "/dev/input/event3"
[    17.605] (--) evdev:   USB Keyboard: Vendor 0x4d9 Product 0x1603
[    17.605] (--) evdev:   USB Keyboard: Found keys
[    17.605] (II) evdev:   USB Keyboard: Configuring as keyboard
[    17.605] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.1/usb7/7-2/7-2:1.0/0003:04D9:1603.0001/input/input4/event3"
[    17.605] (II) XINPUT: Adding extended input device "  USB Keyboard" (type: KEYBOARD, id 9)
[    17.605] (**) Option "xkb_rules" "evdev"
[    17.605] (**) Option "xkb_model" "pc104"
[    17.605] (**) Option "xkb_layout" "us"
[    17.605] (II) config/udev: Adding input device   USB Keyboard (/dev/input/event4)
[    17.606] (**)   USB Keyboard: Applying InputClass "evdev keyboard catchall"
[    17.606] (II) Using input driver 'evdev' for '  USB Keyboard'
[    17.606] (**)   USB Keyboard: always reports core events
[    17.606] (**) evdev:   USB Keyboard: Device: "/dev/input/event4"
[    17.606] (--) evdev:   USB Keyboard: Vendor 0x4d9 Product 0x1603
[    17.606] (--) evdev:   USB Keyboard: Found keys
[    17.606] (II) evdev:   USB Keyboard: Configuring as keyboard
[    17.606] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.1/usb7/7-2/7-2:1.1/0003:04D9:1603.0002/input/input5/event4"
[    17.606] (II) XINPUT: Adding extended input device "  USB Keyboard" (type: KEYBOARD, id 10)
[    17.606] (**) Option "xkb_rules" "evdev"
[    17.606] (**) Option "xkb_model" "pc104"
[    17.606] (**) Option "xkb_layout" "us"
[    17.606] (II) config/udev: Adding input device PC Speaker (/dev/input/event2)
[    17.606] (II) No input driver specified, ignoring this device.
[    17.606] (II) This device may have been added with another device file.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum