Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ glsa 201503-03 ] php
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2189

PostPosted: Sun Mar 08, 2015 3:26 pm    Post subject: [ glsa 201503-03 ] php Reply with quote

Gentoo Linux Security Advisory

Title: PHP: Multiple vulnerabilities (GLSA 201503-03)
Severity: normal
Exploitable: remote
Date: March 08, 2015
Updated: August 22, 2015
Bug(s): #530820, #532914, #533998
ID: 201503-03

Synopsis

Multiple vulnerabilities have been discovered in PHP, the worst of
which could lead to remote execution of arbitrary code.


Background

PHP is a widely-used general-purpose scripting language that is
especially suited for Web development and can be embedded into HTML.


Affected Packages

Package: dev-lang/php
Vulnerable: < 5.5.21
Unaffected: >= 5.5.21
Unaffected: >= 5.4.37 < 5.4.38
Unaffected: >= 5.4.38 < 5.4.39
Unaffected: >= 5.4.39 < 5.4.40
Unaffected: >= 5.4.40 < 5.4.41
Unaffected: >= 5.4.41 < 5.4.42
Unaffected: >= 5.4.42 < 5.4.43
Unaffected: >= 5.4.43 < 5.4.44
Unaffected: >= 5.4.44 < 5.4.45
Unaffected: >= 5.4.45 < 5.4.46
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in PHP. Please review the
CVE identifiers referenced below for details.


Impact

A remote attacker can leverage these vulnerabilities to execute
arbitrary code or cause Denial of Service.


Workaround

There is no known workaround at this time.

Resolution

All PHP 5.5 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-5.5.21"
   
All PHP 5.4 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-5.4.37"
   
All PHP 5.3 users should upgrade to the latest version. This branch is
currently past the end of life and it will no longer receive security
fixes. All PHP 5.3 users are strongly recommended to upgrade to the
current stable version of PHP 5.5 or previous stable version of PHP 5.4,
which are supported till at least 2016 and 2015 respectively.


References

CVE-2014-3710
CVE-2014-8142
CVE-2014-9425
CVE-2014-9427
CVE-2015-0231
CVE-2015-0232


Last edited by GLSA on Sun Aug 23, 2015 4:16 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum