Joined: 12 May 2004
|Posted: Sun Mar 08, 2015 3:26 pm Post subject: [ glsa 201503-03 ] php
|Gentoo Linux Security Advisory
Title: PHP: Multiple vulnerabilities (GLSA 201503-03)
Date: March 08, 2015
Updated: August 22, 2015
Bug(s): #530820, #532914, #533998
Multiple vulnerabilities have been discovered in PHP, the worst of
which could lead to remote execution of arbitrary code.
PHP is a widely-used general-purpose scripting language that is
especially suited for Web development and can be embedded into HTML.
Vulnerable: < 5.5.21
Unaffected: >= 5.5.21
Unaffected: >= 5.4.37 < 5.4.38
Unaffected: >= 5.4.38 < 5.4.39
Unaffected: >= 5.4.39 < 5.4.40
Unaffected: >= 5.4.40 < 5.4.41
Unaffected: >= 5.4.41 < 5.4.42
Unaffected: >= 5.4.42 < 5.4.43
Unaffected: >= 5.4.43 < 5.4.44
Unaffected: >= 5.4.44 < 5.4.45
Unaffected: >= 5.4.45 < 5.4.46
Architectures: All supported architectures
Multiple vulnerabilities have been discovered in PHP. Please review the
CVE identifiers referenced below for details.
A remote attacker can leverage these vulnerabilities to execute
arbitrary code or cause Denial of Service.
There is no known workaround at this time.
All PHP 5.5 users should upgrade to the latest version:
All PHP 5.4 users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/php-5.5.21"
All PHP 5.3 users should upgrade to the latest version. This branch is
|# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/php-5.4.37"
currently past the end of life and it will no longer receive security
fixes. All PHP 5.3 users are strongly recommended to upgrade to the
current stable version of PHP 5.5 or previous stable version of PHP 5.4,
which are supported till at least 2016 and 2015 respectively.
Last edited by GLSA on Sun Aug 23, 2015 4:16 am; edited 2 times in total