Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Missing boot logos with ker>=3.18 (Solved by a bad hack)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
nlsa8z6zoz7lyih3ap
Guru
Guru


Joined: 25 Sep 2007
Posts: 376
Location: Canada

PostPosted: Mon Mar 09, 2015 9:31 pm    Post subject: Missing boot logos with ker>=3.18 (Solved by a bad hack) Reply with quote

These have worked for years but do not with ker>=3.18 even 'tho the relevant kernel configs are the same.
The screen does go to fbdev but the penquins do not show. (Well actually they are my cat, but that surely is irrelevant.)

my grub line is
Code:
linux          /vmlinuz-gentoo   video:mtrr,ywrap 1024x768 net.ifnames=0 ro   quiet

Is any one else having this problem?

PS I am using the i9i5 driver and fbdev, but if I reconfigure to use veafbdev I still have no boot logos.


Last edited by nlsa8z6zoz7lyih3ap on Thu Mar 12, 2015 3:52 am; edited 1 time in total
Back to top
View user's profile Send private message
nlsa8z6zoz7lyih3ap
Guru
Guru


Joined: 25 Sep 2007
Posts: 376
Location: Canada

PostPosted: Thu Mar 12, 2015 1:45 am    Post subject: Reply with quote

I have found the following at: https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.4

Quote:
commit 7c73bd96b40f4fd3ed5064e73dc96139a18fe463
Author: Tomi Valkeinen <tomi.valkeinen@ti.com>
Date: Thu Dec 18 13:40:06 2014 +0200

video/logo: prevent use of logos after they have been freed

commit 92b004d1aa9f367c372511ca0330f58216b25703 upstream.

If the probe of an fb driver has been deferred due to missing
dependencies, and the probe is later ran when a module is loaded, the
fbdev framework will try to find a logo to use.

However, the logos are __initdata, and have already been freed. This
causes sometimes page faults, if the logo memory is not mapped,
sometimes other random crashes as the logo data is invalid, and
sometimes nothing, if the fbdev decides to reject the logo (e.g. the
random value depicting the logo's height is too big).

This patch adds a late_initcall function to mark the logos as freed. In
reality the logos are freed later, and fbdev probe may be ran between
this late_initcall and the freeing of the logos. In that case we will
miss drawing the logo, even if it would be possible.

Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ti.com>
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>


I only sort of understand it but expect that it accounts for my missing logo problem.

Further Questions:
(1) Does this give anyone any ideas for fixes?
(2) Does anyone have boot logos showing with the 3.18.7 kernel?
Back to top
View user's profile Send private message
nlsa8z6zoz7lyih3ap
Guru
Guru


Joined: 25 Sep 2007
Posts: 376
Location: Canada

PostPosted: Thu Mar 12, 2015 3:51 am    Post subject: Reply with quote

I solved this by copying "drivers/video/logo/logo.c" from gentoo-sources-3.17.8-r1 to gentoo-sources-3.18.7.

However this solution is not really a good one as evidently upstream kernel views the new logo.c as an improvement.

Any comments or insights would be appreciated.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum