Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[S]emerge wine Problem
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Tue Mar 10, 2015 12:45 pm    Post subject: [S]emerge wine Problem Reply with quote

Hallo,

wenn ich wine installieren möchte bekomme ich folgende Fehlermeldung:

Code:


 there are no ebuilds to satisfy ">=x11-libs/libX11-1.6.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]"



in der package.use habe ich:

Code:
x11-libs/libX11 abi_x86_64


Was mache ich falsch?

Edit:
hier noch der Rest der Fehlerausgabe:


Code:
emerge: there are no ebuilds to satisfy ">=x11-libs/libX11-1.6.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]".
(dependency required by "x11-libs/libva-1.5.0" [ebuild])
(dependency required by "app-emulation/wine-1.7.38[vaapi,abi_x86_32,abi_x86_64]" [ebuild])
(dependency required by "wine" [argument])


Last edited by Tinitus on Wed Mar 11, 2015 8:05 am; edited 1 time in total
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Wed Mar 11, 2015 6:38 am    Post subject: Reply with quote

Es liegt an dem von dir zitierten Eintrag in der package.use. Wird den raus und es geht. Warum hast du den denn manuell gesetzt?
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Wed Mar 11, 2015 6:51 am    Post subject: Reply with quote

Hallo,

leider liegt es daran nicht.
Wenn der Eintrag raus ist kommt:
Code:

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by app-emulation/wine-1.7.38[vaapi,abi_x86_32]
# required by wine (argument)
=x11-libs/libva-1.5.0 abi_x86_32


Ok gesetzt...

dann wieder:

Code:
emerge: there are no ebuilds to satisfy ">=x11-libs/libX11-1.6.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]".
(dependency required by "x11-libs/libva-1.5.0" [ebuild])
(dependency required by "app-emulation/wine-1.7.38[vaapi,abi_x86_32,abi_x86_64]" [ebuild])


Das Problem fing eigentlich damit an, daß sich etwas im ebuild verändert hat:
Code:

 emerge wine

 * IMPORTANT: 23 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies \

!!! Problem resolving dependencies for app-emulation/wine
... done!

!!! The ebuild selected to satisfy "wine" has unmet requirements.
- app-emulation/wine-1.7.38::gentoo USE="X alsa cups fontconfig gecko jpeg lcms ldap mono mp3 ncurses nls opengl perl pipelight png prelink pulseaudio realtime run-exes samba ssl threads truetype udisks vaapi xcomposite xinerama xml -capi -custom-cflags -dos -gphoto2 -gsm -gstreamer -netapi -odbc -openal -opencl -osmesa -oss -pcap -s3tc -scanner (-selinux) -staging -test -v4l" ABI_X86="32 64 -x32" LINGUAS="de -ar -bg -ca -cs -da -el -en -en_US -eo -es -fa -fi -fr -he -hi -hr -hu -it -ja -ko -lt -ml -nb_NO -nl -or -pa -pl -pt_BR -pt_PT -rm -ro -ru -sk -sl -sr_RS@cyrillic -sr_RS@latin -sv -te -th -tr -uk -wa -zh_CN -zh_TW"

  The following REQUIRED_USE flag constraints are unsatisfied:
    pipelight? ( staging ) vaapi? ( staging )

  The above constraints are a subset of the following complete expression:
    any-of ( abi_x86_32 abi_x86_64 ) test? ( abi_x86_32 ) elibc_glibc? ( threads ) mono? ( abi_x86_32 ) pipelight? ( staging ) s3tc? ( staging ) vaapi? ( staging ) osmesa? ( opengl )


Da ich pipelight wollte habe ich

vaapi und staging in die Use Flags mit aufgenommen.

Nehme ich die wieder raus kommt:

Code:
emerge wine

 * IMPORTANT: 23 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies |

!!! Problem resolving dependencies for app-emulation/wine
... done!

!!! The ebuild selected to satisfy "wine" has unmet requirements.
- app-emulation/wine-1.7.38::gentoo USE="X alsa cups fontconfig gecko jpeg lcms ldap mono mp3 ncurses nls opengl perl pipelight png prelink pulseaudio realtime run-exes samba ssl threads truetype udisks vaapi xcomposite xinerama xml -capi -custom-cflags -dos -gphoto2 -gsm -gstreamer -netapi -odbc -openal -opencl -osmesa -oss -pcap -s3tc -scanner (-selinux) -staging -test -v4l" ABI_X86="32 64 -x32" LINGUAS="de -ar -bg -ca -cs -da -el -en -en_US -eo -es -fa -fi -fr -he -hi -hr -hu -it -ja -ko -lt -ml -nb_NO -nl -or -pa -pl -pt_BR -pt_PT -rm -ro -ru -sk -sl -sr_RS@cyrillic -sr_RS@latin -sv -te -th -tr -uk -wa -zh_CN -zh_TW"

  The following REQUIRED_USE flag constraints are unsatisfied:
    pipelight? ( staging ) vaapi? ( staging )

  The above constraints are a subset of the following complete expression:
    any-of ( abi_x86_32 abi_x86_64 ) test? ( abi_x86_32 ) elibc_glibc? ( threads ) mono? ( abi_x86_32 ) pipelight? ( staging ) s3tc? ( staging ) vaapi? ( staging ) osmesa? ( opengl )


Ein Bug oder sehe ich den Wald vor lauter Bäumen nicht?

Grüße
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Wed Mar 11, 2015 6:59 am    Post subject: Reply with quote

Nach dem heutigen Sync sieht es so aus:

Code:
emerge: there are no ebuilds to satisfy ">=x11-libs/libXfixes-5.0.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]".
(dependency required by "x11-libs/libva-1.5.0" [ebuild])
(dependency required by "media-video/ffmpeg-1.2.6-r1[vaapi]" [installed])
(dependency required by "media-video/makemkv-1.8.13-r1" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Wed Mar 11, 2015 6:59 am    Post subject: Reply with quote

Doch, es liegt daran. Es scheitert daran, dass du noch mehr Dinge gesetzt hast, die sich beißen.

Du hast wine-1.7.38[vaapi,abi_x86_32]. Und dieses abi_x86_32 funktioniert leider nicht mehr mit libX11. Kannst du wine eventuell auf abi_x86_64 umstellen?
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Wed Mar 11, 2015 7:04 am    Post subject: Reply with quote

Hallo,

ich habe wine und pipelight deinstalliert:


dann ein: emerge --update --newuse --deep @world
Code:


emerge: there are no ebuilds to satisfy ">=x11-libs/libXfixes-5.0.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]".
(dependency required by "x11-libs/libva-1.5.0" [ebuild])
(dependency required by "media-video/ffmpeg-1.2.6-r1[vaapi]" [installed])
(dependency required by "media-video/makemkv-1.8.13-r1" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Da scheint noch mehr umgestellt zu sein...
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Wed Mar 11, 2015 7:06 am    Post subject: Reply with quote

Wirf alle abi's aus deiner package.use raus. Und ich habe gerade mal geschaut, wine bekommst du dann mit dem USE-Flag -vaapi installiert.
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Wed Mar 11, 2015 7:15 am    Post subject: Reply with quote

Hallo,

nachdem ich alle abi aus der package.use entfernt habe hat das world update funktioniert.

wine hängt immer noch:

Code:

emerge wine -pv

These are the packages that would be merged, in order:

Calculating dependencies \

!!! Problem resolving dependencies for app-emulation/wine
... done!

!!! The ebuild selected to satisfy "wine" has unmet requirements.
- app-emulation/wine-1.7.38::gentoo USE="X alsa cups fontconfig gecko jpeg lcms ldap mono mp3 ncurses nls opengl perl pipelight png prelink pulseaudio realtime run-exes samba ssl threads truetype udisks xcomposite xinerama xml -capi -custom-cflags -dos -gphoto2 -gsm -gstreamer -netapi -odbc -openal -opencl -osmesa -oss -pcap -s3tc -scanner (-selinux) -staging -test -v4l -vaapi" ABI_X86="32 64 -x32" LINGUAS="de -ar -bg -ca -cs -da -el -en -en_US -eo -es -fa -fi -fr -he -hi -hr -hu -it -ja -ko -lt -ml -nb_NO -nl -or -pa -pl -pt_BR -pt_PT -rm -ro -ru -sk -sl -sr_RS@cyrillic -sr_RS@latin -sv -te -th -tr -uk -wa -zh_CN -zh_TW"

  The following REQUIRED_USE flag constraints are unsatisfied:
    pipelight? ( staging )

  The above constraints are a subset of the following complete expression:
    any-of ( abi_x86_32 abi_x86_64 ) test? ( abi_x86_32 ) elibc_glibc? ( threads ) mono? ( abi_x86_32 ) pipelight? ( staging ) s3tc? ( staging ) vaapi? ( staging ) osmesa? ( opengl )


Was könnte das noch sein?
Schon mal vielen Dank für Deine Mühe und Geduld mit mir.

Edit:

staging hat wieder gefehlt --gelöst.


Last edited by Tinitus on Wed Mar 11, 2015 7:19 am; edited 1 time in total
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Wed Mar 11, 2015 7:19 am    Post subject: Reply with quote

Du musst auch pipelight rauswerfen. Das geht nur mit staging und staging verursacht die abi-Probleme.
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 456

PostPosted: Wed Mar 11, 2015 5:40 pm    Post subject: Reply with quote

Ich habe die Abi Flags in der make.conf global gesetzt, funktioniert mittlerweile ohne Probleme.

Also
ABI_X86="32 64"

Weil ich die vorkompilierten emul-linux-x86 Pakete nicht will sondern ein richtiges multilib System.
Du musst dann nur die entsprechenden emul-linux-x86 Pakete demaskieren.
Back to top
View user's profile Send private message
NP-Hardass
Developer
Developer


Joined: 24 Mar 2013
Posts: 36

PostPosted: Thu Mar 12, 2015 5:57 pm    Post subject: Support Reply with quote

Hello,

I'm the maintainer for wine. I'd be more than happy to assist if you can come into the #gentoo-wine IRC channel on freenode.
I am currently running with all of the staging bells and whistles on a non-emul-linux system. I can tell you for sure that they are not the source of your issue. Instinct tells me that the issue is that you are missing an abi_x86_32 flag on something. Anyway, I'd be more than happy to help if you come on IRC.
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1169
Location: Buchholz/GER

PostPosted: Sun Mar 15, 2015 6:43 pm    Post subject: Reply with quote

Ich konnte die Konflikte ebenfalls mit den Hinweisen von Klaus Meier auflösen. Allen abi-Krams rauswerfen, wine und pipelight weg, staging und -vaapi für wine in package.use festgenagelt und alles neu gebaut.

Läuft!

Danke dafür ...
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Sun Mar 15, 2015 7:11 pm    Post subject: Reply with quote

Ihr müsst wine aber nicht vorher deinstallieren und dann wieder installieren. Die entsprechenden Einträge in die package.use machen und dann ein
Code:
emerge -uDN world
machen bewirkt das Gleiche und braucht viel weniger Schritte.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum