Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sudden but persisting fan-speed and battery level issues
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 13 Sep 2007
Posts: 245
Location: Zürich

PostPosted: Sat Mar 14, 2015 3:13 pm    Post subject: Sudden but persisting fan-speed and battery level issues Reply with quote

Hello, a few days ago I rebooted my computer - just to find out it would not boot. I found out that was because some directories from underneath /lib got moved all over the place. Crazy - right? To this day, I have no idea what happened. Iamben (a knowledgeable seeming guy on IRC) suggested that something like `$(some-internal-portage-comand)` had started pointing to / instead of /usr/lib64 or something. Not to be ignored, is the fact that both / and /usr/ were littered with files called lib or liblib or libliblib - all of them containing some text saying they exist as a fix to this bug. Strange, right?

In any case I SOLVED that issue by manually moving my directories back where they belonged, booting up (surprisingly that worked) and running emerge -e world to make sure all my packages would contain all the files they need.

Almost everything is working nicely again, with two very annoying exceptions:

* My laptop is no longer able to show my battery level (it always says something like 18-22%), and it is no longer showing when I am charging (charging works, though)
* One of my laptop fans is on at full speed ALL THE TIME. The noise it is making is revolting - it's louder than anything I ever heard form a laptop (and mind you this is one f those new fancy boxes, where normally you wouldn't even guess it had a fan if you would not see the vents).

What can I co? can you help me out?

I tried running

find /usr -exec qfile -o {} \; | while read l; do dir=`dirname $l`; file=`basename $l`; mkdir -p /backup/$dir; mv $l /backup/$l; done

to find what files are orphaned and move them, and then this

emerge -av1 `qlist --installed --nocolor | uniq | while read cp; do qlist --exact $cp | while read file; do test -e $file || { echo $cp; echo "$cp: missing $file (and maybe more)" 1>&2; break; }; done; done`

to emerge any packages from which I might have deleted any files - but all to no avail :-/
Check out my initiative to bring Neuroscience software to Gentoo - NeuroGentoo!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum