Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]Fehler beim Versuch Mate zu installieren
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
rrbs
n00b
n00b


Joined: 19 Dec 2014
Posts: 66

PostPosted: Tue Mar 24, 2015 7:18 pm    Post subject: [solved]Fehler beim Versuch Mate zu installieren Reply with quote

Hallo,

ich wollte mate installieren.
Leider gab es bei "mate-base/mate" Probleme.

Kann mir jemand helfen diese zu loesen?

Danke.

hier die Ausgabe:
Code:
emerge mate-base/mate
Unavailable repository 'calculate' referenced by masters entry in '/var/lib/layman/rasdark/metadata/layout.conf'

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies                     i * ERROR: media-gfx/inkscape-0.48.3.1::axs failed (depend phase):
 *   boost-utils.eclass could not be found by inherit()
 *
 * Call stack:
 *                  ebuild.sh, line 584:  Called source '/var/lib/layman/axs/media-gfx/inkscape/inkscape-0.48.3.1.ebuild'
 *   inkscape-0.48.3.1.ebuild, line  12:  Called inherit 'autotools' 'eutils' 'flag-o-matic' 'gnome2' 'python' 'boost-utils'
 *                  ebuild.sh, line 257:  Called die
 * The specific snippet of code:
 *              [[ -z ${location} ]] && die "${1}.eclass could not be found by inherit()"
 *
 * If you need support, post the output of `emerge --info '=media-gfx/inkscape-0.48.3.1::axs'`,
 * the complete build log and the output of `emerge -pqv '=media-gfx/inkscape-0.48.3.1::axs'`.
 * Working directory: '/usr/lib64/python3.3/site-packages'
 * S: '/var/tmp/portage/media-gfx/inkscape-0.48.3.1/work/inkscape-0.48.3.1'
                               ... done!     

emerge: there are no ebuilds to satisfy "sys-power/cpufrequtils".
(dependency required by "mate-base/mate-applets-1.8.1::sabayon-distro" [ebuild])
(dependency required by "mate-base/mate-1.8.0::gentoo[base]" [ebuild])
(dependency required by "mate-base/mate" [argument])


Last edited by rrbs on Sun Mar 29, 2015 4:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1733
Location: St. Wendel

PostPosted: Tue Mar 24, 2015 8:09 pm    Post subject: Reply with quote

Das sieht nicht nach Gentoo aus, sondern nach Calculate, zumindest will das verwendete Overlay das Calculate Overlay und Sabayon ist da auch noch irgendwie drin... räum da am besten erstmal auf, wenn es wirklich Gentoo sein soll.

Bei Gentoo brauchst afaik kein Overlay für Mate.

Bye
Py
Back to top
View user's profile Send private message
rrbs
n00b
n00b


Joined: 19 Dec 2014
Posts: 66

PostPosted: Fri Mar 27, 2015 6:53 pm    Post subject: Reply with quote

so overlays weggenommen.

bekomme aber den block nicht weg:

Code:
emerge mate-base/mate
Unavailable repository 'calculate' referenced by masters entry in '/var/lib/layman/rasdark/metadata/layout.conf'

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies                              ) * ERROR: media-gfx/inkscape-0.48.3.1::axs failed (depend phase):
 *   boost-utils.eclass could not be found by inherit()
 *
 * Call stack:
 *                  ebuild.sh, line 584:  Called source '/var/lib/layman/axs/media-gfx/inkscape/inkscape-0.48.3.1.ebuild'
 *   inkscape-0.48.3.1.ebuild, line  12:  Called inherit 'autotools' 'eutils' 'flag-o-matic' 'gnome2' 'python' 'boost-utils'
 *                  ebuild.sh, line 257:  Called die
 * The specific snippet of code:
 *              [[ -z ${location} ]] && die "${1}.eclass could not be found by inherit()"
 *
 * If you need support, post the output of `emerge --info '=media-gfx/inkscape-0.48.3.1::axs'`,
 * the complete build log and the output of `emerge -pqv '=media-gfx/inkscape-0.48.3.1::axs'`.
 * Working directory: '/usr/lib64/python3.3/site-packages'
 * S: '/var/tmp/portage/media-gfx/inkscape-0.48.3.1/work/inkscape-0.48.3.1'
                            ... done!
[ebuild     U  ] dev-util/gtk-doc-am-1.21 [1.20]
[ebuild  N     ] sys-power/cpupower-3.18  USE="nls -cpufreq_bench -debug"
[ebuild  N     ] x11-themes/mate-backgrounds-1.8.0
[ebuild  N     ] media-plugins/gst-plugins-faac-0.10.23-r1  ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-util/gtk-doc-1.21  USE="-debug -doc -emacs -highlight {-test} -vim" PYTHON_TARGETS="python2_7"
[ebuild  N     ] media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r3  USE="orc -libav" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] mate-extra/mate-calc-1.8.0
[ebuild  N     ] mate-extra/mate-system-monitor-1.8.0
[ebuild  N     ] mate-extra/mate-utils-1.8.1  USE="X ipv6 -applet -debug {-test}"
[ebuild  N     ] media-gfx/eom-1.8.1  USE="X dbus exif jpeg lcms svg tiff -debug -python -xmp" PYTHON_TARGETS="python2_7"
[ebuild  N     ] app-editors/pluma-1.8.1  USE="spell -debug -python {-test}" PYTHON_TARGETS="python2_7"
[ebuild  N     ] x11-terms/mate-terminal-1.8.1
[ebuild  N     ] app-text/atril-1.8.1  USE="dbus gnome-keyring introspection ps tiff -caja -debug -djvu -dvi -t1lib -xps"
[ebuild  N     ] x11-themes/gtk-engines-murrine-0.98.2-r1  USE="themes -animation-rtl" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] x11-themes/murrine-themes-0.98.0
[ebuild  N     ] x11-themes/mate-themes-1.8.0
[ebuild  N     ] sys-power/upower-pm-utils-0.9.23-r2  USE="introspection -ios"
[ebuild  N     ] mate-extra/mate-screensaver-1.8.1  USE="X consolekit libnotify opengl pam -debug -systemd"                                                                                     
[ebuild  N     ] mate-extra/mate-polkit-1.8.0  USE="introspection"                                                                                                                             
[ebuild  N     ] mate-base/mate-session-manager-1.8.1-r1  USE="gnome-keyring ipv6 upower -debug -systemd"                                                                                       
[ebuild  N     ] mate-base/mate-applets-1.8.1  USE="X ipv6 policykit upower -networkmanager" PYTHON_TARGETS="python2_7"                                                                         
[ebuild  N     ] mate-extra/mate-power-manager-1.8.1  USE="applet gnome-keyring policykit -man {-test} -unique"                                                                                 
[ebuild  N     ] app-arch/engrampa-1.8.1  USE="-caja -debug"                                                                                                                                   
[ebuild  N     ] mate-extra/mate-media-1.8.0  USE="aac flac vorbis -debug -mp3 -pulseaudio -speex -twolame"                                                                                     
[ebuild  N     ] x11-misc/mozo-1.8.0  PYTHON_TARGETS="python2_7"                                                                                                                               
[ebuild  N     ] mate-base/mate-1.8.0  USE="base extras themes (-bluetooth)"
[blocks B      ] sys-power/upower ("sys-power/upower" is blocking sys-power/upower-pm-utils-0.9.23-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-power/upower-0.99.2-r1:0/3::gentoo, installed) pulled in by
    sys-power/upower required by (net-misc/networkmanager-0.9.8.10-r1:0/0::gentoo, installed)
    >=sys-power/upower-0.99:= required by (gnome-extra/gnome-power-manager-3.12.2:0/0::gentoo, installed)
    >=sys-power/upower-0.99:= required by (gnome-base/gnome-control-center-3.12.1-r1:2/2::gentoo, installed)
    >=sys-power/upower-0.9.23 required by (xfce-base/xfce4-settings-4.11.2-r1:0/0::gentoo, installed)
    >sys-power/upower-0.99:= required by (x11-wm/mutter-3.12.2:0/0::gentoo, installed)
    sys-power/upower required by @selected
    >=sys-power/upower-0.9 required by (app-misc/tracker-1.0.2:0/100::gentoo, installed)
    >=sys-power/upower-0.9.23 required by (xfce-base/xfce4-session-4.11.0-r2:0/0::gentoo, installed)
    >=sys-power/upower-0.99 required by (gnome-base/gnome-settings-daemon-3.12.2:0/0::gentoo, installed)
    >=sys-power/upower-0.99[introspection] required by (gnome-base/gnome-shell-3.12.2:0/0::gentoo, installed)
    >=sys-power/upower-0.9.23 required by (kde-base/kdelibs-4.13.3-r1:4/4.13::gentoo, installed)

  (sys-power/upower-pm-utils-0.9.23-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-power/upower-pm-utils-0.9.23 required by (mate-base/mate-session-manager-1.8.1-r1:0/0::gentoo, ebuild scheduled for merge)
    >=sys-power/upower-pm-utils-0.9.23 required by (mate-base/mate-applets-1.8.1:0/0::gentoo, ebuild scheduled for merge)
    >=sys-power/upower-pm-utils-0.9.23 required by (mate-extra/mate-power-manager-1.8.1:0/0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


!!! The following installed packages are masked:
- app-admin/hwreport-0.11.0::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Christian Faulhammer <fauli@gentoo.org> (02 Sep 2014)
# website not working anymore and will stay like this,
# tool is useless. See bug 504734

- net-dialup/ppp-2.4.6-r3::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sergey Popov <pinkbyte@gentoo.org> (28 Aug 2014)
# Security mask, wrt bug #519650
# If your application is broken due to this mask,
# please file a separate bug report

- games-board/aisleriot-3.2.3.2-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (19 Mar 2015)
# Hardmasked for ages and still impossible to unmask (#416683).
# Removal in a month.
# Alexandre Rostovtsev <tetromino@gentoo.org> (20 May 2012)
# Requires dev-scheme/guile-2.0.5 which is in lisp overlay and masked;
# bug #416683

- net-misc/tor-0.2.6.2_alpha-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Anthony G. Basile <blueness@gentoo.org> (28 Jan 2015)
# Its broken and we're waiting for fixes from upstream, bug #536196

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


wie krieg ich den weg, damit ich mate installieren kann?

Danke fuer die Hilfe.

gruss ralle
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Fri Mar 27, 2015 7:33 pm    Post subject: Reply with quote

Na, die Lösung steht vermutlich in einer der noch ungelesenen News.
Versuche folgendes
Code:
emerge --deselect sys-power/upower
emerge -av1 sys-power/upower-pm-utils
emerge -av mate-base/mate


Zudem würde ich empfehlen sich auch um die installierten, inzwischen maskierten Pakete zu kümmern.
Back to top
View user's profile Send private message
rrbs
n00b
n00b


Joined: 19 Dec 2014
Posts: 66

PostPosted: Sat Mar 28, 2015 4:27 pm    Post subject: Reply with quote

Josef.95 wrote:
Na, die Lösung steht vermutlich in einer der noch ungelesenen News.
Versuche folgendes
Code:
emerge --deselect sys-power/upower
emerge -av1 sys-power/upower-pm-utils
emerge -av mate-base/mate


Zudem würde ich empfehlen sich auch um die installierten, inzwischen maskierten Pakete zu kümmern.


hat leider nix gebracht.
ich bekomme den block einfach nicht weg.

Code:
Calculating dependencies         ... done!               
[ebuild  N     ] sys-power/upower-pm-utils-0.9.23-r2  USE="introspection -ios"
[blocks B      ] sys-power/upower ("sys-power/upower" is blocking sys-power/upower-pm-utils-0.9.23-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.



was kann ich da noch tun?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Sat Mar 28, 2015 8:43 pm    Post subject: Reply with quote

Hm, hätte normal funktionieren sollen (hier tut es das).
Aber, ein Blick ins Ebuild verrät meist mehr :)

Dein schon installiertes Gnome3 (bzw einige dessen ebuilds) benötigt zwingend sys-power/upower
zb
gnome-power-manager-3.12.2.ebuild:
COMMON_DEPEND="...
>=sys-power/upower-0.99:=
...


Aber, bei den Deps von mate-base/mate benötigt nur mate-session-manager-1.8.1-r1[upower]
upower-pm-utils
Sprich wenn du mate-base/mate-session-manager mit USE=-upower baust sollte Gnome3 und mate-base/mate wahrscheinlich mit dem schon installierten sys-power/upower gleichzeitig installierbar sein.
Magst das mal austesten?
Back to top
View user's profile Send private message
rrbs
n00b
n00b


Joined: 19 Dec 2014
Posts: 66

PostPosted: Sun Mar 29, 2015 4:38 pm    Post subject: Reply with quote

Josef.95 wrote:
Hm, hätte normal funktionieren sollen (hier tut es das).
Aber, ein Blick ins Ebuild verrät meist mehr :)

Dein schon installiertes Gnome3 (bzw einige dessen ebuilds) benötigt zwingend sys-power/upower
zb
gnome-power-manager-3.12.2.ebuild:
COMMON_DEPEND="...
>=sys-power/upower-0.99:=
...


Aber, bei den Deps von mate-base/mate benötigt nur mate-session-manager-1.8.1-r1[upower]
upower-pm-utils
Sprich wenn du mate-base/mate-session-manager mit USE=-upower baust sollte Gnome3 und mate-base/mate wahrscheinlich mit dem schon installierten sys-power/upower gleichzeitig installierbar sein.
Magst das mal austesten?


DANK!!
Jetzt hats gefunzt. Supi.

gruss ralle
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum