Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-qt/qtcore:4 The following update(s) have been skipped
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Sun Mar 29, 2015 11:22 pm    Post subject: dev-qt/qtcore:4 The following update(s) have been skipped Reply with quote

Hallo,

habe heute beim Update folgende Fehler bekommen:

Code:
[ebuild   R    ] dev-qt/qtcore-4.8.5-r2:4  USE="exceptions glib iconv qt3support ssl (-aqua) -debug -icu -pch" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) conflicts with
    ~dev-qt/qtcore-4.8.5[-aqua,-debug,qt3support] required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed)
    ^              ^^^^^                         
    ~dev-qt/qtcore-4.8.5[-aqua,-debug,qt3support] required by (dev-qt/qtsql-4.8.5:4/4::gentoo, installed)
    ^              ^^^^^                         
    ~dev-qt/qtcore-4.8.5[-aqua,-debug] required by (dev-qt/qtmultimedia-4.8.5:4/4::gentoo, installed)
    ^              ^^^^^             
    ~dev-qt/qtcore-4.8.5[-aqua,-debug] required by (dev-qt/qthelp-4.8.5-r2:4/4::gentoo, installed)
    ^              ^^^^^             
    ~dev-qt/qtcore-4.8.5[-aqua,-debug,glib,qt3support] required by (dev-qt/qtgui-4.8.5-r4:4/4::gentoo, installed)
    ^              ^^^^^                             
    ~dev-qt/qtcore-4.8.5[-aqua,-debug] required by (dev-qt/designer-4.8.5:4/4::gentoo, installed)
    ^              ^^^^^             
    ~dev-qt/qtcore-4.8.5[-aqua,-debug,qt3support] required by (dev-qt/qtopengl-4.8.5:4/4::gentoo, installed)
    ^              ^^^^^                         
    ~dev-qt/qtcore-4.8.5[-aqua,-debug] required by (dev-qt/qttest-4.8.5:4/4::gentoo, installed)
    ^              ^^^^^             
    ~dev-qt/qtcore-4.8.5[-aqua,-debug] required by (dev-qt/qtscript-4.8.5:4/4::gentoo, installed)
    ^              ^^^^^             
    ~dev-qt/qtcore-4.8.5[-aqua,-debug,qt3support] required by (dev-qt/qt3support-4.8.5:4/4::gentoo, installed)
    ^              ^^^^^                         
    ~dev-qt/qtcore-4.8.5[-aqua,-debug] required by (dev-qt/qtsvg-4.8.5:4/4::gentoo, installed)
    ^              ^^^^^             
    ~dev-qt/qtcore-4.8.5[-aqua,-debug] required by (dev-qt/qtxmlpatterns-4.8.5:4/4::gentoo, installed)
    ^              ^^^^^             


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

dev-qt/qtdbus:4
dev-qt/qtwebkit:4
dev-qt/qtgui:4


Wie kann man das auflösen?
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Mon Mar 30, 2015 1:35 pm    Post subject: Reply with quote

Nach dem Update heute sieht es wie folgt aus:

Code:
Calculating dependencies... done!
[ebuild  N    #] app-emulation/emul-linux-x86-baselibs-20140508-r12  USE="development kerberos ldap pam" ABI_X86="-32"
[uninstall     ] sys-apps/util-linux-2.25.2-r2
[blocks b      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32]" is blocking sys-apps/util-linux-2.25.2-r2)
[uninstall     ] dev-libs/libgcrypt-1.5.4-r1
[uninstall     ] dev-libs/lzo-2.08
[blocks b      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32]" is blocking dev-libs/lzo-2.08, dev-libs/libgcrypt-1.5.4-r1)
[ebuild   R   #] app-emulation/emul-linux-x86-db-20140508-r1
[blocks B      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]" is blocking dev-libs/openssl-0.9.8z_p5-r1, media-libs/tiff-4.0.3-r6, net-print/cups-2.0.1-r1, media-libs/lcms-2.6-r1, dev-libs/glib-2.42.2, sys-devel/llvm-3.5.0, dev-libs/json-c-0.11-r1, media-libs/libjpeg-turbo-1.3.1, sys-apps/dbus-1.8.16, media-libs/libpng-1.6.16, dev-libs/libgpg-error-1.13, dev-libs/nettle-2.7.1-r1, media-libs/libmng-2.0.2-r1, net-dns/libidn-1.29, dev-libs/libffi-3.0.13-r1, dev-libs/libxml2-2.9.2, net-nds/openldap-2.4.38-r2, dev-libs/expat-2.1.0-r3, dev-libs/libtasn1-4.2, dev-db/sqlite-3.8.7.4, net-libs/gnutls-3.3.10-r2, dev-libs/libxslt-1.1.28-r4, sys-apps/systemd-216-r3)
[blocks B      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]" is blocking sys-libs/readline-6.2_p5-r1, dev-libs/gmp-5.1.3-r1, sys-libs/ncurses-5.9-r3, sys-apps/tcp-wrappers-7.6.22-r1, sys-libs/gpm-1.20.7-r2, sys-devel/gettext-0.19.3, sys-libs/zlib-1.2.8-r1, app-arch/bzip2-1.0.6-r6, sys-apps/attr-2.4.47-r1, dev-libs/openssl-1.0.1l-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/dbus-1.8.16:0/0::gentoo, installed) pulled in by
    sys-apps/dbus required by @selected

  (app-emulation/emul-linux-x86-baselibs-20140508-r12:0/0::gentoo, ebuild scheduled for merge) pulled in by
    ~app-emulation/emul-linux-x86-baselibs-20140508 required by (app-emulation/emul-linux-x86-db-20140508-r1:0/0::gentoo, ebuild scheduled for merge)

  (net-print/cups-2.0.1-r1:0/0::gentoo, installed) pulled in by
    net-print/cups required by @selected

  (sys-libs/zlib-1.2.8-r1:0/0::gentoo, installed) pulled in by
    sys-libs/zlib required by @selected

  (sys-apps/attr-2.4.47-r1:0/0::gentoo, installed) pulled in by
    sys-apps/attr required by @selected

  (sys-apps/tcp-wrappers-7.6.22-r1:0/0::gentoo, installed) pulled in by
    sys-apps/tcp-wrappers required by @selected


Hallo,

wenn ich jetzt alles -wie von emerge vorgeschlagen auf 32 bit setzte können doch die Programme gar nicht mehr mit größerem Arbeitsspeicher umgehen, oder?
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Thu Apr 09, 2015 11:47 am    Post subject: Reply with quote

Hallo Tinitus,

schau mal in deine News (eselect news read new) da müsste eine Info auftauchen für die Multilib-Systeme. Das app-emulation-Zeug brauchst Du dann nicht mehr, Du musst nur die package.use ergänzen. Ist in der info erklärt...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 112

PostPosted: Thu Apr 09, 2015 1:08 pm    Post subject: Reply with quote

Habe mich darüber auch schlau gemacht ... also man kann in die
Code:
make.config
auch das hier eintippen
Code:
ABI_X86="64 32"

für bisschen mehr info kannst du auch meinen post durchlesen hier .. -> http://www.gentooforum.de/artikel/22005/frage-zu-der-news-true-multilib-support-on-amd64-gentoo.html

hoffe es hilft dir weiter

lg
schatti
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Fri Apr 10, 2015 6:16 am    Post subject: Reply with quote

Hallo,

also Problem war die qt Geschichte.... . Dort waren noch nicht alle ebuilds angepaßt.

Ich habe dann nicht wie von Portage vorgeschlagen in 32 bit die Pakete bauen lassen, sondern in 64 bit.
So sind nur einige Pakete in 32bit nötig gewesen.

Nachdem die ebuilds dann aktualisiert wurden ging ein --deep --newuse world Lauf fast durch.... dann ein depclean.... und ein emerge @preserved-rebuild.

Dann lief es wieder. Zum Glück hatte ich ein Backup.
Danke für die Rückmeldungen.
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Mon Apr 20, 2015 7:36 pm    Post subject: Reply with quote

Ich hab ähnliche Probleme, wegen Dienstreisen kein word update seit 2 Montan gemacht und habe eine elend lange block liste bekommen. Zunächst hab ich wie in enews vorgeschlagen die emul-* Pakete deinstalliert, weil ich sonst hunderte von Pakete in package.use mit abi_x86_32 habe ich in /etc/portage/make.conf USE="... abi_x86_32" hinzugefügt, damit waren viele Blocks weg.

Die blöde qt Blocks kriege ich nicht weg, ich weiß nicht, woran es liegt

Code:

Total: 241 packages (92 upgrades, 14 new, 3 in new slots, 132 reinstalls, 2 uninstalls), Size of downloads: 1,132,501 KiB
Conflict: 4 blocks

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge) conflicts with
    ~dev-qt/qtgui-4.8.5[accessibility,-aqua,-debug,qt3support] required by (dev-qt/qt3support-4.8.5:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                       
    ~dev-qt/qtgui-4.8.5[-aqua,-debug] required by (dev-qt/designer-4.8.5:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^             
    ~dev-qt/qtgui-4.8.5[-aqua,-debug,-egl,qt3support] required by (dev-qt/qtopengl-4.8.5:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                             
    ~dev-qt/qtgui-4.8.5[accessibility,-aqua,-debug,qt3support] required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                       
    ~dev-qt/qtgui-4.8.5[-aqua,-debug,glib,qt3support] required by (dev-qt/qtcore-4.8.5-r2:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                             
    ~dev-qt/qtgui-4.8.5[accessibility,-aqua,-debug] required by (dev-qt/qtsvg-4.8.5:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                           


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

dev-qt/qtcore:4
dev-qt/qtdbus:4
dev-qt/qtwebkit:4



hab sämtliche qt-* und skype Pakete deinstalliert und bekomme die Blocks nicht weg. Das einzige KDE Paket, was ich nutze ist amarok.
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Apr 21, 2015 12:53 am    Post subject: Reply with quote

world update hat vorgeschlagen, dass ich

Code:

=dev-qt/qtcore-4.8.6-r1 ~amd64
=dev-qt/qtdbus-4.8.6-r1 ~amd64
=dev-qt/qttranslations-4.8.6-r1 ~amd64
=dev-qt/qtchooser-0_p20150102 ~amd64
=dev-qt/qtgui-4.8.6-r2 ~amd64
=dev-qt/qtwebkit-4.8.6-r1 ~amd64
=dev-qt/qtxmlpatterns-4.8.6-r1 ~amd64
=dev-qt/qt3support-4.8.6-r1 ~amd64
=dev-qt/qtsql-4.8.6-r1 ~amd64
=dev-qt/qtscript-4.8.6-r1 ~amd64



in package.accept_keywords hinzufügen müsste. Hab erstmal es nicht getan und skype deinstalliert, dann waren alle Blocks weg und konnte word update ausführen. Wenn ich aber skype haben will, bekomme ich dann

Code:

emerge net-im/skype -pv
!!! SYNC setting found in make.conf.
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf
 * WARNING: The FEATURES variable contains one or more values that
 * should be disabled under normal circumstances: keepwork

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/lcms-2.6-r1:2::gentoo  USE="jpeg threads tiff zlib -doc -static-libs {-test}" ABI_X86="32* (64) (-x32)" 4,476 KiB
[ebuild   R    ] media-libs/libmng-2.0.2-r1:0/2::gentoo  USE="lcms -static-libs" ABI_X86="32* (64) (-x32)" 930 KiB
[ebuild   R    ] x11-proto/scrnsaverproto-1.2.2-r1::gentoo  USE="-doc" ABI_X86="32* (64) (-x32)" 117 KiB
[ebuild   R    ] x11-libs/libXScrnSaver-1.2.2-r1::gentoo  USE="-static-libs" ABI_X86="32* (64) (-x32)" 284 KiB
[ebuild  N    ~] dev-qt/qtchooser-0_p20150102::gentoo  USE="-qt5 {-test}" 31 KiB
[ebuild     U ~] dev-qt/qtcore-4.8.6-r1:4::gentoo [4.8.5-r2:4::gentoo] USE="exceptions glib iconv qt3support ssl (-aqua) -debug -icu -pch" ABI_X86="32%* (64%*) (-x32)" 235,961 KiB
[ebuild  N    ~] dev-qt/qttranslations-4.8.6-r1:4::gentoo  ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qtscript-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions iconv jit (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qtgui-4.8.6-r2:4::gentoo [4.8.5-r4:4::gentoo] USE="accessibility cups exceptions glib mng qt3support tiff xv (-aqua) -debug -egl -gtkstyle -nas -nis -pch -trace -xinerama" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qtsql-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions qt3support sqlite (-aqua) -debug -freetds -mysql* -oci8 -odbc -pch -postgres (-firebird%)" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qt3support-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="accessibility exceptions (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qtdbus-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtdbus-4.8.6:4 ("<dev-qt/qtdbus-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U ~] dev-qt/qtxmlpatterns-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="(-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qtwebkit-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions gstreamer jit (-aqua) -debug -icu -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtwebkit-4.8.6:4 ("<dev-qt/qtwebkit-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild  N    ~] media-sound/apulse-0.1.4::gentoo  ABI_X86="32 (64) (-x32)" 98 KiB
[ebuild  N    ~] net-im/skype-4.3.0.37-r5::gentoo  USE="apulse -pax_kernel -pulseaudio (-selinux)" 18,859 KiB
[blocks B      ] <dev-qt/qtscript-4.8.6:4 ("<dev-qt/qtscript-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtsvg-4.8.6:4 ("<dev-qt/qtsvg-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] media-plugins/alsa-plugins[pulseaudio] ("media-plugins/alsa-plugins[pulseaudio]" is hard blocking media-sound/apulse-0.1.4)
[blocks B      ] <dev-qt/qttest-4.8.6:4 ("<dev-qt/qttest-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/designer-4.8.6:4 ("<dev-qt/designer-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtdeclarative-4.8.6:4 ("<dev-qt/qtdeclarative-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qt3support-4.8.6:4 ("<dev-qt/qt3support-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtopengl-4.8.6:4 ("<dev-qt/qtopengl-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtxmlpatterns-4.8.6:4 ("<dev-qt/qtxmlpatterns-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtcore-4.8.6:4 ("<dev-qt/qtcore-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtsql-4.8.6:4 ("<dev-qt/qtsql-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtgui-4.8.6:4 ("<dev-qt/qtgui-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)

Total: 16 packages (8 upgrades, 4 new, 4 reinstalls), Size of downloads: 260,752 KiB
Conflict: 14 blocks (12 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtgui:4[accessibility,abi_x86_32(-)] required by (net-im/skype-4.3.0.37-r5:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                               
    ~dev-qt/qtgui-4.8.6[aqua=,debug=,glib=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                                 
    (and 2 more with the same problems)

  (dev-qt/qtgui-4.8.5-r4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtgui-4.8.5[accessibility=,aqua=,debug=,qt3support=] required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                                               
    (and 5 more with the same problem)

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^                                                                                                                                                                                                                                                                                                               

  (dev-qt/qt3support-4.8.5:4/4::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5-r4:4/4::gentoo, installed)
    ^                  ^^^^^                                                                                                                               
    (and 2 more with the same problem)

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtsql-4.8.6[aqua=,debug=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                               

  (dev-qt/qtsql-4.8.5:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.5[aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.5:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                             
    (and 1 more with the same problem)

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtcore:4[abi_x86_32(-)] required by (net-im/skype-4.3.0.37-r5:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                 
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                                           
    (and 7 more with the same problems)

  (dev-qt/qtcore-4.8.5-r2:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.5[aqua=,debug=] required by (dev-qt/qtxmlpatterns-4.8.5:4/4::gentoo, installed)
    ^              ^^^^^                                                                                                                                     
    (and 9 more with the same problem)

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge)
    ^                ^^^^^                                                                                                                                                                                                                                                                                                               

  (dev-qt/qtscript-4.8.5:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.5[aqua=,debug=] required by (dev-qt/designer-4.8.5:4/4::gentoo, installed)
    ^                ^^^^^                                                                                                                               
    (and 2 more with the same problem)

dev-qt/qtxmlpatterns:4

  (dev-qt/qtxmlpatterns-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                                                                                                                                                                                                   

  (dev-qt/qtxmlpatterns-4.8.5:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtxmlpatterns-4.8.5[aqua=,debug=] required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed)
    ^                     ^^^^^                                                                                                                                     


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-qt/qtsvg-4.8.5:4/4::gentoo, installed) pulled in by
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kde-l10n-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kglobalaccel-4.14.3:4/4.14::gentoo, installed)
    dev-qt/qtsvg:4 required by (x11-libs/qtscriptgenerator-0.2.0:0/0::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (sys-auth/polkit-kde-agent-0.99.1-r1:4/4::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kdesu-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kdelibs-4.14.3-r1:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kdebase-kioslaves-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/phonon-kde-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/audiocd-kio-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/libkcddb-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/katepart-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/libkexiv2-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/khelpcenter-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/libkcompactdisc-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kdialog-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/okular-4.14.3:4/4.14::gentoo, installed)
    ~dev-qt/qtsvg-4.8.5[accessibility=,aqua=,debug=] (~dev-qt/qtsvg-4.8.5[accessibility,-aqua,-debug]) required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed)

  (dev-qt/qtopengl-4.8.5:4/4::gentoo, installed) pulled in by
    >=dev-qt/qtopengl-4.8.5:4 required by (kde-base/kdelibs-4.14.3-r1:4/4.14::gentoo, installed)
    >=dev-qt/qtopengl-4.8.5:4 required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)
    dev-qt/qtopengl:4 required by (app-emulation/virtualbox-4.3.18:0/0::gentoo, installed)
    dev-qt/qtopengl:4 required by (x11-libs/qtscriptgenerator-0.2.0:0/0::gentoo, installed)
    dev-qt/qtopengl:4 required by (media-libs/phonon-gstreamer-4.7.2:0/0::gentoo, installed)
    ~dev-qt/qtopengl-4.8.5[aqua=,debug=,qt3support=] (~dev-qt/qtopengl-4.8.5[-aqua,-debug,qt3support]) required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed)

  (dev-qt/qtchooser-0_p20150102:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtchooser required by (dev-qt/qtdbus-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qttranslations-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtxmlpatterns-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtscript-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtgui-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)

  (dev-qt/designer-4.8.5:4/4::gentoo, installed) pulled in by
    >=dev-qt/designer-4.8.5:4 required by (kde-base/libkexiv2-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/audiocd-kio-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kdelibs-4.14.3-r1:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/katepart-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/libkcompactdisc-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/khelpcenter-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/phonon-kde-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kdialog-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/okular-4.14.3:4/4.14::gentoo, installed)
    dev-qt/designer:4 required by (x11-libs/qtscriptgenerator-0.2.0:0/0::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kde-l10n-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kglobalaccel-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kdesu-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kdebase-kioslaves-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (sys-auth/polkit-kde-agent-0.99.1-r1:4/4::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/libkcddb-4.14.3:4/4.14::gentoo, installed)

  (media-sound/apulse-0.1.4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    media-sound/apulse[abi_x86_32(-)] required by (net-im/skype-4.3.0.37-r5:0/0::gentoo, ebuild scheduled for merge)

  (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed) pulled in by
    >=dev-qt/qtdeclarative-4.8.5:4 required by (kde-base/kdelibs-4.14.3-r1:4/4.14::gentoo, installed)

  (media-plugins/alsa-plugins-1.0.28:0/0::gentoo, installed) pulled in by
    media-plugins/alsa-plugins required by @selected
    >=media-plugins/alsa-plugins-1.0.27-r1[pulseaudio] required by (media-sound/pulseaudio-5.0-r7:0/0::gentoo, installed)

  (dev-qt/qttest-4.8.5:4/4::gentoo, installed) pulled in by
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/libkexiv2-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/katepart-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/libkcompactdisc-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/audiocd-kio-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/khelpcenter-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/okular-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/libkcddb-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kdelibs-4.14.3-r1:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kdebase-kioslaves-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kglobalaccel-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kdesu-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (sys-auth/polkit-kde-agent-0.99.1-r1:4/4::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/phonon-kde-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kdialog-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kde-l10n-4.14.3:4/4.14::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-qt/qttranslations-4.8.6-r1::gentoo
=dev-qt/qtcore-4.8.6-r1 ~amd64
# required by app-i18n/ibus-qt-1.3.1::gentoo
# required by @selected
# required by @world (argument)
=dev-qt/qtdbus-4.8.6-r1 ~amd64
# required by dev-qt/qtcore-4.8.6-r1::gentoo
# required by dev-qt/qtwebkit-4.8.6-r1::gentoo
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
=dev-qt/qttranslations-4.8.6-r1 ~amd64
# required by dev-qt/qtcore-4.8.6-r1::gentoo
# required by dev-qt/qttranslations-4.8.6-r1::gentoo
=dev-qt/qtchooser-0_p20150102 ~amd64
# required by dev-qt/qt3support-4.8.6-r1::gentoo
# required by kde-base/kde-l10n-4.14.3::gentoo
# required by sys-auth/polkit-kde-agent-0.99.1-r1::gentoo[linguas_en_GB]
# required by kde-base/kdelibs-4.14.3-r1::gentoo[policykit]
# required by kde-base/kdebase-kioslaves-4.14.3::gentoo
# required by media-sound/amarok-2.8.0-r3::gentoo
# required by @selected
# required by @world (argument)
=dev-qt/qtgui-4.8.6-r2 ~amd64
# required by kde-base/okular-4.14.3::gentoo
# required by @selected
# required by @world (argument)
=dev-qt/qtwebkit-4.8.6-r1 ~amd64
# required by net-im/skype (argument)
=net-im/skype-4.3.0.37-r5 ~amd64
# required by net-im/skype-4.3.0.37-r5::gentoo[apulse]
# required by net-im/skype (argument)
=media-sound/apulse-0.1.4 ~amd64
# required by dev-qt/qtwebkit-4.8.6-r1::gentoo
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
=dev-qt/qtxmlpatterns-4.8.6-r1 ~amd64
# required by dev-qt/qtgui-4.8.6-r2::gentoo[qt3support]
# required by dev-qt/qtwebkit-4.8.6-r1::gentoo
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
=dev-qt/qt3support-4.8.6-r1 ~amd64
# required by dev-qt/qt3support-4.8.6-r1::gentoo
# required by dev-qt/qtgui-4.8.6-r2::gentoo[qt3support]
# required by dev-qt/qtwebkit-4.8.6-r1::gentoo
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
=dev-qt/qtsql-4.8.6-r1 ~amd64
# required by dev-qt/qtgui-4.8.6-r2::gentoo
# required by dev-qt/qtwebkit-4.8.6-r1::gentoo
# required by net-im/skype-4.3.0.37-r5::gentoo
# required by net-im/skype (argument)
=dev-qt/qtscript-4.8.6-r1 ~amd64


also nochmal diesselben Blocks. Das ist nicht normal, dass stable skype so viele unstable Pakete will, oder?
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
__bjoern
n00b
n00b


Joined: 12 Oct 2014
Posts: 26

PostPosted: Tue Apr 21, 2015 1:14 am    Post subject: Reply with quote

Hi,

das liegt daran, dass die emul-linux-x86-* Pakete letztens gemasked wurden. Darum will portage das ABI_X86 USE-flag setzen, jedoch ist dieses bei der aktuellen stable-Version von Qt noch nicht vorhanden. Darum will er die Qt unstable Version reinziehen. Dies kann allerdings zu einem ganz schönen Chaos auf dem System führen. Darum meine Empfehlung: die emul-linux-x86-* Pakete unmasken, bis die neue Qt Version in stable ist.

Also:

/etc/portage/package.unmask
Code:

app-emulation/emul-linux-x86-*


und dann sollte das world update keine Probleme mehr machen.
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Apr 21, 2015 9:06 am    Post subject: Reply with quote

danke, ich werde es heute Abend ausprobieren. Sobald ich versuche skype zu installiere, bekomme ich diese Blocker. Blöd ist nur, dass ich skype deinstallieren musste und ich brauche es :(
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Tue Apr 21, 2015 11:42 am    Post subject: Reply with quote

pablo_supertux wrote:
[...] also nochmal diesselben Blocks. Das ist nicht normal, dass stable skype so viele unstable Pakete will, oder?

Hehe, es gibt zZt kein stable skype im Tree.

Ich würde davon abraten sich die alten, nun ungepflegten toten, inzwischen hart maskierten app-emulation/emul-linux-x86-* Pakete freizuschalten.
Zudem werden sie in kürze wahrscheinlich eh aus dem Tree entfernt - darauf würde ich nicht mehr aufbauen.

Baue dir die von skype benötigten 32 Bit Qt Libs doch besser selbst - sie sind doch im Tree verfügbar :)
Zum freischalten siehe zb den Tipp im https://forums.gentoo.org/viewtopic-p-7730838.html#7730838
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Apr 21, 2015 7:55 pm    Post subject: Reply with quote

Josef.95 wrote:

Ich würde davon abraten sich die alten, nun ungepflegten toten, inzwischen hart maskierten app-emulation/emul-linux-x86-* Pakete freizuschalten.
Zudem werden sie in kürze wahrscheinlich eh aus dem Tree entfernt - darauf würde ich nicht mehr aufbauen.


ja, ich hätte mir 32libs für qt selber gebaut aber dann habe ich eine bessere Idee gehabt:

Code:

mkdir /opt/skype-multilib-noemul
cd /opt/skype-multilib-noemul
wget http://download.skype.com/linux/skype-4.3.0.37.tar.bz2
wget http://dev.gentoo.org/~pacho/emul/emul-linux-x86-qtlibs-20140508.tar.xz

tar xpjf skype-4.3.0.37.tar.bz2
tar xpJf emul-linux-x86-qtlibs-20140508.tar.xz

cd /usr/bin/

vim skype

#!/bin/bash
# hack by pablo

cd /opt/skype-multilib-noemul/skype-4.3.0.37
LD_LIBRARY_PATH=../usr/lib32/qt4 exec ./skype


Damit muss ich die emul-linux-* nicht unmaskieren und eine Abhängigkeitshölle schaffen und kann skype so lange nutzen, bis das dev team multilib support für qt implementiert und ich dann über portage neu installieren kann.
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Tue Apr 21, 2015 8:12 pm    Post subject: Reply with quote

Hehe, True Qt Multilib-Support ist doch nun im Tree (ab qt-4.8.6) verfügbar :)
Ich verstehe nicht warum ihr ihn nicht nutzt...
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4459

PostPosted: Tue Apr 21, 2015 8:14 pm    Post subject: Reply with quote

pablo_supertux wrote:


Damit muss ich die emul-linux-* nicht unmaskieren und eine Abhängigkeitshölle schaffen und kann skype so lange nutzen, bis das dev team multilib support für qt implementiert und ich dann über portage neu installieren kann.

Öhm zu mindestens für Qt4 ist multilib (ABI_X86) support vorhanden (wenn auch nur für die Qt 4.8.6 version)
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Apr 21, 2015 8:36 pm    Post subject: Reply with quote

weil ich im Moment wo ich in package.accept_keywords sowas eingebe wie =dev-qt/qtcore-4.8.6-r1 oder dev-qt/*:4, bekomme ich ein Haufen blocks wie

Code:

[blocks B      ] <dev-qt/qtsvg-4.8.6:4 ("<dev-qt/qtsvg-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtscript-4.8.6:4 ("<dev-qt/qtscript-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtwebkit-4.8.6:4 ("<dev-qt/qtwebkit-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtxmlpatterns-4.8.6:4 ("<dev-qt/qtxmlpatterns-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtdbus-4.8.6:4 ("<dev-qt/qtdbus-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qttest-4.8.6:4 ("<dev-qt/qttest-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/designer-4.8.6:4 ("<dev-qt/designer-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtdeclarative-4.8.6:4 ("<dev-qt/qtdeclarative-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qt3support-4.8.6:4 ("<dev-qt/qt3support-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtopengl-4.8.6:4 ("<dev-qt/qtopengl-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtcore-4.8.6:4 ("<dev-qt/qtcore-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtsql-4.8.6:4 ("<dev-qt/qtsql-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtgui-4.8.6:4 ("<dev-qt/qtgui-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-4.8.6[aqua=,debug=,glib=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                                 
    (and 1 more with the same problem)

  (dev-qt/qtgui-4.8.5-r4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtgui-4.8.5[accessibility=,aqua=,debug=,qt3support=] required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                                               
    (and 6 more with the same problem)

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^                                                                                                                                                                                                                     
...


und ich habe keine Lust diese Blocks zu lösen, indem ich ein Haufen Pakete in package.accept_keywords hinzufüge. Ich würde gerne so wenig unstable Pakete wie möglich nutzen.
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Tue Apr 21, 2015 10:09 pm    Post subject: Reply with quote

Hm nein, dann machst du was falsch.
Der Vorschlag aus https://forums.gentoo.org/viewtopic-p-7730838.html#7730838
sollte gut und problemlos funktionieren (tut es bei den anderen Leuten doch auch).
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Apr 21, 2015 11:03 pm    Post subject: Reply with quote

meinst du das?

Josef.95 wrote:
fbcyborg,
package.accept_keywords:
dev-qt/*:4
should work. (Please remove this if >=Qt-4.8.6 stable is available)
And if you need multilib support
package.use:
dev-qt/*:4 abi_x86_32


Das habe ich gerade ausprobiert,

in package.accept_keywords:

Code:

dev-qt/*:4
net-im/skype
=dev-qt/qtchooser-0_p20150102 ~amd64


und in package.use (wobei ich abi_x86_32 bereits global in USE bei make.conf gesetzt habe)
Code:

dev-qt/*:4 abi_x86_32



Ich bekomme:
Code:

Calculating dependencies... done!
[ebuild  N    ~] dev-qt/qtchooser-0_p20150102::gentoo  USE="-qt5 {-test}" 31 KiB
[ebuild     U ~] dev-qt/qtcore-4.8.6-r1:4::gentoo [4.8.5-r2:4::gentoo] USE="exceptions glib iconv qt3support ssl (-aqua) -debug -icu -pch" ABI_X86="32%* (64%*) (-x32)" 235,961 KiB
[ebuild  N    ~] dev-qt/qttranslations-4.8.6-r1:4::gentoo  ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qtscript-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions iconv jit (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qtgui-4.8.6-r2:4::gentoo [4.8.5-r4:4::gentoo] USE="accessibility cups exceptions glib mng qt3support tiff xv (-aqua) -debug -egl -gtkstyle -nas -nis -pch -trace -xinerama" ABI_X86="32%* (64%*) (-x32)" 51 KiB
[ebuild     U ~] dev-qt/qtsql-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions qt3support sqlite (-aqua) -debug -freetds -mysql* -oci8 -odbc -pch -postgres (-firebird%)" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qt3support-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="accessibility exceptions (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qtdbus-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtdbus-4.8.6:4 ("<dev-qt/qtdbus-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U ~] dev-qt/qtxmlpatterns-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="(-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qtwebkit-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions gstreamer jit (-aqua) -debug -icu -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtwebkit-4.8.6:4 ("<dev-qt/qtwebkit-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild  N    ~] net-im/skype-4.3.0.37-r5::gentoo  USE="pulseaudio -apulse -pax_kernel (-selinux)" 18,859 KiB
[blocks B      ] <dev-qt/qtscript-4.8.6:4 ("<dev-qt/qtscript-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtsvg-4.8.6:4 ("<dev-qt/qtsvg-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtxmlpatterns-4.8.6:4 ("<dev-qt/qtxmlpatterns-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qttest-4.8.6:4 ("<dev-qt/qttest-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/designer-4.8.6:4 ("<dev-qt/designer-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtdeclarative-4.8.6:4 ("<dev-qt/qtdeclarative-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qt3support-4.8.6:4 ("<dev-qt/qt3support-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtopengl-4.8.6:4 ("<dev-qt/qtopengl-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtcore-4.8.6:4 ("<dev-qt/qtcore-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtsql-4.8.6:4 ("<dev-qt/qtsql-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtgui-4.8.6:4 ("<dev-qt/qtgui-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)

Total: 11 packages (8 upgrades, 3 new), Size of downloads: 254,900 KiB
Conflict: 13 blocks (11 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtgui:4[accessibility,abi_x86_32(-)] required by (net-im/skype-4.3.0.37-r5:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                               
    ~dev-qt/qtgui-4.8.6[aqua=,debug=,glib=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                                 
    (and 2 more with the same problems)

  (dev-qt/qtgui-4.8.5-r4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtgui-4.8.5[accessibility=,aqua=,debug=,qt3support=] required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                                               
    (and 5 more with the same problem)

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^                                                                                                                                                                                                                                                                                                               

  (dev-qt/qt3support-4.8.5:4/4::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5-r4:4/4::gentoo, installed)
    ^                  ^^^^^                                                                                                                               
    (and 2 more with the same problem)

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtsql-4.8.6[aqua=,debug=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                               

  (dev-qt/qtsql-4.8.5:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.5[aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.5:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                             
    (and 1 more with the same problem)

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtcore:4[abi_x86_32(-)] required by (net-im/skype-4.3.0.37-r5:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                 
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                                           
    (and 7 more with the same problems)

  (dev-qt/qtcore-4.8.5-r2:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.5[aqua=,debug=] required by (dev-qt/qtxmlpatterns-4.8.5:4/4::gentoo, installed)
    ^              ^^^^^                                                                                                                                     
    (and 9 more with the same problem)

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge)
    ^                ^^^^^                                                                                                                                                                                                                                                                                                               

  (dev-qt/qtscript-4.8.5:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.5[aqua=,debug=] required by (dev-qt/designer-4.8.5:4/4::gentoo, installed)
    ^                ^^^^^                                                                                                                               
    (and 2 more with the same problem)

dev-qt/qtxmlpatterns:4

  (dev-qt/qtxmlpatterns-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                                                                                                                                                                                                   

  (dev-qt/qtxmlpatterns-4.8.5:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtxmlpatterns-4.8.5[aqua=,debug=] required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed)
    ^                     ^^^^^                                                                                                                                     


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-qt/qtsvg-4.8.5:4/4::gentoo, installed) pulled in by
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kde-l10n-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kglobalaccel-4.14.3:4/4.14::gentoo, installed)
    dev-qt/qtsvg:4 required by (x11-libs/qtscriptgenerator-0.2.0:0/0::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (sys-auth/polkit-kde-agent-0.99.1-r1:4/4::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kdesu-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/okular-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kdebase-kioslaves-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kdelibs-4.14.3-r1:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/audiocd-kio-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/libkcddb-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/katepart-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/libkexiv2-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/khelpcenter-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/libkcompactdisc-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kdialog-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/phonon-kde-4.14.3:4/4.14::gentoo, installed)
    ~dev-qt/qtsvg-4.8.5[accessibility=,aqua=,debug=] (~dev-qt/qtsvg-4.8.5[accessibility,-aqua,-debug]) required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed)

  (dev-qt/qtopengl-4.8.5:4/4::gentoo, installed) pulled in by
    >=dev-qt/qtopengl-4.8.5:4 required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)
    >=dev-qt/qtopengl-4.8.5:4 required by (kde-base/kdelibs-4.14.3-r1:4/4.14::gentoo, installed)
    dev-qt/qtopengl:4 required by (app-emulation/virtualbox-4.3.18:0/0::gentoo, installed)
    dev-qt/qtopengl:4 required by (x11-libs/qtscriptgenerator-0.2.0:0/0::gentoo, installed)
    dev-qt/qtopengl:4 required by (media-libs/phonon-gstreamer-4.7.2:0/0::gentoo, installed)
    ~dev-qt/qtopengl-4.8.5[aqua=,debug=,qt3support=] (~dev-qt/qtopengl-4.8.5[-aqua,-debug,qt3support]) required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed)

  (dev-qt/qtchooser-0_p20150102:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtchooser required by (dev-qt/qtdbus-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qttranslations-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtxmlpatterns-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtscript-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtgui-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)

  (dev-qt/designer-4.8.5:4/4::gentoo, installed) pulled in by
    >=dev-qt/designer-4.8.5:4 required by (kde-base/libkexiv2-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/audiocd-kio-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kdelibs-4.14.3-r1:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/katepart-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/libkcompactdisc-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/khelpcenter-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/phonon-kde-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kdialog-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/okular-4.14.3:4/4.14::gentoo, installed)
    dev-qt/designer:4 required by (x11-libs/qtscriptgenerator-0.2.0:0/0::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kde-l10n-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kglobalaccel-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kdesu-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kdebase-kioslaves-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (sys-auth/polkit-kde-agent-0.99.1-r1:4/4::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/libkcddb-4.14.3:4/4.14::gentoo, installed)

  (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed) pulled in by
    >=dev-qt/qtdeclarative-4.8.5:4 required by (kde-base/kdelibs-4.14.3-r1:4/4.14::gentoo, installed)

  (dev-qt/qttest-4.8.5:4/4::gentoo, installed) pulled in by
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/libkexiv2-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/katepart-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/libkcompactdisc-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/audiocd-kio-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/khelpcenter-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/okular-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/libkcddb-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kdelibs-4.14.3-r1:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kdebase-kioslaves-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kglobalaccel-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kdesu-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (sys-auth/polkit-kde-agent-0.99.1-r1:4/4::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/phonon-kde-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kdialog-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kde-l10n-4.14.3:4/4.14::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Ich weiß nach wie vor nicht, was ich falsch mache :?
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Wed Apr 22, 2015 12:10 am    Post subject: Reply with quote

Hm, magst du bitte noch das abgegebene emerge Kommando mit dazu posten?
Gehst du direkt via "emerge skype" drauf los, oder woher stammt die obige Ausgabe?
Ich denke via "emerge -avuDN world" sollte portage am besten auflösen können.
Versuche auch mal mit der von emerge mit empfohlen --backtrack Option,
nimm am besten gleich --backtrack=100

Ich würde versuchen zunächst die schon installierten qt Pakete zu aktualisieren (zb via dem vorgeschlagenen -uDN world Update), und erst danach skype (und deren ggf weiteren Deps) zu installieren.
/edit: Und achte bitte darauf das eine aktuelle portage Version (2.2.18 ist aktuell frisch stable) verwendet wird.
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Wed Apr 22, 2015 12:44 am    Post subject: Reply with quote

da ich skype deinstallieren musste, war der Befehl emerge skype -pv

so, hab nochmal mit anderen Optionen versucht:

Code:

$ emerge skype -pvDt --backtrack=100

These are the packages that would be merged, in order:


Calculating dependencies... done!
[ebuild  N    ~] net-im/skype-4.3.0.37-r5::gentoo  USE="pulseaudio -apulse -pax_kernel (-selinux)" 18,859 KiB
[nomerge       ] dev-qt/qtcore-4.8.6-r1:4::gentoo [4.8.5-r2:4::gentoo] USE="exceptions glib iconv qt3support ssl (-aqua) -debug -icu -pch" ABI_X86="32%* (64%*) (-x32)"
[nomerge       ]  dev-qt/qtchooser-0_p20150102::gentoo  USE="-qt5 {-test}"
[blocks b      ]   <dev-qt/qtwebkit-4.8.6:4 ("<dev-qt/qtwebkit-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U ~]    dev-qt/qtwebkit-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions gstreamer jit (-aqua) -debug -icu -pch" ABI_X86="32%* (64%*) (-x32)" 235,961 KiB
[ebuild     U ~]     dev-qt/qtxmlpatterns-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="(-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks b      ]   <dev-qt/qtdbus-4.8.6:4 ("<dev-qt/qtdbus-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U ~]    dev-qt/qtdbus-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[nomerge       ] kde-base/libkcompactdisc-4.14.3:4/4.14::gentoo  USE="alsa (-aqua) -debug"
[nomerge       ]  dev-qt/qtwebkit-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions gstreamer jit (-aqua) -debug -icu -pch" ABI_X86="32%* (64%*) (-x32)"
[nomerge       ]   dev-qt/qtgui-4.8.6-r2:4::gentoo [4.8.5-r4:4::gentoo] USE="accessibility cups exceptions glib mng qt3support tiff xv (-aqua) -debug -egl -gtkstyle -nas -nis -pch -trace -xinerama" ABI_X86="32%* (64%*) (-x32)"
[ebuild     U ~]    dev-qt/qt3support-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="accessibility exceptions (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[ebuild     U ~]     dev-qt/qtsql-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions qt3support sqlite (-aqua) -debug -freetds -mysql* -oci8 -odbc -pch -postgres (-firebird%)" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[ebuild     U ~]     dev-qt/qtgui-4.8.6-r2:4::gentoo [4.8.5-r4:4::gentoo] USE="accessibility cups exceptions glib mng qt3support tiff xv (-aqua) -debug -egl -gtkstyle -nas -nis -pch -trace -xinerama" ABI_X86="32%* (64%*) (-x32)" 51 KiB
[ebuild     U ~]      dev-qt/qtscript-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions iconv jit (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[nomerge       ] dev-qt/qtcore-4.8.6-r1:4::gentoo [4.8.5-r2:4::gentoo] USE="exceptions glib iconv qt3support ssl (-aqua) -debug -icu -pch" ABI_X86="32%* (64%*) (-x32)"
[ebuild  N    ~]  dev-qt/qttranslations-4.8.6-r1:4::gentoo  ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U ~]   dev-qt/qtcore-4.8.6-r1:4::gentoo [4.8.5-r2:4::gentoo] USE="exceptions glib iconv qt3support ssl (-aqua) -debug -icu -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[ebuild  N    ~]    dev-qt/qtchooser-0_p20150102::gentoo  USE="-qt5 {-test}" 31 KiB
[blocks B      ] dev-qt/qttranslations:4 ("dev-qt/qttranslations:4" is blocking dev-qt/qtcore-4.8.5-r2)
[blocks B      ] <dev-qt/qtsql-4.8.6:4 ("<dev-qt/qtsql-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtgui-4.8.6:4 ("<dev-qt/qtgui-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtcore-4.8.6:4 ("<dev-qt/qtcore-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtopengl-4.8.6:4 ("<dev-qt/qtopengl-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qt3support-4.8.6:4 ("<dev-qt/qt3support-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtdeclarative-4.8.6:4 ("<dev-qt/qtdeclarative-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/designer-4.8.6:4 ("<dev-qt/designer-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qttest-4.8.6:4 ("<dev-qt/qttest-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtxmlpatterns-4.8.6:4 ("<dev-qt/qtxmlpatterns-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtsvg-4.8.6:4 ("<dev-qt/qtsvg-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <dev-qt/qtscript-4.8.6:4 ("<dev-qt/qtscript-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)

Total: 11 packages (8 upgrades, 3 new), Size of downloads: 254,900 KiB
Conflict: 14 blocks (12 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.5-r4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtgui-4.8.5[accessibility=,aqua=,debug=,qt3support=] required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                                               
    (and 5 more with the same problem)

  (dev-qt/qtgui-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtgui:4[accessibility,abi_x86_32(-)] required by (net-im/skype-4.3.0.37-r5:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                               
    ~dev-qt/qtgui-4.8.6[aqua=,debug=,glib=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                                 
    (and 2 more with the same problems)

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.5-r2:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.5[aqua=,debug=] required by (dev-qt/qtxmlpatterns-4.8.5:4/4::gentoo, installed)
    ^              ^^^^^                                                                                                                                     
    (and 9 more with the same problem)

  (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtcore:4[abi_x86_32(-)] required by (net-im/skype-4.3.0.37-r5:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                 
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                                           
    (and 7 more with the same problems)

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.5:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.5[aqua=,debug=] required by (dev-qt/designer-4.8.5:4/4::gentoo, installed)
    ^                ^^^^^                                                                                                                               
    (and 2 more with the same problem)

  (dev-qt/qtscript-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge)
    ^                ^^^^^                                                                                                                                                                                                                                                                                                               

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.5:4/4::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5-r4:4/4::gentoo, installed)
    ^                  ^^^^^                                                                                                                               
    (and 2 more with the same problem)

  (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^                                                                                                                                                                                                                                                                                                               

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.5:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.5[aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.5:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                             
    (and 1 more with the same problem)

  (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtsql-4.8.6[aqua=,debug=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                               

dev-qt/qtxmlpatterns:4

  (dev-qt/qtxmlpatterns-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-4.8.6[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                                                                                                                                                                                                   

  (dev-qt/qtxmlpatterns-4.8.5:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtxmlpatterns-4.8.5[aqua=,debug=] required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed)
    ^                     ^^^^^                                                                                                                                     


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-qt/qtsvg-4.8.5:4/4::gentoo, installed) pulled in by
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kde-l10n-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kglobalaccel-4.14.3:4/4.14::gentoo, installed)
    dev-qt/qtsvg:4 required by (x11-libs/qtscriptgenerator-0.2.0:0/0::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (sys-auth/polkit-kde-agent-0.99.1-r1:4/4::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kdesu-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/okular-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kdebase-kioslaves-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kdelibs-4.14.3-r1:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/audiocd-kio-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/libkcddb-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/katepart-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/libkexiv2-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/khelpcenter-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/libkcompactdisc-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/kdialog-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)
    >=dev-qt/qtsvg-4.8.5:4 required by (kde-base/phonon-kde-4.14.3:4/4.14::gentoo, installed)
    ~dev-qt/qtsvg-4.8.5[accessibility=,aqua=,debug=] (~dev-qt/qtsvg-4.8.5[accessibility,-aqua,-debug]) required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed)

  (dev-qt/qtopengl-4.8.5:4/4::gentoo, installed) pulled in by
    >=dev-qt/qtopengl-4.8.5:4 required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)
    >=dev-qt/qtopengl-4.8.5:4 required by (kde-base/kdelibs-4.14.3-r1:4/4.14::gentoo, installed)
    dev-qt/qtopengl:4 required by (app-emulation/virtualbox-4.3.18:0/0::gentoo, installed)
    dev-qt/qtopengl:4 required by (x11-libs/qtscriptgenerator-0.2.0:0/0::gentoo, installed)
    dev-qt/qtopengl:4 required by (media-libs/phonon-gstreamer-4.7.2:0/0::gentoo, installed)
    ~dev-qt/qtopengl-4.8.5[aqua=,debug=,qt3support=] (~dev-qt/qtopengl-4.8.5[-aqua,-debug,qt3support]) required by (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed)

  (dev-qt/qttranslations-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttranslations-4.8.6 required by (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)

  (dev-qt/qtchooser-0_p20150102:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtchooser required by (dev-qt/qtdbus-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtxmlpatterns-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtscript-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtgui-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtcore-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)
    dev-qt/qtchooser required by (dev-qt/qttranslations-4.8.6-r1:4/4::gentoo, ebuild scheduled for merge)

  (dev-qt/designer-4.8.5:4/4::gentoo, installed) pulled in by
    >=dev-qt/designer-4.8.5:4 required by (kde-base/libkexiv2-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/audiocd-kio-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kdelibs-4.14.3-r1:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/katepart-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/libkcompactdisc-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/khelpcenter-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/phonon-kde-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kdialog-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/okular-4.14.3:4/4.14::gentoo, installed)
    dev-qt/designer:4 required by (x11-libs/qtscriptgenerator-0.2.0:0/0::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kde-l10n-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kglobalaccel-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kdesu-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/kdebase-kioslaves-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (sys-auth/polkit-kde-agent-0.99.1-r1:4/4::gentoo, installed)
    >=dev-qt/designer-4.8.5:4 required by (kde-base/libkcddb-4.14.3:4/4.14::gentoo, installed)

  (dev-qt/qtdeclarative-4.8.5:4/4::gentoo, installed) pulled in by
    >=dev-qt/qtdeclarative-4.8.5:4 required by (kde-base/kdelibs-4.14.3-r1:4/4.14::gentoo, installed)

  (dev-qt/qttest-4.8.5:4/4::gentoo, installed) pulled in by
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/libkexiv2-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/katepart-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/libkcompactdisc-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/audiocd-kio-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/khelpcenter-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/okular-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/libkcddb-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kdelibs-4.14.3-r1:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kdebase-kioslaves-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kglobalaccel-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kdesu-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (sys-auth/polkit-kde-agent-0.99.1-r1:4/4::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/phonon-kde-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kdialog-4.14.3:4/4.14::gentoo, installed)
    >=dev-qt/qttest-4.8.5:4 required by (kde-base/kde-l10n-4.14.3:4/4.14::gentoo, installed)




_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Wed Apr 22, 2015 1:03 am    Post subject: Reply with quote

hmmm, siehe da was ein "emerge world skype" machen kann

Code:

emerge -uvpDN world skype

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] dev-qt/qtchooser-0_p20150102::gentoo  USE="-qt5 {-test}" 31 KiB
[ebuild     U ~] dev-qt/qtcore-4.8.6-r1:4::gentoo [4.8.5-r2:4::gentoo] USE="exceptions glib iconv qt3support ssl (-aqua) -debug -icu -pch" ABI_X86="32%* (64%*) (-x32)" 235,961 KiB
[blocks b      ] <dev-qt/qtcore-4.8.6:4 ("<dev-qt/qtcore-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild  N    ~] dev-qt/qttranslations-4.8.6-r1:4::gentoo  ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qtscript-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions iconv jit (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtscript-4.8.6:4 ("<dev-qt/qtscript-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U ~] dev-qt/qtgui-4.8.6-r2:4::gentoo [4.8.5-r4:4::gentoo] USE="accessibility cups exceptions glib mng qt3support tiff xv (-aqua) -debug -egl -gtkstyle -nas -nis -pch -trace -xinerama" ABI_X86="32%* (64%*) (-x32)" 51 KiB
[blocks b      ] <dev-qt/qtgui-4.8.6:4 ("<dev-qt/qtgui-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U ~] dev-qt/qtsql-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions qt3support sqlite (-aqua) -debug -freetds -mysql* -oci8 -odbc -pch -postgres (-firebird%)" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtsql-4.8.6:4 ("<dev-qt/qtsql-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U ~] dev-qt/qt3support-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="accessibility exceptions (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks b      ] <dev-qt/qt3support-4.8.6:4 ("<dev-qt/qt3support-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U ~] dev-qt/qtdbus-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtdbus-4.8.6:4 ("<dev-qt/qtdbus-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U ~] dev-qt/qtsvg-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="accessibility exceptions (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtsvg-4.8.6:4 ("<dev-qt/qtsvg-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U ~] dev-qt/qttest-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions (-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks b      ] <dev-qt/qttest-4.8.6:4 ("<dev-qt/qttest-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U ~] dev-qt/designer-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions qt3support (-aqua) -debug -declarative -kde -pch -phonon -webkit" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks b      ] <dev-qt/designer-4.8.6:4 ("<dev-qt/designer-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U ~] dev-qt/qtopengl-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions qt3support (-aqua) -debug -egl -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtopengl-4.8.6:4 ("<dev-qt/qtopengl-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U ~] dev-qt/qtxmlpatterns-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="(-aqua) -debug -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtxmlpatterns-4.8.6:4 ("<dev-qt/qtxmlpatterns-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U ~] dev-qt/qtwebkit-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions gstreamer jit (-aqua) -debug -icu -pch" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtwebkit-4.8.6:4 ("<dev-qt/qtwebkit-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U ~] dev-qt/qtdeclarative-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="accessibility exceptions qt3support (-aqua) -debug -pch -webkit" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtdeclarative-4.8.6:4 ("<dev-qt/qtdeclarative-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild  N    ~] net-im/skype-4.3.0.37-r5::gentoo  USE="pulseaudio -apulse -pax_kernel (-selinux)" 18,859 KiB

Total: 16 packages (13 upgrades, 3 new), Size of downloads: 254,900 KiB
Conflict: 13 blocks



Wusste nicht, dass man neben world noch andere Pakete eingeben kann, hab ausprobiert und bin überrascht. Hier löst portage die blocks von alleine. Wieso löst es mit "world" und nicht ohne?
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Wed Apr 22, 2015 1:04 am    Post subject: Reply with quote

Lass skype am besten erst mal weg.
Beachte das portage bei dem Update auch die Deps der schon installierten qt Pakete mit auflösen muss.
Versuche mal
Code:
emerge --deselect skype
emerge -avuDN world --backtrack=100
emerge -av skype


/edit
Da haben wir beide gleichzeitig gepostet. Ich denke wichtig war noch das du nun auch --newuse mit hinzugenommen hast.
Prima das es nun klappt :)
gn8
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Wed Apr 22, 2015 1:24 am    Post subject: Reply with quote

Josef.95 wrote:
Lass skype am besten erst mal weg.
Beachte das portage bei dem Update auch die Deps der schon installierten qt Pakete mit auflösen muss.
Versuche mal
Code:
emerge --deselect skype
emerge -avuDN world --backtrack=100
emerge -av skype


/edit
Da haben wir beide gleichzeitig gepostet. Ich denke wichtig war noch das du nun auch --newuse mit hinzugenommen hast.
Prima das es nun klappt :)
gn8


ja, aber ich bin dennoch nicht glückglich, dass ich man ganzes qt in ~amd64 stellen müsste, denn ich will so wenig ~amd64 Pakete wie möglich haben. Deswegen habe ich mich noch nicht entschieden, ob ich dieses Update mache. Ich habe das Gefühl, dass später noch mehr Probleme machen wird, und das alles nur wegen skype. skype ist leider für mich alternativlos, also bin ich mit meinem Hack glückglich. Ich denke, ich werde noch ein kleines bisschen warten bis diese Pakete stable werden.
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum