Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
systemd hanging on boot[solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Sun Mar 29, 2015 11:29 pm    Post subject: systemd hanging on boot[solved] Reply with quote

I'm having trouble starting up my system under system, the boot sequence stops at failed at loading module {autofs,ipv6}

It had always been this way, there is a good chance I'm missing a package or two, I mess around portage alot
here's my journalctl:
http://pastebin.com/1SbPqxKd

I suspect this might be the problem:
Mar 30 00:56:41 localhost kernel: Switched to clocksource tsc
Mar 30 00:57:05 localhost systemd[1]: Failed to register match for Disconnected message: Connection timed out
Mar 30 00:57:05 localhost systemd-logind[145]: Failed to add match for NameOwnerChanged: Connection timed out
Mar 30 00:57:05 localhost systemd-logind[145]: Failed to fully start up daemon: Connection timed out
Mar 30 00:57:30 localhost systemd[1]: Failed to register match for Disconnected message: Connection timed out
Mar 30 00:57:30 localhost systemd[1]: dbus.service: main process exited, code=exited, status=1/FAILURE
Mar 30 00:57:30 localhost systemd[1]: Unit dbus.service entered failed state.
Mar 30 00:57:30 localhost systemd[1]: systemd-logind.service: main process exited, code=exited, status=1/FAILURE
Mar 30 00:57:30 localhost systemd[1]: Failed to start Login Service.
Mar 30 00:57:30 localhost systemd[1]: Unit systemd-logind.service entered failed state.


thanks


Last edited by Adel Ahmed on Thu Apr 02, 2015 11:19 am; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7134
Location: almost Mile High in the USA

PostPosted: Sun Mar 29, 2015 11:44 pm    Post subject: Reply with quote

My guess would be some option in your kernel isn't set properly ... though I'm not sure yet...
Did you replace your kernel recently, and if using gentoo-sources, have the systemd meta-option enabled?

Actually... This error is really bad for systemd:

Code:
Mar 30 00:56:40 localhost dbus-daemon[146]: Failed to start message bus: Could not get UID and GID for username "messagebus"


Maybe you don't have these userid/groupids in your /etc/passwd /etc/group, respectively?

Code:
fujiko $ grep message /etc/passwd
messagebus:x:101:246:added by portage for dbus:/dev/null:/sbin/nologin
fujiko $ grep message /etc/group
messagebus:x:246:
fujiko $


Note: the numeric uid and gid may be different but "messagebus" should exist.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Thu Apr 02, 2015 11:09 am    Post subject: Reply with quote

yup that was it,
thanks alot I can finally boot into my new system
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum