Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problems with 64 GB sdxc
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Sun Mar 29, 2015 11:51 pm    Post subject: problems with 64 GB sdxc Reply with quote

I have bought 2 sdxc cards, kingston and samsung
I have this problem where after a certain amount of data written problems start happening.

I can copy plenty of data and as soon as the card is unmounted the data is missing.
and II get the following errors in dmesg:
Mar 20 21:48:21 b5400 kernel: Result: hostbyte=0x05 driverbyte=0x00
Mar 20 21:48:21 b5400 kernel: sd 6:0:0:0: [sdc] CDB:
Mar 20 21:48:21 b5400 kernel: cdb[0]=0x2a: 2a 00 02 2d 8b 70 00 00 f0 00
Mar 20 21:48:21 b5400 kernel: blk_update_request: I/O error, dev sdc, sector 36539248
Mar 20 21:48:21 b5400 kernel: Buffer I/O error on dev sdc1, logical block 4567150, lost async page write
Mar 20 21:48:21 b5400 kernel: Buffer I/O error on dev sdc1, logical block 4567151, lost async page write
Mar 20 21:48:21 b5400 kernel: Buffer I/O error on dev sdc1, logical block 4567152, lost async page write
Mar 20 21:48:21 b5400 kernel: Buffer I/O error on dev sdc1, logical block 4567153, lost async page write
Mar 20 21:48:21 b5400 kernel: Buffer I/O error on dev sdc1, logical block 4567154, lost async page write
Mar 20 21:48:21 b5400 kernel: Buffer I/O error on dev sdc1, logical block 4567155, lost async page write
Mar 20 21:48:21 b5400 kernel: Buffer I/O error on dev sdc1, logical block 4567156, lost async page write
Mar 20 21:48:21 b5400 kernel: Buffer I/O error on dev sdc1, logical block 4567157, lost async page write
Mar 20 21:48:21 b5400 kernel: Buffer I/O error on dev sdc1, logical block 4567158, lost async page write
Mar 20 21:48:21 b5400 kernel: Buffer I/O error on dev sdc1, logical block 4567159, lost async page write
Mar 20 21:48:21 b5400 kernel: sd 6:0:0:0: rejecting I/O to offline device
Mar 20 21:48:21 b5400 kernel: sd 6:0:0:0: killing request
Mar 20 21:48:21 b5400 kernel: sd 6:0:0:0: rejecting I/O to offline device
Mar 20 21:48:21 b5400 kernel: sd 6:0:0:0: [sdc] killing request
Mar 20 21:48:21 b5400 kernel: sd 6:0:0:0: rejecting I/O to offline device


I tried formatting on android, formatting using exfat-utils, I cannot seem to get these cards to work, tried using an external card reader, using mtp with android to copy data.

I seriously doubt two cards are problematic

thanks
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42800
Location: 56N 3W

PostPosted: Mon Mar 30, 2015 12:02 am    Post subject: Reply with quote

blakdeath,

Try a sync command before umount.

The umount command may return before the implied sync is complete.
Then if you remove the card, the data is still in you computer cache and not yet on tho card.

The explicit sync will not return until the write cache is flushed to the card.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Fri Apr 03, 2015 10:05 pm    Post subject: Reply with quote

here's what i got:
Apr 04 00:03:47 b5400 mount.exfat[6050]: unknown entry type 0xff
adel@b5400 ~/Desktop $ cp -afv /media/pc/downloads/Season\ 6/ /run/media/adel/6142-BC78/
cp: cannot stat ‘/run/media/adel/6142-BC78/Season 6/Family Guy [6x03] Believe It or Not, Joe's Walking on Air.mkv’: Input/output error

adel@b5400 ~/Desktop $ ls /run/media/adel/6142-BC78/Season\ 6/
ls: reading directory /run/media/adel/6142-BC78/Season 6/: Input/output error
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Tue Apr 14, 2015 11:30 am    Post subject: Reply with quote

I attached the sdxc to a different laptop, then I unplugged the card from that laptop, upon plugging it in my laptop I got the following:
[ 937.000483] sd 7:0:0:0: [sdd] CDB:
[ 937.000484] cdb[0]=0x28: 28 00 00 00 00 00 00 00 08 00
[ 937.000489] blk_update_request: I/O error, dev sdd, sector 0
[ 937.000491] Buffer I/O error on dev sdd, logical block 0, async page read
[ 937.961801] sdd: unable to read partition table
[ 937.965006] sd 7:0:0:0: [sdd] Attached SCSI removable disk


and could neither mount nor read the partition table in fdisk
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Sat Apr 18, 2015 10:17 pm    Post subject: Reply with quote

blakdeath here help anyone?
Back to top
View user's profile Send private message
roarinelk
Guru
Guru


Joined: 04 Mar 2004
Posts: 501

PostPosted: Sun Apr 19, 2015 12:05 pm    Post subject: Reply with quote

How old is your reader? Maybe it can't handle SDXC properly. Is it an external USB one? Does it have a separate power supply you can attach?
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Sun Apr 19, 2015 3:17 pm    Post subject: Reply with quote

well I've tried the built in reader of this year old laptop, and I've also tried the reader that came along with the card itself

both yield the same results
Back to top
View user's profile Send private message
roarinelk
Guru
Guru


Joined: 04 Mar 2004
Posts: 501

PostPosted: Sun Apr 19, 2015 5:54 pm    Post subject: Reply with quote

ok, then enable CONFIG_SCSI_CONSTANTS in your kernel config (SCSI device support -> Verbose SCSI error reporting) and maybe
even CONFIG_LBDAF and CONFIG_BLK_DEV_BSG. I'm interested in the verbose error messages when you try to read/write the card.
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Sun May 17, 2015 11:53 am    Post subject: Reply with quote

here's when I dismount sdd after copying some data:
[ 3246.324239] traps: notification-da[13697] trap int3 ip:7ff58f9475a3 sp:7fff04a2ce10 error:0
[ 3246.515503] sdd: detected capacity change from 67108864000 to 0
[ 3246.528722] gvfs-udisks2-vo[5617]: segfault at 18 ip 00007f38ff33b9b3 sp 00007fff0f96b520 error 4 in libc-2.19.so[7f38ff2c2000+199000]
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Mon May 18, 2015 8:55 am    Post subject: Reply with quote

here's what happene when i tried unmounting:
[40854.299869] sd 6:0:0:0: [sdd]
[40854.299872] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[40854.299874] sd 6:0:0:0: [sdd]
[40854.299875] Sense Key : Not Ready [current]
[40854.299877] sd 6:0:0:0: [sdd]
[40854.299879] Add. Sense: Medium not present
[40854.299881] sd 6:0:0:0: [sdd] CDB:
[40854.299881] Read(10): 28 00 00 00 08 78 00 00 08 00
[40854.299888] blk_update_request: I/O error, dev sdd, sector 2168
[40854.300016] traps: notification-da[7314] trap int3 ip:7f9ae515a5a3 sp:7fff7dd26330 error:0
[40854.301907] sd 6:0:0:0: [sdd]
[40854.301910] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[40854.301912] sd 6:0:0:0: [sdd]
[40854.301913] Sense Key : Not Ready [current]
[40854.301917] sd 6:0:0:0: [sdd]
[40854.301919] Add. Sense: Medium not present
[40854.301922] sd 6:0:0:0: [sdd] CDB:
[40854.301923] Read(10): 28 00 00 00 08 78 00 00 08 00
[40854.301931] blk_update_request: I/O error, dev sdd, sector 2168
[40854.301935] Buffer I/O error on dev sdd1, logical block 15, async page read
[40854.303876] sd 6:0:0:0: [sdd]
[40854.303879] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[40854.303882] sd 6:0:0:0: [sdd]
[40854.303883] Sense Key : Not Ready [current]
[40854.303887] sd 6:0:0:0: [sdd]
[40854.303889] Add. Sense: Medium not present
[40854.303891] sd 6:0:0:0: [sdd] CDB:
[40854.303892] Read(10): 28 00 00 00 08 78 00 00 08 00
[40854.303902] blk_update_request: I/O error, dev sdd, sector 2168
[40854.303905] Buffer I/O error on dev sdd1, logical block 15, async page read
[40854.304877] sd 6:0:0:0: [sdd]
[40854.304879] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7069
Location: almost Mile High in the USA

PostPosted: Sun Jul 26, 2015 12:14 am    Post subject: Reply with quote

I think I'm running into the same problem. Or unsure what the real underlying problem is.

I have a 64GB SDXC card formatted with exfat. I am using the exfat FUSE driver and a Realtek eMMC/MMC controller.

I get tons of block read/write errors when using exfat when it mounts just fine. If I write enough to it, after all the write failures, it will get kicked and the card disappears until I eject and reinsert.

However, IN WINDOWS7 on the same machine, IT WORKS perfectly! And as far as I can tell, Windows is not reporting any errors.

I move this to another eMMC reader (Intel SOC) and Windows 8.1 - IT WORKS FINE! A bit slow at points but after the initial slowness when first using it, the card works perfectly (it might be Windows Defender, but unsure). I haven't gotten Linux working perfectly on this SOC so I can't test this behavior yet.

The same 64G SDXC card put into a USB SDHC reader on another Linux box also exhibits the same bad block errors. I have not tried the SDHC reader in Windows as this reader was meant for a Linux-only machine.

So as far as I can tell there's some very strange bug going on here.

Any of this makes sense to someone? Should I RMA this card?

Another test is that I need to see if Android works with this card...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum