Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SSD changes ACPI behaviour?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 769

PostPosted: Tue Mar 31, 2015 7:27 am    Post subject: SSD changes ACPI behaviour? Reply with quote

I'm seeing some strange behaviour after installing an SSD into a ThinkPad T530. The Fn+F8/F9 display brightness up/down keys no longer function. and syslog logs messages about unhandled ACPI events.
Code:
Mar 31 08:14:08 host logger[2519]: ACPI event unhandled: video/brightnessup BRTUP 00000086 00000000 K

but only for up. The same messages are also logged for volume up (not down) and mute buttons, but they continue to work.

Why is this happening and is there any way to restore the correct behaviour? I have acpi_call-9999 installed, with the acpi_call-1.1.0 patch to compile on kernel 3.17+, and the thinkpad_acpi led_class backlight modules are all loaded.
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 769

PostPosted: Tue Apr 14, 2015 8:49 pm    Post subject: Reply with quote

It's a strange problem. Turns out it's intermittent between reboot. When it works, it logs
Code:

Apr 14 21:46:45 host logger[16075]: ACPI event unhandled: video/brightnessdown BRTDN 00000087 00000000
Apr 14 21:46:45 host pkexec[16076]: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
Apr 14 21:46:45 host pkexec[16076]: user: Executing command [USER=root] [TTY=unknown] [CWD=/home/user] [COMMAND=/usr/sbin/mate-power-backlight-helper --set-brightness 4216]
Apr 14 21:47:08 host logger[16091]: ACPI event unhandled: video/brightnessup BRTUP 00000086 00000000 K
Apr 14 21:47:08 host logger[16094]: ACPI event unhandled: video/brightnessup BRTUP 00000086 00000000
Apr 14 21:47:08 host pkexec[16093]: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
Apr 14 21:47:08 host pkexec[16093]: user: Executing command [USER=root] [TTY=unknown] [CWD=/home/user] [COMMAND=/usr/sbin/mate-power-backlight-helper --set-brightness 3760]

So the problem is not related to the SSD, but a change in the desktop setup.
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3724
Location: Hamburg

PostPosted: Tue Apr 14, 2015 9:07 pm    Post subject: Reply with quote

At my T440s I do not need any acpi_call package ..., works nearly out of the box (config : https://bpaste.net/show/e5a13aab1854)
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 769

PostPosted: Thu Apr 16, 2015 8:40 pm    Post subject: Reply with quote

Removing it completely changes nothing here.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum