Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nouveau, "KMS not enabled" when it should be
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Wed Apr 08, 2015 6:03 pm    Post subject: Nouveau, "KMS not enabled" when it should be Reply with quote

I just upgraded my GTX 460 GPU to a GTX 960. I had to hunt down some answers to make the nvidia driver go away after installing nouveau. Now I'm at the point where the nvidia driver is gone, but no matter what I do, Xorg.0.log says that KMS is not enabled, even though I've enabled nouveau in the kernel both as a module and compiled-in (not at the same time, obviously. I tried one, then the other, but it makes no difference here).

I am stuck. What exactly do I need to do to make nouveau work and get KMS going?

EDIT:

Just learned this chipset is simply not supported before kernel 4.0 rc.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1388

PostPosted: Wed Apr 08, 2015 8:41 pm    Post subject: Reply with quote

cat /proc/cmdline
should not have any of nomodeset nouveau.modeset=0 blacklist=nouveau
also look at /etc/modules for blacklist and my .config
# zcat /proc/config.gz |grep -e DRM -e FB -e NOUV |grep -v '#'
CONFIG_X86_SYSFB=y
CONFIG_DRM=y
CONFIG_DRM_KMS_HELPER=y
CONFIG_DRM_KMS_FB_HELPER=y
CONFIG_DRM_TTM=y
CONFIG_DRM_I2C_SIL164=m
CONFIG_DRM_NOUVEAU=y
CONFIG_DRM_NOUVEAU_BACKLIGHT=y
CONFIG_FB=y
CONFIG_FB_CMDLINE=y
CONFIG_FB_BOOT_VESA_SUPPORT=y
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
CONFIG_FB_BACKLIGHT=y
CONFIG_FB_MODE_HELPERS=y
CONFIG_FB_VESA=y
CONFIG_FB_EFI=y
CONFIG_FB_SIMPLE=y
_________________
the thread ain't easily find an end
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Thu Apr 09, 2015 3:45 am    Post subject: Reply with quote

...IIRC, CONFIG_FB_VESA should actually be not set.
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1388

PostPosted: Thu Apr 09, 2015 9:45 am    Post subject: Reply with quote

@VoidMage, thanks for this hint, it boots a second faster.
VoidMage wrote:
...IIRC, CONFIG_FB_VESA should actually be not set.
Tried nvidiafb but got me:
Code:
Apr 09 11:28:00 maci kernel: ACPI: PCI Interrupt Link [LGPU] enabled at IRQ 16
Apr 09 11:28:00 maci kernel: nvidiafb 0000:02:00.0: BAR 1: can't reserve [mem 0xc0000000-0xcfffffff 64bit pref]
Apr 09 11:28:00 maci kernel: nvidiafb: cannot request PCI regions
using
Code:
#  zcat /proc/config.gz |grep -e DRM -e FB -e NOUV |grep -v '#'
CONFIG_X86_SYSFB=y
CONFIG_DRM=y
CONFIG_DRM_KMS_HELPER=y
CONFIG_DRM_KMS_FB_HELPER=y
CONFIG_DRM_TTM=y
CONFIG_DRM_I2C_ADV7511=m
CONFIG_DRM_I2C_CH7006=m
CONFIG_DRM_I2C_SIL164=m
CONFIG_DRM_I2C_NXP_TDA998X=m
CONFIG_DRM_NOUVEAU=y
CONFIG_NOUVEAU_DEBUG=5
CONFIG_NOUVEAU_DEBUG_DEFAULT=2
CONFIG_DRM_NOUVEAU_BACKLIGHT=y
CONFIG_FB=y
CONFIG_FB_CMDLINE=y
CONFIG_FB_DDC=y
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
CONFIG_FB_BACKLIGHT=y
CONFIG_FB_MODE_HELPERS=y
CONFIG_FB_EFI=y
CONFIG_FB_NVIDIA=y
CONFIG_FB_NVIDIA_I2C=y
CONFIG_FB_NVIDIA_BACKLIGHT=y
CONFIG_FB_SIMPLE=y
Do I need CONFIG_FB_NVIDIA at all, may be CONFIG_FB_EFI is enough?
_________________
the thread ain't easily find an end
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum