Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ solved ] Gnome 3 unscharfe / Grafik laggt und hängt
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
xtrace
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2010
Posts: 76

PostPosted: Mon Jun 29, 2015 11:40 am    Post subject: [ solved ] Gnome 3 unscharfe / Grafik laggt und hängt Reply with quote

Hi,

ich habe Probleme mit meinem Gnome 3.
die Schrift it teilweise dermaßen unscharf, dass man nur noch erahnen kann, was letztlich auf dem Bildschirm steht.
Wenn ich die Maus bewege, ändert sich das und man kann sie besser lesen. Allerdings nicht scharf. Es bleibt verschwommen.
Das Problem habe ich nur mit Gnome. LXDE, KDE und restliche funktionieren problemlos.

Ich habe bereits einiges versucht:
- Hinting aktiviert und auch deaktiviert.
- Auflösung geändert
- anderen NVIDIA Treiber versucht
- Schriftarten gewechselt
- Schrifgröße geändert

Alles ohne Erfolg.

Das Problem tritt unter Gnome Programmunabhänig auf. Also: Innerhalb von Dashboard, Konsole, Firefox, Tastbar etc.

Das System ist komplett stable gehalten.

EDIT: ich nutze das nvidia OpenGL.

Danke.

cu,
xtrace


Last edited by xtrace on Tue Aug 11, 2015 9:17 am; edited 2 times in total
Back to top
View user's profile Send private message
xtrace
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2010
Posts: 76

PostPosted: Tue Jun 30, 2015 6:33 am    Post subject: Reply with quote

Hallo,

ich habe es nun mal auf xrandr gestellt. Damit wird es ein wenig besser. Gut ist es allerdings noch lange nicht. Die Schrift wird verschwommen und ist kaum lesbar.

cu,
xtrace
Back to top
View user's profile Send private message
xtrace
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2010
Posts: 76

PostPosted: Wed Jul 01, 2015 10:09 am    Post subject: Reply with quote

Hallo,

hat noch niemand dieses Problem gehabt?
Bin mittlerweile wirklich ratlos. Ich habe auch bereits alle Einstellungen zurückgesetzt (gnome Order gelöscht).

cu,
xtrace
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3710
Location: Germany

PostPosted: Wed Jul 01, 2015 11:50 am    Post subject: Reply with quote

xtrace wrote:
Bin mittlerweile wirklich ratlos. Ich habe auch bereits alle Einstellungen zurückgesetzt (gnome Order gelöscht).

Hm, da wäre ich mir nicht sicher ob zum testen nur das entfernen des "gnome Ordners" ausreicht. Die Einstellungen sind ja meist auf mehrere Verzeichnisse verteilt (zb auch ~/.config/ ~/.local/ ~/.cache/ usw)

Teste es am besten mal mit einem frischen neu angelegten jungfräulichen Testuser.
Back to top
View user's profile Send private message
xtrace
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2010
Posts: 76

PostPosted: Thu Jul 02, 2015 5:57 am    Post subject: Reply with quote

Hi,

ich habe es mit einem komplett neuen User versucht. Leider besteht das gleiche Problem.

cu,
xtrace
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2251
Location: Germany

PostPosted: Sat Jul 04, 2015 12:34 am    Post subject: Reply with quote

Hmm bisher hatte ich das noch nicht. Mach mal ein Screenshot.

Hast du die Einstellungen vielleicht mal per gnome-extra/gnome-tweak-tool verändert? Vielleicht mal in den normalen Einstellungen gucken. Unter Barrierefreiheit. Da kann man Dinge einstellen wie:

Quote:

-Hoher Kontrast
-Große Schrift
-Vergrößerung


Ansonsten lag es vielleicht an einem Update oder Bug. Welche Version hast du denn? Vielleicht kannst du es ja auf eine Version begrenzen. Nicht das sich Wayland irgendwie eingeschlichen hat.
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1424

PostPosted: Thu Jul 09, 2015 5:55 pm    Post subject: Reply with quote

eselect fontconfig list ?
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
xtrace
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2010
Posts: 76

PostPosted: Mon Jul 13, 2015 4:47 pm    Post subject: Reply with quote

ChrisJumper wrote:
Hmm bisher hatte ich das noch nicht. Mach mal ein Screenshot.

Hast du die Einstellungen vielleicht mal per gnome-extra/gnome-tweak-tool verändert? Vielleicht mal in den normalen Einstellungen gucken. Unter Barrierefreiheit. Da kann man Dinge einstellen wie:

Quote:

-Hoher Kontrast
-Große Schrift
-Vergrößerung


Ansonsten lag es vielleicht an einem Update oder Bug. Welche Version hast du denn? Vielleicht kannst du es ja auf eine Version begrenzen. Nicht das sich Wayland irgendwie eingeschlichen hat.


Hallo,
sorry für die späte Antwort.
Wenn ich einen Screenshot mache, wird das Bild deutlich dargestellt.
Wenn ich was schreibe (wie jetzt dieses Beitrag) wechselt die Schrift von scharf auf undeutlich und verschwommen.


Ich habe mit eselect fontconfig list bei allen Schriftarten einen Stern. Auch ein einzelens deaktivieren hat leider nicht geholfen.
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2251
Location: Germany

PostPosted: Wed Jul 15, 2015 8:55 pm    Post subject: Reply with quote

Hmm, schau mal beim gnome-font-viewer ob manche Schriftarten klar sind. Dann vergleiche es mit deiner fontconfig list und deaktiviere diese die bei dir seltsam dargestellt werden.

Deaktiviere mal diese, wenn du sie noch aktiv hast:
eselect fontconfig list wrote:
[1] 10-autohint.conf
[2] 10-no-sub-pixel.conf
[3] 10-scale-bitmap-fonts.conf
[4] 10-sub-pixel-bgr.conf
[5] 10-sub-pixel-rgb.conf
[6] 10-sub-pixel-vbgr.conf
[7] 10-sub-pixel-vrgb.conf
[8] 10-unhinted.conf
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Thu Jul 16, 2015 7:22 am    Post subject: Reply with quote

xtrace wrote:
Ich habe mit eselect fontconfig list bei allen Schriftarten einen Stern.
Da es sich hierbei nicht um Schriftarten, sondern Konfigurationseinstellungen handelt, die sich zum Teil deutlich widersprechen, ist das keine gute Idee.

Schau dir mal an, wie die folgenden Einträge heißen, ich glaube, das sollte verdeutlichen, was ich meine:
Code:
  [2]   10-autohint.conf
  [3]   10-no-sub-pixel.conf
  [4]   10-scale-bitmap-fonts.conf *
  [5]   10-sub-pixel-bgr.conf
  [6]   10-sub-pixel-rgb.conf
  [7]   10-sub-pixel-vbgr.conf
  [8]   10-sub-pixel-vrgb.conf
  [9]   10-unhinted.conf
  [10]  11-lcdfilter-default.conf
  [11]  11-lcdfilter-legacy.conf
  [12]  11-lcdfilter-light.conf
  [13]  20-unhint-small-dejavu-sans.conf
  [14]  20-unhint-small-dejavu-sans-mono.conf
  [15]  20-unhint-small-dejavu-serif.conf
  [16]  20-unhint-small-vera.conf *
  [17]  25-unhint-nonlatin.conf
Davon einmal abgesehen, dass du mit modernen Desktopumgebungen keine der sub-pixel und auto hinting Optionen brauchst. Stell die mal alle ab.

Und falls du sie aktiviert hast, schalte mal die folgenden ab:
Code:
  [35]  70-no-bitmaps.conf
  [36]  70-yes-bitmaps.conf
(Optionen, die bei dir nicht vorhanden sind, sind natürlich Wurst. Und die Nummern können bei dir natürlich andere sein.)
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3710
Location: Germany

PostPosted: Thu Jul 16, 2015 10:59 am    Post subject: Reply with quote

Huh ja, im fontconfig pauschal *alles* zu aktivieren ist wahrscheinlich wirklich keine gute Idee.
Schau mal ob der Tipp mit dem Reset auf upstream defaults noch hilft.
Back to top
View user's profile Send private message
xtrace
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2010
Posts: 76

PostPosted: Thu Jul 16, 2015 7:06 pm    Post subject: Reply with quote

Hallo,

leider alles ohne Erfolg :-(

Folgend mal ein paar Screenshots (ich habe endlich mal welche mit sichtbaren Fehldarstellungen machen können):

https://picload.org/image/iilwgdr/bildschirmfotovon2015-07-17225.png
https://picload.org/image/iilwgdi/bildschirmfotovon2015-07-17230.png

Wenn ich die Maus nicht bewege und sonst keine Eingaben tätige, verschwimmen die Schriften von alleine (als ob ein Effekt hinterlegt wäre).
Wenn ich die Maus bewege, wechselt die Schrift von verschwommen zu deutlich und umgekehrt.

Ich habe die Probleme ausschließlich unter Gnome. KDE, Fluxbox, Enlightenment, LXDE, XFCE laufen alle ohne Probleme.

LG
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2251
Location: Germany

PostPosted: Thu Jul 30, 2015 7:07 pm    Post subject: Reply with quote

Aus deinem ersten Screenshot, das mit den Ereignissen neben dem Kalender ist normal. Ein Update auf Version 3.16, gestaltet das noch mal um und dann ist das wieder schön.

Bei deinem zweiten Screenshot ist die Schrift im Chromium wirklich hässlich. Ich meine das ich das auch mal hatte, aber ganz unabhängig von Gnome.

Kennst du den gconf-editor? Das ist ja etwas wie die Windows Registry, dort kannst au auch verschiedene Einstellungen vornehmen. Askubuntu.com hat da so ein paar Einstellungen, bin mir aber nicht sicher ob die veraltet sind. Ich meine mich auch zu erinnern das es irgendwo eine Möglichkeit gibt die bevorzugte Schriftart zu setzen.

Das wiki.gentoo.org fontconfig hast du dir bestimmt auch schon angeschaut oder?

Aber mich wundert das es noch nicht geholfen hat, besonders Josef Link.. hat mir damals weitergeholfen meine ich.
Back to top
View user's profile Send private message
xtrace
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2010
Posts: 76

PostPosted: Tue Aug 11, 2015 6:17 am    Post subject: Reply with quote

Hallo,

nachdem ich meine Nvidia-Settings Datei gelöscht und komplett neu eingerichtet habe, habe ich mit den Schriftarten keine Probleme mehr.
Allerdings habe ich nun das Problem, dass sämtliche Spiele unter Playonlinux "laggen" und ruckeln...Die Grafik läuft nicht rund.
Zudem bleibt Gnome immer wieder mal hängen. Es arbeitet für 5 Sekunden gar nicht und aufeinmal macht es mehrere Schritte aufeinmal.
Ich habe ausschließlich SSDs verbaut. Es kann also nicht an einer langsamen Festplatte liegen.

Die Hardware Beschleunigung ist aktiviert. ich habe mit eselect opengl und opencl nvidia ausgewählt.

Soll ich dafür am besten ein neues Thema erstellen?

Cu,
xtrace
Back to top
View user's profile Send private message
scurrell
Tux's lil' helper
Tux's lil' helper


Joined: 18 Mar 2014
Posts: 149

PostPosted: Tue Aug 11, 2015 7:32 pm    Post subject: Reply with quote

Also, wenn du das Thema zu
Gnome3 hat Prolbeme mit nvidia und unscharfen Schriftttypen/Lagging änderst, (Kurz: gnome3 Problem nvidia unscharf lagging)
kann das doch so bleiben wie es ist. Hoffe du kannst das mal irgendwann beheben.
Und wie du schon sagtest, mit xfce, lxde, kde und so gehts ja.
Und [solved] ist das definitiv bestimmt nicht.
_________________
Dampfmaschin
Back to top
View user's profile Send private message
SkaaliaN
Veteran
Veteran


Joined: 21 Apr 2005
Posts: 1349
Location: Tranquility

PostPosted: Tue Aug 11, 2015 8:12 pm    Post subject: Reply with quote

scurrell wrote:
Also, wenn du das Thema zu
Gnome3 hat Prolbeme mit nvidia und unscharfen Schriftttypen/Lagging änderst, (Kurz: gnome3 Problem nvidia unscharf lagging)
kann das doch so bleiben wie es ist. Hoffe du kannst das mal irgendwann beheben.
Und wie du schon sagtest, mit xfce, lxde, kde und so gehts ja.
Und [solved] ist das definitiv bestimmt nicht.


Sein Grundproblem ist gelöst. Das ist das unscharfe, sowie das laggen. Also ist sein solved sehr wohl richtig.
Also für den Rest am besten einen eigenen Thread eröffnen und gut ist.
Sein XFCE, LXDE, etc. hatte Probleme mit der undeutlichen Schrift...wie er auch klar und eindeutig geschrieben hat.
_________________
-RHP- Respect Honor Passion
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum