Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Root filesystem is mounted as read-only
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
toothpick
n00b
n00b


Joined: 31 May 2012
Posts: 53

PostPosted: Sun Apr 12, 2015 8:41 pm    Post subject: [SOLVED] Root filesystem is mounted as read-only Reply with quote

Hi,
Whenever I boot my computer I have to remount my "/" directory manually,
I would be grateful if someone could tell my why this pesky problems occurs...

dmesg:
http://tny.cz/2996c08a

/etc/fstab:
http://tny.cz/e91d3c03

/boot/grub/menu.lst:
http://tny.cz/ce68c765

/usr/src/linux/.config:
http://tny.cz/6a5d7f88


Last edited by toothpick on Wed Apr 15, 2015 5:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
lovelytux
Tux's lil' helper
Tux's lil' helper


Joined: 23 Aug 2013
Posts: 93
Location: Westwoods of Germany

PostPosted: Mon Apr 13, 2015 9:25 am    Post subject: Reply with quote

Hey toothpick!

Do you have root in your runlevel? What says

Code:
rc-update | grep root
?

lovelytux
Back to top
View user's profile Send private message
el muchacho
Tux's lil' helper
Tux's lil' helper


Joined: 26 Mar 2015
Posts: 77

PostPosted: Mon Apr 13, 2015 11:31 am    Post subject: Re: Root filesystem is mounted as read-only Reply with quote

toothpick wrote:
Hi,
Whenever I boot my computer I have to remount my "/" directory manually,
I would be grateful if someone could tell my why this pesky problems occurs...

dmesg:
http://tny.cz/2996c08a

/etc/fstab:
http://tny.cz/e91d3c03

/boot/grub/menu.lst:
http://tny.cz/ce68c765

/usr/src/linux/.config:
http://tny.cz/6a5d7f88


All i can say is I had a similar issue that was caused by an option not enabled in the Kernel, which had to do with TMPFS. As i was using tmpfs in my fstab it somehow contaminated the other mounts on my system. If you use TMPFS double-check your kernel settings.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3076
Location: Illinois, USA

PostPosted: Mon Apr 13, 2015 8:40 pm    Post subject: Reply with quote

From your pasted kernel config
Quote:
CONFIG_DEVTMPFS=y
# CONFIG_DEVTMPFS_MOUNT is not set


Also try adding defaults as in this example. I freely admit that I do't know what "defaults" does.
Quote:
/dev/sda2 / ext4 defaults,noatime,nodiratime 0 1
Back to top
View user's profile Send private message
toothpick
n00b
n00b


Joined: 31 May 2012
Posts: 53

PostPosted: Tue Apr 14, 2015 8:24 pm    Post subject: Reply with quote

I have made the following changes:

.config:
Quote:
CONFIG_DEVTMPFS_MOUNT=y


/etc/fstab:
Quote:
/dev/sda3 / ext4 defaults,noatime,nodiratime 0 1


Quote:
rc-update | grep root
returns nothing

still the situation has not changed :(
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3686
Location: Hamburg

PostPosted: Tue Apr 14, 2015 9:05 pm    Post subject: Reply with quote

toothpick wrote:
Quote:
rc-update | grep root
returns nothing
Code:
rc-update add root boot
?
Back to top
View user's profile Send private message
toothpick
n00b
n00b


Joined: 31 May 2012
Posts: 53

PostPosted: Wed Apr 15, 2015 12:18 pm    Post subject: Reply with quote

Code:
rc-update add root boot


thanks :) that solved it!
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3686
Location: Hamburg

PostPosted: Wed Apr 15, 2015 2:20 pm    Post subject: Reply with quote

toothpick wrote:
that solved it!
urw - now just pls prepend "[solved]" to the title
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum