Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Crazy Screen Resolution on Console
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
txykumat
Tux's lil' helper
Tux's lil' helper


Joined: 24 Nov 2014
Posts: 104

PostPosted: Sun Apr 12, 2015 9:49 pm    Post subject: Crazy Screen Resolution on Console Reply with quote

I bought this laptop with 4k screen and first thing I want to do with it is remove windows and install gentoo. But I am having problem because no matter what I do, console font too small / resolution too high and unchangeable that I cannot see what command I am typing into. Once I get GUI, say KDE, I can scale it to however I want, but in Grub, booting, before /etc/init.d/xdm start , everything is wrong. Could someone with experience with 4k screen laptop help me set things right so I can see what I am typing at console?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Mon Apr 13, 2015 3:56 pm    Post subject: Reply with quote

presuming you are using nouveau or radeon or intel video driver and pirating an old wiki:
Quote:
Generally, a properly configured kernel is all that you need for KMS. It should read the EDID information, and use the highest available resolution.
Forcing a Resolution
If you get a black screen, an incorrect resolution or want to specify the resolution to use, you can force a resolution on the kernel command-line. This can be useful if KMS auto detection fails with rare/incorrect EDID from the monitor.
When using a driver utilizing Kernel Mode Setting, you do not specify any driver name in the video= parameter. For example, setting the screen resolution to 1280x1024, 24bps at 75Hz would be just:
video=1280x1024-24@75

If it doesn't seem to have any effect, you may need to specify the output interface explictly:
video=VGA-1:1280x1024-24@75
You can read the commit message of this feature for further details.
Disabling Modesetting
If you want to disable KMS you will need to pass nomodeset to the kernel. Example:
File: /boot/grub/grub.conf
title Linux - No Framebuffer
root (0,0)
kernel /example-kernel-2.6.29 root=/dev/root nomodeset

I would add video=1024x768-24@60 (you may need to specify connection - video=hdmi-1: 1024x768@60Hz
To define connections, run: for p in /sys/class/drm/*/status; do con=${p%/status}; echo -n "${con#*/card?-}: "; cat $p; done )or nomodeset to the boot loader cmdline

if /var/log/Xorg.0.log exists, take a look at the available resolutions in "supported established timings" and in "modelines" and change video= , if desired, to some other value, suggest common to both lists.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
txykumat
Tux's lil' helper
Tux's lil' helper


Joined: 24 Nov 2014
Posts: 104

PostPosted: Tue Apr 14, 2015 6:53 pm    Post subject: Reply with quote

This worked on Fedora, and Funtoo, but it does not work on Gentoo install. I have no clue why.


DONAHUE wrote:
presuming you are using nouveau or radeon or intel video driver and pirating an old wiki:
Quote:
Generally, a properly configured kernel is all that you need for KMS. It should read the EDID information, and use the highest available resolution.
Forcing a Resolution
If you get a black screen, an incorrect resolution or want to specify the resolution to use, you can force a resolution on the kernel command-line. This can be useful if KMS auto detection fails with rare/incorrect EDID from the monitor.
When using a driver utilizing Kernel Mode Setting, you do not specify any driver name in the video= parameter. For example, setting the screen resolution to 1280x1024, 24bps at 75Hz would be just:
video=1280x1024-24@75

If it doesn't seem to have any effect, you may need to specify the output interface explictly:
video=VGA-1:1280x1024-24@75
You can read the commit message of this feature for further details.
Disabling Modesetting
If you want to disable KMS you will need to pass nomodeset to the kernel. Example:
File: /boot/grub/grub.conf
title Linux - No Framebuffer
root (0,0)
kernel /example-kernel-2.6.29 root=/dev/root nomodeset

I would add video=1024x768-24@60 (you may need to specify connection - video=hdmi-1: 1024x768@60Hz
To define connections, run: for p in /sys/class/drm/*/status; do con=${p%/status}; echo -n "${con#*/card?-}: "; cat $p; done )or nomodeset to the boot loader cmdline

if /var/log/Xorg.0.log exists, take a look at the available resolutions in "supported established timings" and in "modelines" and change video= , if desired, to some other value, suggest common to both lists.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Tue Apr 14, 2015 7:48 pm    Post subject: Reply with quote

did you try both nomodeset and setting video= and neither improved the situation?
if you wish some extra eyes; wgetpaste your .config file, the output of lspci -k, and grub.cfg/grub.conf/kernel cmdline/whatever else the bootloader may be
is an initramfs used for fedora? funtoo? gentoo?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
txykumat
Tux's lil' helper
Tux's lil' helper


Joined: 24 Nov 2014
Posts: 104

PostPosted: Wed Apr 22, 2015 4:15 pm    Post subject: Reply with quote

DONAHUE wrote:
did you try both nomodeset and setting video= and neither improved the situation?
if you wish some extra eyes; wgetpaste your .config file, the output of lspci -k, and grub.cfg/grub.conf/kernel cmdline/whatever else the bootloader may be
is an initramfs used for fedora? funtoo? gentoo?


I kind of got tired of 4k business so I returned the laptop to microsoftstore for $1299. Thank you very much for the offer of help. Greatly appreciated.

PS
I tried both nomodeset and video=1920x1080-24@60 but did not have any effect. Weird thing is it works in Funtoo and all other distro.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum