Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nvidia-drivers and kernel-4.0.0
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 565
Location: USA

PostPosted: Sat Nov 14, 2015 1:51 am    Post subject: Reply with quote

kernelOfTruth wrote:

https://devtalk.nvidia.com/default/topic/894842/linux/340-93-kernel-module-does-not-build-with-kernel-4-3/

https://devtalk.nvidia.com/default/topic/877365/linux/355-11-linux-4-3-rc1-build-error/


also take note that there's an ABI version change with xorg-server 1.18

https://devtalk.nvidia.com/default/topic/894725/linux/abi-version-20-0-issues/


Many thanks. Since I'm still on xorg-server-1.17.4, the patch in the first link worked.
Back to top
View user's profile Send private message
boospy
Apprentice
Apprentice


Joined: 07 Feb 2010
Posts: 299
Location: Austria

PostPosted: Tue Dec 29, 2015 12:07 am    Post subject: Reply with quote

Hello :)

the link to the patch does not work anymore. Can anyone post the right patch please? I would like to add them to latest 4.1.12 .

Thanks and best Regards
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6111
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Dec 30, 2015 12:37 pm    Post subject: Reply with quote

Arch Linux is a way too much moving target (at least for my taste)

I ran into the same problem :lol:

anyway:

Code:
--- a/kernel/nvidia/nv-procfs.c        2015-09-15 00:34:55.346647648 -0400
+++ b/kernel/nvidia/nv-procfs.c        2015-09-15 00:52:10.172514778 -0400
@@ -360,7 +360,8 @@
     registry_keys = ((nvl != NULL) ?
             nvl->registry_keys : nv_registry_keys);
 
-    return seq_printf(s, "Binary: \"%s\"\n", registry_keys);
+    seq_printf(s, "Binary: \"%s\"\n", registry_keys);
+    return 0;
 }
 
 static ssize_t
@@ -560,7 +561,8 @@
     void *v
 )
 {
-    return seq_puts(s, s->private);
+    seq_puts(s, s->private);
+    return 0;
 }
 
 NV_DEFINE_PROCFS_SINGLE_FILE(text_file);

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
boospy
Apprentice
Apprentice


Joined: 07 Feb 2010
Posts: 299
Location: Austria

PostPosted: Wed Dec 30, 2015 3:12 pm    Post subject: Reply with quote

kernelOfTruth wrote:
Arch Linux is a way too much moving target (at least for my taste)

I ran into the same problem :lol:

anyway:

Code:
--- a/kernel/nvidia/nv-procfs.c        2015-09-15 00:34:55.346647648 -0400
+++ b/kernel/nvidia/nv-procfs.c        2015-09-15 00:52:10.172514778 -0400
@@ -360,7 +360,8 @@
     registry_keys = ((nvl != NULL) ?
             nvl->registry_keys : nv_registry_keys);
 
-    return seq_printf(s, "Binary: \"%s\"\n", registry_keys);
+    seq_printf(s, "Binary: \"%s\"\n", registry_keys);
+    return 0;
 }
 
 static ssize_t
@@ -560,7 +561,8 @@
     void *v
 )
 {
-    return seq_puts(s, s->private);
+    seq_puts(s, s->private);
+    return 0;
 }
 
 NV_DEFINE_PROCFS_SINGLE_FILE(text_file);


Thanks a lot! Work with 4.3.3 perfectly!

Best Regars
Back to top
View user's profile Send private message
e3k
Guru
Guru


Joined: 01 Oct 2007
Posts: 426
Location: Inner Space

PostPosted: Sat Jan 23, 2016 2:45 pm    Post subject: Reply with quote

has anyone tested the 340.93-r1 driver with the new kernel 4.1.15-gentoo-r1? it does not work unpatched. the newest legacy 340.xx version is 340.96 (http://www.nvidia.com/Download/driverResults.aspx/95165/en-us). did anyone try to install it?
---
sorry for false alert. somehow i have emerged nouveau drivers with the new kernel which caused a problem with udev. 340.93-r1 nvidia-drivers are working fine with the new kernel 4.1.15-gentoo-r1
_________________
((O.o))
Back to top
View user's profile Send private message
e3k
Guru
Guru


Joined: 01 Oct 2007
Posts: 426
Location: Inner Space

PostPosted: Fri Aug 05, 2016 2:51 pm    Post subject: Reply with quote

i did now upgrade to kernel 4.4.6

can this be related also to the kernel 4.4.6 and nvidia-driver 340.93-r1?
did anyone care to open a bug for this at bugs.gentoo.org?

i did a quick search and i could only find https://bugs.gentoo.org/show_bug.cgi?id=558028 which is kernel 3.18
---edit---
i was able to compile the 340.96 driver on kernel 4.4.6 with this patch:
Code:

--- kernel/os-mlock.c.orig      2015-11-09 06:44:53.000000000 +0100
+++ kernel/os-mlock.c   2016-05-18 19:16:33.263103070 +0200
@@ -45,7 +45,11 @@
     }
 
     down_read(&mm->mmap_sem);
+#if LINUX_VERSION_CODE < KERNEL_VERSION(4,6,0)
     ret = get_user_pages(current, mm, (unsigned long)address,
+#else
+    ret = get_user_pages((unsigned long)address,
+#endif
             page_count, write, force, user_pages, NULL);
     up_read(&mm->mmap_sem);
     pinned = ret;
@@ -58,7 +62,11 @@
     else if (pinned < page_count)
     {
         for (i = 0; i < pinned; i++)
+#if LINUX_VERSION_CODE < KERNEL_VERSION(4,6,0)
             page_cache_release(user_pages[i]);
+#else
+            put_page(user_pages[i]);
+#endif
         os_free_mem(user_pages);
         return RM_ERR_INVALID_ADDRESS;
     }
@@ -85,7 +93,11 @@
     {
         if (write)
             set_page_dirty_lock(user_pages[i]);
+#if LINUX_VERSION_CODE < KERNEL_VERSION(4,6,0)
         page_cache_release(user_pages[i]);
+#else
+        put_page(user_pages[i]);
+#endif
     }
 
     os_free_mem(user_pages);
--- kernel/uvm/nvidia_uvm_lite.c.orig   2015-11-09 06:44:53.000000000 +0100
+++ kernel/uvm/nvidia_uvm_lite.c        2016-05-18 19:16:33.263103070 +0200
@@ -785,7 +785,11 @@
         // a reference so that the fault handling logic is correct:
         //
         get_page(pTracking->uvmPage);
+#if LINUX_VERSION_CODE < KERNEL_VERSION(4,6,0)
         retValue = VM_FAULT_MINOR;
+#else
+        retValue = 0;
+#endif
     }
 
     pRecord->isMapped = NV_TRUE;


provided on suse forums:
https://forums.opensuse.org/showthread.php/518193-openSUSE-Tumbleweed-kernel-update-and-NVIDIA-driver-problem
http://img.susepaste.org/90757339
_________________
((O.o))
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum