Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Acpitool does not return thermal information
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
abduct
Apprentice
Apprentice


Joined: 19 Mar 2015
Posts: 203

PostPosted: Tue Apr 14, 2015 4:00 am    Post subject: [SOLVED] Acpitool does not return thermal information Reply with quote

I am trying to retrieve my CPU thermal information with acpitool although it is showing up as not available.

I used strace on the acpitool application and it turns out it is trying to access "/proc/acpi/thermal_zone/" which does not exist, so in attempts to remedy this I enabled more of the ACPI depreciated file structures in the kernel config and recompiled my kernel, only to have two more directories added to "/proc/acpi/" none of which are thermal_zone.

I am running the 3.2.65 kernel on a HP envy 4 1130us laptop. I have tried to enable quite a few of the depreciated ACPI options in the kernel, but I either haven't found the right one, or this kernel does not support it.

Here are my ACPI kernel options that I have enabled.

Code:
~ # cat /usr/src/linux/.config | grep ACPI
CONFIG_X86_64_ACPI_NUMA=y
CONFIG_ACPI=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_PROCFS=y
CONFIG_ACPI_PROCFS_POWER=y
CONFIG_ACPI_PROC_EVENT=y
CONFIG_ACPI_AC=y
CONFIG_ACPI_BATTERY=y
CONFIG_ACPI_BUTTON=y
CONFIG_ACPI_VIDEO=y
CONFIG_ACPI_FAN=y
CONFIG_ACPI_DOCK=y
CONFIG_ACPI_PROCESSOR=y
CONFIG_ACPI_HOTPLUG_CPU=y
CONFIG_ACPI_THERMAL=y
CONFIG_ACPI_NUMA=y
CONFIG_ACPI_BLACKLIST_YEAR=0
CONFIG_X86_ACPI_CPUFREQ=y
CONFIG_PNPACPI=y
CONFIG_ATA_ACPI=y


If acpitool is no longer a viable way to obtain this information is there another tool out there to retrieve this information from /sys/ instead where the information now resides?

Thanks all!


Last edited by abduct on Wed Apr 15, 2015 7:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
abduct
Apprentice
Apprentice


Joined: 19 Mar 2015
Posts: 203

PostPosted: Wed Apr 15, 2015 7:18 pm    Post subject: Reply with quote

Decided to re-disable the features and roll my own bash script that I run as root to solve the problem.

Code:
        bat_status=`sudo cat /sys/class/power_supply/BAT1/status` ;
        bat_charge_now=`sudo cat /sys/class/power_supply/BAT1/charge_now` ;
        bat_charge_full=`sudo cat /sys/class/power_supply/BAT1/charge_full` ;
        bat_charge_percent=`echo "$bat_charge_now / $bat_charge_full * 100" | bc -l` ;
        system_temp=`sudo cat /sys/class/thermal/thermal_zone0/temp` ;
        system_temp_c=`echo "$system_temp / 1000" | bc -l` ;
        echo "Battery: ${bat_status} (${bat_charge_percent%.*}%), Temp: ${system_temp_c%.*}C" ;


Wonder why no one has patched acpitool to look in the right directories yet.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum