Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
USB mouse continually connecting/disconnecting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Progman3K
l33t
l33t


Joined: 03 Jan 2004
Posts: 665

PostPosted: Fri Apr 17, 2015 2:06 pm    Post subject: USB mouse continually connecting/disconnecting Reply with quote

Hi!

I have a perfectly-functioning mouse, except that the dmesg log is filling with these:

Quote:
[ 3613.706183] usb 2-1.2: USB disconnect, device number 75
[ 3615.163329] usb 2-1.2: new low-speed USB device number 76 using ehci-pci
[ 3615.256698] usb 2-1.2: New USB device found, idVendor=046d, idProduct=c05a
[ 3615.260338] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 3615.264007] usb 2-1.2: Product: USB Optical Mouse
[ 3615.267556] usb 2-1.2: Manufacturer: Logitech
[ 3615.283855] input: Logitech USB Optical Mouse as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/0003:046D:C05A.004B/input/input77
[ 3615.301075] hid-generic 0003:046D:C05A.004B: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Optical Mouse] on usb-0000:00:1d.0-1.2/input0

The above block repeats every ~10 seconds with only the bolded numbers incrementing by one each time.

Other USB devices plugged into the same system (even in the same physical port) DON'T do this.

Does anyone have any idea what is wrong or how to prevent the log from filling with such messages?

Thanks!
Back to top
View user's profile Send private message
MageSlayer
Apprentice
Apprentice


Joined: 26 Jul 2007
Posts: 250
Location: Ukraine

PostPosted: Sun Apr 19, 2015 3:09 pm    Post subject: Re: USB mouse continually connecting/disconnecting Reply with quote

It might be related to autosuspend in laptop-mode-tools package.
Do you have it running?
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1766
Location: Here and Away Again

PostPosted: Mon Apr 20, 2015 2:21 pm    Post subject: ><)))°€ Reply with quote

How long have you been experiencing this, and did you recently upgrade your kernel?

I ask because I started seeing the same sort of thing here after the latest change to I believe from sys-kernel/ck-sources-3.18.3 to 3.19.3.

For me it's not happening that often, however, and instead, rather randomly from the looks of it. Probably only when moving the mouse, too, which does make me believe it might just be the cord that is broken (it went bad before, and I cut it and re-soldered things several years ago). That said I can't get it to do it if I actually try and wiggle the cord for example.

I am soon going for 4.0.0 though, and if it's still happening, I guess I'll try running 3.18.3 for a while again.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2613

PostPosted: Mon Apr 20, 2015 2:37 pm    Post subject: Re: USB mouse continually connecting/disconnecting Reply with quote

Progman3K wrote:
Hi!

I have a perfectly-functioning mouse, except that the dmesg log is filling with these:

Quote:
[ 3613.706183] usb 2-1.2: USB disconnect, device number 75
[ 3615.163329] usb 2-1.2: new low-speed USB device number 76 using ehci-pci
[ 3615.256698] usb 2-1.2: New USB device found, idVendor=046d, idProduct=c05a
[ 3615.260338] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 3615.264007] usb 2-1.2: Product: USB Optical Mouse
[ 3615.267556] usb 2-1.2: Manufacturer: Logitech
[ 3615.283855] input: Logitech USB Optical Mouse as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/0003:046D:C05A.004B/input/input77
[ 3615.301075] hid-generic 0003:046D:C05A.004B: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Optical Mouse] on usb-0000:00:1d.0-1.2/input0
Almost same problem here with the bult-in fingerprint reader. Still unsolved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum