Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
WinXP in primary Partition -> grub.cfg -> no booting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Mati
Apprentice
Apprentice


Joined: 02 Sep 2008
Posts: 172

PostPosted: Fri Apr 17, 2015 7:24 pm    Post subject: WinXP in primary Partition -> grub.cfg -> no booting Reply with quote

HI there,

i'm using grub.cfg and have windows xp on my primary partition with ntfs (dev/sda1) while my gentoo and all other stuff is on the extended partition. I modified my grub.cfg (see below)
but when hitting during booting the windows xp thing, the system simply reboots. How does the entry for the windows xp system have to look like in order to boot properly?

Do you need som more information?

Thanks a lot!

Code:

menuentry "Windows XP " {
     insmod part_msdos
     insmod ntldr
     insmod ntfs
     ntldr (hd0,msdos1)/ntldr
}

# THIS ENTRY DOES NOT WORK AS WELL -> IT COMES UP WITH ERRORS ON VALUES!
menuentry "Windows test" {
     insmod part_msdos
     insmod chain
     drivemap hd0 hd1
     chainloader (hd1,msdos2)+1
}

Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2617

PostPosted: Sat Apr 18, 2015 6:16 am    Post subject: Reply with quote

You might want to use sys-boot/os-prober.
Back to top
View user's profile Send private message
Mati
Apprentice
Apprentice


Joined: 02 Sep 2008
Posts: 172

PostPosted: Sat Apr 18, 2015 8:03 am    Post subject: Reply with quote

Hi,

thanks, but i installed and ran the grub-make-config thing to automatically detect the system. However, it only detected

Code:

Generating grub configuration file ...
Linux-Abbild gefunden: /boot/kernel-3.18.7-gentoo
Linux-Abbild gefunden: /boot/vmlinuz-3.12.21-gentoo-r1


an no windows.

Also in the grub.cfg there is no menu-entry windows...

thanks for further help (i never used os-prober)
Back to top
View user's profile Send private message
wjn
n00b
n00b


Joined: 18 Apr 2015
Posts: 14
Location: JP

PostPosted: Sat Apr 18, 2015 11:38 am    Post subject: Re: WinXP in primary Partition -> grub.cfg -> no booti Reply with quote

Hello.

Anyway, /dev/sda1 is (hd0,msdos1).
"chainloader (hd1,msdos2)+1" is invalid in this case.

For example, try
Code:

menuentry "Windows XP (loader) (on /dev/sda1)" --class windows --class os {
        insmod part_msdos
        insmod ntfs
        set root='(hd0,msdos1)'
        chainloader +1
}



Mati wrote:

Code:

# THIS ENTRY DOES NOT WORK AS WELL -> IT COMES UP WITH ERRORS ON VALUES!
menuentry "Windows test" {
     insmod part_msdos
     insmod chain
     drivemap hd0 hd1
     chainloader (hd1,msdos2)+1
}

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum