Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel 4.0.0 not booting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Stepan
n00b
n00b


Joined: 18 Apr 2015
Posts: 2

PostPosted: Sat Apr 18, 2015 8:11 pm    Post subject: Kernel 4.0.0 not booting Reply with quote

Hello,
I've just compiled kernel 4.0.0 from gentoo-sources and it doesn't boot at all - only black screen before anything (any printk etc).

Config file is almost same as on working 3.19.3 kernel: http://pastebin.com/0Xg5n3Ab

I use kernel as EFI application to boot, ramdisk is embedded in the kernel and cmd line too.

Thank you for your help in advance.
Back to top
View user's profile Send private message
Stepan
n00b
n00b


Joined: 18 Apr 2015
Posts: 2

PostPosted: Sat Apr 18, 2015 8:35 pm    Post subject: Reply with quote

I found "solution"/workaround I don't understand. But If I add
CONFIG_EARLY_PRINTK_EFI=y
It starts booting OK
Back to top
View user's profile Send private message
fulminemizzega
n00b
n00b


Joined: 09 Jun 2013
Posts: 12

PostPosted: Sun May 03, 2015 5:14 pm    Post subject: Also kernel 4.0.1 NOT booting Reply with quote

Hi Stepan,
just solved the same issue you had, but with a different solution, check this (since you also use LZ4 compressed kernel image):
https://bugs.gentoo.org/show_bug.cgi?id=546422

I already had CONFIG_EARLY_PRINTK_EFI=y set in my kernel, changing the compression algorithm fixed it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum