Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No mouse and / or keyboard after startx
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
avitase
n00b
n00b


Joined: 26 Apr 2015
Posts: 37

PostPosted: Sun Apr 26, 2015 5:45 pm    Post subject: No mouse and / or keyboard after startx Reply with quote

Hey guys,
I am trying to install gentoo. I followed the instructions in https://wiki.gentoo.org/wiki/Xorg/Configuration and everything went fine until I type startx. TWM is showing up and I see my mousepointer but I cannot move it. The same for my keyboard - I can see it (obviously ;) ) but typing does not have any effect. Also the capslock light and numpad light etc. do not work.

During installation I used emerge --update --deep --with-bdeps=y --newuse @world; don't know if that can cause any problems.
My /etc/portage/make.conf contains the following
Code:

INPUT_DEVICES="evdev synaptics"
VIDEO_CARDS="nvidia"

I also have recompiled x11-base/xorg-server, x11-drivers/xf86-input-evdev and -synaptics.

/var/log/Xorg.0.log is empty.

I choosed the default/linux/amd64/13.0/desktop profile.

Is it normal, that there is no /etc/init.d/hald?
Back to top
View user's profile Send private message
wjn
n00b
n00b


Joined: 18 Apr 2015
Posts: 14
Location: JP

PostPosted: Sun Apr 26, 2015 6:56 pm    Post subject: Reply with quote

Hello,

Try
Code:
INPUT_DEVICES="evdev mouse keyboard"


And emerge x11-drivers/xf86-input-keyboard x11-drivers/xf86-input-mouse
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7094
Location: Saint Amant, Acadiana

PostPosted: Sun Apr 26, 2015 7:03 pm    Post subject: Reply with quote

Code:
INPUT_DEVICES="evdev synaptics"

The above will handle mice and keyboards, kernel must support evdev for this to work.

INPUT_EVDEV [=y]
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
avitase
n00b
n00b


Joined: 26 Apr 2015
Posts: 37

PostPosted: Sun Apr 26, 2015 9:06 pm    Post subject: Reply with quote

Thanks Jaglover for your reply. I checked my kernel config (via make menuconfig):
Code:
Device Drivers -> Input device support -> <*>  Event interface
, as well as
Code:
-*- Generic input layer

Is that the module you asked me for?

@Wjn (thanks for your reply, too)
I already tried this, but it didn't work either:(

Any other suggestions? Are there other things I could miss in my kernel?

EDIT: I don't know, if this is related to my problem, but when I shutdown there is the error:
Code:
udev: Failed to stop udev using udevadm

Code:
udev: start-stop-daemon: no matching process found
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sun Apr 26, 2015 10:09 pm    Post subject: Reply with quote

definitely related.
are you using openrc or systemd or ??? as your init?
add x11-base/xorg-server udev to /etc/portage/package.use and repeat emerge xorg-server
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7094
Location: Saint Amant, Acadiana

PostPosted: Sun Apr 26, 2015 11:17 pm    Post subject: Reply with quote

Maybe DEVTMPFS is not enabled in kernel.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
avitase
n00b
n00b


Joined: 26 Apr 2015
Posts: 37

PostPosted: Mon Apr 27, 2015 5:27 am    Post subject: Reply with quote

@DONAHUE: I am using openrc. I already have added this flag and recompiled xorg-server, but it didn't work.
Code:

# eix -I xorg-server
...
Installed version: 1.16.4 (glamor ipv6 nptl suid udev xorg -dmx -static-libs -systemd -tslib -unwind -xnest -xvfb ...


@Jaglover: The module "Maintain a devtmpfs filesystem to mount at /dev" was marked as 'built-in'. "Automount devtmpfs at /dev, after the kernel mounted the rootf" was not activated. I now have activated it, but, nevertheless, I have the same problem.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Mon Apr 27, 2015 3:41 pm    Post subject: Reply with quote

rc-update show
udev and udev-mount in sysinit runlevel ?
dbus in default runlevel ?
rc-status
dbus and udev running?
are keyboard and mouse wired or wireless?
if wired, ps2 or usb or ...
if wireless, how is the receiver connected?
make and model of keyboard and mouse?
boot the livemedia and wgetpaste /var/log/dmesg and wgetpaste /var/log/rc.log
_________________
Defund the FCC.
Back to top
View user's profile Send private message
avitase
n00b
n00b


Joined: 26 Apr 2015
Posts: 37

PostPosted: Tue Apr 28, 2015 3:33 pm    Post subject: Reply with quote

rc-update show
Code:

             bootmisc | boot                         
               cronie |      default                 
                 dbus |      default                 
                devfs |                       sysinit
                dmesg |                       sysinit
                 fsck | boot                         
             hostname | boot                         
              hwclock | boot                         
              keymaps | boot                         
            killprocs |              shutdown       
    kmod-static-nodes |                       sysinit
                local |      default                 
           localmount | boot                         
             loopback | boot                         
              modules | boot                         
             mount-ro |              shutdown       
                 mtab | boot                         
             net.eth0 |      default                                                         
             netmount |      default                                                         
               procfs | boot                                                                 
                 root | boot                                                                 
            savecache |              shutdown                                                 
                 swap | boot                                                                 
            swapfiles | boot                                                                 
               sysctl | boot                                                                 
                sysfs |                       sysinit                                         
            syslog-ng |      default                                                         
         termencoding | boot                                                                 
         tmpfiles.dev |                       sysinit                                         
       tmpfiles.setup | boot                                                                 
                 udev |                       sysinit                                         
              urandom | boot

-> I don't see udev-mount...

rc-status (before starting X)
https://bpaste.net/show/6b15146bc297

wgetpaste /var/log/dmesg
https://bpaste.net/show/5582985feae3

wgetpaste /var/log/rc.log
https://bpaste.net/show/0bbc1685007d

My Computer is a Laptop and I use it's keyboard, as well as an external USB mouse (but I have also tried the trackpad).
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Tue Apr 28, 2015 4:11 pm    Post subject: Reply with quote

log and dmesg look (unfortunately) fine
udev mount functions were incorporated into udev a few months back, not a problem.
please pastebin /var/log/Xorg.0.log if it now exists
does emerge -s nvidia-drivers show nvidia-drivers installed? do you have a /etc/X11/xorg.conf file? If not generated using nvidia-xconfig, you might try it. any content in /etc/X11/xorg.conf.d ?
did you run rc-status and check if dbus and udev still running?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
avitase
n00b
n00b


Joined: 26 Apr 2015
Posts: 37

PostPosted: Tue Apr 28, 2015 8:23 pm    Post subject: Reply with quote

sry that I forgot the rc-status in my last post:
https://bpaste.net/show/5ac98254509b
there is no udev? O.o

There is no /var/log/Xorg.0.log (it does exist, but it is empty), as well as /etc/X11/xorg.conf.d (this even does not exist).
/etc/X11/xorg.conf does exist and has the auto generated content of nvidia-xconfig:
https://bpaste.net/show/98e6901e6fe5

I am totaly new to gentoo, so I am not sure, if I understand the output of emerge -s right:
https://bpaste.net/show/fa30354110f1
but in comparison with the output of
Code:
eix -I nvidia-drivers
I think the (right) driver is installed.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Tue Apr 28, 2015 10:24 pm    Post subject: Reply with quote

rc-status udev sysinit is the current format. another of my senior moments.
no /var/log/Xorg.0.log is way beyond strange. xorg.conf.d is a user option place to store original ideas. xorg.conf looks normal for nvidia-xconfig.
Try running
Code:
 X -retro
If all goes well a black and white stippled screen with a moveable mouse. If badly, Xorg.0.log?
You have tried startx as root and regular user?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Wed Apr 29, 2015 1:38 am    Post subject: Reply with quote

does
Code:
ls -l ~/.local/share/xorg/
exist, perhaps with a logfile?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
avitase
n00b
n00b


Joined: 26 Apr 2015
Posts: 37

PostPosted: Wed Apr 29, 2015 9:42 am    Post subject: Reply with quote

There is neither ~/.local for my user nor for root and Xorg.0.log is still empty (after executing X -retro, the nvidia splashscreen came up and afterwards the promised stippled screen, but--again--no mouse or keyboard -> I always have to kill my laptop by pressing the power button, because it is not possible to move to a tty)
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Wed Apr 29, 2015 2:14 pm    Post subject: Reply with quote

does /usr/lib/xorg/modules/input/evdev_drv.so exist?
It may help to enable modules of any item that resembles your laptop In menuconfig section:
Quote:
Device Drivers --->
[*] X86 Platform Specific Device Drivers --->
--- X86 Platform Specific Device Drivers
< > Acer Aspire One temperature and fan driver (NEW)
< > Asus Laptop Extras (NEW)
< > Dell Latitude freefall driver (ACPI SMO88XX) (NEW)
< > Fujitsu Laptop Extras (NEW)
< > Fujitsu Tablet Extras (NEW)
< > Fujitsu-Siemens Amilo rfkill support (NEW)
< > HP laptop accelerometer (NEW)
< > HP wireless button (NEW)
< > MSI Laptop Extras (NEW)
< > Panasonic Laptop Extras (NEW)
< > Sony Laptop Extras (NEW)
< > Lenovo IdeaPad Laptop Extras (NEW)
< > ThinkPad ACPI Laptop Extras (NEW)
< > Thinkpad Hard Drive Active Protection System (hdaps) (NEW)
< > Thermal Management driver for Intel menlow platform (NEW)
<M> WMI (NEW)
< > Topstar Laptop Extras (NEW)
< > Toshiba Bluetooth RFKill switch support (NEW)
< > Toshiba HDD Active Protection Sensor (NEW)
< > CMPC Laptop Extras (NEW)
< > Intel Intelligent Power Sharing (NEW)
< > Device driver to enable PRTL support (NEW)
< > Samsung Laptop driver (NEW)
< > Intel Oaktrail Platform Extras (NEW)
< > Samsung Q10 Extras (NEW)
< > Apple Gmux Driver (NEW)
< > Intel Rapid Start Technology Driver (NEW)
< > Intel Smart Connect disabling driver (NEW)
< > pvpanic device support (NEW)
and redoing the kernel.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
avitase
n00b
n00b


Joined: 26 Apr 2015
Posts: 37

PostPosted: Wed Apr 29, 2015 3:29 pm    Post subject: Reply with quote

I had enabled all Dell options:(

But it really seems to be the Kernel, who causes the problem. I just have installed a genkernel and everything works fine. There is even no error during reboot.
Do I have to pay attention, when I want to change from genkernel to a self compiled one?
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7693
Location: Pelotas, BR

PostPosted: Wed Apr 29, 2015 3:43 pm    Post subject: Reply with quote

avitase wrote:
I had enabled all Dell options:(

But it really seems to be the Kernel, who causes the problem. I just have installed a genkernel and everything works fine. There is even no error during reboot.
Do I have to pay attention, when I want to change from genkernel to a self compiled one?


If genkernel's kernel works, you might want to take note of the modules that are being loaded when you run X.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
avitase
n00b
n00b


Joined: 26 Apr 2015
Posts: 37

PostPosted: Wed Apr 29, 2015 3:47 pm    Post subject: Reply with quote

Should I check the modules when using genkernel? How can I check this?
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7693
Location: Pelotas, BR

PostPosted: Wed Apr 29, 2015 4:10 pm    Post subject: Reply with quote

avitase wrote:
Should I check the modules when using genkernel? How can I check this?


Genkernel will provide a lot of modules for things that you have and things that you don't.

It's easy to do a
Code:

lsmod


afterwards and get the list of loaded modules. Anything missing from this list when you run your own kernel and that breaks X will probably be a guilty party.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43221
Location: 56N 3W

PostPosted: Wed Apr 29, 2015 5:31 pm    Post subject: Reply with quote

avitase,

A few things to poke at.

First, reduce your xorg.conf to just
Code:
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection
comment the rest out. You may want to add some settings back later.
This is the bare minimum to run with the nVidia binary blob.
It will give you a US keymap.

The
Code:
Option         "Device" "/dev/input/mice"
Driver         "mouse"
and
Code:
Driver         "kbd"
are certainly wrong but they should be ignored with evdev in use.

You seemed to be concerned about udev not running.
Check with
Code:
ps -Alf | grep udevd


Code:
$ ps -Alf | grep udevd
Warning: /usr/src/linux/System.map has an incorrect kernel version.
5 S root       200     1  0  80   0 -  9221      - Apr28 ?        00:00:00 /lib/systemd/systemd-udevd --daemon
4 S root      4720  4713  0  80   0 -  1682      - 18:24 pts/0    00:00:00 grep --colour=auto udevd

The important bit is /lib/systemd/systemd-udevd --daemon. If you don't have that xorg will not auto detect your input devices.

Can you ssh into this system from another PC?
That will allow some remote control and diagnostics.

When twm starts and you lose control, do you get text prompts in the three xterm windows?

Which profile are you using?
Code:
eselect profile list
will show an * against the selected profile.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum