Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HELP] Kernel panic - not syncing : Attemted to kill init!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
tattonaga
n00b
n00b


Joined: 02 Mar 2015
Posts: 11

PostPosted: Mon May 04, 2015 6:24 am    Post subject: [HELP] Kernel panic - not syncing : Attemted to kill init! Reply with quote

help me for solve this problem, i dont know how to fix it :(

http://s1081.photobucket.com/user/boytechno/media/IMG_20150504_125227.jpg.html
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2574

PostPosted: Mon May 04, 2015 6:53 am    Post subject: Reply with quote

It looks like you didn't specify a correct root= option here. Fixing it will probably fix your problem.

It looks to me like switch_root is trying to run /sbin/init from the filesystem and failing, probably because it thinks the wrong partition is your root.

We need more information to be more helpful. What boot loader are you using? How is it configured? What partitions did you use for your install? How was that initramfs generated?
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
tattonaga
n00b
n00b


Joined: 02 Mar 2015
Posts: 11

PostPosted: Mon May 04, 2015 7:12 am    Post subject: Reply with quote

The Doctor wrote:
It looks like you didn't specify a correct root= option here. Fixing it will probably fix your problem.

It looks to me like switch_root is trying to run /sbin/init from the filesystem and failing, probably because it thinks the wrong partition is your root.

We need more information to be more helpful. What boot loader are you using? How is it configured? What partitions did you use for your install? How was that initramfs generated?


i just restart my pc, i dont know why this error happen. previously not error like this.
my partition
/dev/sda1 boot
/dev/sda2 swap
/dev/sda3 root
i use grub2, i just run this command for make grub "grub2-install /dev/sda" and "grub2-mkconfig -o /boot/grub/grub.cfg"
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2574

PostPosted: Mon May 04, 2015 6:23 pm    Post subject: Reply with quote

We need to see more, probably the grub.cfg and whatever files you had to edit to generate that.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum