Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mce: Unable to init device /dev/mcelog
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
dab_s_bad
n00b
n00b


Joined: 08 May 2008
Posts: 54
Location: Toledo City, Cebu, Philippines

PostPosted: Mon May 04, 2015 3:43 pm    Post subject: mce: Unable to init device /dev/mcelog Reply with quote

just browsing my dmesg on my Geode System :)..., but for some reason I see this error/warning.

Code:
[    1.189656] mce: Unable to init device /dev/mcelog (rc: -5)


how can we solve this? or MCE on Geode is not supported perhaps?

I see from the website: http://www.mcelog.org/installation.html
and it indicates to create a udev rule but am not sure how to do it :(

here is what the website is suggesting:
Quote:
Verify you got a /dev/mcelog. If not create one with mknod /dev/mcelog c 10 227 On udev based systems you can also add a udev rule file in /usr/lib/udev/rules.d like
ACTION=="add", KERNEL=="mcelog", SUBSYSTEM=="misc", TAG+="systemd", ENV{SYSTEMD_WANTS}+="mcelog.service"
This is needed if the /dev is not persistent, as in many newer distributions. Typically the distribution package for mcelog takes care of that.


does creating the udev rule solves this?, any insights from our elite people here!? ^_^

my kernel contains:
Code:
CONFIG_X86_MCE=y
# CONFIG_X86_MCE_INTEL is not set
CONFIG_X86_MCE_AMD=y
# CONFIG_X86_ANCIENT_MCE is not set
CONFIG_X86_MCE_THRESHOLD=y
CONFIG_X86_MCE_INJECT=m
CONFIG_EDAC_DECODE_MCE=m
# CONFIG_EDAC_MCE_INJ is not set


btw..., the geode system is not systemd type but openrc. and on booting my system, I have a kernel + initrd (from Genkernel) as I have an LVM + separate /usr if this helps a bit.

if need to give further info, please let me know.

thanks in advance
Back to top
View user's profile Send private message
dab_s_bad
n00b
n00b


Joined: 08 May 2008
Posts: 54
Location: Toledo City, Cebu, Philippines

PostPosted: Wed May 06, 2015 12:13 pm    Post subject: Reply with quote

did try "mknod /dev/mcelog c 10 227" but still the same thing, will still have to experiment with udev rules
Back to top
View user's profile Send private message
dab_s_bad
n00b
n00b


Joined: 08 May 2008
Posts: 54
Location: Toledo City, Cebu, Philippines

PostPosted: Sun May 10, 2015 2:22 am    Post subject: Reply with quote

just tried to run mcelog and it is saying that the Geode Proc is not supported. I'll just have to disable then mce from kernel in the future
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum