Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
unable to compile ATI drivers in 4.0.1 hardened sources
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
lutel
Tux's lil' helper
Tux's lil' helper


Joined: 19 Oct 2003
Posts: 93
Location: Pomroczna

PostPosted: Fri May 08, 2015 6:42 am    Post subject: unable to compile ATI drivers in 4.0.1 hardened sources Reply with quote

Hi,

I got the error while emerging ATI drivers (the same for 14.12-r3), anyone succeed in compiling this?

Cheers
Tomek

Code:
>>> Emerging (2 of 2) x11-drivers/ati-drivers-15.1::gentoo
 * fglrx-installer_15.200.orig.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                               [ ok ]
 * xvba-sdk-0.74-404001.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                      [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     4.0.1-hardened-GR
 *
 * Please note that this driver only supports graphic cards based on
 * Evergreen chipset and newer.
 * This includes the AMD Radeon HD 5400+ series at this moment.
 *
 * If your card is older then use x11-drivers/xf86-video-ati
 * For migration informations please refer to:
 * http://www.gentoo.org/proj/en/desktop/x/x11/ati-migration-guide.xml
 *
>>> Unpacking source...
>>> Unpacking fglrx-installer_15.200.orig.tar.gz to /tmp/portage/x11-drivers/ati-drivers-15.1/work
>>> Unpacking xvba-sdk-0.74-404001.tar.gz to /tmp/portage/x11-drivers/ati-drivers-15.1/work/xvba_sdk
>>> Source unpacked in /tmp/portage/x11-drivers/ati-drivers-15.1/work
>>> Preparing source in /tmp/portage/x11-drivers/ati-drivers-15.1/work ...
 * Applying ati-powermode-opt-path-3.patch ...                                                                                                           [ ok ]
 * Applying ati-drivers-x32_something_something.patch ...                                                                                                [ ok ]
 * Applying ati-drivers-12.9-KCL_AGP_FindCapsRegisters-stub.patch ...                                                                                    [ ok ]
 * Applying ati-drivers-13.8-beta-include-seq_file.patch ...                                                                                             [ ok ]
 * Applying fgl_glxgears-do-not-include-glATI.patch ...                                                                                                  [ ok ]
 * Applying const-notifier-block.patch ...                                                                                                               [ ok ]
 * Applying use-kernel_fpu_begin.patch ...                                                                                                               [ ok ]
>>> Source prepared.
>>> Configuring source in /tmp/portage/x11-drivers/ati-drivers-15.1/work ...
>>> Source configured.
>>> Compiling source in /tmp/portage/x11-drivers/ati-drivers-15.1/work ...
 * Preparing fglrx module
make -j8 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- 'LDFLAGS=-m elf_x86_64' GCC_VER_MAJ=4 KVER=4.0.1-hardened-GR KDIR=/usr/src/linux 'CFLAGS_MODULE+=-DMODULE -DATI -DFGL' CFLAGS_MODULE+=-DCOMPAT_ALLOC_USER_SPACE=arch_compat_alloc_user_space kmod_build
make -C /usr/src/linux SUBDIRS=/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory '/usr/src/linux-4.0.1-hardened'

  WARNING: Symbol version dump ./Module.symvers
           is missing; modules will have no dependencies and modversions.

  CC [M]  /tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
  CC [M]  /tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
  CC [M]  /tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_agp.o
  CC [M]  /tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_debug.o
  CC [M]  /tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o
  CC [M]  /tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_io.o
  CC [M]  /tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_pci.o
  CC [M]  /tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_str.o
  CC [M]  /tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_iommu.o
/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_str.c: In function ‘KCL_STR_Strnicmp’:
/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_str.c:172:5: error: implicit declaration of function ‘strnicmp’ [-Werror=implicit-function-declaration]
     return strnicmp(s1, s2, count);
     ^
cc1: some warnings being treated as errors
scripts/Makefile.build:258: recipe for target '/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_str.o' failed
make[2]: *** [/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_str.o] Error 1
make[2]: *** Waiting for unfinished jobs....
/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.c:839:20: warning: ‘KCL_ACPI_Slot_No_Hotplug’ defined but not used [-Wunused-function]
 static acpi_status KCL_ACPI_Slot_No_Hotplug(KCL_ACPI_DevHandle handle, u32 lvl, void *data, void **rv)
                    ^
/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_iommu.c: In function ‘KCL_IOMMU_CheckInfo’:
/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_iommu.c:237:21: warning: unused variable ‘pdev’ [-Wunused-variable]
     struct pci_dev* pdev = (struct pci_dev*)pcidev;
                     ^
/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘kcl_mem_pat_setup’:
/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4501:9: error: implicit declaration of function ‘read_cr4’ [-Werror=implicit-function-declaration]
         cr4 = read_cr4();
         ^
/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4502:9: error: implicit declaration of function ‘write_cr4’ [-Werror=implicit-function-declaration]
         write_cr4(cr4 & ~X86_CR4_PGE);
         ^
/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_iommu.c: In function ‘KCL_IOMMU_RestoreCBs’:
/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_iommu.c:230:1: warning: control reaches end of non-void function [-Wreturn-type]
 }
 ^
/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: At top level:
/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:6426:12: warning: ‘KCL_fpu_save_init’ defined but not used [-Wunused-function]
 static int KCL_fpu_save_init(struct task_struct *tsk)
            ^
cc1: some warnings being treated as errors
scripts/Makefile.build:258: recipe for target '/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o' failed
make[2]: *** [/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
Makefile:1468: recipe for target '_module_/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x' failed
make[1]: *** [_module_/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[1]: Leaving directory '/usr/src/linux-4.0.1-hardened'
Makefile:88: recipe for target 'kmod_build' failed
make: *** [kmod_build] Error 2
 * ERROR: x11-drivers/ati-drivers-15.1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/ati-drivers-15.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/ati-drivers-15.1::gentoo'`.
 * The complete build log is located at '/tmp/portage/x11-drivers/ati-drivers-15.1/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/x11-drivers/ati-drivers-15.1/temp/environment'.
 * Working directory: '/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x'
 * S: '/tmp/portage/x11-drivers/ati-drivers-15.1/work'

>>> Failed to emerge x11-drivers/ati-drivers-15.1, Log file:

>>>  '/tmp/portage/x11-drivers/ati-drivers-15.1/temp/build.log'

 * Messages for package x11-drivers/ati-drivers-15.1:

 *
 * Please note that this driver only supports graphic cards based on
 * Evergreen chipset and newer.
 * This includes the AMD Radeon HD 5400+ series at this moment.
 *
 * If your card is older then use x11-drivers/xf86-video-ati
 * For migration informations please refer to:
 * http://www.gentoo.org/proj/en/desktop/x/x11/ati-migration-guide.xml
 * ERROR: x11-drivers/ati-drivers-15.1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/ati-drivers-15.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/ati-drivers-15.1::gentoo'`.
 * The complete build log is located at '/tmp/portage/x11-drivers/ati-drivers-15.1/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/x11-drivers/ati-drivers-15.1/temp/environment'.
 * Working directory: '/tmp/portage/x11-drivers/ati-drivers-15.1/work/common/lib/modules/fglrx/build_mod/2.6.x'
 * S: '/tmp/portage/x11-drivers/ati-drivers-15.1/work'
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Fri May 08, 2015 6:55 pm    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=548118

if you use the patch or patches provided there, please post the results. Curious.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Vienna
n00b
n00b


Joined: 28 Sep 2008
Posts: 14

PostPosted: Sun May 17, 2015 10:13 pm    Post subject: Reply with quote

This patch did the trick (from the bugreport):
https://548118.bugs.gentoo.org/attachment.cgi?id=403430

Used x11 overlay and edited ebuild on ati-drivers-15.1
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Mon May 18, 2015 2:09 am    Post subject: Reply with quote

Thanks for the info!
_________________
Defund the FCC.
Back to top
View user's profile Send private message
lutel
Tux's lil' helper
Tux's lil' helper


Joined: 19 Oct 2003
Posts: 93
Location: Pomroczna

PostPosted: Mon May 18, 2015 6:03 am    Post subject: Reply with quote

Looking forward for the patch in the portage tree ;)
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Wed May 20, 2015 10:48 am    Post subject: Reply with quote

lutel wrote:
Looking forward for the patch in the portage tree ;)

That won't happen, because of licensing problems.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
lutel
Tux's lil' helper
Tux's lil' helper


Joined: 19 Oct 2003
Posts: 93
Location: Pomroczna

PostPosted: Wed May 20, 2015 3:07 pm    Post subject: Reply with quote

Surely you're joking! ATI drivers are already in the tree, patch is open source, why it can't be uploaded to portage?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Wed May 20, 2015 5:09 pm    Post subject: Reply with quote

the kernel-4.* source changed EXPORT_SYMBOL to EXPORT_SYMBOL_GPL for some functions that need to be used by firegl_public.c
googling "EXPORT_SYMBOL to EXPORT_SYMBOL_GPL" will give access to a lot of discussion
_________________
Defund the FCC.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri May 22, 2015 7:13 pm    Post subject: Reply with quote

DONAHUE wrote:
the kernel-4.* source changed EXPORT_SYMBOL to EXPORT_SYMBOL_GPL for some functions that need to be used by firegl_public.c
googling "EXPORT_SYMBOL to EXPORT_SYMBOL_GPL" will give access to a lot of discussion


ough - those kind of discussions again

either time for the kernel devs to change their stance

or the AMD devs to update their drivers :?


Nivida managed in the past to get their driver working - why not AMD, too ?


Either that access is crucial for the function of the driver and can't be circumvented

or they're having a hard time to do it (work on AMDGPU, rights department, etc.)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
theism
n00b
n00b


Joined: 12 Sep 2013
Posts: 2
Location: Chernigov

PostPosted: Tue Jun 02, 2015 3:48 pm    Post subject: Reply with quote

patch for fglrx 15.1 with kernel 4.0.4: http://blackcatlinux.narod.ru/trash/fglrx/fglrx15.1_src_fix.tar.bz2
Back to top
View user's profile Send private message
Aison
n00b
n00b


Joined: 14 Feb 2005
Posts: 3

PostPosted: Mon Jul 20, 2015 9:27 am    Post subject: Similar problem now for x11-drivers/ati-drivers-15.7 Reply with quote

x11-drivers/ati-drivers-15.7 is not compiling too :-(
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Mon Jul 20, 2015 1:59 pm    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=548118
https://bugs.gentoo.org/show_bug.cgi?id=554590
for discussions answers patches procedures
_________________
Defund the FCC.
Back to top
View user's profile Send private message
zolom
n00b
n00b


Joined: 07 Apr 2012
Posts: 32

PostPosted: Mon Jul 20, 2015 5:39 pm    Post subject: Reply with quote

Personally, I had trouble finding a patch -- my 'workaround' was simply living with an earlier kernel. :oops: I'm using fglrx 15.7 with gentoo sources 3.19.8.
Back to top
View user's profile Send private message
Elleni
l33t
l33t


Joined: 23 May 2006
Posts: 858

PostPosted: Mon Jul 20, 2015 10:12 pm    Post subject: Reply with quote

Found working patch for ati-drivers-15.7 in the second Link provided by DONAHUE:

https://bugs.gentoo.org/attachment.cgi?id=406958

works with gentoo-sources-4.1.2 :D

Thanks
Back to top
View user's profile Send private message
blue-ark
n00b
n00b


Joined: 26 Jul 2015
Posts: 5
Location: Germany/NRW

PostPosted: Sun Jul 26, 2015 8:39 pm    Post subject: Reply with quote

Hello Elleni and others :)

Would you explain, how you did apply this patch? I downloaded it from https://bugs.gentoo.org/show_bug.cgi?id=548118 (The 15.7-one), too. But I absolutely don't understand, how I should apply it. The Directory is an working directory. Somewhere I read, that the patch is not to be applied in the working directory. (I also think so). But where? ;)

Would be nice to know, how I can get installed the 15.7-fglrx on my gentoo (with kernel 4.1.3) too :)

Thanks a lot :)
_________________
GlG
blue-ark
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sun Jul 26, 2015 8:51 pm    Post subject: Reply with quote

Download 15.7-r1.patch to
/etc/portage/patches/x11-drivers/ati-drivers/15.7-r1.patch
Kernel-4.1.3 requires two patches to be run in a terminal:

sed -i 's/EXPORT_SYMBOL_GPL(cpu_tlbstate)/EXPORT_SYMBOL(cpu_tlbstate)/g' /usr/src/linux/arch/x86/mm/init.c

and

sed -i 's/EXPORT_SYMBOL_GPL(pci_ignore_hotplug)/EXPORT_SYMBOL(pci_ignore_hotplug)/g' /usr/src/linux/drivers/pci/pci.c

After these edits; recompile/reinstall the kernel and then emerge ati-drivers.

general info:
https://wiki.gentoo.org/wiki//etc/portage/patches
https://forums.gentoo.org/viewtopic-t-867029-start-0.html

Edit to get rid of my typo in second command
_________________
Defund the FCC.


Last edited by DONAHUE on Mon Jul 27, 2015 12:36 pm; edited 3 times in total
Back to top
View user's profile Send private message
blue-ark
n00b
n00b


Joined: 26 Jul 2015
Posts: 5
Location: Germany/NRW

PostPosted: Sun Jul 26, 2015 9:22 pm    Post subject: Reply with quote

Hello DONAHUE,

many many thanks for your so fast reply :) I wil go to try now :)
_________________
GlG
blue-ark
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sun Jul 26, 2015 10:35 pm    Post subject: Reply with quote

see edit above, fast but sloppy, I was,,,,
_________________
Defund the FCC.
Back to top
View user's profile Send private message
blue-ark
n00b
n00b


Joined: 26 Jul 2015
Posts: 5
Location: Germany/NRW

PostPosted: Mon Jul 27, 2015 3:29 am    Post subject: Reply with quote

Never mind, Donahue :) This can happen :) I wondered, yes, of course ;)

Because in the init.c-File under
Code:
arch/x86/mm
was not any
Code:
EXPORT_SYMBOL_GPL(pci_ignore_hotplug)
- entry. But the command could be applied ;)

Thought, probably used the wrong patch (there are two: 15.7 & 15.7-r1) Tried...

But now, refreshed the site and saw your edited post :)

Code:
sed -i 's/EXPORT_SYMBOL_GPL(pci_ignore_hotplug)/EXPORT_SYMBOL(pci_ignore_hotplug)/g' /usr/src/linuxdrivers/pci/pci.c
<- There only a slash have to be between "linux" and "drivers". Seen byself :)

Thanx a lot, Donahue :) Installation works now :)
_________________
GlG
blue-ark
Back to top
View user's profile Send private message
blue-ark
n00b
n00b


Joined: 26 Jul 2015
Posts: 5
Location: Germany/NRW

PostPosted: Mon Sep 07, 2015 1:38 am    Post subject: Reply with quote

Hello again ;)

After the Patching-"lessons" ;) I had changed the kernel between from 4.1.3 to 4.1.6. This change was without any problems: Only patched the kernel (GPL->Non-"GPL"-containing-strings).

But now, the kernel 4.2.0 and above causes problems again :(((((((

Patched with:

Code:

sed -i 's/EXPORT_SYMBOL_GPL(cpu_tlbstate)/EXPORT_SYMBOL(cpu_tlbstate)/g' /usr/src/linux/arch/x86/mm/init.c
sed -i 's/EXPORT_SYMBOL_GPL(pci_ignore_hotplug)/EXPORT_SYMBOL(pci_ignore_hotplug)/g' /usr/src/linux/drivers/pci/pci.c


Then I tried the Patch https://bugs.gentoo.org/show_bug.cgi?id=548118
named to "ati-drivers-15.7.patch". It is newer. Thought, it would be the compliant one for solving the issues since GLP&NON-GPL-"War".

What the hell is... To Kernel 4.x - ati-drivers built without a problem. So, might think: "No problem would occour for ever..." - But then, appeared Kernel-Tree 4.x and every-Kernel-change is getting a nervous-game :((((

Would like to ask, could help me anybody in the issue with Kernel-4.2.0-r1 and ati-drivers-15.7? Probably, there ist now a third "GPL"-one who have to change to "without"-GPL?

Thanks al lot previously :)))
_________________
GlG
blue-ark
Back to top
View user's profile Send private message
blue-ark
n00b
n00b


Joined: 26 Jul 2015
Posts: 5
Location: Germany/NRW

PostPosted: Tue Sep 08, 2015 7:22 am    Post subject: Reply with quote

Sorry for Reposting...

I have solved the issue: :D

There I got the error:
Code:
FATAL: modpost: GPL-incompatible module fglrx.ko uses GPL-only symbol 'kernel_fpu_end'


But in which file?

Today, I already thought, "however, will going back to 4.1.6..." but couldn't do. First wanted to make some experiments...

Providing this command:
Code:
grep -r -i 'EXPORT_SYMBOL_GPL(kernel_fpu_end)' /usr/src/linux


This found two Files in
Code:
/usr/src/linux/arch/x86/kernel/fpu

init.c
core.c

In whose the "_GPL" - Ending was to be erased. - Recompiled Kernel:
Code:
make && make modules_install


After this, Ati-Drivers could be rebuilt for the 4.2.0-r1-gentoo-sources by
Code:
emerge @modules_rebuild

_________________
GlG
blue-ark
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Mon Sep 14, 2015 6:44 am    Post subject: Reply with quote

Fernando Rodriguez has a solution at https://github.com/fernando-rodriguez/portage-overlay/tree/master/x11-drivers/ati-drivers . It has been tested on amd64 and compiles, installs, and runs on kernels 3.18.16, 4.1.6, and 4.2. It appears ready for addition to the testing branch. His work has no EXPORT_SYMBOL_GPL issues. It supports glxinfo and glxgears on kernel-4.2 . Manual download from the amd driver page is required. Fetch instructions are in the ebuild. Thanks, Fernando.
I have obsoleted my less effective offerings.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Pale
n00b
n00b


Joined: 23 Sep 2009
Posts: 14

PostPosted: Wed Sep 16, 2015 1:45 pm    Post subject: Reply with quote

I need a guide on how to use Fernando's ebuilds (whichever one works with kernel 4.1.6) or on how apply the patches in the bug reports.

I've tried making /usr/local/portage/x11-drivers/ati-drivers and put all the files from the git hub in there, creating digests, and adding PORDIR_OVERLAY="/usr/local/portage" to make.conf

if i cd to /usr/local/portage/x11-drivers/ati-drivers and run emerge "one of them.".ebuild it still fails to compile ( and warns me that directly targeting .ebuilds is broken). Doing emerge --ask x11-drivers/ati-drivers-15.7-r1 is not a vaild package atom. ( i thought pordir overlay was supposed to make that work )

The 15.7-r1 needed me to download some files manually, it took me forever to figure out where to put them (/usr/portage/distfiles), and the one I downloaded from ati was newer than the one in the ebuild file, i just renamed it to what it said in the ebuild. Still failed when i ran it from *.ebuild. Don't know how to run it any other way.

I'm making zero progress by googling and I've gotten really frustrated with myself. My head hurts.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Wed Sep 16, 2015 7:10 pm    Post subject: Reply with quote

Browse to http://support.amd.com/en-us/download/desktop/previous/detail?os=Linux%20x86_64&rev=15.7 to download the version you need so you can patch it. If necessary (I need to), move or copy amd-driver-installer-15.20.1046-x86.x86_64.zip to /usr/portage/distfiles and
chown portage:portage /usr/portage/distfiles/amd-driver-installer-15.20.1046-x86.x86_64.zip .
Browse to https://github.com/fernando-rodriguez/portage-overlay and actuate "Download ZIP" button .
unzip portage-overlay-master.zip .
I followed https://wiki.gentoo.org/wiki/Project:Overlays/User_Guide#Installing_layman to install layman and then to add the x11 overlay.
Then assuming that Fernando's files were downloaded to Downloads and unzipped there: cp -ar Downloads/portage-overlay-master/x11-drivers/ati-drivers /var/lib/layman/x11/x11-drivers/
Then ebuild /var/lib/layman/x11/x11-drivers/ati-drivers/ati-drivers-15.7-r1.ebuild manifest

/var/lib/layman/make.conf is location for PORTDIR_OVERLAY="
/var/lib/layman/x11
$PORTDIR_OVERLAY
"

BTW, the 15.7 version is replaced by 15.9 version, Fernando's current patches are for 15.7 version, 15.7 is available in the archive. Know nothing about 15.9 working.

Also BTW, the kernel 4.3-rc1 discontinues support for direct access to mtrr, ati-drivers with patches compiles against 4.3-rc1 but warns mtrr_add and mtrr_delete are undefined/not found. GUI operation in this condition is horrible; many apps fail to open with no report, others with segfault.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Pale
n00b
n00b


Joined: 23 Sep 2009
Posts: 14

PostPosted: Wed Sep 16, 2015 8:49 pm    Post subject: Reply with quote

Thanks for the quick reply! No luck sadly.

I made it to "ebuild /var/lib/layman/x11/x11-drivers/ati-drivers/ati-drivers-15.7-r1.ebuild manifest " then it complains about not being able to download 14.9 drivers. Why would it even try to download those? I thought I was getting 15.7.

Code:
!!! x11-drivers/ati-drivers-14.9-r1 has fetch restriction turned on.
!!! This probably means that this ebuild's files must be downloaded
!!! manually.  See the comments in the ebuild for more information.

 * The driver packages
 * amd-catalyst-14-9-linux-x86-x86-64.zip xvba-sdk-0.74-404001.tar.gz
 * need to be downloaded manually from
 * http://support.amd.com/en-us/download/desktop?os=Linux%20x86_64
 * and http://developer.amd.com/wordpress/media/2012/10/xvba-sdk-0.74-404001.tar.gz
!!! Fetch failed for amd-catalyst-14-9-linux-x86-x86-64.zip, can't update Manifest


I put xvba-sdk-0.74-404001.tar.gz in distfiles, but i think it may be for the 14.9 drivers. IDK. :x

emerge --ask =x11-drivers/ati-drivers-15.7-r1 does this every time even though i say yes now.
Code:
tux ati-drivers # emerge --ask =x11-drivers/ati-drivers-15.7-r1

 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] x11-drivers/ati-drivers-15.7-r1  USE="modules qt4 -debug -gdm-hack -pax_kernel -static-libs" ABI_X86="32 (64)"

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by =x11-drivers/ati-drivers-15.7-r1 (argument)
=x11-drivers/ati-drivers-15.7-r1 ~amd64

Would you like to add these changes to your config files? [Yes/No]


Update:
I did echo "=x11-drivers/ati-drivers-15.7-r1 ~amd64" >> /etc/portage/package.accept_keywords to get around the above.

Now I get Failed Patch: kernel-4.1.0-rc3.patch
Code:
 * Messages for package x11-drivers/ati-drivers-15.7-r1:

 *
 * Please note that this driver only supports graphic cards based on
 * Evergreen chipset and newer.
 * This includes the AMD Radeon HD 5400+ series at this moment.
 *
 * If your card is older then use x11-drivers/xf86-video-ati
 * For migration informations please refer to:
 * http://www.gentoo.org/proj/en/desktop/x/x11/ati-migration-guide.xml
 * Failed Patch: kernel-4.1.0-rc3.patch !
 *  ( /etc/portage/patches//x11-drivers/ati-drivers/kernel-4.1.0-rc3.patch )
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/x11-drivers/ati-drivers-15.7-r1/temp/kernel-4.1.0-rc3.patch.out
 * ERROR: x11-drivers/ati-drivers-15.7-r1::x11 failed (prepare phase):
 *   Failed Patch: kernel-4.1.0-rc3.patch!
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 3852:  Called epatch_user
 *   environment, line 1203:  Called epatch
 *   environment, line 1176:  Called die
 * The specific snippet of code:
 *               die "Failed Patch: ${patchname}!";
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/ati-drivers-15.7-r1::x11'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/ati-drivers-15.7-r1::x11'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-15.7-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-15.7-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/ati-drivers-15.7-r1/work'
 * S: '/var/tmp/portage/x11-drivers/ati-drivers-15.7-r1/work'


UPDATE: Its working now, that last error was my fault. I forgot to remove a patch I was trying earlier from /etc/portage/patches. DOH. Thanks Donahue.


Last edited by Pale on Wed Sep 16, 2015 11:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum