Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
unable to compile ATI drivers in 4.0.1 hardened sources
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Wed Sep 16, 2015 9:58 pm    Post subject: Reply with quote

ls /var/lib/layman/x11/x11-drivers/ati-drivers/
should yield:
ati-drivers-14.12-r3.ebuild ati-drivers-15.7.ebuild files
ati-drivers-15.1.ebuild ati-drivers-15.7-r1.ebuild Manifest
if not, if you see:
/usr/portage/x11-drivers/ati-drivers/files
/usr/portage/x11-drivers/ati-drivers/ati-drivers-14.4_p1.ebuild
/usr/portage/x11-drivers/ati-drivers/ati-drivers-14.6_beta2.ebuild
/usr/portage/x11-drivers/ati-drivers/ati-drivers-14.9-r2.ebuild
/usr/portage/x11-drivers/ati-drivers/ati-drivers-14.12-r2.ebuild
/usr/portage/x11-drivers/ati-drivers/ati-drivers-14.12-r3.ebuild
/usr/portage/x11-drivers/ati-drivers/ati-drivers-15.1.ebuild
/usr/portage/x11-drivers/ati-drivers/ati-drivers-15.7.ebuild
/usr/portage/x11-drivers/ati-drivers/ati-drivers-15.7-r1.ebuild
/usr/portage/x11-drivers/ati-drivers/ChangeLog
/usr/portage/x11-drivers/ati-drivers/Manifest
/usr/portage/x11-drivers/ati-drivers/metadata.xml
Fernando's files did not replace those at /var/lib/layman/x11/x11-drivers/ati-drivers

if the ls /var/lib/layman/x11/x11-drivers/ati-drivers/ is as expected portage may not be finding layman.
PORTDIR= should be in /var/lib/layman/make.conf not in /etc/portage/make.conf
is source /var/lib/layman/make.conf in /etc/portage/make.conf ?
do you have artifacts from last attempt?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
yaclo
n00b
n00b


Joined: 11 Sep 2015
Posts: 20

PostPosted: Fri Sep 18, 2015 3:35 pm    Post subject: Reply with quote

DONAHUE wrote:
Fernando Rodriguez has a solution at https://github.com/fernando-rodriguez/portage-overlay/tree/master/x11-drivers/ati-drivers . It has been tested on amd64 and compiles, installs, and runs on kernels 3.18.16, 4.1.6, and 4.2. It appears ready for addition to the testing branch. His work has no EXPORT_SYMBOL_GPL issues. It supports glxinfo and glxgears on kernel-4.2 . Manual download from the amd driver page is required. Fetch instructions are in the ebuild. Thanks, Fernando.
I have obsoleted my less effective offerings.


it's not working on 4.2
Code:

FATAL: modpost: GPL-incompatible module fglrx.ko uses GPL-only symbol 'kernel_fpu_end'
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Fri Sep 18, 2015 5:24 pm    Post subject: Reply with quote

you can run:
sed -i 's/EXPORT_SYMBOL_GPL(kernel_fpu_end)/EXPORT_SYMBOL(kernel_fpu_end)/g' /usr/src/linux/arch/x86/kernel/fpu/core.c
sed -i 's/EXPORT_SYMBOL_GPL(kernel_fpu_begin)/EXPORT_SYMBOL(kernel_fpu_begin)/g' /usr/src/linux/arch/x86/kernel/fpu/core.c
recompile the kernel
repeat the emerge

The same problem returned on my 4.2 kernels
_________________
Defund the FCC.
Back to top
View user's profile Send private message
yaclo
n00b
n00b


Joined: 11 Sep 2015
Posts: 20

PostPosted: Fri Sep 18, 2015 7:23 pm    Post subject: Reply with quote

DONAHUE wrote:
you can run:
sed -i 's/EXPORT_SYMBOL_GPL(kernel_fpu_end)/EXPORT_SYMBOL(kernel_fpu_end)/g' /usr/src/linux/arch/x86/kernel/fpu/core.c
sed -i 's/EXPORT_SYMBOL_GPL(kernel_fpu_begin)/EXPORT_SYMBOL(kernel_fpu_begin)/g' /usr/src/linux/arch/x86/kernel/fpu/core.c
recompile the kernel
repeat the emerge

The same problem returned on my 4.2 kernels


i fixed via other way :twisted:
Back to top
View user's profile Send private message
deltamalloc
Apprentice
Apprentice


Joined: 18 Jan 2013
Posts: 279

PostPosted: Sat Sep 19, 2015 8:39 pm    Post subject: Reply with quote

I'm having problems with this again. I'm on the 4.0.5-gentoo stable kernel.

Trying the patches I get:

Code:

 * Applying user patches from /etc/portage/patches//x11-drivers/ati-drivers ...
 *   kernel-4.0.5.patch ...

 * Failed Patch: kernel-4.0.5.patch !
 *  ( /etc/portage/patches//x11-drivers/ati-drivers/kernel-4.0.5.patch )
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/x11-drivers/ati-drivers-15.9/temp/kernel-4.0.5.patch.out

 * ERROR: x11-drivers/ati-drivers-15.9::gentoo failed (prepare phase):
 *   Failed Patch: kernel-4.0.5.patch!
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called pre_src_prepare
 *        bashrc, line    7:  Called epatch_user
 *   environment, line 1206:  Called epatch
 *   environment, line 1179:  Called die
 * The specific snippet of code:
 *               die "Failed Patch: ${patchname}!";
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/ati-drivers-15.9::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/ati-drivers-15.9::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-15.9/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-15.9/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/ati-drivers-15.9/work'
 * S: '/var/tmp/portage/x11-drivers/ati-drivers-15.9/work'


Full output of .out file:

https://bpaste.net/show/adf78bb603f5

Without the patches I get:

Code:

/var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.c:839:20: warning: 'KCL_ACPI_Slot_No_Hotplug' defined but not used [-Wunused-function]
 static acpi_status KCL_ACPI_Slot_No_Hotplug(KCL_ACPI_DevHandle handle, u32 lvl, void *data, void **rv)
                    ^
/var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:6436:12: warning: 'KCL_fpu_save_init' defined but not used [-Wunused-function]
 static int KCL_fpu_save_init(struct task_struct *tsk)
            ^
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_agp.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_debug.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_io.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_pci.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_str.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_iommu.o
/var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_str.c: In function 'KCL_STR_Strnicmp':
/var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_str.c:172:5: error: implicit declaration of function 'strnicmp' [-Werror=implicit-function-declaration]
     return strnicmp(s1, s2, count);
     ^
cc1: some warnings being treated as errors
scripts/Makefile.build:258: recipe for target '/var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_str.o' failed
make[2]: *** [/var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_str.o] Error 1
make[2]: *** Waiting for unfinished jobs....
/var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_iommu.c: In function 'KCL_IOMMU_RestoreCBs':
/var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_iommu.c:230:1: warning: control reaches end of non-void function [-Wreturn-type]
 }
 ^
Makefile:1390: recipe for target '_module_/var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x' failed
make[1]: *** [_module_/var/tmp/portage/x11-drivers/ati-drivers-15.9/work/common/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[1]: Leaving directory '/usr/src/linux-4.0.5-gentoo'
Makefile:88: recipe for target 'kmod_build' failed
make: *** [kmod_build] Error 2


What is the correct procedure to make this work now?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Sun Sep 20, 2015 4:06 pm    Post subject: Reply with quote

At this moment:
There is an ati-drivers-15.9.ebuild and patch files in portage being worked on; the digest is wrong, epatch'es are missing in files.
Fernando Rodriguez has a working ati-drivers-15.9.ebuild and patch files in his local portage overlay at
https://github.com/fernando-rodriguez/portage-overlay .

What I did:

Downloaded the AMD Catalyst™ 15.9 Proprietary Linux Graphics Driver
http://support.amd.com/en-us/download/desktop?os=Linux%20x86_64
to /usr/portage/distfiles
and ran
Code:
chown portage:portage /usr/portage/distfiles/amd-catalyst-15.9-linux-installer-15.201.1151-x86.x86_64.zip

Installed layman and then the X11 overlay following
https://wiki.gentoo.org/wiki/Project:Overlays/User_Guide#Installing_layman .

Downloaded Fernando's overlay
https://github.com/fernando-rodriguez/portage-overlay/archive/master.zip
to /root/Downloads/portage-overlay-master.zip .
and ran
Code:
unzip /root/Downloads/portage-overlay-master.zip
to create directory
/root/Downloads/portage-overlay-master
Then ran:
Code:
cp -ar /root/Downloads/portage-overlay-master/x11-drivers/ati-drivers/* /var/lib/layman/x11/x11-drivers/ati-drivers/
to update ebuilds and patch files to Fernando's.
Then ran:
Code:
ebuild /var/lib/layman/x11/x11-drivers/ati-drivers/ati-drivers-15.9.ebuild manifest
to update the digest.

Ran:
Code:
echo "x11-drivers/ati-drivers ~amd64" >> /etc/portage/package.keywords
I then tested Fernando's work by running
Code:
emerge ati-drivers
against kernels gentoo-sources-3.18.6, gentoo-sources-4.1.6, gentoo-sources-4.2.0-r1, git-sources-4.2-rc8, git-sources-4.3-rc1. All compiled, installed, ran xfce4, and ran glxinfo and glxgears. GUI performance was snappy in xfce4.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Wed Sep 23, 2015 2:53 pm    Post subject: Reply with quote

The portage tree has now incorporated Fernando Rodriguez' outstanding work as ati-drivers-15.9-r1 .
If you have implemented user patches for ati-drivers (as part of our 4 month struggle), suggest run
Code:
rm -rf /etc/portage/patches/x11-drivers/ati-drivers*
No longer needed and may cause problems.
AMD still has fetch restrictions imposed on the AMD Catalyst™ 15.9 Proprietary Linux Graphics Driver requiring a manual download of the AMD Catalyst™ 15.9 Proprietary Linux Graphics Driver from
http://support.amd.com/en-us/download/desktop?os=Linux%20x86_64
to /usr/portage/distfiles . After the download run:
Code:
chown portage:portage /usr/portage/distfiles/amd-catalyst-15.9-linux-installer-15.201.1151-x86.x86_64.zip
echo "ati-drivers ~amd64" >> /etc/portage/package.keywords
emerge --sync
emerge -1av ati-drivers

_________________
Defund the FCC.
Back to top
View user's profile Send private message
knightcode
n00b
n00b


Joined: 17 Apr 2016
Posts: 1
Location: New York, NY

PostPosted: Sun Apr 17, 2016 3:32 pm    Post subject: Reply with quote

Why am I still having a problem with 15.9-r1??? The error is "redefinition of '__flush_tlb_all' in fglrx.

Code:

/var/tmp/portage/x11-drivers/ati-drivers-15.9-r1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:259:0: warning: "__flush_tlb" redefined
 #define __flush_tlb() native_write_cr3(native_read_cr3())
 ^
In file included from ./arch/x86/include/asm/highmem.h:26:0,
                 from include/linux/highmem.h:34,
                 from /var/tmp/portage/x11-drivers/ati-drivers-15.9-r1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:123:
./arch/x86/include/asm/tlbflush.h:13:0: note: this is the location of the previous definition
 #define __flush_tlb() __native_flush_tlb()
 ^
/var/tmp/portage/x11-drivers/ati-drivers-15.9-r1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:261:20: error: redefinition of ‘__flush_tlb_all’
 static inline void __flush_tlb_all(void)
                    ^
In file included from ./arch/x86/include/asm/highmem.h:26:0,
                 from include/linux/highmem.h:34,
                 from /var/tmp/portage/x11-drivers/ati-drivers-15.9-r1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:123:
./arch/x86/include/asm/tlbflush.h:124:20: note: previous definition of ‘__flush_tlb_all’ was here
 static inline void __flush_tlb_all(void)
                    ^
/var/tmp/portage/x11-drivers/ati-drivers-15.9-r1/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:6490:12: warning: ‘KCL_fpu_save_init’ defined but not used [-Wunused-function]


emerge info:

Code:
[ebuild  N     ] x11-drivers/ati-drivers-15.9-r1  USE="modules qt4 -debug -gdm-hack -pax_kernel -static-libs"

Code:

Portage 2.2.26 (python 2.7.10-final-0, default/linux/x86/13.0/desktop/gnome/systemd, gcc-4.9.3, glibc-2.21-r2, 4.1.15-gentoo-r1 i686)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.1.15-gentoo-r1-i686-Intel-R-_Core-TM-_i5-2500_CPU_@_3.30GHz-with-gentoo-2.2
KiB Mem:     2761648 total,    894160 free
KiB Swap:    8388604 total,   8386752 free
Timestamp of repository gentoo: Sun, 03 Apr 2016 16:15:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r1::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.21-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.namerica.gentoo.org/gentoo-portage
    priority: -1000

bitcoin
    location: /var/lib/layman/bitcoin
    masters: gentoo
    priority: 0

java
    location: /var/lib/layman/java
    masters: gentoo
    priority: 1

barzog-overlay
    location: /var/lib/layman/barzog-overlay
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA dlj-1.1 skype-eula Oracle-BCLA-JavaSE"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.3/conf /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=core2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://www.gtlib.gatech.edu/pub/gentoo ftp://ftp.ussg.iu.edu/pub/linux/gentoo "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X Xaw3d a52 aac acl acpi alsa audiofile avahi bash-completion berkdb bluetooth branding bzip2 cairo cdb cdda cddb cdparanoia cdr cli colord cracklib crypt css cups cxx dbus dri dts dvb dvd dvdr dvdread eds emacs emboss encode exif fam ffmpeg firefox flac fontconfig fortran ftp gdbm gif gimp glamor gnome gnome-keyring gnome-online-accounts gnutls gpm graphviz gstreamer gtk hal iconv icu introspection ios ipod ipv6 java java5 java6 javascript jpeg jpeg2k lame lcms ldap libnotify libsecret lirc mad mmx mng modules mp3 mp4 mpeg mplayer mysql nas nautilus ncurses nls nptl ogg openal opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt3support quicktime readline samba sdl seccomp session smp sndfile spell sse2 sse3 ssl startup-notification svg systemd tcpd theora threads tiff tracker truetype udev udisks unicode upower usb v4l v4l2 vorbis wavpack win32codecs wxwidgets x264 x86 xattr xcb xine xinerama xml xulrunner xv xvid zeroconf zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="radeon intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum