Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[S]gnome 3.16 Blocks gnome-overlay Layman
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Mon May 11, 2015 6:44 am    Post subject: [S]gnome 3.16 Blocks gnome-overlay Layman Reply with quote

Hallo,

bekomme hier 2 Blocks.

Wie löst man die auf?

Code:
[ebuild     U  ] gnome-base/gnome-3.16.0 [3.14.0]
[blocks B      ] <dev-util/gdbus-codegen-2.44.0 ("<dev-util/gdbus-codegen-2.44.0" is blocking dev-libs/glib-2.44.0)
[blocks B      ] <x11-libs/gtk+-2.24.27-r2:2 ("<x11-libs/gtk+-2.24.27-r2:2" is blocking dev-util/gtk-update-icon-cache-3.14.13)


Last edited by Tinitus on Tue May 12, 2015 6:31 pm; edited 2 times in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3630
Location: Germany

PostPosted: Mon May 11, 2015 8:25 am    Post subject: Reply with quote

Hm, das sind allesamt Versionen die es so im aktuellen portage Tree noch nicht gibt.
Code:
eix -e gnome-base/gnome
* gnome-base/gnome
     Available versions:  (2.0) 3.12.0 3.14.0
       {accessibility +bluetooth +cdr +classic cups +extras}
     Homepage:            http://www.gnome.org/
     Description:         Meta package for GNOME 3, merge this package to install
folgedessen stammen die bei dir wahrscheinlich aus einem Overlay?
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Mon May 11, 2015 8:36 am    Post subject: Reply with quote

Ja dem gnome overlay....

Habe einen Bug Report aufgemacht. Und ein Problem schon lösen können...
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3630
Location: Germany

PostPosted: Mon May 11, 2015 8:53 am    Post subject: Reply with quote

Puh, deine Begabung uns mit Fehlinformationen zu versorgen ist beachtlich...
Füge dem Thread-Titel doch bitte die Info hinzu das es sich um ebulds aus einem Overlay handelt.
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Mon May 11, 2015 11:08 am    Post subject: Reply with quote

Josef.95 wrote:
Puh, deine Begabung uns mit Fehlinformationen zu versorgen ist beachtlich...
Füge dem Thread-Titel doch bitte die Info hinzu das es sich um ebulds aus einem Overlay handelt.


Das find ich jetzt schon ein wenig unhöflich....vielleicht werden es deshalb immer weniger Anfragen hier im deutschen Gentoo Forumsteil..............

Es wäre schön die Posts auf Anmerkungen zur Anfrage zu beschränken....und ich habe nicht angefangen!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3630
Location: Germany

PostPosted: Mon May 11, 2015 11:29 am    Post subject: Reply with quote

Tinitus wrote:
Josef.95 wrote:
Puh, deine Begabung uns mit Fehlinformationen zu versorgen ist beachtlich...
Füge dem Thread-Titel doch bitte die Info hinzu das es sich um ebulds aus einem Overlay handelt.


Das find ich jetzt schon ein wenig unhöflich....vielleicht werden es deshalb immer weniger Anfragen hier im deutschen Gentoo Forumsteil..............

Es wäre schön die Posts auf Anmerkungen zur Anfrage zu beschränken....und ich habe nicht angefangen!

Sorry nein, das war nicht unhöflich gemeint.

Es ist halt sehr verwirrend und unverständlich, wenn du Anfragen zu einem Bruchstück einer emerge Ausgabe stellst,
ohne zu erwähnen das es sich um ebuilds aus einem Overlay handelt. Solche essentielle Info sollte schon mit dabei sein, denn ohne die wird kaum jemand verstehen können worum es überhaupt geht.
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Mon May 11, 2015 11:34 am    Post subject: Reply with quote

Na gut hier die emerge Ausgabe komplett:

Code:
[ebuild     U ~] dev-libs/vala-common-0.28.0 [0.26.2]
[ebuild     U ~] x11-libs/gnome-pty-helper-0.40.0 [0.38.3]
[ebuild     U ~] gnome-extra/gnome-user-docs-3.16.1 [3.14.2]
[ebuild  NS   ~] media-libs/libmediaart-1.9.0 [0.7.0] USE="gtk introspection -qt4 -qt5 {-test} -vala"
[ebuild     U ~] net-misc/youtube-dl-2015.05.10 [2015.05.04]
[ebuild  NS   ~] dev-lang/vala-0.28.0 [0.24.0-r1, 0.26.2] USE="{-test}"
[ebuild     U ~] gnome-base/gsettings-desktop-schemas-3.16.1 [3.14.1]
[ebuild     U ~] x11-themes/gnome-backgrounds-3.16.0 [3.14.1]
[ebuild     U ~] dev-libs/libinput-0.13.0 [0.7.0]
[ebuild     U ~] gnome-base/dconf-0.24.0 [0.22.0]
[ebuild     U ~] media-libs/cogl-1.20.0 [1.18.2-r1]
[ebuild     U ~] x11-themes/adwaita-icon-theme-3.16.0 [3.14.1]
[ebuild  NS    ] x11-libs/gtk+-2.24.27 [3.16.2] USE="cups introspection xinerama (-aqua) -debug -examples {-test} -vim-syntax" ABI_X86="(64) -32 (-x32)"
[ebuild     U ~] media-libs/clutter-1.22.0 [1.20.0]
[ebuild     U ~] gnome-base/gnome-desktop-3.16.1 [3.14.2]
[ebuild     U ~] x11-libs/gtksourceview-3.16.1 [3.14.3]
[ebuild     U ~] net-wireless/gnome-bluetooth-3.16.1 [3.14.0]
[ebuild     U ~] dev-libs/gjs-1.43.3 [1.42.0]
[ebuild     U ~] x11-libs/vte-0.40.0 [0.38.3] USE="crypt%*"
[ebuild     U ~] x11-themes/gnome-themes-standard-3.16.0 [3.14.2.3] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U ~] sys-apps/baobab-3.16.1 [3.14.1]
[ebuild     U ~] gnome-extra/gucharmap-3.16.2 [3.14.2]
[ebuild     U ~] app-dicts/gnome-dictionary-3.16.1 [3.14.2] USE="introspection%*"
[ebuild     U ~] gnome-base/gnome-keyring-3.16.0 [3.14.0]
[ebuild     U ~] media-gfx/gnome-font-viewer-3.16.0 [3.14.1]
[ebuild     U ~] gnome-extra/gnome-system-monitor-3.16.0 [3.14.1]
[ebuild     U ~] gnome-extra/gnome-calculator-3.16.0 [3.14.1]
[ebuild     U ~] media-gfx/eog-3.16.1 [3.14.3]
[ebuild     U ~] net-misc/vino-3.16.0 [3.14.2]
[ebuild     U ~] net-libs/webkit-gtk-2.8.1 [2.6.5] USE="X%* -gles2% -wayland%"
[ebuild     U ~] www-client/epiphany-3.16.0 [3.12.1]
[ebuild     U ~] media-gfx/shotwell-0.22.0 [0.20.1-r1]
[ebuild     U ~] gnome-extra/yelp-3.16.0 [3.14.1]
[ebuild     U ~] dev-util/anjuta-3.16.0 [3.14.1]
[ebuild     U ~] games-board/gnome-chess-3.16.2 [3.14.3]
[ebuild     U ~] games-puzzle/gnome-tetravex-3.16.0 [3.14.0]
[ebuild     U ~] games-puzzle/gnome-sudoku-3.16.0 [3.14.2]
[ebuild     U ~] games-puzzle/swell-foop-3.16.1 [3.14.0]
[ebuild     U ~] gnome-extra/gnome-power-manager-3.16.1 [3.14.1]
[ebuild     U ~] games-puzzle/lightsoff-3.16.1 [3.14.1]
[ebuild     U ~] games-puzzle/gnome-klotski-3.16.1 [3.14.2]
[ebuild     U ~] games-board/gnome-mahjongg-3.16.0 [3.14.1]
[ebuild     U ~] games-puzzle/hitori-3.16.1 [3.14.3]
[ebuild     U ~] games-board/tali-3.16.0 [3.14.0]
[ebuild     U ~] games-board/gnome-mines-3.16.1 [3.14.1]
[ebuild     U ~] games-puzzle/five-or-more-3.16.1 [3.14.1]
[ebuild     U ~] x11-wm/mutter-3.16.1.1 [3.14.3]
[ebuild     U ~] media-video/cheese-3.16.1 [3.14.2]
[ebuild     U ~] games-arcade/gnome-nibbles-3.16.1 [3.14.1]
[ebuild     U ~] games-arcade/gnome-robots-3.16.1 [3.14.2]
[ebuild     U ~] media-gfx/gnome-screenshot-3.16.0 [3.14.0-r1]
[ebuild     U ~] games-board/four-in-a-row-3.16.1 [3.14.2]
[ebuild     U ~] games-puzzle/quadrapassel-3.16.0 [3.14.0]
[ebuild     U ~] net-misc/vinagre-3.16.0 [3.14.3]
[ebuild     U ~] games-board/iagno-3.16.1 [3.14.2]
[ebuild     U ~] gnome-base/gvfs-1.24.1 [1.22.3] USE="-nfs%"
[ebuild     U ~] sci-geosciences/geocode-glib-3.16.0 [3.14.0]
[ebuild     U  ] gnome-base/gnome-core-libs-3.16.0 [3.14.0]
[ebuild     U ~] app-editors/gedit-3.16.1 [3.14.3]
[ebuild     U ~] dev-libs/libgweather-3.16.1 [3.14.3]
[ebuild     U ~] gnome-base/gnome-settings-daemon-3.16.1 [3.14.2]
[ebuild     U ~] gnome-extra/gnome-weather-3.16.2.1 [3.14.1] USE="{-test%}"
[ebuild     U ~] gnome-base/gnome-session-3.16.0 [3.14.0-r1]
[ebuild     U ~] sys-apps/gnome-disk-utility-3.16.0 [3.14.0]
[ebuild     U ~] gnome-base/gnome-control-center-3.16.1 [3.14.2-r1]
[ebuild     U ~] gnome-extra/gnome-contacts-3.16.2 [3.14.2]
[ebuild     U ~] media-sound/gnome-music-3.16.1 [3.14.3.1]
[ebuild     U ~] net-im/empathy-3.12.9 [3.12.7]
[ebuild     U ~] gnome-base/nautilus-3.16.1 [3.14.2-r1]
[ebuild     U ~] app-text/evince-3.16.0 [3.14.2] USE="nsplugin%*"
[ebuild     U ~] app-cdr/brasero-3.12.1 [3.12.0]
[ebuild     U ~] app-arch/file-roller-3.16.1 [3.14.2]
[ebuild     U ~] media-sound/sound-juicer-3.16.1 [3.14.0]
[ebuild     U ~] gnome-extra/gnome-documents-3.16.0 [3.14.2]
[ebuild     U ~] gnome-base/gnome-shell-3.16.1 [3.14.3] PYTHON_TARGETS="python3_3%* -python3_4%"
[ebuild     U ~] gnome-base/gdm-3.16.1.1 [3.14.1-r1]
[ebuild     U ~] gnome-extra/gnome-tweak-tool-3.16.1 [3.14.2]
[ebuild     U ~] x11-terms/gnome-terminal-3.16.1 [3.14.2-r2]
[ebuild     U  ] gnome-base/gnome-core-apps-3.16.0 [3.14.0]
[ebuild     U ~] gnome-extra/gnome-shell-extensions-3.16.1 [3.14.3]
[ebuild     U  ] gnome-base/gnome-extra-apps-3.16.0 [3.14.0-r1]
[ebuild     U  ] gnome-base/gnome-3.16.0 [3.14.0]
[blocks B      ] <x11-libs/gtk+-2.24.27-r2:2 ("<x11-libs/gtk+-2.24.27-r2:2" is blocking dev-util/gtk-update-icon-cache-3.14.13)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-libs/gtk+-2.24.27:2/2::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/gtk+:2 required by (net-dns/avahi-0.6.31-r6:0/0::gentoo, installed)
    x11-libs/gtk+:2 required by (media-video/vlc-2.1.5-r1:0/5-7::gentoo, installed)
    x11-libs/gtk+:2 required by (app-cdr/nero-4.0.0.0b:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.24:2 required by (dev-python/pygtk-2.24.0-r4:2/2::gentoo, installed)
    >=x11-libs/gtk+-2.6:2 required by (dev-python/gnome-python-base-2.28.1-r1:2/2::gentoo, installed)
    x11-libs/gtk+:2 required by (www-plugins/adobe-flash-11.2.202.457:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.24.23:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=x11-libs/gtk+-2.24.23:2[abi_x86_64(-)]) required by (x11-themes/gtk-engines-2.20.2-r1:2/2::gentoo, installed)
    >=x11-libs/gtk+-2.24.15:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=x11-libs/gtk+-2.24.15:2[abi_x86_64(-)]) required by (dev-cpp/gtkmm-2.24.4-r1:2.4/2.4::gentoo, installed)
    >=x11-libs/gtk+-2.24.23:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=x11-libs/gtk+-2.24.23:2[abi_x86_64(-)]) required by (gnome-base/libglade-2.6.4-r2:2.0/2.0::gentoo, installed)
    >=x11-libs/gtk+-2.24.23:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=x11-libs/gtk+-2.24.23:2[abi_x86_64(-)]) required by (gnome-base/libgnomecanvas-2.30.3-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.24:2 required by (app-editors/gummi-0.6.5:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.24.10:2 required by (net-libs/webkit-gtk-2.4.8:3/25::gentoo, installed)
    x11-libs/gtk+:2[introspection?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (x11-libs/gtk+:2[introspection,abi_x86_64(-)]) required by (dev-libs/libdbusmenu-12.10.2-r2:0/0::gentoo, installed)
    x11-libs/gtk+:2 required by (app-accessibility/caribou-0.4.17:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.24.15:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=x11-libs/gtk+-2.24.15:2[abi_x86_64(-)]) required by (x11-themes/gnome-themes-standard-3.16.0:0/0::gnome, ebuild scheduled for merge)
    x11-libs/gtk+:2 required by (app-i18n/ibus-1.5.5:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.8.12:2 required by (gnome-base/libbonoboui-2.24.5-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.24:2 required by (dev-java/icedtea-bin-7.2.5.3:7/7::gentoo, installed)
    >=x11-libs/gtk+-2.12:2 required by (x11-libs/gtksourceview-2.10.5-r2:2.0/2.0::gentoo, installed)
    x11-libs/gtk+:2= required by (www-client/chromium-43.0.2357.52:0/0::gentoo, installed)
    x11-libs/gtk+:2 required by (www-client/google-chrome-42.0.2311.135_p1:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.14:2 required by (gnome-base/libgnomeui-2.24.5-r1:0/0::gentoo, installed)
    x11-libs/gtk+:2 required by (media-gfx/xsane-0.999-r1:0/0::gentoo, installed)
    x11-libs/gtk+:2 required by (app-crypt/pinentry-0.9.0:0/0::gentoo, installed)
    x11-libs/gtk+:2 required by (net-ftp/gftp-2.0.19-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.20.0:2 required by (media-libs/libcanberra-0.30-r4:0/0::gentoo, installed)
    x11-libs/gtk+:2 required by (net-dialup/ppp-2.4.7:0/2.4.7::gentoo, installed)
    x11-libs/gtk+:2 required by (x11-libs/wxGTK-2.8.12.1-r1:2.8/2.8::gentoo, installed)
    >=x11-libs/gtk+-2.6:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=x11-libs/gtk+-2.6:2[abi_x86_64(-)]) required by (gnome-base/libgnomeprintui-2.18.6-r1:2.2/2.2::gentoo, installed)
    x11-libs/gtk+:2 required by (x11-themes/redhat-artwork-5.0.8-r4:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.4:2 required by (x11-libs/gksu-2.0.2-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.18:2 required by (net-libs/gtk-vnc-0.5.4:0/0::gentoo, installed)
    x11-libs/gtk+:2/2= required by (www-client/chromium-43.0.2357.52:0/0::gentoo, installed)
    x11-libs/gtk+:2 required by (games-misc/xcowsay-1.3:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.18:2 required by (www-client/seamonkey-2.33.1-r1:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.6:2 required by (app-editors/gvim-7.4.273:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.24.10:2 required by (net-libs/webkit-gtk-2.8.1:4/37::gnome, ebuild scheduled for merge)
    x11-libs/gtk+:2 required by (dev-perl/gtk2-perl-1.247.0:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.20:2[introspection?] (>=x11-libs/gtk+-2.20:2[introspection]) required by (x11-libs/mx-1.4.7-r1:1.0/1.0::gentoo, installed)
    >=x11-libs/gtk+-2.12:2 required by (app-misc/tracker-1.2.5:0/100::gentoo, installed)
    >=x11-libs/gtk+-2.12:2 required by (x11-libs/libgksu-2.0.12-r2:2/2::gentoo, installed)
    >=x11-libs/gtk+-2.18:2 required by (www-client/firefox-37.0.2:0/0::gentoo, installed)
    x11-libs/gtk+:2 required by (app-text/gtkspell-2.0.16:2/2::gentoo, installed)
    >=x11-libs/gtk+-2.12:2 required by (sys-boot/plymouth-0.8.8-r4:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.24:2 required by (app-office/libreoffice-4.4.1.2:0/0::gentoo, installed)
    >=x11-libs/gtk+-2.24.10:2 required by (media-gfx/gimp-2.8.14:2/2::gentoo, installed)
    x11-libs/gtk+:2 required by (net-print/gutenprint-5.2.9:0/0::gentoo, installed)

  (dev-util/gtk-update-icon-cache-3.14.13:0/0::gnome, installed) pulled in by
    dev-util/gtk-update-icon-cache required by @selected
    >=dev-util/gtk-update-icon-cache-3 required by (x11-libs/gtk+-3.16.2:3/3::gnome, installed)


Ich habe

noch

Code:
=dev-util/gdbus-codegen-2.44.0 ~amd64


demaskiert deshalb hängt nur noch Einer...


Icon Cache gibt es nur in 3.14.13

Code:
eix -s gtk-update-icon-cache
[I] dev-util/gtk-update-icon-cache [1]
     Available versions:  ~2.24.27 (~)3.14.13
     Installed versions:  3.14.13(08:48:14 11.05.2015)
     Homepage:            http://www.gtk.org/
     Description:         GTK update icon cache

[1] "gnome" /var/lib/layman/gnome
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3630
Location: Germany

PostPosted: Mon May 11, 2015 11:42 am    Post subject: Reply with quote

Tinitus wrote:
Code:
[blocks B      ] <x11-libs/gtk+-2.24.27-r2:2 ("<x11-libs/gtk+-2.24.27-r2:2" is blocking dev-util/gtk-update-icon-cache-3.14.13)

Hier wird wahrscheinlich mindestens >=x11-libs/gtk+-2.24.27-r2
benötigt.
Schau mal ob es die Version schon gibt.
/edit: Ja die sollte im gnome Overlay verfügbar sein, siehe https://gitweb.gentoo.org/proj/gnome.git/tree/x11-libs/gtk+
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Mon May 11, 2015 1:10 pm    Post subject: Reply with quote

Hatte ich schon installiert:

Code:
emerge gtk+ -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] x11-libs/gtk+-3.16.2:3::gnome  USE="X colord cups introspection xinerama (-aqua) -broadway -cloudprint -debug -examples {-test} -vim-syntax -wayland" ABI_X86="(64) -32 (-x32)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

Trotzdem bleibt der Block...
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3630
Location: Germany

PostPosted: Mon May 11, 2015 1:28 pm    Post subject: Reply with quote

Hehe, es geht um gtk+:2 (nicht um gtk+:3)
Versuche
Code:
emerge -av1 =x11-libs/gtk+-2.24.27-r2

/Edit:
Schau dazu auch in der Ausgabe von
Code:
eix -e gtk+
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Mon May 11, 2015 4:25 pm    Post subject: Reply with quote

Macht euch doch keinen Stress und wartet etwas ab. Gnome wird ja nicht im Block aktualisiert wie KDE sondern wandert Stück für Stück ins Overlay. Da haken noch mehr Dinge. Ich denke, in 2 Tagen sieht das ganz anders aus.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3630
Location: Germany

PostPosted: Mon May 11, 2015 5:03 pm    Post subject: Reply with quote

Naja, portage würde
Code:
[ebuild  NS    ] x11-libs/gtk+-2.24.27 [3.16.2] USE="cups introspection xinerama (-aqua) -debug -examples {-test} -vim-syntax" ABI_X86="(64) -32 (-x32)"
in Slot 2 neu hinzu installieren (das ist stable aus den portage Tree),
benötigt wird aber =x11-libs/gtk+-2.24.27-r2 aus dem gnome Overlay.
Vermutlich wurde die Version einfach noch nicht freigeschaltet?
Back to top
View user's profile Send private message
Fijoldar
Apprentice
Apprentice


Joined: 10 Apr 2013
Posts: 248

PostPosted: Mon May 11, 2015 5:46 pm    Post subject: Reply with quote

Ich habe hier auf einem Rechner ebenfalls Gnome 3.16 aus dem Overlay installiert. Soweit läuft es eigentlich ganz gut. Ich kann allerdings den Rat geben, es nicht auf einem stable System zu versuchen oder man will sich den Spaß geben, alle Pakete, die nötig sind, einzeln frei zu schalten (das sind eine Menge). Auf einem System, das sowieso schon ~86 oder ~amd64 ist, dürfte es weniger Schwierigkeiten geben (habe es selbst versucht).

Man sollte auch beachten, dass GDM nun automatisch Wayland nutzt. Nutzer mit proprietären Grafikkarten Treibern können damit Probleme haben. Das lässt sich aber über die /etc/gdm/custom.conf regeln.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Mon May 11, 2015 5:53 pm    Post subject: Reply with quote

Hei, danke für den Tipp. Hatte gerade etwas im Diskussionsforum dazu geschrieben. Da hatte ich schon bei 3.14 Wayland probiert. Es geht jetzt. Aber das Geflackere ist bei mir unerträglich. Jetzt weiß ich, wie ich es bei Bedarf zum Testen mal anschalten kann.
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Tue May 12, 2015 5:40 am    Post subject: Reply with quote

Welche Waylan Bibliothek braucht gnome

bei mir stockt es bei:

Code:
configure: error: Package requirements (gdk-wayland-3.0) were not met:

No package 'gdk-wayland-3.0' found



Ich denke mal die hier fehlt:

Code:
* dev-libs/wayland
     Available versions:  ~0.95.0 ~1.0.6 ~1.1.0 ~1.2.0 1.2.1 ~1.2.1-r1 ~1.3.0 1.4.0 ~1.5.0 ~1.6.0 1.6.1 ~1.7.0 {doc static-libs ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Homepage:            http://wayland.freedesktop.org/
     Description:         Wayland protocol libraries


Bloß welche Version....Will nicht zu weit nach vorne...
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Tue May 12, 2015 5:42 am    Post subject: Reply with quote

Klaus Meier wrote:
Hei, danke für den Tipp. Hatte gerade etwas im Diskussionsforum dazu geschrieben. Da hatte ich schon bei 3.14 Wayland probiert. Es geht jetzt. Aber das Geflackere ist bei mir unerträglich. Jetzt weiß ich, wie ich es bei Bedarf zum Testen mal anschalten kann.


Gibst Du mal Dein Wissen weiter.....stehe auch kurz davor....
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Tue May 12, 2015 5:42 am    Post subject: Reply with quote

Keine Ahnung, was du da machst. Du setzt das USE-Flag "wayland" und alles andere geht von alleine. Jedenfalls bei mir.
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Tue May 12, 2015 5:48 am    Post subject: Reply with quote

Klaus Meier wrote:
Keine Ahnung, was du da machst. Du setzt das USE-Flag "wayland" und alles andere geht von alleine. Jedenfalls bei mir.


Ich installiere gnome-316 und demaskiere nur die Pakete die Portage vorschlägt. Bin auf einem Stable System und möchte nur so wenig wie möglich unstable Pakete installieren.

Die Jungs haben es schon gefixt auf meinen Bugreport hin....

Es baut......
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Tue May 12, 2015 5:51 am    Post subject: Reply with quote

Ich nutze testing. Auch wenn das einige hier anders sehen, ein Mix aus stable und Overlay macht noch mehr Stress als ein Overlay mit testing.
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Tue May 12, 2015 6:55 am    Post subject: Reply with quote

Also jetzt ist fast alles durchgelaufen nur:

Code:

[ebuild  N    ~] dev-util/gtk-update-icon-cache-3.14.13::gnome  0 KiB
[ebuild  N     ] dev-qt/qtchooser-0_p20150102::gentoo  USE="(-qt5) {-test}" 31 KiB
[ebuild     U  ] dev-qt/qtcore-4.8.6-r2:4::gentoo [4.8.5-r2:4::gentoo] USE="exceptions glib iconv qt3support ssl (-aqua) -debug -icu -pch" ABI_X86="(64%*) -32% (-x32)" 235.961 KiB
[blocks b      ] <dev-qt/qtcore-4.8.6:4 ("<dev-qt/qtcore-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks b      ] dev-qt/qttranslations:4 ("dev-qt/qttranslations:4" is blocking dev-qt/qtcore-4.8.5-r2)
[ebuild  N     ] dev-qt/qttranslations-4.8.6-r1:4::gentoo  ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] dev-qt/qtscript-4.8.6-r2:4::gentoo [4.8.5:4::gentoo] USE="exceptions jit (-aqua) -debug -pch (-iconv%*)" ABI_X86="(64%*) -32% (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtscript-4.8.6:4 ("<dev-qt/qtscript-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U  ] dev-qt/qtgui-4.8.6-r4:4::gentoo [4.8.5-r4:4::gentoo] USE="accessibility cups exceptions glib mng qt3support tiff xinerama xv (-aqua) -debug -egl -gtkstyle -nas -nis -pch -trace" ABI_X86="(64%*) -32% (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtgui-4.8.6:4 ("<dev-qt/qtgui-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U  ] dev-qt/qtsql-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions qt3support sqlite (-aqua) -debug -freetds -mysql -oci8 -odbc -pch -postgres (-firebird%)" ABI_X86="(64%*) -32% (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtsql-4.8.6:4 ("<dev-qt/qtsql-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U  ] dev-qt/qt3support-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="accessibility exceptions (-aqua) -debug -pch" ABI_X86="(64%*) -32% (-x32)" 0 KiB
[blocks b      ] <dev-qt/qt3support-4.8.6:4 ("<dev-qt/qt3support-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U  ] dev-qt/qtdbus-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions (-aqua) -debug -pch" ABI_X86="(64%*) -32% (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtdbus-4.8.6:4 ("<dev-qt/qtdbus-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U  ] dev-qt/qtsvg-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="accessibility exceptions (-aqua) -debug -pch" ABI_X86="(64%*) -32% (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtsvg-4.8.6:4 ("<dev-qt/qtsvg-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U  ] dev-qt/designer-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions qt3support (-aqua) -debug -declarative -kde -pch -phonon -webkit" ABI_X86="(64%*) -32% (-x32)" 0 KiB
[blocks b      ] <dev-qt/designer-4.8.6:4 ("<dev-qt/designer-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U  ] dev-qt/qttest-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions (-aqua) -debug -pch" ABI_X86="(64%*) -32% (-x32)" 0 KiB
[blocks b      ] <dev-qt/qttest-4.8.6:4 ("<dev-qt/qttest-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U  ] dev-qt/qtopengl-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions qt3support (-aqua) -debug -egl -pch" ABI_X86="(64%*) -32% (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtopengl-4.8.6:4 ("<dev-qt/qtopengl-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U  ] dev-qt/qtxmlpatterns-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="(-aqua) -debug -pch" ABI_X86="(64%*) -32% (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtxmlpatterns-4.8.6:4 ("<dev-qt/qtxmlpatterns-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U  ] dev-qt/qtmultimedia-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="alsa exceptions (-aqua) -debug -pch" ABI_X86="(64%*) -32% (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtmultimedia-4.8.6:4 ("<dev-qt/qtmultimedia-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U  ] dev-qt/qtwebkit-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="exceptions gstreamer icu jit (-aqua) -debug -pch" ABI_X86="(64%*) -32% (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtwebkit-4.8.6:4 ("<dev-qt/qtwebkit-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[ebuild     U  ] dev-qt/qtdeclarative-4.8.6-r1:4::gentoo [4.8.5:4::gentoo] USE="accessibility exceptions qt3support (-aqua) -debug -pch -webkit" ABI_X86="(64%*) -32% (-x32)" 0 KiB
[blocks b      ] <dev-qt/qtdeclarative-4.8.6:4 ("<dev-qt/qtdeclarative-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102)
[blocks B      ] <x11-libs/gtk+-2.24.27-r2:2 ("<x11-libs/gtk+-2.24.27-r2:2" is blocking dev-util/gtk-update-icon-cache-3.14.13)

Total: 17 packages (14 upgrades, 3 new), Size of downloads: 235.991 KiB
Conflict: 16 blocks (1 unsatisfied)


Code:
eix -s gtk-update-icon-cache
* dev-util/gtk-update-icon-cache [1]
     Available versions:  ~2.24.27 (~)3.14.13
     Homepage:            http://www.gtk.org/
     Description:         GTK update icon cache

[1] "gnome" /var/lib/layman/gnome



Jetzt werden die meisten gnome Programme extrem stark vergrößert dargestellt. Bei einer Auflösung von 1920x1200 sind die Buchstaben in der Konsole ca. 9 mm hoch.
Evolution ist fast nicht benutzbar.

Und die gnome Einstellungen gehen noch nicht...


Edit:
Die Fensterskalierung war hoch gesetzt...
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Tue May 12, 2015 7:00 am    Post subject: Reply with quote

Hast du denn gnome 3.14 drauf oder wolltest du gleich 3.16? Ich sagte doch schon, es ist noch nicht komplett und da geht einiges noch nicht. Es ist aktuell nur benutzbar, wenn du erst 3.14 installierst und dann, soweit wie es schon geht, ein Update auf 3.16 machst. Deshalb ist es ja auch im Overlay. Wenn alles perfekt funktioniert, dann ist es im Portage. Du kannst nicht erwarten, dass alles, was in einem Overlay ist, problemlos genutzt werden kann.

Warte noch ein paar Tage, dann wird es gehen.
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Tue May 12, 2015 7:05 am    Post subject: Reply with quote

Habe nun 3.16 auf meinem Stable drauf. Nur die Pakete demaskiert die gebraucht werden.

Ist einfach genial. Viele kleine Verbesserungen und gefühlt viel schneller als 3.14.

Bin bisher begeistert.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3630
Location: Germany

PostPosted: Tue May 12, 2015 7:45 am    Post subject: Reply with quote

Tinitus wrote:
Also jetzt ist fast alles durchgelaufen nur:

Code:
[...]
[blocks B      ] <x11-libs/gtk+-2.24.27-r2:2 ("<x11-libs/gtk+-2.24.27-r2:2" is blocking dev-util/gtk-update-icon-cache-3.14.13)

Total: 17 packages (14 upgrades, 3 new), Size of downloads: 235.991 KiB
Conflict: 16 blocks (1 unsatisfied)


Code:
eix -s gtk-update-icon-cache
* dev-util/gtk-update-icon-cache [1]
     Available versions:  ~2.24.27 (~)3.14.13
     Homepage:            http://www.gtk.org/
     Description:         GTK update icon cache

[1] "gnome" /var/lib/layman/gnome

[...]

Ach schade, den Blocker hast du scheinbar immer noch nicht aufgelöst.
Mich würde noch interessieren warum man das nicht macht. (so ist es doch nichts halbes, und nichts ganzes).

/edit
Und sorry das ich so penetrant nachfrage, aber das Thema
"gnome 3.16 Blocks gnome-overlay Layman"
scheint bisher ja noch nicht gelöst worden zu sein?
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Tue May 12, 2015 1:37 pm    Post subject: Reply with quote

Die Lösung ist eigentlich alle gtk+ Pakete zu demaskieren. Aber dann gibt es noch ein kleines Problem.

Gnome läuft trotzdem rund. Mußte nur noch die alte nautilus config löschen....
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3630
Location: Germany

PostPosted: Tue May 12, 2015 2:41 pm    Post subject: Reply with quote

Tinitus wrote:
Die Lösung ist eigentlich alle gtk+ Pakete zu demaskieren. [...]
Hm nein, das sollte nicht wirklich nötig sein. In der emerge Ausgabe (oder besser noch im ebuild) ist doch genau ersichtlich welche gtk+ Version tatsächlich benötigt wird.
Warscheinlich sollte ein Eintrag wie "~x11-libs/gtk+-2.24.27:2::gnome" ausreichend sein (das schließt die geforderte x11-libs/gtk+-2.24.27-r2:2 Version aus dem gnome Overlay mit ein).
Aber nungut - ich gebs auf.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum