Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Please Help with theis segfault!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
ev0child
n00b
n00b


Joined: 24 Apr 2015
Posts: 8

PostPosted: Mon May 11, 2015 6:25 pm    Post subject: Please Help with theis segfault!! Reply with quote

I'm having great difficultly trying to install Gentoo/xp dual boot on virtual box. I have been given this task as part of an assignment in uni so my knowledge of Linux systems is very limited. First i create my hard disk (vdi) of 10.00GB then mount the image of Gentoo minimal installation. The boot screen loads and asks me to select my boot like so: [img]http://s16.postimg.org/cyvyegt8x/dual_boot3.jpg[/img] I type "Gentoo" and it proceeds.

The next bit i get to is to select my key map and i leave it at default, immediately after this i get this screen : [img]http://s28.postimg.org/ka7hx1j6x/dual_boot.jpg[/img] Please can someone help me rectify this segmentation fault? It seems there is no documentation anywhere on the net to do with this problem.

if i leave it the next screen i get is : [img]http://s12.postimg.org/41jwvmull/dual_boot2.jpg[/img]

I really don't understand why this is happening, its not like I've set anything up to make this fault happen, Its a fresh install of both Gentoo and virtual box.
Any information on this would be much appreciated.
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1733
Location: St. Wendel

PostPosted: Mon May 11, 2015 7:13 pm    Post subject: Reply with quote

I see no real problem, what is your actual problem?
Back to top
View user's profile Send private message
ev0child
n00b
n00b


Joined: 24 Apr 2015
Posts: 8

PostPosted: Mon May 11, 2015 7:31 pm    Post subject: re Reply with quote

the segmentation fault i get after the "making tmpfs for /newroot" is that not a problem? is it not going to cause me problems further down the install? Plus the red exclamation marks i get on the third screenshot, there is a couple more before that shot but i couldn't capture tem.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7071

PostPosted: Mon May 11, 2015 7:36 pm    Post subject: Reply with quote

hi ev0child, say welcome to py-ro (we call him py-ro the blind here)

While you manage to get a prompt, the segfault on nfs shouldn't be really a problem except if you plan use some nfs while installing, the root scramble is not one too, as scramble or unknown, the result remain the same, you have a root login already, if you need, you can change the password to something you like.
The inittab per itself isn't a problem as it won't affect your system, whatever it was trying to do was for the livecd booting, nothing to care that much.

But even you were lucky, segfault may prove defective livecd or hardware fault. if the image is at fault, let's say you can ignore them, but if the segfault comes from hardware, you'll be in trouble while installing the distro and get sefault you would not be able to ignore this time.
You can look at dmesg to see what these segfaults are about (but without futher info, the segfault on cp is really, really not a good news). With heat coming back, defective, dusty fan... can lead to cpu getting hot, next one would be bad ram, but as you use virtualbox, i'm afraid it's something to look at also.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum