Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ALSA vs GA Z77X UD5H rev 1.0
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 268
Location: Cleebronn, Germany

PostPosted: Tue May 12, 2015 12:57 pm    Post subject: ALSA vs GA Z77X UD5H rev 1.0 Reply with quote

Guten Tag liebe Gentoo- Gemeinde, dieses mal habe ich leider Probleme mit meinem Motherboard Gigabyte GA Z77X UD5H rev 1.0: ALSA (Advanced Linux Sound Architecture Driver Version k3.18.11-gentoo.) bringt keinen Ton auf meine Boxen. Auch Live CDs habe ich schon getestet, alle ohne Erfolg. Ein "cat /proc/asound/cards" bringt folgende Ausgabe:
Code:
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7530000 irq 30
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf7080000 irq 17
 2 [Device         ]: USB-Audio - USB PnP Sound Device
                      C-Media Electronics Inc. USB PnP Sound Device at usb-0000:00:1a.0-1.4.2, full s
0 ist hier mein Motherboard,
1 meine NVidia Grafikkarte (HDMI) und
2 meine Logitech G110 Tastatur mit integriertem Headset- Anschluss (funktioniert!).
Ein "lspci | grep Audio" bringt folgende Ausgabe:
Code:
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
01:00.1 Audio device: NVIDIA Corporation GF110 High Definition Audio Controller (rev a1)
ebenfalls habe ich die Datei "/etc/asound.conf" erstellt:
Code:
pcm.hda-intel {
   type hw
   card 0
}

ctl.hda-intel {
   type hw
   card 0
}
Leider finde ich keine gute (deutschsprachige) Dokumentation zu dem ganzen (Waere ueber Links dankbar), habe daher ein paar Fragen:
- Wie bekomme ich Sounds auf meine Boxen?
- Kann ich eine Soundkarte deaktivieren ("blacklist snd-hda-intel" geht nicht, da BEIDE Karten den Treiber haben)?
- Wie kann ich geaenderte Konfigurationen ohne Neustart testen?
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Tue May 12, 2015 3:56 pm    Post subject: Reply with quote

Hast du dieses Sounddevice im Kernel aktiviert? Mit welcher LiveCD hast du denn getestet? Kann ja sein, dass da gar keine Soundunterstützung mit dabei ist. Kannst du es mal mit Ubuntu oder Windows testen?

Wenn da nichts geht, dann kaputt.
Back to top
View user's profile Send private message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 268
Location: Cleebronn, Germany

PostPosted: Tue May 12, 2015 4:45 pm    Post subject: Reply with quote

Kaputt nein, denn das System ist ein dual-boot System, auf Windows 7 (soll ja ersetzt werden) funktioniert es. Ich habe die Ubuntu 14.04 versucht, auch da geht es nicht. Bin derzeitig am kernel-update, wobei ich bezweifle das dieses den Fehler beheben wird. Ich habe auch einen Thread im englischen Forum gefunden. Einen Befehl habe ich dort auch gefunden: "equery l -f "^.*alsa.*$"":
Code:
 * Searching for ^.*alsa.*$ ...
[IP-] [  ] media-libs/alsa-lib-1.0.28:0
[IP-] [  ] media-plugins/alsa-plugins-1.0.28:0
[IP-] [  ] media-plugins/gst-plugins-alsa-0.10.36-r1:0.10
[IP-] [  ] media-sound/alsa-utils-1.0.28:0.9


Was ich nun weiss ist das es nicht unter Debian, Ubuntu und SuSE funktioniert. Any Ideas / Tutorials?
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 112

PostPosted: Tue May 12, 2015 9:29 pm    Post subject: Reply with quote

Hmm laut Homepage steht da was von Realtek ALC898 codec.

Ich hab leider gerade kein Gentoo zur Hand in der Arbeit, aber eventuell gibt es im Kernel diesen Treiber !?

http://www.gigabyte.at/products/product-page.aspx?pid=4139#sp

Hoffe es hilft dir den Sound endlich zu aktivieren :)

mfg
schatti
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Wed May 13, 2015 6:44 am    Post subject: Reply with quote

Google spuckt da aus, dass es Probleme mit dem Sound gibt. Aber die Artikel sind alle schon drei Jahre alt. Lösung sollte sein, die Treiber von Realktek zu installieren. Aber wie gesagt, das ist ziemlich alt. Eigentlich sollte der Kernel das können.

Hier der Link, die Lösung dann ganz am Ende: http://askubuntu.com/questions/197960/compatibility-ubuntu-with-gigabyte-ga-z77x-ud5h-wb-wifi
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed May 13, 2015 10:31 pm    Post subject: Reply with quote

Schattenschlag wrote:
Hmm laut Homepage steht da was von Realtek ALC898 codec.

Ich hab leider gerade kein Gentoo zur Hand in der Arbeit, aber eventuell gibt es im Kernel diesen Treiber !?

http://www.gigabyte.at/products/product-page.aspx?pid=4139#sp

Hoffe es hilft dir den Sound endlich zu aktivieren :)

mfg
schatti


ist seit 1.0.24 bzw. 1.0.25 in alsa drin:

http://www.alsa-project.org/main/index.php/Changes_v1.0.24_v1.0.25


stichwortartig zur Lösung:

wenn pulseaudio installiert ist - über pavucontrol die HDMI-Ausgabe deaktivieren und "Built-in Audio" (wie auch immer das auf deutsch heißt ;) ) auf Analog Stereo Ausgabe stellen

falls es immer noch nicht geht: über alsamixer im terminal die passenden Kanäle unmuten ( mit Taste M )



https://bbs.archlinux.org/viewtopic.php?id=180102

https://wiki.archlinux.org/index.php/PulseAudio/Examples#Simultaneous_HDMI_and_analog_output

https://wiki.archlinux.org/index.php/PulseAudio

https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting

https://wiki.archlinux.org/index.php/PulseAudio/Configuration


falls es Probleme mit dem Verständnis der Seiten gibt (leider nicht auf deutsch), mit Google Chrome oder Chromium öffnen und den Übersetzer drüber laufen lassen
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum