Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage conflict: needs both -qt3support and +qt3support ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
el muchacho
Tux's lil' helper
Tux's lil' helper


Joined: 26 Mar 2015
Posts: 77

PostPosted: Thu May 14, 2015 5:38 pm    Post subject: Portage conflict: needs both -qt3support and +qt3support ? Reply with quote

Hi,


i'm having a weird conflict which looks to me like I need to reinstall existing packages with special USE flags, one with and one without qt3support...

Calculating dependencies... done!
Code:

emerge: there are no ebuilds built with USE flags to satisfy "~dev-qt/qtcore-4.8.6[aqua=,debug=,glib=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]".
!!! One of the following packages is required to complete your request:
- dev-qt/qtcore-4.8.6-r2::gentoo (Change USE: +qt3support)
- dev-qt/qtgui-4.8.6-r4::gentoo (Change USE: -qt3support)
(dependency required by "dev-qt/qtgui-4.8.6-r4::gentoo" [ebuild])
(dependency required by "x11-drivers/ati-drivers-14.12-r3::gentoo[qt4]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


This is for an update.

Now, the existing package.use flags I have are (and I realized they are conflicting):

Code:
# required by dev-qt/qtsql-4.8.5
# required by dev-qt/qt3support-4.8.5
# required by dev-qt/qtgui-4.8.5-r4[qt3support]
# required by x11-drivers/ati-drivers-14.12-r3[qt4]
# required by x11-base/xorg-drivers-1.16[video_cards_fglrx]
# required by x11-base/xorg-server-1.16.4[xorg]
# required by x11-drivers/xf86-input-evdev-2.9.1
=dev-qt/qtcore-4.8.5-r2 qt3support


Code:
# required by dev-qt/qtgui-4.8.5-r4
# required by app-emulation/virtualbox-4.3.18[-headless,qt4]
# required by virtualbox (argument)
=dev-qt/qtcore-4.8.5-r2 -qt3support


Code:

dev-qt/qtgui qt3support gtkstyle


Code:
# required by dev-qt/qtopengl-4.8.5
# required by app-emulation/virtualbox-4.3.18[-headless,qt4,opengl]
# required by virtualbox (argument)
=dev-qt/qtgui-4.8.5-r4 -qt3support


How do I navigate out of this mess ?
Back to top
View user's profile Send private message
bstaletic
Apprentice
Apprentice


Joined: 05 Apr 2014
Posts: 225

PostPosted: Thu May 14, 2015 5:52 pm    Post subject: Reply with quote

Portage processes in alphabetical order, but also top-to-bottom. Try removing both flags and leting portage figure it out. Then set the flag appropriately.
Back to top
View user's profile Send private message
el muchacho
Tux's lil' helper
Tux's lil' helper


Joined: 26 Mar 2015
Posts: 77

PostPosted: Thu May 14, 2015 11:11 pm    Post subject: Reply with quote

Yes i'm trying this. I've run a --newuse after that... then a full deep update.... strangely i end up having to re-emerge 100+ packages including gcc, firefox, coreutils, gawk and many more... 8O
Back to top
View user's profile Send private message
jburns
Veteran
Veteran


Joined: 18 Jan 2007
Posts: 1048
Location: Massachusetts USA

PostPosted: Fri May 15, 2015 12:20 am    Post subject: Reply with quote

The change that portage is asking for is
Code:
dev-qt/qtcore-4.8.6-r2::gentoo (Change USE: +qt3support)
or
Code:
dev-qt/qtgui-4.8.6-r4::gentoo (Change USE: -qt3support)


If anything on your system needs qt3support then change dev-qt/qtcore. If nothing on your system needs qt3support then change dev-qt/qtgui. But only change one of them not both.
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2574

PostPosted: Fri May 15, 2015 12:50 am    Post subject: Reply with quote

qt3support is best handled globally in make.conf, not in package.use. Set it one way or the other in make.conf and accept the consequences. You probably want it on.

I recommend you think of 2 kinds of use flags: local and global. Local are the things that only affect 1 or 2 packages and may do different things on different packages like dvd or bindist. These go in package.use. Global use flags affect many packages and are fundamental (ie, they need to be all on or all off.) These go in make.conf.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum