Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PureVideo/UVD/AVIVO support, what graphics card?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
deltamalloc
Apprentice
Apprentice


Joined: 18 Jan 2013
Posts: 279

PostPosted: Sat May 16, 2015 7:27 pm    Post subject: PureVideo/UVD/AVIVO support, what graphics card? Reply with quote

I have a GeForce GT 630 graphics card. I don't need good 3D acceleration, but I need accelerated video decoding support for playback of normal video. GT 630 provides this. However, the nvidia proprietary driver suffers from tearing, and no matter how I try to correct this, it is always still present in some form of another, vsync is simply ignored by the binary blob driver in some cases. As for nouveau, I have a different problem, the system is simply unstable. I don't even get a kernel panic, the system just freezes with no warning whatsoever, the system is not really frozen, it is just unimaginably slow. The mouse cursor can still be moved, but it will move something on the order of one pixel every 15 seconds.

However, that is just background information and besides the point.

I need a different graphics card. What graphics card(s) are known to have good support for Gentoo, with no known issues regarding hardware accelerated video decoding? Should I buy some AMD graphics card? How good is the AMD support?

The requirements are simply:

* vsync must work properly, no tearing is acceptable for video playback.
* Hardware accelerated video decoding must work.

What card, if any, meets these requirements?

I don't care about anything else.
Back to top
View user's profile Send private message
micmac
l33t
l33t


Joined: 28 Nov 2003
Posts: 993

PostPosted: Sun May 17, 2015 6:34 pm    Post subject: Reply with quote

Hello deltamalloc,

I think you should try again with your nvidia card. I think disabling things like Composite/Xinerama is a good first step. I use the following xorg.conf, maybe it gives you some ideas what your xorg.conf could look like.

Code:

Section "ServerLayout"
    Identifier     "Default"
    Screen      0  "Screen0" 0 0
    Option         "Xinerama" "0"
EndSection

Section "ServerLayout"
    Identifier     "VDR"
    Screen      0  "Screen1" 0 0
    Option         "Xinerama" "0"
EndSection

Section "Files"
    ModulePath      "/usr/lib64/xorg/modules"
    ModulePath      "/usr/lib64/opengl/xorg-x11/extensions"
    FontPath        "/usr/share/fonts/misc:unscaled"
    FontPath        "/usr/share/fonts/Type1"
    FontPath        "/usr/share/fonts/TTF"
    #FontPath        "/usr/share/fonts/dejavu/"
    FontPath        "/usr/share/fonts/75dpi:unscaled"
    FontPath        "/usr/share/fonts/100dpi:unscaled"
EndSection

Section "Module"
    SubSection     "extmod"
        Option         "omit XFree86-DGA"
    EndSubSection
EndSection

Section "ServerFlags"
    Option         "UseDefaultFontPath" "false"
    Option         "AllowMouseOpenFail" "true"
    Option         "BlankTime" "0"
    Option         "StandbyTime" "0"
    Option         "SuspendTime" "0"
    Option         "OffTime" "0"
    Option         "DefaultServerLayout" "Default"                                                                                                                                                                                           
    Option         "Xinerama" "false"                                                                                                                                                                                                       
EndSection                                                                                                                                                                                                                                   
                                                                                                                                                                                                                                             
Section "InputClass"                                                                                                                                                                                                                         
    Identifier     "DE keyboard"                                                                                                                                                                                                             
    MatchIsKeyboard     "true"                                                                                                                                                                                                               
    Option         "XkbLayout" "de"                                                                                                                                                                                                         
EndSection                                                                                                                                                                                                                                   
                                                                                                                                                                                                                                             
Section "Monitor"                                                                                                                                                                                                                           
    Identifier     "Monitor0"                                                                                                                                                                                                               
    VendorName     "Philips"                                                                                                                                                                                                                 
    ModelName      "TV"                                                                                                                                                                                                             
    HorizSync      15.0 - 75.0                                                                                                                                                                                                               
    VertRefresh    24.0 - 62.0                                                                                                                                                                                                               
    Option         "UseEDIDFreqs" "false"                                                                                                                                                                                                   
    Option         "UseEDIDDpi" "false"                                                                                                                                                                                                     
    Option         "DPI" "59 x 59"                                                                                                                                                                                                           
    Option         "DPMS"                                                                                                                                                                                                                   
    #DisplaySize   827 465                                                                                                                                                                                                                   
    Option         "ModeValidation" "NoVesaModes, NoXServerModes, AllowNonEdidModes"                                                                                                                                                         
    ModeLine       "1920x1080_23.976" 74.175 1920 2558 2602 2750 1080 1084 1089 1125 +hsync +vsync                                                                                                                                           
EndSection                                                                                                                                                                                                                                   
                                                                                                                                                                                                                                             
Section "Device"                                                                                                                                                                                                                             
    Identifier     "Device0"                                                                                                                                                                                                                 
    Driver         "nvidia"                                                                                                                                                                                                                 
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 520M"
    Option         "ModeDebug" "false"
    Option         "NoLogo" "true"
    #Option        "UseDisplayDevice" "DFP-0"
    Option         "ConnectToAcpid" "false"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "ColorRange" "Limited"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "1920x1080_50 +0+0"
    Option         "ColorRange" "Limited"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "disable"
EndSection

Section "InputClass"
        Identifier      "PHILIPS MCE USB IR Receiver- Spinel plus"
        MatchProduct    "PHILIPS MCE USB IR Receiver- Spinel plus"
        MatchIsKeyboard "true"
        Option          "Ignore" "true"
EndSection
Back to top
View user's profile Send private message
deltamalloc
Apprentice
Apprentice


Joined: 18 Jan 2013
Posts: 279

PostPosted: Thu May 21, 2015 6:38 pm    Post subject: Reply with quote

micmac wrote:
Hello deltamalloc,

I think you should try again with your nvidia card. I think disabling things like Composite/Xinerama is a good first step. I use the following xorg.conf, maybe it gives you some ideas what your xorg.conf could look like.

[/code]


I'm pretty sure I've tried both before, but at least I have tried it again now, and the tearing is still there.

I have altered my X config based on yours, it is now as follows:

Code:

Section "Extensions"
   Option         "Composite" "Disable"
EndSection

Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
   Option          "Xinerama" "0"
EndSection

Section "ServerFlags"
    Option         "UseDefaultFontPath" "false"
    Option         "AllowMouseOpenFail" "true"
    Option         "BlankTime" "0"
    Option         "StandbyTime" "0"
    Option         "SuspendTime" "0"
    Option         "OffTime" "0"
    Option         "DefaultServerLayout" "X.org Configured"
    Option         "Xinerama" "false"
EndSection

Section "Files"
   ModulePath   "/usr/lib64/xorg/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/OTF/"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "glx"
#   Disable "dri"
#   Disable "dri2"
EndSection

Section "Module"
    SubSection     "extmod"
        Option         "omit XFree86-DGA"
    EndSubSection
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier    "Monitor0"
   VendorName    "LG"
   ModelName     "LG"
#   HorizSync     15.0 - 75.0
#   VertRefresh   24.0 - 62.0
#   Option        "UseEDIDFreqs" "false"
#   Option        "UseEDIDDpi" "false"
   Option        "DPMS"
   #DisplaySize  827 465
   Option        "ModeValidation" "NoVesaModes, NoXServerModes, AllowNonEdidModes"   
   Option        "DPI" "110 x 110"
   Modeline      "1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 +HSync +Vsync
EndSection

Section "Device"
   Identifier  "Card0"
   Driver      "nvidia"
   VendorName  "NVIDIA Corporation"
   BoardName   "GeForce GT 630"
#   Driver      "nouveau"
   BusID       "PCI:1:0:0"
   Option      "GLXVBlank" "true"
EndSection

Section "Screen"
   Identifier    "Screen0"
   Device        "Card0"
   Monitor       "Monitor0"
   DefaultDepth  24
   Option        "Stereo" "0"
#   Option        "ColorRange "Limited"
#   Option        "metamodes" "1920x1080_50 +0+0"
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection


I can verify that Xorg.0.log states:

Code:

[   170.874] (**) Extension "Composite" is disabled
[   170.846] (**) Option "Xinerama" "0"


I can also verify that in nvidia-settings I have "Sync to vblank" enabled, "Allow flipping" disabled and that I have "high quality" set to the highest setting.

None of these make no different, there is still tearing.

Are you sure that you don't also have tearing? Please note that it only shows up on certain video files and during certain types of animations.
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Fri May 22, 2015 7:51 am    Post subject: Reply with quote

ISTR you don't want to enable "sync to vblank" in the driver, as the xorg server does it nowadays.

Can't hurt to try it without, anyhow.
Back to top
View user's profile Send private message
deltamalloc
Apprentice
Apprentice


Joined: 18 Jan 2013
Posts: 279

PostPosted: Fri May 22, 2015 6:18 pm    Post subject: Reply with quote

steveL wrote:
ISTR you don't want to enable "sync to vblank" in the driver, as the xorg server does it nowadays.

Can't hurt to try it without, anyhow.


Thanks for the advice. Sadly I've tried that numerous times already.
Back to top
View user's profile Send private message
deltamalloc
Apprentice
Apprentice


Joined: 18 Jan 2013
Posts: 279

PostPosted: Tue Jun 09, 2015 10:46 pm    Post subject: Reply with quote

No proper solution for this problem exists in X. See http://unix.stackexchange.com/questions/182801/why-is-video-tearing-such-a-problem-in-linux

At best it can be minimized.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum