Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installation woes
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Albion
n00b
n00b


Joined: 07 Feb 2012
Posts: 31
Location: England

PostPosted: Tue May 19, 2015 8:01 am    Post subject: Installation woes Reply with quote

Good morning all,

Please note I have been trying to install Gentoo on UEFI/GPT of late but keep on getting errors such as

Quote:
grub2-install: error: /usr/lib/grub/x86_64-efi/modinfo.sh doesn't exist. Please specify --target or --directory.


Quote:
livecd init.d # ls /usr/lib/grub/x86_64-efi/
ls: cannot access /usr/lib/grub/x86_64-efi/: No such file or directory


My partitions are as follows:

Quote:
/dev/sda1 +2M EFI (EF00) (Unformatted)
/dev/sda2 +128M Boot (EF02) (FAT32)
/dev/sda3 +73G Swap (8200) (Swap)
/dev/sda4 +100G / (8300) (EXT4)
/dev/sdb1 +100G /usr (8300) (EXT4)
/dev/sdb2 +100G /var (8300) (EXT4)
/dev/sdb3 +100G /tmp (8300) (EXT4)
/dev/sdc1 +2.7TB /home (8300) (EXT4)


I'm using an Intel Core i7-4770 CPU with 32GB RAM.

Thanks in advance
Back to top
View user's profile Send private message
massimo
Veteran
Veteran


Joined: 22 Jun 2003
Posts: 1226

PostPosted: Tue May 19, 2015 8:10 am    Post subject: Reply with quote

Did you set GRUB_PLATFORMS accordingly in make.conf before emerging grub?
_________________
Hello 911? How are you?
Back to top
View user's profile Send private message
Albion
n00b
n00b


Joined: 07 Feb 2012
Posts: 31
Location: England

PostPosted: Tue May 19, 2015 8:27 am    Post subject: Reply with quote

Thanks for your prompt reply. I hadn't done that because I didn't know I had to, I didn't see it in the manual. I just corrected that though and them re-emerged grub and got a different error:

Quote:
livecd init.d # grub2-install /dev/sda
Installing for x86_64-efi platform.
grub2-install: error: cannot find EFI directory.


Thanks in advance.
Back to top
View user's profile Send private message
massimo
Veteran
Veteran


Joined: 22 Jun 2003
Posts: 1226

PostPosted: Tue May 19, 2015 9:09 am    Post subject: Reply with quote

cannot find EFI directory
_________________
Hello 911? How are you?
Back to top
View user's profile Send private message
Albion
n00b
n00b


Joined: 07 Feb 2012
Posts: 31
Location: England

PostPosted: Tue May 19, 2015 9:20 am    Post subject: Reply with quote

That's it.

This is the listing for the subdirectory of directory/boot/efi

Quote:
livecd init.d # ls -l /boot/efi/boot
total 5702
-rwxr-xr-x 1 root root 5838256 May 18 20:51 boot64.efi
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum